Beantwortet Onlineshop-Abgleich bricht ab bei Bildübertragung: (500) interner Serverfehler

  • Wichtiger Hinweis Liebe Kunden, solltet Ihr den DATEV Rechnungsdatenservice 2.0 nutzen, dann müsst Ihr bis zum 30.06.2024 JTL-Wawi 1.9 installieren. Danach wird die Schnittstelle für ältere Versionen nicht mehr unterstützt.
  • JTL-Connect 2024: Ihr habt noch kein Ticket? Jetzt Early Bird Ticket zum Vorzugspreis sichern! HIER geht es zum Ticketverkauf

<johnny>

Aktives Mitglied
7. Mai 2020
13
4
Hallo zusammen,

unser Onlineshop Relaunch verzögert sich aktuell leider, weil seit ein paar Tagen keine Bildübertragung an den WooCommerce Shop möglich ist.

Zur Ausgangssituation:
Initial wurde die WaWi mit allen Daten aus dem bestehenden Shop bestückt, was damals auch vollständig geklappt hat. In den vergangenen Wochen wurden in der Warenwirtschaft viele weitere Artikel angelegt. Testweise konnten Testartikel erfolgreich inkl. Bildern in den Shop übertragen werden. Freitag habe ich dann über Artikel>Bildgrößen alle Artikelbilder auf ein einheitliches Format skaliert bzw. konvertiert (jpg, 1800x2400px). Der anschließend durchgeführte Komplettabgleich endete beim Schritt Bildübertragung mit folgender Fehlermeldung:

wawi-shop-abgleich-error-20201127.png

Seitdem habe ich viel probiert, jedoch bricht der Abgleich immer im Abschnitt Bildübertragung mit dieser Fehlermeldung ab, teilweise werden maximal einige Dutzend Bilder übertragen.

Bisher probierte Lösungen:
- Alle artikelbezogenen Daten und Bilder in WooCommerce löschen, neu per Warenwirtschaft einspielen.
- Alle artikelbezogenen Daten und Bilder in WooCommerce löschen, Connector-Plugin deinstallieren, Connector Tabellen in MySQL DB löschen, Connector in WaWi zurücksetzen, Plugin neuinstallieren und in WaWi Onlineshop einrichten
- WaWi Einstellung: Artikelbilder vor jedem Bildimport löschen und neu anlegen
- connector.s3db Zugriffsrechte auf rw - rw - r stellen (war rw - r- r)
- WaWi Update von 1.5.26.0 auf 1.5.34.1
- Apache Neustart
- Ändern der Übertragungseinstellungen in der WaWi, mehr bzw. weniger Bilder pro Paket

Läuft der Onlineshop-Abgleich per Worker, dann synchronisiert der Worker regelmäßig den Shop bei Abgleich-Laufzeiten von einigen Minuten, beendet den Abgleich ohne Fehlermeldung, die Bilder werden aber ebenfalls nicht alle übertragen. Außerdem schickt der Abgleich die wenigen Bilder, die er dann mal hochlädt, mehrfach hoch bzw. bei jedem Abgleich erneut, obwohl im Shop schon vorhanden.

Ich hoffe sehr, dass ihr mir hier weiterhelfen könnt, langsam rennt die Zeit für den Launch davon...

Beste Grüße
Jonas
_________
System (hat bis Freitag so funktioniert):
Wordpress 5.5.3
WooCommerce 4.7.1 (vorher 4.7.0)
WaWi 1.5.34.1 (vorher 1.5.26.0)
Connector 1.15.2
 

Xantiva

Sehr aktives Mitglied
28. August 2016
1.787
313
Düsseldorf
Hast Du schon mal die (Error-)Logs des Webservers geschaut (wie in der Fehlermeldung angegeben)? Denn schließlich ist der es, der den #500er produziert. Vielleicht hat der PHP zu wenig Speicher?
 
  • Gefällt mir
Reaktionen: <johnny>

<johnny>

Aktives Mitglied
7. Mai 2020
13
4
Der Webserver Error- bzw Access- Log zeigte leider keine Fehlercodes über den 500er hinaus. Du hast mich dann aber doch auf die richtige Schiene gebracht und ich habe über die php.ini des Webservers die Max Execution Time sowie Memory Limit und Max File Sizes hochgesetzt. Und siehe da, heute Nacht lief der Abgleich erfolgreich durch 🤩
Ich denke es wird die execution time gewesen sein, da diese mit 30 sec vorher wirklich sehr niedrig gesetzt war.

Vielen Dank @Xantiva und alles Gute!
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Alle Kunden für Onlineshop freischalten Allgemeine Fragen zu JTL-Shop 0
Neu Artikel ohne Bestand im Onlineshop JTL-Shop - Fehler und Bugs 2
Neu Darstellung Lieferzeiten im Onlineshop (Germanized Pro) WooCommerce-Connector 0
Neu Plattformen Onlineshop Shopkunden Kundenregistrierung User helfen Usern - Fragen zu JTL-Wawi 1
Neu Onlineshop ist offline Allgemeine Fragen zu JTL-Shop 3
OBI, Kaufland, Otto automatischer Abgleich einstellen JTL-Wawi 1.8 1
Amazon Abgleich im Worker hängt ständig JTL-Wawi 1.8 3
Neu ebay Abgleich dauert ewig Arbeitsabläufe in JTL-Wawi 3
Neu Fehler Abgleich Shopware 6 Shopware-Connector 1
Neu Eazy Auction Abgleich ab 1.9.4.1 mit neuer Option "PDF-Erzeugung" Amazon-Anbindung - Fehler und Bugs 1
Neu Nach Update auf 1.9.4.2: Amazon-Abgleich hängt bei "Empfange VCS Rechnungsdaten" Amazon-Anbindung - Fehler und Bugs 2
Neu JTL POS nach Update kein Abgleich mehr JTL-POS - Fehler und Bugs 2
Neu Abgleich Woocommerce / JTL mit dem Connector Shopware-Connector 1
Neu Shopware 5: Nach Backup-Einspielung führt der Connector keinen Abgleich mehr durch Shopware-Connector 3
Kein ebay Abgleich seit Update auf 1.9.4.1 - error calling EaEbayNegotiationEligibleItemPost eBay-Anbindung - Fehler und Bugs 10
Neu Nach Abgleich von ca. 23500 Bildern ist nur ein bruchteil in Wordpress/Woocommerce verfügbar WooCommerce-Connector 2
JTL WAWI 1.8.12.2 Shopware 6 / Connector Abgleich Fehler Gelöste Themen in diesem Bereich 3
Neu Probleme mit Artikel Abgleich Shopware-Connector 2
Abgleich dauert sehr lange wegen Timeout/ Dateiname zu lang JTL-Wawi 1.8 1
JTL Worker Manueller Abgleich nicht möglich trotz deaktivierem Worker 2.0 JTL-Wawi 1.8 4
Worker 2.0 Abgleich dauert sehr lange JTL-Wawi 1.7 8
Fehler beim Rendering der Attribute bei SCX Abgleich kaufland.de - Anbindung (SCX) 4
Neu JTL-Connector bricht Bilderabgleich mit Fehler ab WooCommerce-Connector 0
Neu Artikel import bricht ab JTL-Ameise - Fehler und Bugs 2

Ähnliche Themen