In Diskussion "No Session" Fehler nach Update auf modified 2.0.5.1

D.EINS

Neues Mitglied
16. Juli 2020
3
0
Hallo wertes Forum!
Ich bearbeite zurzeit im Auftrag eines Kunden seinen Shop. Dieser wurde auf die aktuelle modified eCommerce Version 2.0.5.1 gebracht. Der Kunde hat anschließend die neueste Version des JTL-Connectors, der die Freigabe zur entsprechenden modified-Version hat, installiert und konfiguriert.
Seit dem Update erscheint in den Logs folgender Fehler:
global.ERROR: Exception 'jtl\Connector\Core\Exception\SessionException' (Code: 0) with message 'No session' in phar:///var/www/htdocs/modified/jtlconnector/index.php/vendor/jtl/connector/src/Application/Application.php:595

Meine Frage daher: Sind in der Richtung häufige Fehlerursachen bekannt? Ich glaube nicht, dass der JTL-Connector einen Fehler hat, aber ich kann ohne Weiteres auch keinen Fehler in der modified Installation ausmachen.

Die Eckdaten:
PHP-Version: 7.2.32
JTL-Connector-Version: 2.0.2.4
JTL-WaWi Version: 1.5.13.0
modified eCommerce Version: 2.0.5.1

--
Weitere Logs:

session-2020-07-16.log
Code:
[2020-07-16 16:42:09] session.DEBUG: Write session with id (ab54b4tduk2p5ujh90oeug6cj6) [] []
[2020-07-16 16:42:09] session.DEBUG: Close session [] []

rpc-2020-07-16.log
Code:
[2020-07-16 16:42:09] rpc.DEBUG: RequestPacket: {"method":"core.connector.auth","params":"{\"token\":\"****************\"}","jtlrpc":"2.0","id":"57d349a7f5694956998e5ffb39346a60"} [] []
[2020-07-16 16:42:09] rpc.DEBUG: Params: {"token":"****************"} [] []
[2020-07-16 16:42:09] rpc.DEBUG: {"result":{"sessionId":"ab54b4tduk2p5ujh90oeug6cj6","lifetime":1440},"error":null,"jtlrpc":"2.0","id":"57d349a7f5694956998e5ffb39346a60"} [] []

database-2020-07-16.log
Code:
[2020-07-16 16:42:09] database.DEBUG: SElECT configuration_key,configuration_value FROM configuration [] []

global-2020-07-16.log
Code:
[2020-07-16 16:42:09] global.ERROR: Exception 'jtl\Connector\Core\Exception\SessionException' (Code: 0) with message 'No session' in phar:///var/www/htdocs/modified/jtlconnector/index.php/vendor/jtl/connector/src/Application/Application.php:595 [] []

Wäre super, wenn sich über das Forum Hilfe finden lässt! Vielleicht haben auch andere das Problem (gehabt) und können Berichten - würde mich riesig freuen.
 

D.EINS

Neues Mitglied
16. Juli 2020
3
0
Hallo Shahne,

Danke für die schnelle Reaktion! Den Integrity Check haben wir bereits ausgeführt, ohne nennenswerte Auffälligkeiten. Ich hänge den Screenshot hier nochmal an.
Ich hatte als erste Vermutung, dass es an der PHP Version liegen könnte. Vorher war 7.3 bei dem Shop im Einsatz, das habe ich auf 7.2 runtergestuft, leider noch mit dem selben Ergebnis.
Sollte ich vielleicht doch nochmal 7.1 und 7.0 testen?

Beste Grüße,
D.EINS
 

Anhänge

  • screencapture-integrity-check-2020-07-17-10_08_47.png
    screencapture-integrity-check-2020-07-17-10_08_47.png
    261,2 KB · Aufrufe: 9

D.EINS

Neues Mitglied
16. Juli 2020
3
0
Das Problem konnte inzwischen gelöst werden: Die PHP Version war der Auslöser für diesen Fehler. Nachdem diese auf 7.0 gesetzt wurde, konnte die WaWi wieder eine Verbindung zum Shop herstellen und den Abgleich erfolgreich ausführen.

Die PHP-Versionen 7.2 und 7.3 funktionieren demnach noch nicht für den Connector. Version 7.1 habe ich nicht getestet, der Kunde ist froh, dass der Abgleich wieder funktioniert.

Der Thread kann damit geschlossen werden.
 

vapish

Aktives Mitglied
11. März 2018
46
2
Diesen Fehler hatte ich auch. Das Problem konnte ich lösen, in dem ich die Shop ver. 2.0.5.0 wieder installiert habe. Der Connector unterstützt nur bis ver. 2.0.5.0
 

Ähnliche Themen