Neu Nach Update auf 5.2.1 HTTP 500 Error beim Aufruf von Kategorie-Seiten

Schnuffelwuffel

Gut bekanntes Mitglied
13. November 2020
83
27
Hallo zusammen,

habe heute das Upgrade auf Shop-Version 5.2.1 laufen lassen. Heute morgen hatte ich schon einen gravierenden Fehler in Zusammenarbeit mit dem JTL Support sehr schnell beheben können.

Leider ist mir erst jetzt aufgefallen, dass keine Kategorie-Seiten aufrufbar sind. Hier kommt generell der HTTP 500 Fehler.

Ich habe schon einiges probiert.

- Redis Cache deaktiviert.
- Sämtliche Caches geleert.
- Komplettabgleich mit der WAWI gemacht (inklusive der Kategorien)

Leider keine Besserung.
Hat jemand eine Idee?

Danke und viele Grüße
Markus von Schnuffelwuffel
 

Schnuffelwuffel

Gut bekanntes Mitglied
13. November 2020
83
27
Hallo zusammen,

ich konnte die Fehlerursache eingrenzen.

Vielleicht hat jemand das gleiche Problem, deshalb teile ich den Fortschritt direkt hier.

Nach dem Deaktivieren aller Plug-Ins waren die Kategorie-Seiten wieder aufrufbar.

Danach habe ich alle PlugIns einzeln wieder aktiviert.

Der "Übeltäter" ist das Google Tracking PlugIn von Webstollen. Konkret ist es innerhalb des PlugIns das Google Analytics 4 Tracking. Wenn man dieses deaktiviert, funktioniert alles. Interessanterweise ist das aber unabhängig davon, ob dem Tracking innerhalb des Consent Tools zugestimmt wurde. Rein das Aktivieren der Funktion bringt die Kategorie-Seiten zum Absturz.

Ich werde morgen bei Webstollen gleich ein Ticket aufmachen.

Viele Grüße
Markus
 
  • Gefällt mir
Reaktionen: B2B-IT

Schnuffelwuffel

Gut bekanntes Mitglied
13. November 2020
83
27
Guter Hinweis!

Es ist natürlich sehr sinnvoll, dass im JTL Extension Store kompatibel bis „aktuellste Version“ steht. Dort hatte ich nämlich alle PlugIns geprüft, die ich verwende.
 
  • Gefällt mir
Reaktionen: 2009Butch

7-Lights

Aktives Mitglied
14. Januar 2020
35
6
Danke für die Info... auch bei uns hat das Plugin nach dem update zu selbigen Problemen geführt. Interessant war aber auch, dass es mit manchen Geräten kein Fehler gab. Evtl. je nachdem welche Trackingdaten erlaubt wurden. Bei iOS ging es z.B. auf manchen Geräten.
 
  • Gefällt mir
Reaktionen: Schnuffelwuffel

Schnuffelwuffel

Gut bekanntes Mitglied
13. November 2020
83
27
Das Tracking PlugIn wird nach Auskunft von Webstollen in einer neuen Version übrigens in ca. 2 Wochen erscheinen.

In der Kommunikation, was die Kompatibiltät angeht, gibt es jedenfalls noch Luft nach oben. Im Extension Store wurde von Webstollen immerhin reagiert und die Kompatibilität angepasst, was ja sehr gut ist. Andere haben das noch nicht gemacht, so dass die PlugIns immer noch Kompatibilität für 5.2 vortäuschen, obwohl da keine ist.

Da ich selbst Software-Entwickler bin, kann ich verstehen, dass es viel Arbeit ist, seine Produkte aktuell zu halten. Nichts desto trotz kam weder Shop 5.2 noch die Umstellung auf PHP 8.1 überraschend, so dass man das hätte vorbereiten können. Für die JTL Plugins wurde auch direkt im Shop Backend angezeigt, dass ein Update nach der Aktualisierung auf Shop 5.2 benötigt wird. Technisch gibt es also schon jetzt die Möglichkeit, das im Backend anzuzeigen. Ich frage mich, warum diese Funktionalität nicht generell verwendet wird. Ich hätte jedenfalls mit dem Shop Update noch länger gewartet, zumal wir noch Mollie verwenden, das Tracking aktuell nicht funktioniert, wir mit der bereits geplanten Installation von uptain noch warten müssen, usw.
 

B2B-IT

Gut bekanntes Mitglied
15. Januar 2016
120
10
Hallo zusammen,

ich konnte die Fehlerursache eingrenzen.

Vielleicht hat jemand das gleiche Problem, deshalb teile ich den Fortschritt direkt hier.

Nach dem Deaktivieren aller Plug-Ins waren die Kategorie-Seiten wieder aufrufbar.

Danach habe ich alle PlugIns einzeln wieder aktiviert.

Der "Übeltäter" ist das Google Tracking PlugIn von Webstollen. Konkret ist es innerhalb des PlugIns das Google Analytics 4 Tracking. Wenn man dieses deaktiviert, funktioniert alles. Interessanterweise ist das aber unabhängig davon, ob dem Tracking innerhalb des Consent Tools zugestimmt wurde. Rein das Aktivieren der Funktion bringt die Kategorie-Seiten zum Absturz.

Ich werde morgen bei Webstollen gleich ein Ticket aufmachen.

Viele Grüße
Markus
Bei uns ist das Google Analytics 4 Tracking deaktiviert, trotzdem kam es zum http500 Fehler. Interessanter Weise aber nur in Edge und Chrome Browser auf PC (auf Smartphones im Chrome keine Probleme). Im Firefox komplett ohne Probleme.
 

Ähnliche Themen