Gelöst Nach Domainumstellung funktioniert der Admin Login nicht mehr

Surfganic

Aktives Mitglied
23. November 2018
27
2
Rheda-Wiedenbrück
Ich habe die Domain meiner Website verändert. Der Shop läuft nach Änderung der Configdatei. Allerdings kann ich mich nicht mehr im Adminberreich einloggen. Wenn ich ein neues Passwort festlege, kann ich mich anschließend trotzdem nicht einloggen. Bzw werde in den Adminbereich weitergeleitet.
Vielen Dank für eure Hilfe. Cheers Steve
 
Zuletzt bearbeitet:

Mirko.Schmidt User deaktiviert

Guest
Eine Fehlermeldung zu nennen oder was genau passiert wäre hilfreich 🙂
 

Mirko.Schmidt User deaktiviert

Guest
Am besten einmal ein Link schicken, gerne auch per Unterhaltung.
 

Mirko.Schmidt User deaktiviert

Guest
Im Frontend wird auf www.Surfganic.com weitergeleitet und im Backend nicht, da wohl irgendwo eine Eintragung (config oder .htaccess). Ich konnte gerade Dummy Daten eingeben und hab dann die typische Fehlermeldung bekommen "Benutzername oder Passwort falsch". Sprich die Überprüfung findet statt. Wurde der Browser Cache geleert, ein anderer Browser genutzt?
 

Surfganic

Aktives Mitglied
23. November 2018
27
2
Rheda-Wiedenbrück
Im Frontend wird auf www.Surfganic.com weitergeleitet und im Backend nicht, da wohl irgendwo eine Eintragung (config oder .htaccess). Ich konnte gerade Dummy Daten eingeben und hab dann die typische Fehlermeldung bekommen "Benutzername oder Passwort falsch". Sprich die Überprüfung findet statt. Wurde der Browser Cache geleert, ein anderer Browser genutzt?
Also am Browser wird es nicht liegen. alles neu gestartet.
Hier die Config Datei weiter unten findest du die htaccess Datei:

<?php
define('PFAD_ROOT', 'xxxxxxxxxxxxxxxxxxxxxxxxx');
define('URL_SHOP', 'http://surfganic.com');
define('DB_HOST','xxxxxxxxxxxxxxx');
define('DB_NAME','xxxxxxxxxxx');
define('DB_USER','xxxxxxxxxxxxx');
define('DB_PASS','xxxxxxxxxxxxxx');

define('BLOWFISH_KEY', 'xxxxxxxxxxxxxxxx');

//enables printing of warnings/infos/errors for the shop frontend
define('SHOP_LOG_LEVEL', 0);
//enables printing of warnings/infos/errors for the dbeS sync
define('SYNC_LOG_LEVEL', 0);
//enables printing of warnings/infos/errors for the admin backend
define('ADMIN_LOG_LEVEL', 0);
//enables printing of warnings/infos/errors for the smarty templates
define('SMARTY_LOG_LEVEL', 0);
//excplicitly show/hide errors
ini_set('display_errors', 0);










HTACCESS


<IfModule mod_setenvif.c>
<IfModule mod_headers.c>
<FilesMatch "\.(bmp|cur|gif|ico|jpe?g|png|svgz?|webp)$">
SetEnvIf Origin ":" IS_CORS
Header set Access-Control-Allow-Origin "*" env=IS_CORS
</FilesMatch>

SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
</IfModule>
</IfModule>

<IfModule mod_filter.c>
<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE \
"application/atom+xml" \
"application/javascript" \
"application/json" \
"application/ld+json" \
"application/manifest+json" \
"application/rdf+xml" \
"application/rss+xml" \
"application/schema+json" \
"application/vnd.geo+json" \
"application/vnd.ms-fontobject" \
"application/x-font-ttf" \
"application/x-javascript" \
"application/x-web-app-manifest+json" \
"application/xhtml+xml" \
"application/xml" \
"font/eot" \
"font/opentype" \
"image/bmp" \
"image/svg+xml" \
"image/vnd.microsoft.icon" \
"image/x-icon" \
"text/cache-manifest" \
"text/css" \
"text/html" \
"text/javascript" \
"text/plain" \
"text/vcard" \
"text/vnd.rim.location.xloc" \
"text/vtt" \
"text/x-component" \
"text/x-cross-domain-policy" \
"text/xml"
</IfModule>
<IfModule mod_mime.c>
AddEncoding gzip svgz
</IfModule>
</IfModule>

<IfModule !mod_filter.c>
<IfModule mod_deflate.c>
<FilesMatch "\\.(js|css|html|htm|xml)$">
SetOutputFilter DEFLATE
</FilesMatch>
</IfModule>
</IfModule>

<IfModule mod_expires.c>
ExpiresActive on
ExpiresDefault "access plus 1 months"
</IfModule>

<IfModule mod_headers.c>
Header unset ETag

Header set X-UA-Compatible "IE=edge"
Header set X-Content-Type-Options "nosniff"
Header unset X-Powered-By

<FilesMatch "\.(eot|otf|tt[cf]|woff2?)$">
Header set Access-Control-Allow-Origin "*"
</FilesMatch>

<FilesMatch "\.(appcache|atom|bbaw|bmp|crx|css|cur|eot|f4[abpv]|flv|geojson|gif|htc|ico|jpe?g|js|json(ld)?|m4[av]|manifest|map|mp4|oex|og[agv]|opus|otf|pdf|png|rdf|rss|safariextz|svgz?|swf|topojson|tt[cf]|txt|vcard|vcf|vtt|webapp|web[mp]|webmanifest|woff2?|xloc|xml|xpi)$">
Header unset X-UA-Compatible
</FilesMatch>
</IfModule>

<IfModule mod_rewrite.c>
RewriteEngine on

#REWRITE ANPASSUNG 1 (REWRITEBASE)
#Wenn Ihr Shop in einem Unterverzeichnis (also z.B. meinedomain.de/meinverzeichnis) installiert ist, so kommentieren Sie die kommende Zeile aus und passen Sie den Verzeichnisnamen an
RewriteBase /

#REWRITE ANPASSUNG 2 (auf www.meinedomain.de umleiten)
#Ihr Shop sollte nicht unter www.meinedomain.de und nur meinedomain.de erreichbar sein, siehe: http://guide.jtl-software.de/index....tion#4._Einrichtung_einer_Domainweiterleitung
#RewriteCond %{HTTP_HOST} ^meinedomain.de
#RewriteRule ^(.*)$ http://www.meinedomain.de/$1 [r=301,L]

#REWRITE ANPASSUNG 3 (Entfernt abschlieÃenden Slash per 301-Redirect)
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_URI} ^(.*)/$
#RewriteRule ^. %1 [L,R=301]

#Rewrite der JTL-Shop-URLs
#Aendern Sie an diesen Zeilen nichts!
RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ includes/sitemap.php?datei=$1 [L]
RewriteRule ^export/((sitemap_).*\.(xml|txt)(\.gz)?)$ $1 [L]
RewriteRule ^asset/(.*)$ includes/libs/minify/?g=$1 [L]
RewriteRule ^robots.txt$ robots.php [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^. index.php [L]
</IfModule>

FileETag None
#Server Signatur deaktivieren
#ServerSignature Off
 

Mirko.Schmidt User deaktiviert

Guest
Ich habe mal die Werte aus der Config zensiert, sowas sollte hier niemals öffentlich gepostet werden. In der Config ist aber die Konstante "URL_SHOP" ohne www, hier am besten mal mit www ausprobieren. Zu dem Browser schließen und neuöffnen hilft da nicht. Die Browserdaten müssen schon gelöscht werden, da ansonsten diese immer noch vorhanden sind. Was passiert den wenn falsche Daten eingegeben werden?
 

Surfganic

Aktives Mitglied
23. November 2018
27
2
Rheda-Wiedenbrück
Ich habe mal die Werte aus der Config zensiert, sowas sollte hier niemals öffentlich gepostet werden. In der Config ist aber die Konstante "URL_SHOP" ohne www, hier am besten mal mit www ausprobieren. Zu dem Browser schließen und neuöffnen hilft da nicht. Die Browserdaten müssen schon gelöscht werden, da ansonsten diese immer noch vorhanden sind. Was passiert den wenn falsche Daten eingegeben werden?

Also mit www. klappt es auch nicht. Es wird mir immer angezeigt. Benutzer oder Passwort Falsch. - Wenn ich auf Passwort ändern gehe, bekomm ich eine Mail, wo ich das neue Passwort doppelt eintrage. Dann gehts wieder zum Log In - und dann gebe ich das neu Passwort ein und dann komm ich trotzdem nicht weiter....
 

Surfganic

Aktives Mitglied
23. November 2018
27
2
Rheda-Wiedenbrück
Also mit www. klappt es auch nicht. Es wird mir immer angezeigt. Benutzer oder Passwort Falsch. - Wenn ich auf Passwort ändern gehe, bekomm ich eine Mail, wo ich das neue Passwort doppelt eintrage. Dann gehts wieder zum Log In - und dann gebe ich das neu Passwort ein und dann komm ich trotzdem nicht weiter....

Danke für die Hilfe läuft wieder 🙂
 

Ähnliche Themen