Neu LS-POS - RAW Druckvorlage problem mit @Logo1

poi

Gut bekanntes Mitglied
25. Januar 2008
537
21
Hallo,
durch einen Hardwarefehler (Kassenöffner defekt) sind wir derzeit gezwungen, die Kassenlade direkt über den Bon-Drucker anzusteuern. Das Problem jetzt, die Windows Druckvorlage können wir nun nicht mehr nutzen, da der Befehl zum Kassenlade öffnen nicht durchgereicht wird. Also im RAW Modus betreiben. Jetzt wird unser Logo nicht mehr gedruckt, da wir das über die Druckvorlage realisiert hatten.

Das aktuelle Logo ist im Speicher vom Bon Drucker, der Testdruck klappt ebenfalls. Ich muss das Logo nun direkt mit dem Befehl @Logo1=???? drucken, damit komme ich noch nicht klar.

Unser Bon Drucker ist ein Citizen CT-S2000. Mit dem Citizen-Windows-Tool kann ich den Speicher bearbeiten und die Logos einpflegen. Ich kann Keys eingeben und den Modus wechseln. Wie geht es nun weiter?! Wie steuere ich das Logo an damit es gedruckt wird??

Danke für Hilfe und Gruß!
 

poi

Gut bekanntes Mitglied
25. Januar 2008
537
21
Heute nochmal gelesen, gesucht und nix gefunden.
Im Drucker ist das Logo mit dem Key L1 hochgeladen und auch im Speicher. Testdruck ist okay.
Die LS-POS Druckereinstellungen passen, der Drucker macht ja im RAW Modus auch was er soll. Die Codes unter 'Logo1' sind voreingestellt. Ich weiss nicht wie ich das anpassen soll, wie findet LS-POS das Logo auf Speicher 'L1'?

Danke für Hilfe, mit Druckercodes kenne ich mich nur oberflächlich aus.
 

F.Schneider

Moderator
MLBanner
14. Juli 2014
201
14
Franken
Hallo Poi,
die Druckercodes für die Variablen @Logo1 ... 3 in der Vorlage werden über die Einstellung "Modell" unter Hardware->Drucker für...->...Bons definiert. Dort gibt es auch Vorlagen für die Modelle Citizen CT-S801 und CT-S310 (siehe Screenshot unten). Bitte wähle diese testweise einmal aus und versuche damit, einen neuen Bon zu drucken.
Alternativ wird es voraussichtlich ab der nächsten Version von LS-POS möglich sein, die Windows- Druckvorlagen auch im Raw-Modus zu nutzen.
1589795339533.png
 

poi

Gut bekanntes Mitglied
25. Januar 2008
537
21
Hi,
bin gerade im Urlaub.

diesen Drucker habe ich probiert. Druck ist okay, aber das Logo wird nicht gedruckt. Daraufhin habe ich versucht mich mit der Materie zu befassen. Logo ist im Drucker. Vom Drucker aus alles positiv. Von LS-POS aus nur Text, kein Logo.
Muss der Key im Druckerspeicher eine bestimmte Bezeichnung haben? Ich vermute dass der Treiber den Speicher nicht anspricht...

Danke und Gruß!