Neu Jtl OAuth2

  • Ersteller des Themas Ersteller des Themas Amir2020
  • Erstellungsdatum Erstellungsdatum

Amir2020

Gut bekanntes Mitglied
23. Dezember 2020
106
7
Hi Ihr Lieben,

vor ab: wir sind auf dem Gebiet Laie. Es wurden ja schon einige Ausführungen gemacht zum Neuverfahren der UPS mittels OAuth2. Wir nutzen die Jtl-Wawi Version 1.7.13.1 und versenden ausschließlich mit UPS.
Wir führen also die UPS Kundennummer und die API Token, alles in JTL-Wawi Shipping Labels Einstellungen hinterlegt und läuft alles gut. Wir sind nehme ich an, nun auch betroffen von dieser Umstellung auf OAuth2 Verfahren.
Kann jemand für Anfänger wie wir es sind, erläutern wie genau wir am besten vorgehen sollten. Wir haben nun gelesen dass eine höhere Version als die wie wir sie haben, erforderlich ist?? Wenn ja, müssen wir in dieser "neuen" Versiond der Jtl-wawi erneut mit unseren UPS-daten wie Benutzername und Kennwort in dem Jtl-Shipping Labels Bereich wieder einrichten???

Danke im Voraus für eure Hilfe(n).
 

Morimus

Sehr aktives Mitglied
16. Mai 2019
653
144
Wir haben nun gelesen dass eine höhere Version als die wie wir sie haben, erforderlich ist??

Ja, das ist richtig.
Das neue OAuth2 Verfahren ist ab der Wawi Version 1.9.4.0 möglich.


Wenn ja, müssen wir in dieser "neuen" Versiond der Jtl-wawi erneut mit unseren UPS-daten wie Benutzername und Kennwort in dem Jtl-Shipping Labels Bereich wieder einrichten???

Ihr müsst euren Benutzernamen und das Passwort für das Weblogin von UPS haben.
Man wird auf die Website weitergeleitet und loggt sich ein.

Das war es auch schon.
Die alten Versandarten können weiter genutzt werden.
 

TobiasN82

Aktives Mitglied
25. Januar 2019
47
5
Hi,
wir haben heute das Update auf 1.9.4.1 gemacht und beim Drucken über den Packtisch bekommen wir den folgenden Fehler beim Versand mit UPS:

15.05.2024 11:47:32

Originalmeldung
Meldung: {"response":{"errors":[{"code":"120100","message":"Missing or invalid shipper number"}]}}

Code: BadRequest

ID: ac296df3-5a31-4207-ab63-88a9f6f29b84

Typ: Error

Source: Provider

Woran kann das liegen?
VG
Tobias
 

TobiasN82

Aktives Mitglied
25. Januar 2019
47
5
Problem gelöst, bei Kundennummer muss die Kundennummer von UPS rein. Bei mir stand da noch der Benutzername von vor dem Update.
 
  • Gefällt mir
Reaktionen: recent.digital

Ähnliche Themen