In Bearbeitung iZettle-Netzwerk-Fehler seit JTL-POS 1.0.3.4

Nachto

Mitglied
17. Dezember 2019
47
6
Guten Tag,

seit dem Update auf JTL-POS 1.0.3.4 (ERPConnected, auf Chromebox 3) kommt es bei der Nutzung mit iZettle sehr häufig vor (davor noch nie), dass keine Kartenzahlungen über iZettle mehr durchgeführt werden können und in JTL-POS nach der PIN-Eingabe durch den Kunden der Fehler kommt, dass das Gerät nicht mit dem Internet verbunden sei und man die Netzwerkeinstellungen prüfen soll. Gesagt getan - der Browser funktioniert einwandfrei, ebenso die restlichen Apps mit Internet.
Das einzige was Abhilfe schafft ist das Neustarten des kompletten Rechners - irgendwann tritt das Problem jedoch erneut auf.

Die Kasse selber ist mit dem Internet per LAN verbunden und in anderen Apps funktioniert das Internet einwandfrei nur bei der Kartenzahlung meckert er plötzlich.
Ob dies nun im Zusammenhang mit dem Update steht kann ich nicht sagen, jedoch klappte es vor dem Update einwandfrei, was mich darauf schließen lässt das es daran liegt.
 

Stefan_F

Moderator
Mitarbeiter
21. Juli 2017
284
49
Hallo Nachto,

unsere Entwicklung hat mir soeben bestätigt, dass es hier keine Änderungen gab.
Bisher ist uns ein solches Verhalten nur bekannt, wenn die 2,4Ghz WLAN-Verbindung, die im ähnlichen Bereich funkt, wie die Bluetooth-Verbindung, das Signal beeinträchtigt. Falls möglich, kann ich empfehlen das WLAN-Netzwerk auf 5Ghz umzustellen, sodass die Verbindung weniger gestört wird. Wir prüfen das Ganze aber intern zusätzlich noch einmal mit unseren Geräten.

Gruß Stefan
 
Zuletzt bearbeitet:

Nachto

Mitglied
17. Dezember 2019
47
6
Hallo Stefan,

vielen Dank für die schnelle Rückmeldung!
Ich werde ebenfalls einmal prüfen ob das 2,4 GHz-Band aktiv ist. Das kuriose ist das wir ebenfalls nichts an der technischen Seite verändert haben und dieser Fehler erst seit dem Update auftreten tut.
Auch ist die Fehlermeldung etwas kurios, da diese im iZettle-Bezahlfenster ist nachdem der Kunde die PIN bestätigt hat und "Warte..." kam. Auch bei erneutem Starten des Zahlvorganges klappt die Verbindung zwischen Kasse und iZettle problemlos - der Kunde kann erneut die PIN eingeben und es wird auf dem Kassendisplay visuell dargestellt wie die Ziffern eingegeben werden. Nach Bestätigung und warten kommt dann wieder der selbe Fehler - dass keine Netzwerkverbindung aufgebaut werden konnte. Was für mich so klingt, als könne iZettle nicht aus der App heraus zu den iZettle-Servern kommunizieren. Aber das ist auch nur eine Vermutung. Denn wenn das Bluetooth-Signal gestört wäre würde der Rest (Kommunikation mit dem Terminal z.B.) nicht funktionieren.

Ich hoffe dass die Infos ein Stück weiterhelfen.
 

Nachto

Mitglied
17. Dezember 2019
47
6
Hallo,

einmal ein kleines Update.
Heute haben wir einen weiteren Fehler, welcher ebenfalls mit iZettle zusammenhängt. Und zwar haben wir gerade das Problem, dass sobald man Artikel in den "Warenkorb" packt und auf "Zur Kasse" geht diese extrem langsam lädt. Es kommt so vor, als wenn nichts passiert. Wenn man anschließend in den Kategorien/Favoriten geht ist alles verschwunden. Nach einiger Zeit (knapp 1 Minute) öffnet sich dann der "Zur Kasse"-Dialog und alles klappt wieder. Wenn ich während es lädt in die Einstellungen gehe laden alle Unterpunkte - bis auf die Zahlungsanbieter, dort ist nur eine weiße Seite.
Wenn nun der Dialog "Zur Kasse" geöffnet wurde und ich dann in den Einstellungen auf "Zahlungsanbieter" gehe ist alles wie vorher.

Freundliche Grüße
Nachto

Nachtrag: Testweise habe ich in der JTL-POS unter Zahlungsarten den iZettle rausgelöscht und anschließend neu angelegt und die Verbindung gelöst. Danach wurde der iZettle-Kartenleser neu verbunden und nun scheint alles bisher einwandfrei wie vorher zu funktionieren. Eventuell hat sich da beim Update im System vertüdelt. Bleibt abzuwarten ob dadurch auch der Netzwerkfehler behoben ist :)
 
Zuletzt bearbeitet:

Stefan_F

Moderator
Mitarbeiter
21. Juli 2017
284
49
Hallo Nachto,

klingt für mich tatsächlich eher nach einem Problem mit dem Netzwerk und der Kommunikation selbst oder aber dem Gerät.
Prüfe am besten nochmal das Netzwerk und ob die Verbindung zwischen den Geräten stabil ist.
Des Weiteren kannst du mal schauen, ob es irgendwelche Besonderheiten beim Gerät gibt. In den App-Einstellungen kann man dazu auch den Cache und den Speicherplatzbedarf von JTL-POS einsehen. Vielleicht ist der Cache sehr voll oder sogar der Gerätespeicher selbst bald ausgeschöpft.

Gruß Stefan
 

Nachto

Mitglied
17. Dezember 2019
47
6
Hallo Stefan,

also das Problem tritt weiterhin auf, keine Netzwerkverbindung laut iZettle (ERPConnect funktioniert zeitgleich trotzdem, also die Synchronisierung) und nach einem Neustart klappt alles wieder.
Bezüglich des WLAN's habe ich heute mal nachgeschaut und bemerkt, dass das 2,4 GHz-Band doch aktiv ist - ich schaue mal welche Geräte bei uns dieses unbedingt benötigen und schalte es ansonsten ab zum testen.

Beim Speicherplatz habe ich ebenfalls nachgeschaut - laut OS sind noch insgesamt 16 GB Speicherplatz frei. Wegen des Caches von JTL-POS hatte ich nun leider nicht explizit geschaut, falls dieser "sehr voll" ist, kann man diesen Bedenkenlos löschen oder sollte vorher eine Sicherung durchgeführt werden der JTL-POS (höchstwahrscheinlich würde ich dies aus Prinzip schon tun).

Langsam sind wir auch am überlegen auf ein Terminal mit O.P.I-Schnittstelle umzusteigen um diese Problematik nicht mehr so zu haben - von den Gebühren her gleicht sich das hochgerechnet sogar fast aus.

Ich werde mal weiter probieren und dann berichten, vielen Dank auf jeden Fall für die Hilfestellung!

Freundliche Grüße
Nachto
 

Stefan_F

Moderator
Mitarbeiter
21. Juli 2017
284
49
Hallo Nachto,

das Thema mit der 2,4 Ghz WLAN-Verbindung würde ich nach Möglichkeit auf jeden Fall einmal testen.

Was das Thema mit dem Cache angeht. Hier kann in den App-Einstellungen unter dem Punkt Speicher der Cache geleert werden. Hier sieht man auch, wie groß dieser aktuell ist. Ich würde aber trotzdem vorher auch immer ein Backup der POS-Datenbank empfehlen, damit du hier auf gar keinen Fall Daten verlierst. Auch wenn das eine mit dem anderen normalerweise nichts zu tun hat. Und da ja eh noch genug Speicher auf dem Gerät selbst frei ist, sollte das kein Problem darstellen.

Was das Thema über OPI angeht. Es ist sicherlich ein Vorteil hier Geräte zu nutzen, die z.B. über LAN angebunden werden können, da aus der Natur der Sache die Verbindung hier deutlich stabiler und weniger störungsanfälliger läuft.

Gruß Stefan
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
In Bearbeitung iZettle Zahlung - und danach kein Abschluß des Bons Allgemeine Fragen zu JTL-POS 9
Gelöst Epson Tm m30 + TSE mit Wlan Netzwerk verbinden Gelöste Themen in diesem Bereich 1
Neu WAWI DB Update Fehler eines Mandanten User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim Abgleich JTL nach WooCommerce User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim Abgleich: Der Remoteserver hat einen Fehler zurückgegeben: (504) Gatewaytimeout. WooCommerce-Connector 0
Neu Fehler bei Datenbanksicherung JTL-Wawi - Fehler und Bugs 1
Neu Kunden Login Fehler Undefined index: kundenlogin_max_loginversuche in ... JTL-Shop - Fehler und Bugs 1
Neu Fehler beim Abgleich: Exception: Error while encoding into JSON: Malformed UTF-8 characters, possibly incorrectly encoded WooCommerce-Connector 5
Neu Datevconnect Rechnungsdatenservice: Fehler beim erstellen des XML übertragungsformates Schnittstellen Import / Export 0
In Bearbeitung Undefinierter Fehler / Absturz bei Bon starten JTL-POS - Fehler und Bugs 7
Gelöst TSE Anbindung TM-30 Fehler "TSE1_ERROR_SIG_ERROR" Einrichtung / Updates von JTL-POS 1
Beantwortet LS POS 2.0.0 Fehler - keine Kassen-OID Fragen rund um LS-POS 1
Abgelehnt Unexpected character encountered FEHLER Gelöste Themen in diesem Bereich 1
Neu Unexpected character encountered FEHLER JTL-ShippingLabels - Fehler und Bugs 2
Neu 500 Remote Server Fehler Amazon-Anbindung - Fehler und Bugs 7
Neu EBAY FEHLER Die datediff-Funktion hat zu einem Überlauf geführt. Die Anzahl von datepart-Werten, die zwei Datums-/Uhrzeitinstanzen trennen,ist zu groß JTL-Wawi - Fehler und Bugs 2
Neu Exportdokumente Fehler bei Auftragswert 0 für DHL und Warenpost International User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim hochladen mit der Ameise JTL-Ameise - Fehler und Bugs 10
Gelöst Fehler beim Mailversand JTL-Shop - Fehler und Bugs 1
Neu Internetmarke Fehler Code 9000003 JTL-ShippingLabels - Fehler und Bugs 5
Neu Fehler 0 in Kategoriebeschreibung Onlineshop-Anbindung 0
Neu Wawi Print Log Beim Exportieren ist ein Fehler aufgetreten Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Fehler bei erster Anbindung eBay-Anbindung - Fehler und Bugs 2
Neu Fehler bei der Installation + Datenbank Installation von JTL-Wawi 4
Neu Fehler beim Abgleich neu eingestellter Produkte. JTL-Wawi - Fehler und Bugs 0
In Bearbeitung Fehlercode 6039 und SKU / GCID Fehler Amazon-Anbindung - Fehler und Bugs 6
JTL Shop 5 unter "localhost" Fehler beim Setzen des Cookies Einrichtung JTL-Shop5 0
In Bearbeitung Es ist ein Fehler aufgetreten! JTL-muss beendet werden.1.0.3.12 (3573) Einrichtung / Updates von JTL-POS 1
Neu Shop 5.0.1: Artikel in 1. Kat führt zu Fehler 500 JTL-Shop - Fehler und Bugs 5
Neu Product-Stream Fehler nach dem Sliden JTL-Shop - Fehler und Bugs 1
Neu Fehler Shopabgleich WooCommerce-Connector 0
Neu Shop 5 - Nova Template Umlaute/Sonderzeichen Fehler im Kundenmenü/Registrierung Templates für JTL-Shop 8
In Bearbeitung Fehler in JTL-POS-Display App JTL-POS - Fehler und Bugs 1
Neu 5.0.1 - Fehler OnPage Composer JTL-Shop - Fehler und Bugs 0
Neu IDU Upload Fehler Schnittstellen Import / Export 9
Neu Fehler beim Update auf die neue Version der JTL Wawi User helfen Usern - Fragen zu JTL-Wawi 2
Neu Fehler beim Update auf die neue Version der JTL Wawi User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim Update auf die neue Version der JTL Wawi User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim Update auf die neue Version der JTL Wawi User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung (wahrscheinlich kein Fehler) JTL-POS erkennt besonderen EAN/ISBN nicht als Artikel JTL-POS - Fehler und Bugs 2
Neu Wawi Datenabgleich mit JTL Shop 5.0.1 nicht möglich - Fehler 8 JTL-Wawi - Fehler und Bugs 0
Neu Fehler Erstellung XRechnung User helfen Usern 0
Neu Neuerstellung von Produktseiten IT, FR, ES nicht lösbarer Fehler Amazon-Lister - Fehler und Bugs 2
Neu Fehler beim Einspielen des Backups auf neuem Rechner Installation von JTL-Wawi 7
Neu Rechnungskorrektur - gleicher Baustein in Drucken Mailen Speichern - Fehler bei Mailen, Speichern Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Fehler bei Update auf 1.5.41.0 Installation von JTL-Wawi 2
Neu Fehler bei JTL Rückübertragung der Zahlung in den Shop PrestaShop-Connector 5
Neu Dotliquid: {% break %} wirft Fehler JTL-Wawi - Fehler und Bugs 0
Neu Rundungs-Fehler 0% Steuersatz Tagesabschluss Allgemeine Fragen zu JTL-POS 6
Gelöst Fehler im Druck des Kassenbuches / Unterschiedlich für unterschiedliche Zeiträume Gelöste Themen in diesem Bereich 2
Ähnliche Themen