Neu Fehler im Warenkorb

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

basteldehs

Sehr aktives Mitglied
27. Februar 2017
719
109
Chemnitz
Hi,
so es gibt noch ein Fehlerchen im Warenkorb, also wenn ich auf das Warenkorb-Icon klicke komme ich ja zum Warenkorb und da erscheint de Fehler, über den Button Zur Kasse, siehe Foto
fehler-warenkorb.jpg

grüssle Mario
 

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
61
22
Hallo @basteldehs ,

das ist nur eine "Decprecation Meldung", es wird also auf alten "Dinge" zugegriffen, was aber prinzipiell noch funktioniert.
Insofern alles auf dem neusten Stand ist sollte das dennoch nicht auftreten, daher 2 Ideen:
- Template Cache löschen
- falls du den entsprechenden {block} in einem Child-Template überschrieben hast, müsstest du das entsprechend anpassen

Viele Grüße
Michael
 

basteldehs

Sehr aktives Mitglied
27. Februar 2017
719
109
Chemnitz
Hi MHillman,
Danke für die Info, jedoch gibt es noch eine Notice: Undefined index beim Einloggen aufs Kundenkonto
warenkorb.jpg

Im Child-Template habe ich nur die header.tpl und footer.tpl

Jedoch die Meldung ist noch da, obwohl Chache geleert.

Wenn man ware in den Korb legt
Notice: Undefined index: warenkorbpers_nutzen in /www/hxxxxxs/xxxxxxxx/modellbaubedarf.eu/includes/src/Cart/PersistentCart.php on line 500

und die Meldung vom Warenkorb ist auch noch da
Deprecated: JTL\Checkout\Versandart: getter should be used to get cCountryCode in /www/xxxs/xxxxxx/modellbaubedarf.eu/includes/src/MagicCompatibilityTrait.php on line 34

grüsse Mario
 

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
61
22
Es ist völlig okay Bescheid zu geben wenn es irgendwo Meldungen gibt.

Notice: Undefined index: warenkorbpers_nutzen
Das wurde vor ca. 2 Tagen in der entsprechenden Migration behoben, dafür müsstest du die Migration "Remove unused settings" vom 10.7 nochmal erneut ausführen.

Die "Deprecation Meldung" hatte ich auch gerade, als ich von einem alten Branch auf den aktuellen master gewechselt habe. Es hat bei mir geholfen den Template- Cache zu leeren. Also unter "Administration > System > Cache" und dann der Button unten rechts "Gesamten Template Cache leeren".

Viele Grüße
Michael
 

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
61
22
Unter "Administration > System > Aktualisieren" kannst du einzelne Migrationen erneut ausführen.

Es kann aber sein, dass du dafür in der config.JTL- Shop.ini.php noch folgendes einfügen musst:
define('ADMIN_MIGRATION', true);
 

DRaufeisen

Moderator
Mitarbeiter
3. Mai 2016
61
9
Halle (Saale)
Irgendwie hast du es geschafft, eine Migration rückgängig zu machen, die von 2016 ist. Das ist jetzt doof...
Ich glaub da hilft es nur, die Migrationsdatei manuell zu löschen. Das ist die "20160209145631_mailtemplate_adminpwlost.php" unter updates/migrations
 

basteldehs

Sehr aktives Mitglied
27. Februar 2017
719
109
Chemnitz
jep, habe die datei mal gelöscht, von 2016 hatte ausversehen auf so einen Orangen Knopf gedrückt bei Erfolgreiche Migrationen und das war die 20160209145631_mailtemplate_adminpwlost

:)
 

DRaufeisen

Moderator
Mitarbeiter
3. Mai 2016
61
9
Halle (Saale)
Naja, du arbeitest ja auch gerade mit einem Bleeding-Edge System. Nach dem Release können wir keine ausgelieferten Migrationen mehr modifizieren und es sollte auch nicht notwendig sein, einzelne Migrationen anzupacken.
 

basteldehs

Sehr aktives Mitglied
27. Februar 2017
719
109
Chemnitz
zb. das noch ein Fehler (Notice) drin ist, sobald ich mich im Kundenkonto anmelde oder schon was im Warenkorb habe und mich dann als Kunde Anmelde (mit vorhandenen Kunden Konto )

anmelden-warenkorb.jpg

bei weiteren Bestelldurchgang, kommen keine Fehler mehr

grüssle Mario
 

basteldehs

Sehr aktives Mitglied
27. Februar 2017
719
109
Chemnitz
habe ich auch nichr vor die einfach durchzuklicken, ich schalte dann mal lieber wieder define('ADMIN_MIGRATION', false); auf false, nicht das ich zu viel blödsinn mache :)
Nach dem Release können wir keine ausgelieferten Migrationen mehr modifizieren und es sollte auch nicht notwendig sein, einzelne Migrationen anzupacken
ist ausversehen passiert

:) :)
 

basteldehs

Sehr aktives Mitglied
27. Februar 2017
719
109
Chemnitz
man sollte auch bedenken:
für den Programmierer sieht es fast immer einfach und logisch aus,
für den Anwender der keine Ahnung bis bisl Ahnung hat, so wie ich dor Mario, der überall drauf klickt was geht :) da kommen eben die Fehler her, was euch ja auch zugute kommt um solche Fehler zu entdecken und zu vermeiden.

ODER?

Ansonsten kann ich jederzeit den Shop neu aufsetzen. Wir befinden uns ja in der Testphase.

grüssle Mario
 

basteldehs

Sehr aktives Mitglied
27. Februar 2017
719
109
Chemnitz
es ist ja auch ein Phänomen, das nach dem kleinen Updatet, die Fotos Artikel, Kategorie, Neu im Sortiment und Top Angebot wieder nicht sichtbar sind.
Obwohl, der Cache im Adminbereich ( System --> Cache ) und ( Fehlerbehebung --> Bilder ) und Browser Cache gelöscht und sogar im Ordner template_c mal gelöscht.

Na das muss mal einer erklären, wie das Phänomen zustande kommt.

Dies sollte, gerade in einem neuen System nicht mehr vorkommen, Oder?

Ich möchte es ja nur verstehen.

grüssle Mario
 

basteldehs

Sehr aktives Mitglied
27. Februar 2017
719
109
Chemnitz
es ist ja auch ein Phänomen, das nach dem kleinen Updatet, die Fotos Artikel, Kategorie, Neu im Sortiment und Top Angebot wieder nicht sichtbar sind.
Obwohl, der Cache im Adminbereich ( System --> Cache ) und ( Fehlerbehebung --> Bilder ) und Browser Cache gelöscht und sogar im Ordner template_c mal gelöscht.
also das Phänomen mit den Bildern habe ich gefunden und zwar lag es an der neuen header.tpl die heute geupdatet wurde ( im NOVA Template ) und ich hatte in meinem Child-Template noch von Anfang der Woche die header.tpl drin ( habe momentan nur die eine drin ) habe diese auch erneuert und jetzt sind die Bilder auch wieder da.

freu, freu und grüssle Mario
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Shop 5 RC3 - kleiner Fehler bei "noindex" von Merkmalen JTL-Shop - Ideen, Lob und Kritik 0
Neu Fehler bei der Authentifizierung. Das Passwort in den Online Shop Einstellungen ist falsch. WooCommerce-Connector 0
Neu Fulfillment Network Abgleich Fehler -> Benachrichtung per Email User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung Fehler bei Layoutauswahl JTL-Wawi - Fehler und Bugs 2
Neu Shop5 Installation Fehler URL install.php?task=doinstall nicht erreichbar JTL-Shop - BETA - Feedback und Bugmeldungen 4
Neu Fehler bei Mahnlauf JTL-Wawi - Fehler und Bugs 1
Offen Nova Auswahlassistent - 2 Fehler gefunden JTL-Shop - BETA - Feedback und Bugmeldungen 3
Neu Worker zeigt oft Fehler bei Ebay Abgleich 1.5.31.0 User helfen Usern - Fragen zu JTL-Wawi 7
Neu Fehler beim Scannen von Artikeln - Artikel nicht gefunden! ABER es gibt ihn doch! JTL-POS - Fehler und Bugs 12
Neu Woher kommt der Fehler "CSRF-Warnung fuer Login: 1" in den JTL Logs? Allgemeine Fragen zu JTL-Shop 0
Gelöst Fehler bei Beendigung Objektname "Timer" nicht gefunden Gelöste Themen in diesem Bereich 2
Neu Fehler in Export- CSV der Bons JTL-POS - Fehler und Bugs 1
In Bearbeitung [WAWI-50281] Schwerer Fehler in dot liquid führt zu Fehlberechnungen - Typen Deklaration Problem JTL-Wawi - Fehler und Bugs 18
Neu Versanddaten mit Fehler bei Umlagerungen erneut exportieren User helfen Usern - Fragen zu JTL-Wawi 1
Gelöst Fehler bei Cond(Page() == 1, 110, 10) Gelöste Themen in diesem Bereich 3
Neu Workflow Fehler bat Datei wird nicht ausgeführt User helfen Usern - Fragen zu JTL-Wawi 1
Neu schwerwiegender Fehler nach Buchung Barentnahme nach Tagesabschluß JTL-POS - Fehler und Bugs 6
Neu Fehler bei Sichtbarkeit Kundengruppe(Rabatt) nach Aktivierung von Kategorie für die JTL-POS JTL-POS - Fehler und Bugs 2
Gelöst Fehler beim Erstellen des FBA Anlieferplans - Missing_Dimensions Amazon-Lister - Fehler und Bugs 3
In Diskussion TSE1_ERROR_TRANSACTION_NOT_STARTED - unbehebbaren Fehler in 1.0.2.8 JTL-POS - Fehler und Bugs 4
Abgelehnt Fehler bei Update: "SQLSTATE[42S22]: Column not found: 1054 Unknown column 'l.type' in 'field list'" Gelöste Themen in diesem Bereich 4
Neu Datenbank Fehler - tpreise Spalte kKundengruppe in tpreise nicht vorhanden JTL-Shop - Fehler und Bugs 1
Gelöst [Deutsche Post] UPDATE: 09.10.20 Fehler beim erstellen der Versandetiketten Gelöste Themen in diesem Bereich 1
Neu Smarty Syntax-Fehler JTL-Shop - BETA - Feedback und Bugmeldungen 1
Neu Fehler im Shop bei Passwort JTL-Shop - Fehler und Bugs 6
Fehler bei Update auf Version>= 1.5.30.x JTL-Wawi - Fehler und Bugs 2
In Bearbeitung JTL 1.5.30.3 Fehler: "Kein gueltiges Bild hinterlegt." User helfen Usern - Fragen zu JTL-Wawi 3
Neu CLS Fehler in Search Console Allgemeine Fragen zu JTL-Shop 3
Neu Wann kommt die nächste Connector Version? Nächster Fehler Modified eCommerce-Connector 0
Neu Onlineshop Abgleich Fehler Woocomerce Connector Onlineshop-Anbindung 6
Gelöst PayPal Express - Fehler im Log Plugins für JTL-Shop 2
In Bearbeitung Leeres Feld "Produktart" führt bei Ebay zu Fehler eBay-Anbindung - Fehler und Bugs 5
Neu Fehler nach öffnen einer E-Mail Servicedesk (Beta) 5
Gelöst Kritischer Fehler - JTL Shop 4 Gutschein + Konfigurator Plugins für JTL-Shop 2
Gelöst 02.10.2020 Ebay Abgleich Fehler Gelöste Themen in diesem Bereich 2
Neu Fehler beim versenden der Emails über ServiceDesk Servicedesk (Beta) 5
Neu JTL Shopware Connector Fehler beim Import von Kunden und Bestellungen Onlineshop-Anbindung 2
Verwiesen an Support JTL Fehler beim Ausliefern JTL-Wawi - Fehler und Bugs 1
Gelöst Prime by Seller, Fehler beim erstellen des DPD Etiketts Amazon-Anbindung - Fehler und Bugs 2
In Bearbeitung Worker ebay Abgleich zeigt heute stets Fehler User helfen Usern - Fragen zu JTL-Wawi 10
In Bearbeitung Fehler bei Artikeleinstellen auf Ebay: "Produktart fehlt" User helfen Usern - Fragen zu JTL-Wawi 4
Neu DHL Versenden 3.0 einrichten - Verursacht Fehler JTL-ShippingLabels - Fehler und Bugs 2
Neu WAWI Mail-Einstellungen SMTP "Verbindung testen" Fehler beim Versenden der E-Mail JTL-Wawi - Fehler und Bugs 10
Neu Fehler im Connector 3.0 Modified eCommerce-Connector 1
Neu Fehler nach Update 1.5.30.0 - Aufragsdruck sql_variant-Datentyp in Datetime & IGL Problem Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 15
Gelöst Fehler nach Update von 1.0 auf 1.5.29.3 Gelöste Themen in diesem Bereich 3
Neu Ausliefern Fehler 1.5.30 Tracking ID auf Rechnung fehlt! JTL-Wawi - Fehler und Bugs 2
Gelöst Login zur Datenbank Fehler 772 Installation von JTL-Wawi 1
Neu Fehler nach Update auf 1.5.30.0 beim Mailen JTL-Wawi - Fehler und Bugs 26
In Bearbeitung Ameis Import Fehler! Vorgang wurde abgebrochen????? JTL-Ameise - Fehler und Bugs 2
Ähnliche Themen