Neu Fehler beim Onlineshop-Abgleich > prices[0].vat ist NULL

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

antigravity

Neues Mitglied
22. Dezember 2020
3
1
Hallo zusammen,

vorab muss ich sagen das ich die JTL Wawi erst austeste und ich möchte sie wirklich mögen, glaubt mir. Aber ich habe Probleme die mich jetzt schon sehr viele Stunden und Aggresionen gekostet haben. Da ich hier im Forum nichts gefunden habe hier mein Problem:

Ich versuche meinen Shopware Shop initial einmal in die Wawi zu laden und das funktioniert auch bei den Kategorien, Herstellern, Aufträgen und Co. Jedoch nicht bei den Artikeln. Da wird sofort abgebrochen mit folgender Meldung:

Das NULL-Objekt kann nicht in einen Werttyp konvertiert werden.
Error converting value {null} to type 'System.Decimal'. Path 'prices[0].vat'.
bei System.Convert.ChangeType(Object value, Type conversionType, IFormatProvider provider)
bei Newtonsoft.Json.Serialization.JsonSerializerInternalReader.EnsureType(JsonReader reader, Object value, CultureInfo culture, JsonContract contract, Type targetType)


Shopware Version: 5.6.9
JTL-Wawi Version: 1.5.36.0
Connector Version: 2.8.2

Ich habe bereits meine kompletten Artikel aufgeräumt und schön alle Werte gefüllt gemäß Recherche hier im Forum: purchase_price, price_EK, price_H usw ... Auch die Tax Id's passen bei allen Artikeln.
Und trotzdem bekomme ich diese Meldung.

Hier ein Sample Datensatz:

<<< product.pull: {"result":[{"basePriceUnitId":["",0],"id":["1414_46",0],"manufacturerId":["2",2],"masterProductId":["",0],"measurementUnitId":["",0],"partsListId":["",0],"productTypeId":["",0],"shippingClassId":["",0],"unitId":["",0],"additionalHandlingTime":0,"asin":"","availableFrom":null,"basePriceDivisor":0,"basePriceFactor":0,"basePriceQuantity":0,"basePriceUnitCode":"","basePriceUnitName":"","considerBasePrice":false,"considerStock":true,"considerVariationStock":false,"creationDate":"2020-01-01T00:00:00+0100","discountable":true,"ean":"","epid":"","hazardIdNumber":"","height":0,"isActive":false,"isBatch":false,"isBestBefore":false,"isbn":"","isDivisible":false,"isMasterProduct":true,"isNewProduct":false,"isSerialNumber":false,"isTopProduct":false,"keywords":"","length":0,"manufacturerNumber":"","manufacturer":null,"measurementQuantity":0,"measurementUnitCode":"","minBestBeforeDate":null,"minimumOrderQuantity":1,"minimumQuantity":0," modified":null,"newReleaseDate":null,"nextAvailableInflowDate":null,"nextAvailableInflowQuantity":0,"note":"","originCountry":"","packagingQuantity":0,"permitNegativeStock":true,"productWeight":0,"purchasePrice":0,"recommendedRetailPrice":0,"serialNumber":"","shippingWeight":0,"sku":"AGD10046.0","sort":0,"stockLevel":{"productId":["1414_46",0],"sku":"","stockLevel":99},"supplierDeliveryTime":0,"supplierStockLevel":0,"taric":"","unNumber":"","upc":"","vat":16,"width":0,"attributes":[{"id":["1540_27",0],"productId":["",0],"isCustomProperty":false,"isTranslated":false,"i18ns":[{"productAttrId":["1540_27",0],"languageISO":"ger","name":"sfExport","value":"1"}]},{"id":["price_group_id",0],"productId":["",0],"isCustomProperty":false,"isTranslated":false,"i18ns":[{"productAttrId":["price_group_id",0],"languageISO":"ger","name":"price_group_id","value":"1"}]}],"categories":[{"categoryId":["27",23],"id":["",0],"productId":["1414_46",0]}],"checksums":[],"configGroups":[],"customerGroupPackagingQuantities":[],"fileDownloads":[],"i18ns":[{"productId":["1414_46",0],"deliveryStatus":"","description":"<p>Profi Kurse sind immer exklusive Verbandsmaterialien<\/p>","languageISO":"ger","measurementUnitName":"","metaDescription":"","metaKeywords":"","name":"Divemaster","shortDescription":"","titleTag":"","unitName":"","urlPath":""}],"invisibilities":[],"mediaFiles":[],"partsLists":[],"prices":[{"customerGroupId":["1",0],"customerId":["",0],"id":["1414_46_0",0],"productId":["1414_46",0],"sku":"","vat":null,"items":[{"productPriceId":["1414_46_0",0],"netPrice":508.62068965516999696774291805922985076904296875,"quantity":1}]},{"customerGroupId":["",0],"customerId":["",0],"id":["1414_46_0",0],"productId":["1414_46",0],"sku":"","vat":null,"items":[{"productPriceId":["1414_46_0",0],"netPrice":508.62068965516999696774291805922985076904296875,"quantity":0}]}],"specialPrices":[],"specifics":[],"varCombinations":[],"variations":[{"id":["1414_46_6",0],"productId":["1414_46",0],"sort":2,"type":"radio","i18ns":[{"productVariationId":["1414_46_6",0],"languageISO":"ger","name":"Verband"}],"invisibilities":[],"values":[{"id":["1414_46_6_5",0],"productVariationId":["1414_46_6",0],"ean":"","extraWeight":0,"sku":"","sort":0,"stockLevel":0,"extraCharges":[],"i18ns":[{"productVariationValueId":["1414_46_6_5",0],"languageISO":"ger","name":"PADI"}],"invisibilities":[]},{"id":["1414_46_6_6",0],"productVariationId":["1414_46_6",0],"ean":"","extraWeight":0,"sku":"","sort":0,"stockLevel":0,"extraCharges":[],"i18ns":[{"productVariationValueId":["1414_46_6_6",0],"languageISO":"ger","name":"SDI\/TDI"}],"invisibilities":[]}]}],"warehouseInfo":[]}],"error":null,"jtlrpc":"2.0","id":"699ffee842034e258319bba1bc937bd9"}


Es handelt sich hier um einen Artikel mit zwei Varianten. Im Hauptartikel steht hier auch noch der Wert 16 drin. Man findet aber auch zweimal den Wert NULL.

Hat jemand eine Idee?
Bitte melden wenn noch mehr Informationen gebraucht werden.
 

Anhänge

McAvity

Sehr aktives Mitglied
7. September 2016
481
112
@antigravity

Das Problem sollte darin liegen, dass die Varianten, im Gegensatz zum Vaterartikel, keinen MwSt.-Satz hinterlegt haben.
Trag bei den Varianten den korrekten MwSt.-Satz ein und der Import sollte funktionieren.

Die relevanten Ausschnitte sind die folgenden:

-Varterartikel:
"productId":["1414_46",0],"sku":"","stockLevel":99},"supplierDeliveryTime":0,"supplierStockLevel":0,"taric":"","unNumber":"","upc":"","vat":16,"
- Kindartikel:
"id":["1414_46_0",0],"productId":["1414_46",0],"sku":"","vat":null,
Das Problem liegt hierbei anscheinend bei Shopware, da beim Erstellen der Kindartikel wohl manchmal der MwSt.-Satz des Vaterartikels "flöten" geht (neben anderen Daten).
Probelm besteht wohl auch in Shopware 6, zumindest gibt es da ein paar Einträge im Issuetracker.

MfG

McAvity
 

antigravity

Neues Mitglied
22. Dezember 2020
3
1
Danke @McAvity für die Rückmeldung. Das Problem ist allerdings das sich die Steuern nicht wirklich einstellen lassen. Wenn ich einen Export/Import inklusive der Variantenartikel mache dann steht die Steuer bei den Varianten überall richtig drin. Auf der Datenbank sind Varianten allerdings anders abgebildet und haben nicht mal ein Tax Feld in irgend einer Form. In der Artikel Tabelle hat auch jede Zeile einen Tax Wert drinstehen.

Kann es sein das der Connector das vom Vaterartikel übernehmen sollte wenn sich das in der Shopware Oberfläche nicht mal einzeln einstellen lässt?

Wenn das allerdings ne allgemeine Sache ist dann müssten ja viele andere auch diese Probleme haben .... sehr seltsam.
 

McAvity

Sehr aktives Mitglied
7. September 2016
481
112
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Fehler 32600 Fehler beim OnlineShop-Abgleich zw. JTL WAWI und Shopify Shopify-Connector 0
Neu Fehler beim Datenbankexport JTL-Wawi - Fehler und Bugs 7
Neu Fehler beim Update der WAWI auf eine Version ab 1.5.40 Installation von JTL-Wawi 9
In Bearbeitung Fehler auf Übertragungsebene beim Empfang von Ergebnissen vom Server. (provider: Session Provider, error: 18 - Verbindung von Peer geschlossen) eBay-Anbindung - Fehler und Bugs 1
Neu Fehler beim versenden von Rechnungen per mail User helfen Usern - Fragen zu JTL-Wawi 0
Gelöst Seit gestrigem Win10 Update Fehler beim DHL Label Druck JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 3
Neu Fehler beim Ausliefern von Aufträgen - Ein ungültiger Längenparameter wurde an die LEFT- oder SUBSTRING-Funktion.... V1.5.38.1 JTL-Wawi - Fehler und Bugs 9
Neu Fehler in der Version 1.3.0.0 beim Befehl: JTL-Wawi - Fehler und Bugs 4
Neu Fehler 504 und Abbruch beim OnlineAbgleich JTL-Shop - Fehler und Bugs 2
Neu Fehler beim Erstellen des Fensterhandles. JTL-Wawi - Fehler und Bugs 0
Neu Probleme seit Update auf 1.5.38.1 : keine Amazon FBA Bestellungen mehr und Fehler beim Zugriff auf Wawi Logbuch Amazon-Anbindung - Fehler und Bugs 1
Neu Fehler beim Übertragen von Artikeln (Produktbeschreibung) WooCommerce-Connector 0
Neu Version 1.5.38.0 Fehler beim Neuanlegen von Artikeln nach Amazon JTL-Wawi - Fehler und Bugs 1
Neu Gambio Abgleich Fehler beim Produktabgleich/Bilder Gambio-Connector 9
Neu Fehler beim Gambio Connector Fehlermeldung Payment Gambio-Connector 18
Neu Problem beim buchen der Inventurbestände (DB Fehler) JTL-Wawi - Fehler und Bugs 0
In Diskussion 16.01.2021 16:54:27Originalmeldung Meldung: Fehler beim Erstellen der HTTP-Anforderung für https://api.jtl-shipping.de/dhl/JtlWebApi.svc. JTL-ShippingLabels - Fehler und Bugs 2
Verwiesen an Support Fehlermeldung beim Labelerstellen: Fehler (Fehler bei Entschlüsselungsvorgang, siehe interne Ausnahme.) beim Übertragen von Daten über den HTTP-Kanal. JTL-ShippingLabels - Fehler und Bugs 1
Neu Fehler beim Export von Datev Rechnungs Daten Schnittstellen Import / Export 1
Neu [Fehler] Gambio Abgleich Fehler beim Produktabgleich Gambio-Connector 1
Neu Fehler beim Ausführen des Testskript für Shop 5 Installation / Updates von JTL-Shop 10
Neu Fehler und Abbruch beim Shopabgleich zu Shopware User helfen Usern - Fragen zu JTL-Wawi 3
Neu Fehler beim Speichern und Drucken einer Lagerbewertung JTL-Wawi - Fehler und Bugs 5
Neu Fehler beim Ausliefern Auftrag wird nicht ausgeliefert: Keine Teillieferung erlaubt JTL-Wawi - Fehler und Bugs 4
Neu Fehler beim aktivieren des Consent Managers in Shop 5.0 Installation / Updates von JTL-Shop 4
Neu Fehler beim importieren vom Template Themeart User helfen Usern - Fragen zu JTL-Wawi 0
Neu JTL-Shop 5 - Fehler beim Scrollen zum Seitenende (Smartphone) JTL-Shop - Fehler und Bugs 2
Gelöst Fehler beim Einstellen von Artikle Ebay eBay-Anbindung - Fehler und Bugs 4
Neu Update 1.5.34 auf 1.5.36 -> Fehler beim DB bereinigen JTL-Wawi - Fehler und Bugs 0
Neu Fehler 404 beim Shopabgleich JTL-Wawi - Fehler und Bugs 2
Gelöst Warenpost International - Fehler beim versenden Gelöste Themen in diesem Bereich 3
Neu Fehler bei Verknüpfung Wawi zu SQL Datenbank von JTL Installation von JTL-Wawi 0
In Bearbeitung Schwerer MwSt-Fehler: Downgrade möglich? JTL-POS - Fehler und Bugs 7
Neu Shop5 / Fehler 500 bei Upload eines Plugins JTL-Shop - Fehler und Bugs 2
Neu Instalation läuft nicht wegen Fehler Installation / Updates von JTL-Shop 2
Neu Update bricht mit Fehler ab JTL-Wawi - Fehler und Bugs 13
Neu Fehler bei DHL Versandexport & DHL Versand 3.0 JTL-ShippingLabels - Fehler und Bugs 11
In Bearbeitung CSV Ein Fehler in der Kopfzeile JTL-POS - Fehler und Bugs 2
Neu Erster Lieferscheindruck nach Start der JTL-Wawi: Fehler JTL-Wawi - Fehler und Bugs 0
In Bearbeitung TSE-Fehler Swissbit Fehler 8 JTL-POS - Fehler und Bugs 3
Neu Fehler Retoure Stücklistenartikel bei teilweiser Rücksendung Arbeitsabläufe in JTL-Wawi 0
Neu Domainumzug zu Strato --> Plesk 500 Fehler, Admin-Backend erreichbar Allgemeine Fragen zu JTL-Shop 5
Neu Artikelexport aus JTL Shop 5 exportieren fehler JTL-Shop - Fehler und Bugs 1
Neu Fehler bei Umstellung auf Hermes HSI JTL-ShippingLabels - Fehler und Bugs 4
Neu Rechnungsdatenservice 2.0 Fehler - keine Objektinstanz Schnittstellen Import / Export 1
Neu Nova Child Source-Map-Fehler 404 JTL-Shop - Fehler und Bugs 1
Neu VCS Lite, Fehler/BUG bei A-Z Garantieanträgen Amazon-Anbindung - Fehler und Bugs 1
Neu eBay Abgleich Fehler - [Error][Code:21916984] eBay-Anbindung - Fehler und Bugs 7
Neu Kein Onlineshop-Abgleich möglich - Kategorie-Senden Fehler Shopware-Connector 1
In Bearbeitung ich habe TSE AUSFALL Fehler 2 bekommen. JTL-POS - Fehler und Bugs 2
Ähnliche Themen