Neu Fehler beim Bilderabgleich

chris LE

Aktives Mitglied
8. Februar 2007
32
1
Leipzig
Ich bekomme bei Abgleich eine Fehlermeldung:
Code:
Fehler beim Bilder-Abgleich: Der Shop sendet dauerhaft gleiche Daten. Um eine Endlosschleife zu verhindern, wird der Abgleich abgebrochen.

   bei jtlCore.ControllerClasses.Connector.Abgleich.Funktionen.ConnectorPuller.Pull[TEntity](Int64 quantity)
   bei jtlCore.ControllerClasses.Connector.Abgleich.EntityAbgleicher.ConnectorPullTask`1.Run()
   bei JTL.Connector.Business.SyncRunner.Run()

Das ist nicht neu und liegt wohl daran, dass ich Bilder manuell aktiviert und beim Anlegen neuer Artikel den Abgleich zig mal habe ausführen müssen, weil nicht alle Bilder übertragen wurden.
Kann mir jemand auf die Sprünge helfen, aus welchen (lokal/remote) Datenbanken ich was löschen muss, damit der Abgleich wieder fehlerfrei funktioniert?
Code:
[
"product#=#p_2346_2291",
10131
]
Merci!
 

swissguy01

Offizieller Servicepartner
SPBanner
14. Januar 2022
68
18
Gross, Schweiz
Firma
seo-webdesign-coaching.ch
Hallo Chris LE
Verstehe ich dies richtig, dass Du die Artikel und Bilder im Webshop neu angelegt oder geändert hast?

Versuche doch mal dies zu deaktivieren:
JTL-Wawi/Plattformen/Verkaufskanäle/ JTL-Connector/Allgemein/Daten aus dem Onlineshop importieren/Artikel-Kategorien

Vielleicht hilft dies Dir weiter, dass der normale Abgleich WAWI --> Onlineshop wieder erfolgreich funktioniert.

Regnerische Grüsse aus der Schweiz
Armin
 
  • Gefällt mir
Reaktionen: chris LE

chris LE

Aktives Mitglied
8. Februar 2007
32
1
Leipzig
Hallo Chris LE
Verstehe ich dies richtig, dass Du die Artikel und Bilder im Webshop neu angelegt oder geändert hast?

Versuche doch mal dies zu deaktivieren:
JTL-Wawi/Plattformen/Verkaufskanäle/ JTL-Connector/Allgemein/Daten aus dem Onlineshop importieren/Artikel-Kategorien

Vielleicht hilft dies Dir weiter, dass der normale Abgleich WAWI --> Onlineshop wieder erfolgreich funktioniert.

Regnerische Grüsse aus der Schweiz
Armin
Hallo Armin,

Das löst zwar nicht das grundsätzliche Problem, dass der Shopabgleich nur jedes 3. Mal die Bilder komplett hochlädt, verschiebt es aber in den Januar, wenn ich wieder den Kopf für sowas frei habe :)
Du hast mir sehr geholfen, vielen Dank!
 

swissguy01

Offizieller Servicepartner
SPBanner
14. Januar 2022
68
18
Gross, Schweiz
Firma
seo-webdesign-coaching.ch
Hallo Armin,

Das löst zwar nicht das grundsätzliche Problem, dass der Shopabgleich nur jedes 3. Mal die Bilder komplett hochlädt, verschiebt es aber in den Januar, wenn ich wieder den Kopf für sowas frei habe :)
Du hast mir sehr geholfen, vielen Dank!
Hallo Chris
Wir hatten auch das Problem.
Zuverlässiger wurde es, als wir die Anzahl Bilder pro Upload begrenzt haben. Der Upload dauert minimal etwas länger, aber seitdem haben wir keine Probleme mehr.
Dies kannst Du in der Connectoreinstellungen vornehmen.
Evt. hilft es auch bei Dir.
Schöne Adventszeit.
Gruss Armin
 
  • Gefällt mir
Reaktionen: chris LE

chris LE

Aktives Mitglied
8. Februar 2007
32
1
Leipzig
Hallo Chris
Wir hatten auch das Problem.
Zuverlässiger wurde es, als wir die Anzahl Bilder pro Upload begrenzt haben. Der Upload dauert minimal etwas länger, aber seitdem haben wir keine Probleme mehr.
Dies kannst Du in der Connectoreinstellungen vornehmen.
Evt. hilft es auch bei Dir.
Schöne Adventszeit.
Gruss Armin
Das schaue ich mir mal in Ruhe an, danke.
Dir auch eine schöne Adventszeit.
 

FinnMika

Mitglied
29. April 2022
38
11
Bei uns fügt der Connector auch die ganze Zeit die Bilder erneut zu den Produkten hinzu. Inzwischen haben wir auf den Produktseiten die Produktbilder zig Mal und der Speicher auf dem WordPress Server wird eng.
Neue Produktbilder werden allerdings nicht hinzugefügt.

Hat jemand einen Tipp wie wir das gefixt bekommen?
 

swissguy01

Offizieller Servicepartner
SPBanner
14. Januar 2022
68
18
Gross, Schweiz
Firma
seo-webdesign-coaching.ch
Bei uns fügt der Connector auch die ganze Zeit die Bilder erneut zu den Produkten hinzu. Inzwischen haben wir auf den Produktseiten die Produktbilder zig Mal und der Speicher auf dem WordPress Server wird eng.
Neue Produktbilder werden allerdings nicht hinzugefügt.

Hat jemand einen Tipp wie wir das gefixt bekommen?
Hallo FinnMika

Ja, evt. hätte ich ne Idee.

Bei einem anderen Import-Tool in Wordpress hatten wir ein ähnliches Problem.

Verstehe ich es richtig, dass der Filename des Bildes immer wieder wechselt, hat die Form mit einer fortlaufenden Indexierung am Ende? z.B: meinbild-12.jpg?
und bei jedem Upload dies wieder erhöht wird?

Der Grund für diese Indexierung war in unserem Fall, dass das File bereits auf dem Bilderverzeichnis in Wordpress vorhanden war. Beim Upload des gleichen Bildes wurde
von Wordpress dies festgestellt, dass das File im Verzeichnis schon vorhanden ist, und darum wird eine vorlaufende Indexierung des "neuen" Bildes vorgenommen.

Die Lösung war, einfach dieses File im Verzeichnis zu löschen (zB: Mittels FTP-Zugriff auf das Bilderuploadverzeichnis), im Produkt dann das Bild mit der Indexierung auch zu löschen.
Danach nochmals einen Import ausführen zu lassen.

Von da an wurden keine neuen Bilder-Indexierungen von Wordpress angelegt.

Evt. hilft Dir dies auch weiter.

Gruss Armin
 
Ähnliche Themen
Titel Forum Antworten Datum
Fehler beim erstellen von Aufträgen JTL-Wawi App 2
Fehler beim importieren eines Backups JTL-Wawi 1.8 2
Neu Fehler beim Bearbeiten von PLZ & Ort im Kundenkonto (Update 5.3.0) JTL-Shop - Fehler und Bugs 6
Fehler beim Rendering der Attribute bei SCX Abgleich kaufland.de - Anbindung (SCX) 4
Neu Fehler beim Zahlungsabgleich - Zahlungsmodul - Wawi 1.5.55.6 Gelöste Themen in diesem Bereich 14
Neu Fehler beim erstellen von Aufträgen. Digitale Unterschrift im Auftrag. JTL-Wawi - Fehler und Bugs 0
In Diskussion Fehler beim Versenden von E-Mails: "Could not convert socket to TLS" JTL-POS - Fehler und Bugs 1
Fehler beim Datenbank - JTL WAWI Connector WooCommerce-Connector 1
Neu Webp Bild aufruf Fehler beim ersten mal laden JTL-Shop - Fehler und Bugs 2
RLIMIT_NPROC is exceeded & fehler 503 beim Abgleich und beim Bestellabschluss Einrichtung JTL-Shop5 0
Neu ebay- Angebote-laufende Angebote: Fehler beim Laden der Daten, der mehrteilige Bezeichner "Custom-fWawiArtikelpreisBrutto" konnte nicht gebunden werde JTL-Wawi - Fehler und Bugs 2
Neu Fehler beim Update von Exportformat Google Shopping JTL-Shop - Fehler und Bugs 1
Barcodescanner Fehler mit ein "U" am Ende JTL-Wawi 1.8 0
Neu Fehler bei Sprach- und Währungsumstellung Allgemeine Fragen zu JTL-Shop 0
Nach Aufruf von Stored Procedure 'Kunde.spKundeUpdate' schwere Fehler in JTL (z.B. Kundenliste, Workflow-Editor) JTL-Wawi 1.8 2
Neu Fehler: Footer/Boxen - Kategoriefilter löscht Boxensortierung Allgemeine Fragen zu JTL-Shop 0
Neu Stripe - Fehler icomoon.ttf Plugins für JTL-Shop 0
Neu Gravierender Fehler in der Shop Software Betrieb / Pflege von JTL-Shop 3
Neu Fehler bei Bearbeitung von Designvorlagen eBay-Designvorlagen - Fehler und Bugs 0
Neu Smarty-Fehler im Logfile JTL-Shop - Fehler und Bugs 1
Neu Fehler: Sonderpreis falsch formatiert, wird nicht importiert; obwohl importiert genau wie exportiert User helfen Usern - Fragen zu JTL-Wawi 0
Neu Microsoft Remote Desktop Fehler Cloutapp Desktop und Lauscher JTL-Wawi - Fehler und Bugs 3
Neu OPC - Video Portlet Fehler (v.5.3.0) JTL-Shop - Fehler und Bugs 0
Neu Logfile: SQL Fehler, aber warum? JTL-Shop - Fehler und Bugs 2
Neu Google Listings & Ads image Fehler WooCommerce-Connector 2
Installations Fehler (SQLSTATE[HY000] [2002] No such file or directory ) Einrichtung JTL-Shop5 1
Neu JTL-Shop 5.3.0 RC3 Fehler nach Update Portlet Banner, fehlendes Produkt JTL-Shop - Fehler und Bugs 0
In Diskussion Gesamt Ban Rabatt zuweisen - Fehler? JTL-POS - Fehler und Bugs 4
Kein Fehler von 1.6.39 zu 1.8.12 JTL-Wawi 1.8 4
Umzug Datenbank Fehler aufgrund unterschiedlicher Versionen Einrichtung JTL-Shop5 1
Neu SQL-Fehler bei Volltextsuche und Sonderzeichen JTL-Shop - Fehler und Bugs 0
Neu E-Mail mit Strato - Fehler normal? Betrieb / Pflege von JTL-Shop 6
Neu jtl wawi Versanddatenexport Originalmeldung: In der Sendung trat mindestens ein harter Fehler auf. Code: 1101 Schnittstellen Import / Export 2
Neu 21916639, 21916585, 21916664 Fehler Gelöste Themen in diesem Bereich 4
Neu Inaktive Artikel werden mit 404 Fehler bei Google Search angezeigt Allgemeine Fragen zu JTL-Shop 2
Neu Fehler Übertragung Sendungsnummern an eBay JTL-Wawi 1.7 2
Neu Fehler SQL-Schema importieren bei Neuinstallation Installation / Updates von JTL-Shop 7
Was bedeutet dieser Fehler? - Jtlwa wai update to 1.8.11 JTL-Wawi 1.8 2
Workflow: Mahnungen - Fehler JTL-Wawi 1.8 5
Bug? Fehler EAN (Kaufland.cz) auf Kaufland.de aber korrekt kaufland.de - Anbindung (SCX) 1
Neu Fehler nach Serverumzug Gelöste Themen in diesem Bereich 3
Neu Datenbank Upgrade Fehler(#7110FFD83C0136E0) JTL-Wawi - Fehler und Bugs 0
Neu Fehler bei Update von 1.5.55.8 auf jede weitere Version bis einschließlich 1.8.11.0 Gelöste Themen in diesem Bereich 3
Neu Frage: Email Adressen Validator Fehler Allgemeine Fragen zu JTL-Shop 0
Neu beim Umstieg von unicorn auf SCX Bilder aktivieren Otto.de - Anbindung (SCX) 1
Neu Überverkäufe aktiviert doch beim Artikel steht Ausverkauft JTL-Shop - Fehler und Bugs 1
Neu E-Mail-Adresse beim Versand von Lieferantenbestellungen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Sendeverzögerung (in Stunden) beim Newsletter Allgemeine Fragen zu JTL-Shop 2
Neu Error beim öffnen von Artikeln und Unterkategorien in zweiter Sprache JTL-Shop - Fehler und Bugs 1
Neu Kann uns jemand beim Otto einrichten helfen? Dienstleistung, Jobs und Ähnliches 3

Ähnliche Themen