Neu Fehler bei Übertragung (413) Request Entity Too Large + The EntityManger is closed

musikfast

Mitglied
3. Juli 2020
78
11
Ich habe wieder das Problem, dass mein Abgleich nicht funktioniert.

Grundgerüst:
Wawi: 1.4.46.4
Shopware: 5.7.2
Connector: 2.11.0

Zum Ablauf:

Ich habe gemerkt, dass der Abgleich nicht funktioniert, weil neue Artikel nicht im Shop erscheinen. Im Backend habe ich mich elend lange damit befasst, das aktuelle Update (SW 5.7.2) aufzuspielen, was dann endlich zu einer Neuinstallation von Shopware führte. Nach dem auch die wichtigsten Einstellungen für den Shop getroffen worden sind, wollte ich schon mal einen Abgleich durchführen, um Kategorien und Artikeln im Shop zu haben, damit ich die Feinheiten im Layout besser ausarbeiten kann.
Dann Fehlermeldung:
Fehler:
Exception: Der Remoteserver hat einen Fehler zurückgegeben: (413) Request Entity Too Large.
Der Remoteserver hat einen Fehler zurückgegeben: (413) Request Entity Too Large.
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei product.push: Der Remoteserver hat einen Fehler zurückgegeben: (413) Request Entity Too Large.

Der Remoteserver hat einen Fehler zurückgegeben: (413) Request Entity Too Large.

Response: <Empty>
Exception bei product.push: Der Remoteserver hat einen Fehler zurückgegeben: (413) Request Entity Too Large.

Der Remoteserver hat einen Fehler zurückgegeben: (413) Request Entity Too Large.

Response: <Empty>
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.dpvNGdeSEwU(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.FEsNGnXT1AX(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.dpvNGdeSEwU(String , Object , Boolean , NetworkCredential )


Die PHP-Einstellungen sind alle erlativ hoch, höher als benötigt. Aber das hilft nicht. Log sind alle vorhanden.

Wenn weitere Infos benötig werden, bitte sagen, ich kümmere mich drum.
Ticket ist auch eröffnet.

Liebe Grüße
 

Anhänge

  • Connector-Abgleich-Debug 20210713 09-33-49.txt
    2,2 MB · Aufrufe: 1
  • shopware5-connector-logs.zip
    12,3 KB · Aufrufe: 0

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.434
299
Hallo @musikfast,

seit kurzem werden beim Senden von Artikeln zum Shop aufgrund der OSS Regelung vom 01.07. zusätzlich pro Artikel die Steuersätze für die verschiedenen Länder mitgesendet. Dadurch hat sich die Payload beim Artikelexport vergrößert. Setze die Upload Paketgröße in den Connector Einstellungen in JTL-Wawi mal testweise auf 10. Falls das nicht reicht, dann versuche diese weiter zu reduzieren.

Alternativ kann die maximal erlaubte Größe der Payload serverseitig angehoben werden. Höchstwahrscheinlich ist diese bei dir über den Webserver begrenzt. Hier ein Tutorial wie man je nach Webserver (Apache oder nginx) die Größe ändern kann.
 

musikfast

Mitglied
3. Juli 2020
78
11
Danke für die Antwort. Ich habe zwischenzeitlich die Einstellungen stark runter gefahren (Paketgröße 10-15) und aktuell ist ein Shopabgleich am Laufen. Ergebnis kommt später. (Deshalb habe ich noch keine Meldung weiter gegeben)
Das mit der OSS Regelung leuchtet ein, die hatte ich nicht mehr auf dem Schirm, weil ich eigentlich nur innerhalb Deutschland versende.

Den Webserver werde ich auch mal nachjustieren, obwohl die Einstellung schon extrem eingestellt ist (siehe Anhang)
Allerdings habe ich wahrscheinlich die Parameter für den Payload nicht verändert.
 

Anhänge

  • Einstellung php Shopware .png
    Einstellung php Shopware .png
    64,5 KB · Aufrufe: 4

musikfast

Mitglied
3. Juli 2020
78
11
hier mal die aktuellen Einstellungen im Übertragungsparameter für den Abgleich mit Shopware. Ich habe die sogar noch weiter runtergestellt
@Immanuel
 

Anhänge

  • Abgleich Übertragungsparameter.png
    Abgleich Übertragungsparameter.png
    33 KB · Aufrufe: 5

musikfast

Mitglied
3. Juli 2020
78
11
Das hat jetzt super funktioniert. Abgleich ist gut gelaufen.
Ich habe aber einen zweiten Lauf gleich danach angestoßen, aber mit anderen Parametern in der Wawi und eine neue Fehlermeldung bekommen (bei der Übertragung von Artikeln).

Fehler:
Exception: The EntityManager is closed.
The EntityManager is closed.
Merkmale-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei specific.push: The EntityManager is closed.

The EntityManager is closed.

Response: {"result":[],"error":{"code":0,"message":"The EntityManager is closed.","data":null},"jtlrpc":"2.0","id":"6a7a065308624db1ae471d0f0e469e43"}
Exception bei specific.push: The EntityManager is closed.

The EntityManager is closed.

Response: {"result":[],"error":{"code":0,"message":"The EntityManager is closed.","data":null},"jtlrpc":"2.0","id":"7e888388536a4aaba9aae9a9ac6ad710"}
bei jtlCore.ControllerClasses. Connector.Abgleich.Connector.dpvNGdeSEwU(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.FEsNGnXT1AX(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.dpvNGdeSEwU(String , Object , Boolean , NetworkCredential )




Ich werde gleich die Parameter wieder runterstellen und schauen, was kommt
 

Anhänge

  • Abgleich Übertragungsparameter 2.png
    Abgleich Übertragungsparameter 2.png
    32,4 KB · Aufrufe: 1

musikfast

Mitglied
3. Juli 2020
78
11
so schnell bin ich wieder da und muss sagen, dass die neue Fehlermeldung nicht weg geht.

Mein nächste Schritt ist die Einstellung auf dem Webserver in de php.ini
Ich halte euch auf dem Laufenden
 

musikfast

Mitglied
3. Juli 2020
78
11
Ich habe den Connector neuinstalliert, jetzt scheint der Abgleich wieder zu funktionieren. Mal sehen, wie lange.
Die Einstellungen in der php.ini sind schon ok.
 
  • Gefällt mir
Reaktionen: Immanuel
Ähnliche Themen
Titel Forum Antworten Datum
Neu JTL Shop 5.1 kritischer Fehler bei Installation mit Demodaten Installation / Updates von JTL-Shop 1
Neu Fehler bei Kommunikation mit Server - Repricer funktioniert nicht JTL-Repricer für JTL-Wawi und Web 0
JTL Shop Sitemap Probleme Allgemeiner HTTP Fehler bei Google Einrichtung JTL-Shop5 10
Neu Fehler bei der Migration auf InnoDB - tzahlungslog Upgrade JTL-Shop4 auf JTL-Shop5 6
Neu Fehler beim Verbindungsaufbau: Exception bei global_data.pull: Short and Long cannot be null Modified eCommerce-Connector 0
Neu Fehler bei der Synchronisierung mit Shopware Starten mit JTL: Projektabwicklung & Migration 2
Fehler bei der Installation von JTL Shop 5 Einrichtung JTL-Shop5 3
Einstellen von Schrift und Farbe & Fehler bei Anzeigen von Bildern Einrichtung JTL-Shop5 3
Neu Fehler bei Account xxxx [Amazon.de]: Ihr Account ist nicht aktiv. Amazon-Anbindung - Fehler und Bugs 1
Neu Fehler bei erster Anbindung eBay-Anbindung - Fehler und Bugs 2
Fehler bei Update: "SQLSTATE[42S01]: Base table or view already exists Upgrade JTL-Shop4 auf JTL-Shop5 4
Neu Fehler bei Bildübertragung Gambio-Connector 6
Neu Fehler bei Überschreibung der Artikelnummern Shopify-Connector 3
Neu Fehler - weiße seite bei sprach wechsel auf englisch JTL-Shop - Fehler und Bugs 3
Neu JTL-Wawi Fehler bei der Anmeldung JTL-Wawi - Fehler und Bugs 3
In Bearbeitung Fehler bei mehreren gleichen Produkten Allgemeine Fragen zu JTL-POS 3
JTL Shop 5: Warenkorb - Fehler bei Steuer B2B-Kunden? Ausblenden der Versandkosten, wenn 0,00 € möglich? Einrichtung JTL-Shop5 2
Neu Fehler bei Wareneingang JTL-Wawi - Fehler und Bugs 1
Neu Fehler bei der Suche in der Version 4.05 geht nicht JTL-Shop - Fehler und Bugs 2
Neu Leider gibt es nach wie vor Fehler bei der Ausgabe von Adressetiketten JTL-Wawi - Fehler und Bugs 0
Neu Fehler bei Installation der Community Free Version Einrichtung JTL-Shop5 2
Neu Open Vpn mit JTL Wawi - Netzlaufwerke Fehler Installation von JTL-Wawi 2
Neu Netzwerkdrucker gehen nicht mehr Fehler 0x0000011b User helfen Usern 4
Neu Ameise Import Fehler - Falsche Formatierung JTL-Ameise - Fehler und Bugs 3
In Bearbeitung Fehler "Typ " 'Decimal' für Eigenschaft 'Anzahl' konvertiert werden. " in Worflow mit DotLiquid JTL-Workflows - Ideen, Lob und Kritik 3
Neu Der Remoteserver hat einen Fehler zurückgegeben: (500) Interner Serverfehler. WooCommerce-Connector 0
Gelöst Picklistenerstellung Fehler @kAmazonUser... [WAWI-57509] JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 4
Neu (!) JTL Shop 5 Fehler "Struktur-Migration" Installation / Updates von JTL-Shop 3
Neu Artikel duplizieren erzeugt immer diesen Fehler User helfen Usern - Fragen zu JTL-Wawi 7
Neu Woocomerce Shop Ablgeich Fehler JTL-Plugin : CustomerTrait.php:68 WooCommerce-Connector 1
Neu Fehler beim Update auf 5.1 JTL-Shop - Fehler und Bugs 2
Neu Allgemeiner Fehler wenn DHL Labels gleichzeitig erstellt werden JTL-ShippingLabels - Fehler und Bugs 0
Neu Amazon Fehler Code 99001 - Maße Kopf bis Fuss, Seite zu Seite und Boden bis Unterkante Amazon-Lister - Fehler und Bugs 2
Neu DHL Express GWS Fehler JTL-ShippingLabels - Fehler und Bugs 0
Neu Fehler mit Sonderzeichen in den Metadaten der Artikel. JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim laden des Projektbausteins JTL-Wawi - Fehler und Bugs 1
Neu Fehler beim Shopabgleich Modified eCommerce-Connector 0
Neu WMS Mobile immer wieder Fehler JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
Neu Feld "image" fehlt Google Search Console Fehler JTL Shop 4 Allgemeine Fragen zu JTL-Shop 1
Neu Ungültige Backend-Antwort. Ein serverseitiger Fehler trat auf. HTTP error 500 Installation / Updates von JTL-Shop 0
PHP Version 7.4 + 8 generiert Fehler 500 (shop5) Einrichtung JTL-Shop5 1
Neu Fehler beim Update -kein Update möglich User helfen Usern - Fragen zu JTL-Wawi 1
Neu 26.08.2021 16:30 Uhr - ABGLEICH FEHLER eBay-Anbindung - Fehler und Bugs 2
Neu Shop 5 Installation Fehler Keine config.JTL-Shop.ini.php gefunden. JTL-Shop - Fehler und Bugs 2
Neu Passwort es ist ein Fehler aufgetreten Allgemeine Fragen zu JTL-Shop 2
Neu Fehler "Mehrere Stammelemente vorhanden in Zeile.." beim Versuch Shopdaten zu updaten Arbeitsabläufe in JTL-Wawi 0
Neu Fehler beim Onlineshop-Abgleich (Bilder Synchronisation) Onlineshop-Anbindung 0
Neu Fehler beim Artikel duplizieren seit Wawi 1.5.48.1 JTL-Wawi - Fehler und Bugs 2
Neu Ständig amazon worker Abgleich Fehler JTL-Wawi - Fehler und Bugs 4
Neu Fehler aus der Amazon Schnittstelle Amazon-Anbindung - Fehler und Bugs 1

Ähnliche Themen