Neu ebay Vorlage kopieren und hinzufügen- Merkmale (Attribute) fehlen!

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

WigWam Markus

Sehr aktives Mitglied
19. Juli 2008
1.111
14
Bayrisch Kongo
Ginge erst Anfang nächste Woche, bin schon auf dem Sprung ins lange WE ;)

Vorlage wurde mittels "Kopieren" erstellt, dann die Attribute händisch gesetzt da diese ja aktuell nicht mehr mitkopiert werden. Beim nächsten Abgleich wird der Artikel automatisch eingestellt, da der entsprechende Haken gesetzt ist, allerdings ohne die Attribute, diese sind weder in der Vorlage des laufenden Angebots (Bild 2) noch bei Ebay gesetzt. In der Stamm-Vorlage auf deren Basis das Angebot erstellt wird sind diese aber gesetzt (Bild 1).
 

Anhänge

JohnFrea

Sehr aktives Mitglied
21. September 2017
226
50
Das neue Verhalten, Kategorieattribute überhaupt nicht mehr mit zu kopieren, auch nicht, wenn man eine globale Vorlage aus einer bestehenden Vorlage erzeugen will, ist ein deutlicher Rückschritt.

Mein Vorschlag: Eine Abfrage, ob die Kategorieattribute mit kopiert werden sollen oder nicht. Und ebenfalls diese Abfrage, wenn man Vorlagen zwischen zwei Artikeln kopiert.

Ich habe das auch als Ticket Ticket#2019082310002511 eingereicht.

So ist es im Alltag EXTREM viel Mehrarbeit.
 
  • Gefällt mir
Reaktionen: serkan

Rektor

Sehr aktives Mitglied
22. November 2011
279
67
Ginge erst Anfang nächste Woche, bin schon auf dem Sprung ins lange WE ;)

Vorlage wurde mittels "Kopieren" erstellt, dann die Attribute händisch gesetzt da diese ja aktuell nicht mehr mitkopiert werden. Beim nächsten Abgleich wird der Artikel automatisch eingestellt, da der entsprechende Haken gesetzt ist, allerdings ohne die Attribute, diese sind weder in der Vorlage des laufenden Angebots (Bild 2) noch bei Ebay gesetzt. In der Stamm-Vorlage auf deren Basis das Angebot erstellt wird sind diese aber gesetzt (Bild 1).
Also dieses Problem haben wir bei der aktuell verwendeten Wawi 1.4.33.1 nicht
 

Freakbiz

Gut bekanntes Mitglied
25. April 2011
116
11
weiteres zu Ticket#2019082310002511 von JohnFrea :

Mir ist seit Freitag aufgefallen dass vereinzelt Auktionen (sich verlängernde) und GTC Festpreisartikel (wohl neu eingestellte) bei "Einzustellende" Angebote hängen und nicht mehr gelistet werden.
Problem: Marke und HAN nicht gesetzt, obwohl die bei der Vorlage natürlich gefüllt sind.
Lösung: alles wieder mit großem händischem Aufwand belegen und neu abschicken. Ob die abgelaufene Auktion dann nach 10 Tage wieder "hängt" weiss ich momentan nicht.

Kann das sonst jemand bestätigen? Bitte mal bei "Einzustellende" Angebote nachschauen, Danke...
 
  • Gefällt mir
Reaktionen: serkan

Rektor

Sehr aktives Mitglied
22. November 2011
279
67
weiteres zu Ticket#2019082310002511 von JohnFrea :

Mir ist seit Freitag aufgefallen dass vereinzelt Auktionen (sich verlängernde) und GTC Festpreisartikel (wohl neu eingestellte) bei "Einzustellende" Angebote hängen und nicht mehr gelistet werden.
Problem: Marke und HAN nicht gesetzt, obwohl die bei der Vorlage natürlich gefüllt sind.
Lösung: alles wieder mit großem händischem Aufwand belegen und neu abschicken. Ob die abgelaufene Auktion dann nach 10 Tage wieder "hängt" weiss ich momentan nicht.

Kann das sonst jemand bestätigen? Bitte mal bei "Einzustellende" Angebote nachschauen, Danke...
Eigentlich recht einfach, das zu berichtigen. Wenn Marke und HAN beim Artikel eingetragen sind, einfach in "Einzustellende" Angebote alle Artikel markieren, rechte Maustaste, Marke HAN hinterlegen und an ebay neu übertragen. Obwohl wir auch bei allen Angeboten die Pflichtfelder ausfüllen, gibt es manchmal fehlerhafte Angebote, weshalb auch immer dann die Pflichtfelder nicht mehr befüllt sind.
Vielleicht auch mal die Wawi-Version nennen, wo das Verhalten auftritt.
 

Freakbiz

Gut bekanntes Mitglied
25. April 2011
116
11
Vielleicht auch mal die Wawi-Version nennen, wo das Verhalten auftritt.
Die aktuellste, vorher gab es das Problem ja nicht - 1.4.34.0

Eigentlich recht einfach, das zu berichtigen. Wenn Marke und HAN beim Artikel eingetragen sind, einfach in "Einzustellende" Angebote alle Artikel markieren, rechte Maustaste, Marke HAN hinterlegen und an ebay neu übertragen. Obwohl wir auch bei allen Angeboten die Pflichtfelder ausfüllen, gibt es manchmal fehlerhafte Angebote, weshalb auch immer dann die Pflichtfelder nicht mehr befüllt sind.
Schön wenn sich das bei Marke/HAN mit weiteren Arbeitsschritten lösen lässt, jedoch hatte ich eben auch das Problem mit den Pflichtfeldern, die in der Vorlage gefüllt und beim Angebot dann leer sind. Das bleibt alles hängen und fordert ständig Nacharbeit.

Marke/HAN hinterlegen ist wohl auch neu oder "bugpräventiv" implementiert worden? Für Italien hatte das vor ein paar Wochen noch nicht funktioniert, das mussten wir noch ein paar hundert Angebote zurückstellen und warten, da die Marke auch nicht übertragen wurde. Ansonsten ging ja nur die händische Nacharbeit.

Gefühlt denkt die Konkurrenz zwei Schritte weiter (z.B. Amazon Rechnungsuploads) und hier gehts mit 1.4er Verschlimmbesserungen zwei Schritte zurück. Das Problem hier bei den Vorlagen sind doch Basics, die von sich aus funktionieren müssten.
 
  • Gefällt mir
Reaktionen: serkan

Freakbiz

Gut bekanntes Mitglied
25. April 2011
116
11
In Sachen Lösung des Problems ist mir ist eben aufgefallen dass die Kategorie an sich nicht mehr passt.
Ich hatte eine Ebayvorlage von einer Herrenjacke in das neue Angebot kopiert und dort dann in der Ebayvorlage die Kategorie auf Kinderjacke abgeändert. Die Merkmale wurden von mir soweit auf Kinderjacken abgeändert. Hat in der Vorlage gepasst, beim einzustellenden ebay Angebot war die Kategorie jedoch Herrenjacke und alle Felder leer. Möglicherweise liegt hier irgendwo ein Bug.
 

serkan

Aktives Mitglied
8. September 2012
51
14
Hier passt vorne und hinten nichts, nachdem man mühselig eine Lösung improvisiert, stehe ich vor dem nächsten BUG.

Wieso existiert die Option alphabetisch Haken setzen oder nicht, wenn es in der Maske Merkmalszuweisung doch nur alphabetisch anzuwählen ist?

Begrüßen würde ich ebenso, wenn Bezeichnungen für Merkmale mit eigenen Werten gesetzt werden können, im Anschluss mit Ebaywerten mappen.
 

Rektor

Sehr aktives Mitglied
22. November 2011
279
67
Wieso existiert die Option alphabetisch Haken setzen oder nicht, wenn es in der Maske Merkmalszuweisung doch nur alphabetisch anzuwählen ist?
Das verstehe ich allerdings nicht. In unserer Wawi-Version gibt es die Pfeile "nach oben/nach unten".

Es ist eigentlich unglaublich, welche Fehler es nach der Wawi-Version 1.4.33.1 gibt. Am besten gar nicht mehr updaten, bis JTL zur Besinnung kommt.
 
Zuletzt bearbeitet:

Stephan K.

Sehr aktives Mitglied
14. Mai 2014
725
83
Im RC 1.5.7 ist der Fehler noch immer vorhanden, wie ich leider feststellen muss. Wenn man Angebot kopiert, kann man sie eigentlich gleich zeitaufwendig komplett neu erstellen, da das Kopieren leer ist...
 

JohnFrea

Sehr aktives Mitglied
21. September 2017
226
50
Pflegen der Merkmale im Artikel ist ja schon sinnvoll. Sinnvoller als einzelnes Pflegen in einer Vorlage. Was dann aber nötig ist, ist die Möglichkeit, die Merkmale flexibel auf eBay Kategorieattribute zu mappen.

Ich denke, dieser Vorschlag würde einen Haufen Problem lösen. Einfach mal auf "abstimmen" klicken.

https://issues.jtl-software.de/issues/WAWI-38643
 

mvh

Sehr aktives Mitglied
26. Oktober 2011
272
53
Hallo,
Es ist kein Fehler, sondern eine grundsätzliche Entscheidung von JTL
s. stored procedure spCopyEbayItem:

SQL:
 ----------------------------------------------------------------------
    -- kopiere ebay_specific
    ----------------------------------------------------------------------

    /* --ebay Merkmale werden nicht mehr einfach kopiert, sondern aus dem Artikelstamm gezogen.
    INSERT dbo.ebay_specific
    (
       kItem,
       cName,
       cValue,
       nCustom
    )
    SELECT
        @kItemNew,
        cName,
        cValue,
        nCustom
    FROM dbo.ebay_specific
    WHERE dbo.ebay_specific.kItem = @kItemOld;
    */
Wenn die Kommentar-Zeilen /* und */ wieder entfernt werden, dann funktioniert es wieder wie in WaWi 1.3.XX
 

mvh

Sehr aktives Mitglied
26. Oktober 2011
272
53
Hallo,
Es ist kein Fehler, sondern eine grundsätzliche Entscheidung von JTL
s. stored procedure spCopyEbayItem:

SQL:
 ----------------------------------------------------------------------
    -- kopiere ebay_specific
    ----------------------------------------------------------------------

    /* --ebay Merkmale werden nicht mehr einfach kopiert, sondern aus dem Artikelstamm gezogen.
    INSERT dbo.ebay_specific
    (
       kItem,
       cName,
       cValue,
       nCustom
    )
    SELECT
        @kItemNew,
        cName,
        cValue,
        nCustom
    FROM dbo.ebay_specific
    WHERE dbo.ebay_specific.kItem = @kItemOld;
    */
Wenn die Kommentar-Zeilen /* und */ wieder entfernt werden, dann funktioniert es wieder wie in WaWi 1.3.XX
Das Verhalten in 1.5.10 ist anders:
SQL:
--ebay Merkmale werden nicht mehr einfach kopiert, sondern aus dem Artikelstamm gezogen (außer der Artikel ist gleich)
IF (@SameArtikel = 1)
    BEGIN
        INSERT dbo.ebay_specific
        (
            kItem,
            cName,
            cValue,
            nCustom,
            kMerkmal,
            kMerkmalWert,
            kSprache
        )
        SELECT
            @kItemNew,
            cName,
            cValue,
            nCustom,
            kMerkmal,
            kMerkmalWert,
            kSprache
        FROM dbo.ebay_specific
        WHERE ebay_specific.kItem = @kItemOld;
    END
Wir haben es etwas verändert:
SQL:
--ebay Merkmale werden nicht mehr einfach kopiert, sondern aus dem Artikelstamm gezogen (außer der Artikel ist gleich oder von der globalen Vorlage)

    IF (@SameArtikel = 1 OR @FromGlobalTemplate = 1)
    BEGIN
        INSERT dbo.ebay_specific
        (
            kItem,
            cName,
            cValue,
            nCustom,
            kMerkmal,
            kMerkmalWert,
            kSprache
        )
        SELECT
            @kItemNew,
            cName,
            cValue,
            nCustom,
            kMerkmal,
            kMerkmalWert,
            kSprache
        FROM dbo.ebay_specific
        WHERE ebay_specific.kItem = @kItemOld;
    END
 

mvh

Sehr aktives Mitglied
26. Oktober 2011
272
53
Das Verhalten in 1.5.10 ist anders:
SQL:
--ebay Merkmale werden nicht mehr einfach kopiert, sondern aus dem Artikelstamm gezogen (außer der Artikel ist gleich)
IF (@SameArtikel = 1)
    BEGIN
        INSERT dbo.ebay_specific
        (
            kItem,
            cName,
            cValue,
            nCustom,
            kMerkmal,
            kMerkmalWert,
            kSprache
        )
        SELECT
            @kItemNew,
            cName,
            cValue,
            nCustom,
            kMerkmal,
            kMerkmalWert,
            kSprache
        FROM dbo.ebay_specific
        WHERE ebay_specific.kItem = @kItemOld;
    END
Wir haben es etwas verändert:
SQL:
--ebay Merkmale werden nicht mehr einfach kopiert, sondern aus dem Artikelstamm gezogen (außer der Artikel ist gleich oder von der globalen Vorlage)

    IF (@SameArtikel = 1 OR @FromGlobalTemplate = 1)
    BEGIN
        INSERT dbo.ebay_specific
        (
            kItem,
            cName,
            cValue,
            nCustom,
            kMerkmal,
            kMerkmalWert,
            kSprache
        )
        SELECT
            @kItemNew,
            cName,
            cValue,
            nCustom,
            kMerkmal,
            kMerkmalWert,
            kSprache
        FROM dbo.ebay_specific
        WHERE ebay_specific.kItem = @kItemOld;
    END
Wir haben den Code nicht auch für ebay_item2kombi angepasst und so ist die Variable @FromGlobalTemplate bei uns definiert:
SQL:
DECLARE @FromGlobalTemplate INT = 0;
 SET @FromGlobalTemplate =
 (
   SELECT CASE WHEN Type='G' THEN 1 ELSE 0 END 
  FROM dbo.ebay_item 
  WHERE dbo.ebay_item.kItem = @kItemOld
 );
 

JohnFrea

Sehr aktives Mitglied
21. September 2017
226
50
Oh man, wir sind seit WOCHEN daran, gegen die Verschlimmbesserungen seitens JTL in den Stammdaten an zu arbeiten und dann kommen hier solche "einfachen" Hacks, die erstmal vielversprechend aussehen. Schade, daß das nicht von JTL selbst kommt.
Eine einfache Abfrage, ob man die Werte aus den Stammdaten oder aus der globalen Vorlage ziehen möchte, würde es SO viel einfacher machen...
 

mvh

Sehr aktives Mitglied
26. Oktober 2011
272
53
Oh man, wir sind seit WOCHEN daran, gegen die Verschlimmbesserungen seitens JTL in den Stammdaten an zu arbeiten und dann kommen hier solche "einfachen" Hacks, die erstmal vielversprechend aussehen. Schade, daß das nicht von JTL selbst kommt.
Eine einfache Abfrage, ob man die Werte aus den Stammdaten oder aus der globalen Vorlage ziehen möchte, würde es SO viel einfacher machen...
Es tut mir leid, ich habe den Beitrag erst vor kurzem gesehen, sonst hätte ich den Code schon früher veröffentlicht. Die Abfrage kann man auch so umschreiben, wie Du vorschlägst.
Die Werte aus dem Artikelstamm-Merkmalen überschreiben nicht die Werte aus der globalen Vorlage, sondern werden zu den E-Bay Kategorie-Attributen hinzugefügt, zumindest mit dem Code.
Viele Grüße, Ihr mvh-Team
 

lxshld

Aktives Mitglied
8. Juni 2018
61
8
Es tut mir leid, ich habe den Beitrag erst vor kurzem gesehen, sonst hätte ich den Code schon früher veröffentlicht. Die Abfrage kann man auch so umschreiben, wie Du vorschlägst.
Die Werte aus dem Artikelstamm-Merkmalen überschreiben nicht die Werte aus der globalen Vorlage, sondern werden zu den E-Bay Kategorie-Attributen hinzugefügt, zumindest mit dem Code.
Viele Grüße, Ihr mvh-Team
Wie können wir die Lösung bei uns einbinden? Haben wir noch nie gemacht...
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu ebay Merkmale und MPN (HAN) werden aus Artikel nicht mehr in holländische Vorlage übernommen JTL-Wawi - Fehler und Bugs 0
Gelöst Neuer Artikel - eBay-Vorlage beinhaltet keine Kategorie Einrichtung und Installation von JTL-eazyAuction 2
Neu Hallo irgendwie wurde ein Angebot doppelt bei Ebay hochgeladen abwohl ich nur eine Vorlage erstellt habe eBay-Anbindung - Fehler und Bugs 1
Neu Beschreibung bei ebay aktualisieren Arbeitsabläufe in JTL-Wawi 0
Neu Konfigurationsartikel auch für eBay? User helfen Usern - Fragen zu JTL-Wawi 1
In Bearbeitung Konfliktmeldung aus dem Marktplatz öffnet falschen Ebay-Fall eBay-Anbindung - Fehler und Bugs 1
Gelöst Gelöst: Artikelmerkmale werden nicht in die EBAY Angebotsvorgale übernommen Einrichtung und Installation von JTL-eazyAuction 2
Neu ebay managed payments - Zahlen auf Rechnung - Rechnungsvorlage? User helfen Usern - Fragen zu JTL-Wawi 5
Gelöst Warenpost2.0 Versandmeldung an EBAY Gelöste Themen in diesem Bereich 2
Neu Ebay-Angebot werden bei Null-Lagerbestand nicht automatisch beendet eBay-Anbindung - Fehler und Bugs 2
Neu eBay Merkmal aus Liste aktualisieren User helfen Usern - Fragen zu JTL-Wawi 0
Neu Varianten in laufenden eBay-Angeboten mit Verkäufen eBay-Anbindung - Fehler und Bugs 5
Neu Massen update von ebay Angeboten Arbeitsabläufe in JTL-Wawi 2
Neu Artikel wird immer wieder bei Ebay gestoppt - wie kann ich feststellen warum - workflow User helfen Usern - Fragen zu JTL-Wawi 6
Neu Ebay Nachrichten über Api ins Servidesk? Servicedesk (Beta) 1
Neu Ebay beanstandet Bildbreite - mutmaßlich das Shoplogo User helfen Usern - Fragen zu JTL-Wawi 3
Gelöst Ausländische eBay Martkplätze - Obwohl Angebote bereits online, zeigt Wawi als "einzustellend" ein. Einrichtung und Installation von JTL-eazyAuction 1
Neu Neue Ebay Zahlungsmöglichkeiten User helfen Usern - Fragen zu JTL-Wawi 1
Gelöst Designvorlage, Ebay Kategorie 60811 eBay-Designvorlagen - Fehler und Bugs 1
Gelöst eBay Angebot manual update image issue eBay-Anbindung - Fehler und Bugs 3
Neu Ebay Cross Selling Galerie aus mehreren Abfragen füllen? User helfen Usern - Fragen zu JTL-Wawi 0
Neu Help: eBay stock management / Amazong listing advices. User helfen Usern 2
Gelöst Bei Ebay werden keine Bestellungen abgeholt, Auktionen werden nicht übermittelt, Zertifikatsfehler Gelöste Themen in diesem Bereich 1
In Bearbeitung [Zahlungsabgleich] Von Ebay einbehaltene Steuer User helfen Usern - Fragen zu JTL-Wawi 1
In Bearbeitung Fehler beim eBay Angebote Import eBay-Anbindung - Fehler und Bugs 1
In Bearbeitung Problem beim Update der Vorlagen für eBay eBay-Designvorlagen - Fehler und Bugs 11
Gelöst 1.5.24.1 - Worker übernimmt keine Amazon/ebay Bestellungen Gelöste Themen in diesem Bereich 4
Gelöst ebay-Shop Link / Kategorien funktioniert nicht eBay-Designvorlagen - Fehler und Bugs 2
In Bearbeitung Menge zu eBay - wird nicht übertragen eBay-Anbindung - Fehler und Bugs 6
Neu Weißt jemand wo man bei ebay eine automatische Mailantwort hinterlegt User helfen Usern - Fragen zu JTL-Wawi 7
In Bearbeitung Aktualisieren vn eBay Angeboten dauert schon 20 Stunden eBay-Anbindung - Fehler und Bugs 1
In Bearbeitung ebay-Abgleich Mwst Senkung Template wirde nicht übertragen eBay-Anbindung - Fehler und Bugs 5
Offen "Ebay Kategorien" werden zu Woocommerce product_attributes Shop Synchronisation mit JTL WooCommerce-Connector 1
In Bearbeitung Variation nachträglich bei eBay Angebot Einrichtung und Installation von JTL-eazyAuction 4
Gelöst Umsatzsteuer Ebay Angebotsvorlage noch auf 19% eBay-Anbindung - Fehler und Bugs 5
Neu eBay-Shop-Kategorie 1 in der Ameise per CSV funktioniert nicht JTL-Ameise - Fehler und Bugs 7
In Bearbeitung Fahrzeugverwendungsliste / KFZ Teile / Ebay Tecdoc eBay-Anbindung - Ideen, Lob und Kritik 1
Neu Fehler bei Übertragung / Anlage neue Kunden von eBay eBay-Anbindung - Fehler und Bugs 6
In Bearbeitung Designvorlage Änderungen eBay eBay-Designvorlagen - Fehler und Bugs 3
Gelöst Zahlungsabgleich Ebay Managed Payments neue Zahlungsabwicklung eBay-Anbindung - Ideen, Lob und Kritik 3
Gelöst Wie kann man eine automatische eBay Kategorien-befüllung vornehmen? eBay-Anbindung - Ideen, Lob und Kritik 3
Neu Mehrere Versandarten in eBay Angebote User helfen Usern - Fragen zu JTL-Wawi 0
Neu Problem mit Bildern Ebay Variationsartikel Arbeitsabläufe in JTL-Wawi 8
Neu Tatsächlicher Shopname / Herkunft der Bestellung im Auftrag (Shops, eBay, Amazon, Unicorn 2 mit Etsy, Real etc) Arbeitsabläufe in JTL-Wawi 6
Neu Avast blokiert Bilder auf eBay eBay-Anbindung - Fehler und Bugs 5
Neu Galleriebild ebay User helfen Usern - Fragen zu JTL-Wawi 3
Neu Hat jemand eine Idee wie man ebay Kategorien in den ebay-Vorlagen per WF einbinden kann? User helfen Usern - Fragen zu JTL-Wawi 1
In Bearbeitung Probleme mit dem ebay-Abgleich - "Die Eingabezeichenfolge hat das falsche Format" JTL-Wawi - Fehler und Bugs 6
Neu Ebay-Vorlagen von inaktiven Artikel löschen eBay-Designvorlagen - Ideen, Lob und Kritik 2
Neu Für diesen artikel existiert ein ebay angebot diese zeichnung darf nicht geändert werden User helfen Usern - Fragen zu JTL-Wawi 3
Ähnliche Themen