Neu Artikelattribut als Teil der Beschreibung auf LS drucken klappt nicht (ganze Beschreibung "veschwindet")

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.

_sm_

Neues Mitglied
14. Mai 2019
1
0
#1
Hallo liebes JTL-Forum,

Was ich erreichen möchte:
Wir möchten zu jedem Artikel einen Hinweistext mit auf den LS drucken. Bisher haben wir manuell in das Hinweisfeld im Auftrag zu jeder Position einen mehrzeiligen Text aus einer Tabelle für alle Artikel kopiert. Nun soll das automatisch stattfinden. Also bei jedem Artikel wird der Text hinterlegt und automatisch beim Erstellen des LS unter dem Artikelnamen angefügt. (Tabelle Lieferscheinpositionen [Vorgang.Positionen], Tab Datenzeile, im Dropdown "Positionen" der vierte Eintrag mit Inhalt (vermutlich der default?):
Lieferscheinpositionen.Artikelbezeichnung+ "¶" + Vorgang.Auftrag.Hinweis.Text +
Cond(Len(Lieferscheinpositionen.SeriennummernAlsText) > 0 ,"¶Seriennummer: " + Lieferscheinpositionen.SeriennummernAlsText,"")
Mein Vorgehen bisher:
Zuerst ein eigenes Feld verwendet, dann allerdings schnell festgestellt, das wird nicht klappen, da sich der Hinweis der Sprache anpassen muss (Den Text der eigenen Felder kann ich nur zusammen einfügen, da die angebotene Variable keine genauere Auswahl bietet)
Mein aktueller Stand ist, dass mittels eines Artikelattributs das am besten erreicht werden kann.
Also das Attribut neu angelegt (In Gruppe Shop, WMS und schließlich eine eigene Gruppe erstellt, nacheinander natürlich, alles ohne Erfolg) und "ArtikelHinweis" genannt (ohne ""), später auch noch "Bob" ausprobiert, um evtl. Namenskonflikte auszuschließen. Attribut bei einem Artikel mit dem Text per HTML-Editor befüllt jeweils für deutsch und englisch.
Zu guter letzt im Vorlageneditor an oben genannter Stelle Alias$ (“ArtikelHinweis",Auftragspositionen.Artikel.AttributeAlsText) eingefügt:
Lieferscheinpositionen.Artikelbezeichnung+ "¶" + Vorgang.Auftrag.Hinweis.Text +
Alias$("ArtikelHinweis",Auftragspositionen.Artikel.AttributeAlsText) +
Cond(Len(Lieferscheinpositionen.SeriennummernAlsText) > 0 ,"¶Seriennummer: " + Lieferscheinpositionen.SeriennummernAlsText,"")
Einen Testauftrag erstellt mit dem Artikel, bei dem ich das neue Attribut befüllt habe, damit ich sofort die Änderungen in der Druckvorschau sehen kann.

Mein Problem: Wenn ich das neue Attribut auf dem LS hinzufüge, bleibt das Feld der Beschreibung ganz leer (!?), also auch die anderen Variablen, die ohne neues Attribut einwandfrei funktionieren, werden plötzlich nichtmehr angezeigt.

Habe ich einen Denkfehler? Oder ist der Weg über das Artikelattribut das Problem?

Vielen Dank für eure Hilfe
 

Ähnliche Themen