Neu Artikel werden nicht aktualisiert

utuz

Gut bekanntes Mitglied
26. Juni 2008
484
13
Hallo Leute,
es ist zum verückt werden. Immer was anderes.
Datenbestand per Ameise aktualisiert.
Im Artikelstamm wird das richtig angezeigt und wenn ich die Daten zum Shop sende, sieht es so aus, als wenn die Artikel aktualisiert werden, tatsächlich bleibt alles beim alten.
Was kann ich tun?
WaWi 15.48.2 und der neueste Connector.
SW 5.6.7
Gruß Joachim
 

Scriptfarm DEV

Aktives Mitglied
7. Dezember 2018
63
17
Haste mal die Logs in allen System kontrolliert?
Ändere doch mal nur eine Kleinigkeit an einem Artikel, nur ein Buchstabe oder sowas und synchronisiere ihn.
 

utuz

Gut bekanntes Mitglied
26. Juni 2008
484
13
Ich komme dem Problem näher.
Habe nun festgestellt, das zwar der WaWi Preis richtig ist, aber der für meine Shopkundern nicht aktualisiert wird.
Da das bisher funktioniert hat stimmt mich das seltsam.
Jedenfalls ist mir das bisher nicht aufgefallen, was bedeutet, das diesen Problem auch schon länger existieren könnte.

Ich habe jetzt mehrere Preise überprüft und bei allen, die preiselich sich verändert haben, wurde der WaWi Preis zwar aktualisiert, aber der Shoppreis nicht.
Probeweise habe ich zwei Artikel gelöscht und habe dann die Tabelle per Ameise neu eingelesen und und anschließend beide Artikel überprüft und nun sind die Preise aktualiesiert.

Daraus folgere ich, das entweder liegt das an der Formatierung meiner Tabelle, hier im besonderen die Spalte mit dem Preis, oder die WaWi Version die ich benutze hat eine Macke.
Normal würde ich nicht weiter rummachen und die Daten einmal komplet löschen und wieder neu einlesen. Das ist aber immer auch mit Stress bei Google verbunden, denn die Daten werden ja auch in SW gelöscht und sind damit für Google eine Zeitlöang nicht erreichbar. Ist jedenfalls meine Erfahrung.
Also was kann ich sonst tun?
Gruß Joachim
 

Scriptfarm DEV

Aktives Mitglied
7. Dezember 2018
63
17
Auf keinenfall alles löschen, daß würde das Problem bestimmt nicht beseitigen.
Du hast doch alles korrekt in der Wawi drin. Du musst nur den Fehler finden und dann alles abgleichen. Irgendwas muckt an der Zuweisung. Ich bin aber sicher, ein Blick in die Logs aller Systeme, sollte den Fehler rasch offenbaren. Wenn bei der Synchronisierung die Parität und Zuordnung der Artikeldaten nicht passt, sollte das auch geloggt werden. Mit etwas suche über das Ausschlussverfahren, sollte das Problem zu finden sein, da es kein Software, sondern bestimmt ein Konfigurationsfehler ist.
 
Zuletzt bearbeitet:

utuz

Gut bekanntes Mitglied
26. Juni 2008
484
13
Das gibt es immer wieder mal, das man vergeblich versucht was zu überschreiben, bzw. kleine Änderungen einfach nicht übernommen werden.
Ich denke es ist schwierig den Grund dafür zu finden.
Es ist das stochern im Nebel und es bleibt eigentlich nur Try and error.
Das kostet Zeit und ist insoweit problematisch, weil unangepoasste Preise schnell zu weiteren Stress führen können.

Ich stelle mir das unglaublisch schwierig vor, Logs dahingehend zu untersuchen, wo was nicht richtig funktioniert hat.
Wenn man davon keine Ahnung hat ist das sinnlose Zeitverschwendung.
Da sich ja nicht alle Preise ändern sondern nur ein paar, müsste man genau diese in den Logs finden???
Und wenn ich die gefunden habe, was dann.
In ersterline bin ich User und kein Programmierer.

Selbst wenn ich mir fast immer selber helfen kann, heißt das nicht, das ich deshalb den großen Plan hätte.
Damit will ich sagen, das ich was greifbares brauche um daraus was zu machen.
Ausschlussverfahren ist schon eine Möglichkeit, aber was sollte ich denn ausschließen??
Aber gerade kommt mir eine Idee.
Unabhängig davon, wären weitere Vorschläge gut.
Auch wenn das nicht immer direkt zum Ziel führt hillft mir das schon, Probleme einzukreisen und Ideen zu entwickeln.
Gruß Joachim
 

Scriptfarm DEV

Aktives Mitglied
7. Dezember 2018
63
17
Dafur musst du kein Programmierer sein, sondern ein Anwender der die Funktionen und Anwendung seiner Software versteht.
Du musst auch keine endlosen Logs durchsuchen.
Einfach mal einen neuen Artikel anlegen und in den Shop übertragen und wenn die Stammdaten abweichen die letzten Log Einträge einsehen,
daß selbe einfach mit einem vorhandenen Artikel den Artikelpreis mal ändern, mit dem Shop Abgleichen und in Logs schauen.
Das sind ganz einfache Grundlagen und die ersten Schritte einer Fehleranalyse.
Jedenfalls bevor ich auf eine Idee komme, meinen gesamten Shop zu löschen, in der Hoffnung das Problem so zu lösen C:-
Gute Nacht von mir..
 
Zuletzt bearbeitet:

utuz

Gut bekanntes Mitglied
26. Juni 2008
484
13
Ganz verstanden hast Du mein Problem nicht.
Es geht nicht um das übertragen in den Shop. Das hatte ich zunächst vermutet, hat sich aber als Falsch rausgestellt.

Ich hatte ja geschrieben, das ich mich dem Problem nähere, denn das Problem liegt in der WaWi.
Legt man einen Artikel von Hand an, werden die Preise der WaWi, den Drucken, Amazon, und seinem Shop zugeordnet, wenn man die Option Shop ausgewählt hast.
Das funktioniert immer einwandfrei.

Mein Problem liegt darin, das meine Artikel per Tabelle über die Ameine in die WaWi eingelesen werden.
Die Preise werden für die Platform WaWi ohne Probleme aktualisiert, aber die nicht Preise für den Shop.

Ich hatte weiter geschrieben, das ich zwei Artikel gelöscht und wieder per Ameine eingelesen habe und siehe da, die Preise stimmen.
Es bringt also nichts, Artikel neu anzulegen um daraus was herauslesen zu können,

Das Problem liegt darin, das nicht sämtliche alten Preise mit den neuen Preisen überschrieben werden.
Ich werde mal ein paar Daten aus der Tabelle ein eine andere Tabelle übernehmen und es so versuchen.
Vielleicht hilft das ja das Problem einzugrenzen.

Noch eine Anmerkung.
Wenn ich schreibe, das ich die Datern komplett löschen würde, hat das nichts mit dem Shop als solches zu tun.
Der Shop ist doch noch da, es geht nur um die Daten. Die lese ich ja per Tabelle über die Ameise ein.
Nur dauert das ewig und da das im Shop neu angelegt wird verändern sich ein paar parameter, sodas eben Google stress macht und das möchte ich vermeiden.

Würde man alles Händisch eingebracht haben, wäre das natürlich was anderes.

Zudem gibt es Backips.
Gruß Joachim

Unten habe ich mal zur Veranschaulichung zwei Bilder angefügt.
artikelpreis-WaWi.jpg

Artikelpreis-Shop.jpg
 
Zuletzt bearbeitet:

utuz

Gut bekanntes Mitglied
26. Juni 2008
484
13
So zur Info!
Ich habe jetzt folgendes gemacht.
Zunächst habe ich von meiner Tabelle Nur die Preise und die Lagerstände per Ameise eingelesen.
Habe hier experimentieren müssen, weil das zunächst ohne Auswirkungen geblieben ist.
Die Logs waren nur insofern hilfreich, das die Menge an nicht geänderten Daten angezeigt wurde. Ansonsten keine weitere nutzbringende Information.

Als letztes habe ich die Option gewählt vorhandene Preise vor Aktualisierung löschen. Das hat jetzt zum gewünschten Erfolg geführt.
Allerdings lösst das nicht das grunsätzliche Problem.
Denn wenn ich per Tabelle Artikelaktualisierungen betreibe, dann bezieht sich die Aktualisierung auch auf die Preise.
Hier ist irgendwas im argen.

Durchaus möglich, das das allgemein bisher unbemerkt geblieben ist.
Es wäre jedenfalls angeraten, das sich JTL mal der Sache annimmt und sei es um am Ende festzustgellen alles gut.
Gruß Joachim
 

utuz

Gut bekanntes Mitglied
26. Juni 2008
484
13
Kleine Berichtigung.
Ich habe gerade gesehen, das es in der Ameise bei dem Reiter Artikeldaten man auch Artikelpreise vorher löschen wählen kann.
Also sollte allrs gut sein.
War tatsächlich ein Einstellungsproblem meinerseits.
Gruß Joachim
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Artikel werden nicht auf eBay entfernt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Artikel in Konfigurationsgruppen werden nicht ausgeliefert JTL-Wawi - Fehler und Bugs 0
Neu Artikel in Auftrag werden nicht verknüpft JTL-Ameise - Fehler und Bugs 2
Neu Artikel kann nicht auf Amazon eingestellt werden - [Herkunftsland = null] Amazon-Lister - Fehler und Bugs 1
In Bearbeitung Wurzelkategorie - Artikel werden nicht nach POS übertragen Allgemeine Fragen zu JTL-POS 1
Neu WMS - Pickliste → Artikel soll von 2 verschiedenen Lagerplätzen genommen werden, obwohl der Bestand auf dem ersten Lagerplatz ausreicht User helfen Usern - Fragen zu JTL-Wawi 4
In Bearbeitung Artikel werden doppelt angezeigt JTL-Wawi - Fehler und Bugs 4
Neu Shop 5.1.1 Artikel werden nach Wawi Wareneingang von allen Shop Wunschlisten gelöscht JTL-Shop - Fehler und Bugs 3
Neu Nur ausgewählte Artikel können direkt ins Ausland bestellt werden Betrieb / Pflege von JTL-Shop 0
Neu Artikel werden dupliziert JTL-Wawi - Fehler und Bugs 3
Gelöst Bonvorlage - Anmerkung Artikel werden gedruckt Gelöste Themen in diesem Bereich 2
Shop5 Export Idealo Artikel mit Umlauten werden in Idealo mit Sonderzeichen dargestellt Einrichtung JTL-Shop5 8
Neu Nach SQL Server Upgrade, manche Artikel nicht mehr abrufbar JTL-Wawi - Fehler und Bugs 0
Neu Altersabfrage für Artikel mit Altersbeschränkung Allgemeine Fragen zu JTL-Shop 0
Neu Versandkostenfreie Artikel ohne andere Versandarten darstellen Allgemeine Fragen zu JTL-Shop 0
Neu Artikel im Shop die in der WAWI nicht existieren? JTL-Wawi - Fehler und Bugs 2
Neu Artikelbestandsampel je Artikel einstellen Allgemeine Fragen zu JTL-Shop 0
Neu Artikel automatisch deaktivieren an Tag X User helfen Usern - Fragen zu JTL-Wawi 2
Neu Coupon-Lösung für "Artikel kostenlos + kostenfreier Versand (nur DE)" Plugins für JTL-Shop 0
Verfügbare Artikel-Menge eines bestimmten Lagers im Shop anzeigen Einrichtung JTL-Shop5 0
Neu JTL Wawi 1.6 Shop Anbindung Anzahl Artikel Arbeitsabläufe in JTL-Wawi 3
In Diskussion Artikel deaktivieren Shopware-Connector 1
Neu JTL Wawi 1.6 - Sortierung Artikel Angebote & Aufträge JTL-Wawi - Ideen, Lob und Kritik 0
Neu smartyvariable aus Artikel Bilder cPfadgross in custom.js verwenden? Technische Fragen zu Plugins und Templates 1
Neu Nach Relaunch haben Artikel andere Hauptkategorie - wie kann ich das steuern? Gambio-Connector 1
Neu Shop 5 Artikel ohne Bestand ausblenden Allgemeine Fragen zu JTL-Shop 2
Neu Artikel erscheinen nicht in WAWI Artikelliste User helfen Usern - Fragen zu JTL-Wawi 10
Neu Fehlermeldung "Freiposition", obwohl Artikel angelegt wurde JTL-Wawi - Fehler und Bugs 1
Neu Text ändern: Artikel verfügbar ab xx.xx.xxxx Allgemeine Fragen zu JTL-Shop 2
Neu Haken bei "Dieser Artikel ist ein Stücklistenartikel" mit der Ameise entfernen JTL-Ameise - Fehler und Bugs 1
Neu Fehlermeldung bei Artikel duplizieren JTL-Wawi - Fehler und Bugs 4
Neu Artikel im JTL Shop ohne Verknüpfung in der JTL Wawi ? JTL-Wawi - Fehler und Bugs 5
Neu Artikel auf englisch übersetzen User helfen Usern - Fragen zu JTL-Wawi 2
Neu Eigene Übersicht für Artikel - Artikelbild anzeigen lassen Individuelle Listenansichten in der JTL-Wawi 0
Neu Eigene Übersicht für Artikel - Artikelbild anzeigen lassen Individuelle Listenansichten in der JTL-Wawi 0
Neu Eigenschaftswerte(Variationswerte z.B. Pflichtfreitextfeld bei custom Artikel) in pushed_success.tpl hinzufügen Shop5 Nova Template Templates für JTL-Shop 1
Neu Wawi Artikel Meterware / Stückgut bei Amazon Bestellung als Set / Rolle ausbuchen User helfen Usern - Fragen zu JTL-Wawi 0
Neu WebInterpret löscht Artikel User helfen Usern - Fragen zu JTL-Wawi 0
Neu Im Gambio Shop sind viele Artikel im Backend doppelt auch in der Datenbank und Klarna Problem Gambio-Connector 3
Neu Ameise Preise / Bestände QuickSync Artikel arbeitet angeblich nicht mit Lagerbestand User helfen Usern - Fragen zu JTL-Wawi 1
Neu FBA Bestände lassen sich nicht von WaWi Artikel entfernen Amazon-Anbindung - Fehler und Bugs 0
Neu Attribute mit der Ameise in Artikel einfügen User helfen Usern - Fragen zu JTL-Wawi 6
Neu Artikel wurde aus den Warenkorb entfernt! WARUM? (Konfigurator) Allgemeine Fragen zu JTL-Shop 0
Neu Bestandsabgleich zwischen Variationen und Einzel Artikel gleiches Produkt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Artikel erscheinen nicht im Shop, merkwürdiges Verhalten bei Klick auf Rubriknamen Allgemeine Fragen zu JTL-Shop 2
Neu Amazon bestände mit Dropshipping artikel + Lagerartikel (Stückliste) Onlineshop-Anbindung 0
Neu Lieferzeitproblem: $Artikel->cEstimatedDelivery = 'Null' - Barzahlung ist NICHT aktiv! Einrichtung von JTL-Shop4 1
Neu WooCommerce Artikel Synchronisation bringt Fehler WooCommerce-Connector 0
Neu Newsletter - keine Artikel, Hersteller oder Kategorien verfügbar !!! JTL-Shop - Fehler und Bugs 2
In Diskussion Workflow - Info wenn Artikel im anderen Lager vorhanden ist JTL-Workflows - Ideen, Lob und Kritik 0

Ähnliche Themen