Neu WAWI Update 1.5.50.2 + JTL Shop 5.1.1 Server down - Too many Connections SQL

R-W

Aktives Mitglied
18. September 2021
38
6
Hamburg
Liebe JTL und Leser,
wir haben von einem JTL Partner updaten lassen auf WAWI 1.5.50.2 (Am 2.11.2021 - Danach schon erste Serverausfälle) und Shop 5.1.1 (Am 6.11.21), nun fliegt uns der Server alle paar Minuten um die Ohren:

HTTP ERROR 500
A database error occurred
SQLSTATE[HY000] [1040] Too many connections
SQLSTATE[HY000] [1040] Too many connections
DATABASE ERROR: CONNECTION FAILED!
Unable to connect to the database!
Please contact your server-administrator.

Ab und zu ist der Shop da, die Admin vom Shop nur kurz erreichbar, solange der Server mitspielt.
Haben den Worker auch mal ausgeschaltet, was auch keine Verbesserung brachte.
Bitten um Tipps ob wir irgendwas in der WAWI anders einstellen müssen, um stabil auch Online laufen können? (Wochenende-Servicepartner nicht erreichbar).
Unser Hoster WebGo (Hoster des Jahres seit Jahren) unseres Managed Servers ist auch dran und sagte das Unmengen an Querys laufen, nur Kalt-Neustart das System, SQL abgestellt, wieder für einige Zeit an den Start brachte. Dann baut sich das Problem wieder auf.
Durch was wird diese Datenflut verursacht?
Oder gibts nen Fehler in diesen Konfig WaWi-Shop angeboten als "stable Versionen" ?

Linux Server PHP 7.4.16 MySql 5.5.5.-10.3.23-Maria DB-1:10+3.23+maria-strech
PHP Ausführungszeit 120
PHP-Speicherlimit 1536M
Max PHP Übertragungsgröße File/Post 100M
Templateversion 5.1.1 / Datenbankversion 5.1.1 / Template Version 1.0.8

Vielen Dank für jeden Tipp/Hinweis DANKE EUCH
 

NewBuy

Sehr aktives Mitglied
29. August 2016
2.113
321
evtl. Unicorn2 im Einsatz?
Wenn ja könnte die Ursache daran liegen hatten wir gehabt
 

mvh

Sehr aktives Mitglied
26. Oktober 2011
1.217
461
Liebe JTL und Leser,
wir haben von einem JTL Partner updaten lassen auf WAWI 1.5.50.2 (Am 2.11.2021 - Danach schon erste Serverausfälle) und Shop 5.1.1 (Am 6.11.21), nun fliegt uns der Server alle paar Minuten um die Ohren:

HTTP ERROR 500
A database error occurred
SQLSTATE[HY000] [1040] Too many connections
SQLSTATE[HY000] [1040] Too many connections
DATABASE ERROR: CONNECTION FAILED!
Unable to connect to the database!
Please contact your server-administrator.

Ab und zu ist der Shop da, die Admin vom Shop nur kurz erreichbar, solange der Server mitspielt.
Haben den Worker auch mal ausgeschaltet, was auch keine Verbesserung brachte.
Bitten um Tipps ob wir irgendwas in der WAWI anders einstellen müssen, um stabil auch Online laufen können? (Wochenende-Servicepartner nicht erreichbar).
Unser Hoster WebGo (Hoster des Jahres seit Jahren) unseres Managed Servers ist auch dran und sagte das Unmengen an Querys laufen, nur Kalt-Neustart das System, SQL abgestellt, wieder für einige Zeit an den Start brachte. Dann baut sich das Problem wieder auf.
Durch was wird diese Datenflut verursacht?
Oder gibts nen Fehler in diesen Konfig WaWi-Shop angeboten als "stable Versionen" ?

Linux Server PHP 7.4.16 MySql 5.5.5.-10.3.23-Maria DB-1:10+3.23+maria-strech
PHP Ausführungszeit 120
PHP-Speicherlimit 1536M
Max PHP Übertragungsgröße File/Post 100M
Templateversion 5.1.1 / Datenbankversion 5.1.1 / Template Version 1.0.8

Vielen Dank für jeden Tipp/Hinweis DANKE EUCH
Moin,
poste bitte den Wert für mySQL max_connections SHOW VARIABLES LIKE "max_connections";
Danke, Ihr mvh-Team
 

dercoderkm

Offizieller Service Partner
SPBanner
21. Dezember 2019
80
22
Firma
Made in Dortmund
Wie sieht denn der Config Wert für max_connections aus auf dem Datenbankserver? ( Bitte mal folgendes ausühren "SHOW VARIABLES LIKE "max_connections";" )
Wie sehen eure Besucherzahlen dazu aus?
 

R-W

Aktives Mitglied
18. September 2021
38
6
Hamburg
Hallo und Danke für die Antworten. Wir haben alles uns angeschaut.
Jetzt Server gewechselt auf superschnellen SSD und teuren Webserver für Shop umgerüstet und aktuell auf
JTL: WAWI auf 1.5.51.0 - SHOP: 5.1.1.0

😒 ..ERGEBNIS: 503 FEHLER bei Abgleich. Abgleich hängt. Abgleich abgebrochen. Zig Bestellungen hängen im Shop...

Superschneller Shop..aber der Abgleich mit WAWI nur noch kpl. Abbruch.
Es ist zum ko.....!! Seit 6 Monaten lief JTL WAWI und SHOP nicht ein einziges Mal fehlerfrei.
Wir können keine Bestellungen abrufen, Preis oder Mengen werden nicht mehr erneuert,
...und wir arbeiten mit TEUREN von JTL empfohlenen offiziellen JTL Partnern zusammen. Unser Umsatz geht total den Bach hinunter. Updaten teuer wie die Doofen mit diesen JTL Service Partnern und nichts bessert sich.

Wer kann uns JTL Partner empfehlen die ihr Handwerk gelernt haben ? *BITTE*
Welches WAWI Update passt denn nun zu JTL SHOP 5.1.1.0 - Oder müssen wir jedes Update teuer mitnehmen, bis es irgendwann wieder Abgleiche macht? Wahnsinn 🙁

: Neueste Shop LOG Fehler u.a.:

Fehler 02.12.2021 - 09:59:37

JTLdbeSSyncGlobals::dbDelInsert failed: tsprache, data: stdClass Object
(
kSprache: 1
cNameEnglisch: German
cNameDeutsch: Deutsch
cISO: ger
cStandard: Y
cShopStandard: Y
active: 1
)

Fehler 01.12.2021 - 18:39:58

Error executing query: DELETE tsuchcache, tsuchcachetreffer
FROM tsuchcache
LEFT JOIN tsuchcachetreffer
ON tsuchcachetreffer.kSuchCache = tsuchcache.kSuchCache
WHERE tsuchcache.dGueltigBis IS NOT NULL
AND DATE_ADD(tsuchcache.dGueltigBis, INTERVAL 5 MINUTE) < NOW()
SQLSTATE[HY000]: General error: 1205 Lock wait timeout exceeded; try restarting transaction
 

Ähnliche Themen