Zahlungsabgleich fehlerhaft.

Delphis1982

Mitglied
16. Mai 2022
8
1
Hallo,

wir nutzen JTL 1.7 und haben unser Konto bei der Commerzbank.
Wir sind jetzt von FinTS auf EBICS umgestiegen und haben zwei User für die EBICS Nutzung.
Von einem User wurde eine Schlüsseldatei angelegt, die mein Chef innerhalb von BankingZV nutzt.
Abgleich klappt tadellos und flott, alles wird korrekt angezeigt.
Der zweite User hat ebenfalls eine EIGENE Schlüsseldatei und ist in JTL eingebunden.
Die Freischaltung hat geklappt, die Konten werden angezeigt, das war's auch schon.
Bekloppterweise werden mir nur die Umsätze vom 25.10.2023 angezeigt, nichts davor und nichts dahinter (und nein, es war nicht in Königswinter).
Anruf bei der Bank hat ergeben, dass die Umsätze jeden Tag korrekt vom User JTL abgerufen werden.
Sie werden aber in JTL nicht angezeigt. Wo werden die Daten innerhalb der Datenbank abgelegt oder was läuft hier falsch?

Nochmal zur Erinnerung:
Der andere User bekommt alles korrekt angezeigt. Beide User haben jeweils ihre EIGENE Schlüsseldatei. Es gibt also EIN Partnerkonto bei der CoBa, aber ZWEI Teilnehmer.

Anbei mal zwei Screenies:
1.jpg
2.jpg
 

Delphis1982

Mitglied
16. Mai 2022
8
1
So, folgendes, nachdem ich heute gerade eben ein Telefonat mit der Bank hatte, hatte der Mitarbeiter einen Blick auf den Monitor, WÄHREND ich den Abgleich gemacht habe:
Die Dateien werden täglich erstellt und erst am Folgetag gelöscht, ein Abruf ist also den ganzen Tag MEHRMALS möglich, das wird bei denen auch als Wiederholungsabruf angezeigt.
Die Bank teilte mit, dass die Umsatzdaten korrekt abgerufen und übertragen wurden. Damit ist die Pflicht der Bank erfüllt, Verbindung abgebaut.
Jetzt ist folgendes:
Die Commerzbank stellt die Umsätze als CAMT.053 zur Verfügung, das ist in JTL im Spooler auch so eingestellt (Auftragsart C53).
Im Log wird aber beim Abruf die Auftragsart STA angezeigt, das wäre dann MT940, und dadurch ist es kein Wunder, dass JTL nichts anzeigt.
Die Umsatzdaten liegen also als CAMT.053 vor, dies ist auch so eingestellt, JTL behandelt die Daten aber trotzdem als MT940.
Wo kann ich also JTL klipp und klar sagen, wie er die Daten behandeln soll? Es hat ja immerhin EIN EINZIGES MAL funktioniert.
 

Delphis1982

Mitglied
16. Mai 2022
8
1
Sorry, ja, Ticket ist eröffnet. Ich entschuldige mich dafür, dass ich zweigleisig fahre, aber ich will das Problem so schnell wie möglich erledigt haben, da ich nicht lange in der Firma bleiben werde.
 

Delphis1982

Mitglied
16. Mai 2022
8
1
So, Statusmeldung:
JTL kann laut Support via EBICS offenbar ausschließlich MT940 verarbeiten (STA), auch, wenn im Spooler CAMT.053 (C53) angeboten wird.
Die Commerzbank hat aber vor kurzem den Versand auf CAMT.053 umgestellt. Der Zeitpunkt war einfach reiner Zufall,
weil JTL frisch eingerichtet war und der Abgleich EINMAL funktioniert hat, am nächsten Tag schon nicht mehr.
Dieser Zufall hat die Fehlersuche ziemlich erschwert.
Also bei der Commerzbank angerufen und den Versand wieder auf MT940 umstellen lassen. Da muss man etwas hartnäckig sein, da das nicht der übliche Support machen kann, sondern ein höheres Tier aus der Technik.
Hat ca 3 Tage gedauert mit der Umstellung. Es kam zwar keine Benachrichtigung, dass umgestellt wurde, aber der Abgleich hat irgendwann einfach wieder funktioniert.

Vielen Dank für die Hilfe und ein nettes Dankeschön an den Support für den Hinweis.
Diesbezüglich aber eine kleine Anregung für künftige Versionen:
Wenn JTL beim Abgleich ein Format vorgelegt bekommt, mit welchem er nichts anfangen kann, wäre eine Benachrichtigung schön.
Normalerweise sollte es kein Problem darstellen, festzustellen, ob ein Zahlungsabgleich NICHT im MT940 vorliegt.
Die Logs zeigen das zwar an, aber das muss man ja erstmal WISSEN, dass es daran liegt. Außerdem muss man die Log-Stufe erstmal auf Debug umstellen.

Kann als GELÖST markiert werden.
Vielen Dank und guten Rutsch.
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: recent.digital

bauks

Aktives Mitglied
9. Januar 2020
14
3
So, Statusmeldung:
JTL kann laut Support via EBICS offenbar ausschließlich MT940 verarbeiten (STA), auch, wenn im Spooler CAMT.053 (C53) angeboten wird.
Die Commerzbank hat aber vor kurzem den Versand auf CAMT.053 umgestellt. Der Zeitpunkt war einfach reiner Zufall,
weil JTL frisch eingerichtet war und der Abgleich EINMAL funktioniert hat, am nächsten Tag schon nicht mehr.
Dieser Zufall hat die Fehlersuche ziemlich erschwert.
Also bei der Commerzbank angerufen und den Versand wieder auf MT940 umstellen lassen. Da muss man etwas hartnäckig sein, da das nicht der übliche Support machen kann, sondern ein höheres Tier aus der Technik.
Hat ca 3 Tage gedauert mit der Umstellung. Es kam zwar keine Benachrichtigung, dass umgestellt wurde, aber der Abgleich hat irgendwann einfach wieder funktioniert.

Vielen Dank für die Hilfe und ein nettes Dankeschön an den Support für den Hinweis.
Diesbezüglich aber eine kleine Anregung für künftige Versionen:
Wenn JTL beim Abgleich ein Format vorgelegt bekommt, mit welchem er nichts anfangen kann, wäre eine Benachrichtigung schön.
Normalerweise sollte es kein Problem darstellen, festzustellen, ob ein Zahlungsabgleich NICHT im MT940 vorliegt.
Die Logs zeigen das zwar an, aber das muss man ja erstmal WISSEN, dass es daran liegt. Außerdem muss man die Log-Stufe erstmal auf Debug umstellen.

Kann als GELÖST markiert werden.
Vielen Dank und guten Rutsch.
Hallo und Danke für die Info!
Wir haben noch einige Fragen, auf die wir leider keine Antwort finden:

Gibt es einen Grund für den Wechsel von FinTS zu EBICS?

Werden per EBICS bei einem mehrfachen Abruf im Laufe des Tages jeweils alle neu dazugekommenen Überweisungen in die Wawi eingespielt?

Oder wird die MT940 Datei tatsächlich nur einmal täglich von der Commerzbank erstellt und somit auch täglich nur die Überweisungen berücksichtigt, die bis zum erstellen der MT940 Datei eingegangen sind?
Wenn ja, lässt sich wenigstens der Zeitpunkt einrichten?
 

Delphis1982

Mitglied
16. Mai 2022
8
1
Hallo und Danke für die Info!
Wir haben noch einige Fragen, auf die wir leider keine Antwort finden:
Gibt es einen Grund für den Wechsel von FinTS zu EBICS?
Ja, gibt es: PSD2.
Vorgänge müssen automatisiert laufen, da ist es sehr ungünstig, wenn ein Vorgang plötzlich eine TAN anfragen will.

Werden per EBICS bei einem mehrfachen Abruf im Laufe des Tages jeweils alle neu dazugekommenen Überweisungen in die Wawi eingespielt?
Oder wird die MT940 Datei tatsächlich nur einmal täglich von der Commerzbank erstellt und somit auch täglich nur die Überweisungen berücksichtigt, die bis zum erstellen der MT940 Datei eingegangen sind?
Normalerweise wird die Datei 1x täglich erstellt und auf dem Server bereitgestellt. Sie wird NICHT im Laufe des Tages aktualisiert.
Manche Banken löschen diese Datei nach dem Abruf, manche nicht. Die Commerzbank löscht sie zumindest NICHT.
Das, was Du willst, nennt sich wohl Intraday Abruf. Das sind dann die sogenannten "vorgemerkten Umsätze".
Das läuft dann nicht über C53, sondern C52 und muss bei den allermeisten Banken wohl separat gebucht oder freigeschaltet werden.
Wir haben das nicht eingerichtet, benötigen wir auch nicht, aber ich weiß, dass man bei EBICS sowas tatsächlich gesondert aktivieren muss.
Wenn ja, lässt sich wenigstens der Zeitpunkt einrichten?
Ich wage zu bezweifeln, dass die Bank den Erstellzeitpunkt für jeden Kunden individuell einstellen kann oder will, ich gehe eher vom Datumswechsel aus, also 0 Uhr.
Ich habe zwar nicht danach gefragt, aber wie gesagt, ich gehe schon aus praktischen Gründen nicht davon aus, dass da was eingestellt werden kann.
 
Zuletzt bearbeitet:
Ähnliche Themen
Titel Forum Antworten Datum
Neu 1.8.11.1 Kriterien für automatischen Zahlungsabgleich Arbeitsabläufe in JTL-Wawi 0
Zahlungsabgleich: Amazon Pay ab JTL-Wawi 1.8.10.0 JTL-Wawi 1.8 3
Neu Fehler beim Zahlungsabgleich Wawi 1.7.15.4 JTL-Wawi - Fehler und Bugs 0
Neu Issue SHOP-1348: Sortierung nach Preis unter Umständen fehlerhaft Allgemeine Fragen zu JTL-Shop 0
Neu Bilder öffnen sich in mobiler Version fehlerhaft. Allgemeine Fragen zu JTL-Shop 0
Neu Preisliste Sortierung immer noch fehlerhaft? JTL-Wawi - Fehler und Bugs 0
Beschreibung wird beim Import fehlerhaft übernommen JTL-Wawi 1.8 0
JTL-WaWi eBay Angebotsvorlage Versand/Zahlung fehlerhaft JTL-Wawi 1.8 0
Neu JTL-Shop 5 Nova-Template / Darstellung der Produktliste teilweise fehlerhaft JTL-Shop - Fehler und Bugs 1
Neu Shop Bilder-Anzeige in Firefox fehlerhaft Allgemeine Fragen zu JTL-Shop 0
Neu Shop Bilder-Anzeige in Firefox fehlerhaft Allgemeine Fragen zu JTL-Shop 6
In Bearbeitung Buchungsdaten Export - Dateien fehlerhaft oder leer Allgemeine Fragen zu JTL-POS 1
AMEISE EXPORT DATEV Schnittstelle Fehlerhaft JTL-Wawi 1.8 4
Neu OPC: Product-Stream innerhalb von (zweiter) Registerkarte fehlerhaft JTL-Shop - Fehler und Bugs 3
Neu Statistiken immer noch fehlerhaft Arbeitsabläufe in JTL-Wawi 2
Konfigurationsgruppenanzeige Fehlerhaft JTL-Wawi 1.8 5

Ähnliche Themen