Gelöst Webseite ist immer wieder offline

mrarchitekt

Aktives Mitglied
31. August 2010
42
1
Bad Salzuflen
Hallo Community,

Wir haben seit zwei Wochen immer wieder das Problem, das die Webseite komplett off geht, weil der Connector-Job zu viel Speicherbedarf hat.

Webseite hat nicht wirklich viele Artikel, der Connector war auf 300 Sekunden zugriff eingestellt - habe den jetzt auf 1200 gestellt in der Hoffnung, das wir damti weiterkommen und nicht mehr so oft beim Support um einen Neustart bitten müssen. Sonstige Einstellungen haben wir auch überprüft und da ist nicht weiter Auffälliges.

aus den Logs werde ich nicht schlau, laut Support addieren sich die Abfragen und weil die nicht fertig werden, kommt das Problem.

Vielen Dank für jeden Tip
 

Anhänge

mrarchitekt

Aktives Mitglied
31. August 2010
42
1
Bad Salzuflen
Erneuter Ausfall nach nur wenigen Stunden:
Folgende Mail als Hinweis vom Support.

<
Hallo,

vielen Dank für Ihre Anfrage.

Laut den sehr häufig auftretenden Fehlermeldungen im Errorlog :

[09-Jan-2018 22:57:37] WARNING: [pool w0175512] child 12497 said into stderr: "NOTICE: PHP message: PHP Fatal error: Maximum execution time of 30 seconds exceeded in /www/htdocs/w0175512/autos-ersatzteile.de/engine/Shopware/Components/Thumbnail/Generator/Basic.php on line 239"

scheint hier ein Bildverarbeitungsplugin sehr lange für die Ausführung zu benötigen und damit die Anzeige der Seite blockieren. Sie können die Ausführungszeit per .htaccess ( php_value max_execution_time 60 )etwas erhöhen, aber das wird einen Fehler in der Software wahrscheinlich nicht dauerhaft beheben.

Jemand sowas schon gehabt?


Gesendet von iPhone mit Tapatalk
 

Xantiva

Sehr aktives Mitglied
28. August 2016
1.795
316
Düsseldorf
Er schreibt Dir doch schon, was Du machen solltest ...
Erhöhe die max_execution_time für den Shop, mal mindestens auf 120. Der Connector soll sich 1200 s genehmigen dürfen, aber der Shop nur 30 s?
 

Puma7

Sehr aktives Mitglied
4. Mai 2016
409
44
Hi,

mir scheint, dass das Hosting etwas schwach auf der Brust ist.
Manche Prozesse brauchen einige Ressourcen und nach der Warnmeldung liegt es eher daran das der Server etwas überlastet ist und die Bilder nicht in 30 Sekunden verarbeiten kann.
Kannst du uns etwas zu dem Hosting sagen? Also ein paar Daten wie viel Resourcen für dich zur Verfügung stehen.
 

Daniel B.

Moderator
17. Juni 2009
1.430
40
Hey,

denke auch, dass dein Hosting Server etwas zu schwach ist. Du kannst allerdings in der JTL-Wawi einstellen, wie viele Daten auf einmal geschickt werden sollen. Am besten stellst du die Anzahl kleiner, damit du die Last verteilen kannst.

Lg,
Daniel
 

Ähnliche Themen