Neu Wawi-Datenbankabfrage SUCHE SPALTE für Wert wahr oder falsch ARTIKELATTRIBUT

mona

Gut bekanntes Mitglied
26. April 2016
266
20
Hallo

Ich möchte mir eine Liste anzeigen, in welcher mein Funktionsattribut mit ID 27 den Wert 'false' hat.

Finde aber in der Datenbank die entsprechende Tabelle bzw. Spalte nicht für meine Abfrage.

[tArtikelAttribut] kAttribut = 27

Dankeschön
 

mona

Gut bekanntes Mitglied
26. April 2016
266
20
Hallo Thomas

Danke - die habe ich auch schon durchleuchtet. Aber dort habe ich nur
,[kArtikel] numerische Werte
,[kAttribut] numerische Werte
,[kShop] den Wert 0

Dachte erst es sei kShop mit 0 für false und 1 für true, aber dort habe ich nur den Wert 0 bei allen Artikeln.

In einem sehr früheren Beitrag schrieb jemand es sei die Tabelle dbo.tstring. Sowas habe ich aber nicht.
Sonst irgendeine Idee?

Danke & Gruss
mona
 

mona

Gut bekanntes Mitglied
26. April 2016
266
20
Danke, das könnte sie sein. Muss ich erst mal mit einer JOIN-Abfrage herausfinden, da ich mit den Werten der kArtikelAttribute
in der Tabelle momentan nichts anfangen kann...

Lieben Dank
 

mona

Gut bekanntes Mitglied
26. April 2016
266
20
Darf ich nochmals fragen.
Hier das Attribut, welches auf falsch gesetzt ist, dieses möchte ich, sofern falsch, löschen (per Workflow leider nicht möglich)
snipping.JPG

Meine Abfrage hat die Bedingung nWertInt = 0, doch beim Resultat gibt es mir bei nWertInt die 1 an. Richtigerweise müsste es bei falsch hier 0 anzeigen. (bei SELECT und WHERE musste ich nWertInt auch einmal mit und einmal ohne Punkt schreiben, da sonst Fehlermeldung )
Abfrage:
snipping2.JPG
Vielleicht eine Idee? Lieben Dank & Gruss
 

John

Sehr aktives Mitglied
3. März 2012
2.100
343
Berlin
nWertInt ist vom Typ Interger und nicht String. Entsprechend darf die 1 nicht in Anführungszeichen. Gleiches gilt für kArtikel
 

John

Sehr aktives Mitglied
3. März 2012
2.100
343
Berlin
Hallo

Ich möchte mir eine Liste anzeigen, in welcher mein Funktionsattribut mit ID 27 den Wert 'false' hat.

Finde aber in der Datenbank die entsprechende Tabelle bzw. Spalte nicht für meine Abfrage.

[tArtikelAttribut] kAttribut = 27

OK, lassen wir das SQL mal beiseite. Wieso machst Du das nicht über einen Temporären Filter in der Artikelliste? Oder über einen Filter in der Ameise?
Da hast Du doch dann die fertige Liste aller betroffenen Artikel.
 
  • Gefällt mir
Reaktionen: mona

mona

Gut bekanntes Mitglied
26. April 2016
266
20
Hallo John

Gut Idee, habe nun die Liste per Ameise und mit Filter exportiert.
(Komischerweise gibt es mir mit dem Filter gesetzt auf "exportiere mir den Wert des Attributes FALSE bzw. 0" eine Liste mit dem Wert 1 für die TRUE-Einträge.........genau wie in der Datenbank..... )

Frage:
Wenn ich nun das Attribut per Ameise löschen möchte,
muss ich einfach dort wo die Attributwerte stehen, leer lassen beim importieren. Richtig? Oder besser die ganze Zeile weglassen, wenn ich noch ein zusätzliches Attribut drin habe mit Verweis auf die Artikelnummer?
Danke & Gruss
 
Zuletzt bearbeitet:

SportNet

Sehr aktives Mitglied
16. Oktober 2014
121
27
Frage:
Wenn ich nun das Attribut per Ameise löschen möchte,
muss ich einfach dort wo die Attributwerte stehen, leer lassen beim importieren. Richtig? Oder besser die ganze Zeile weglassen, wenn ich noch ein zusätzliches Attribut drin habe mit Verweis auf die Artikelnummer?

Selectiv Löschen kannst du ein einzelnes Attribut nicht, du könntest es aber auf den gewünschten neuen Wert setzen. Wenn es vorher 1 war dann auf 0 beispielsweise.

Entfernen geht nur über den Umweg ALLE Attribute der besagten Artikel vorher per Ameise zu exportieren und sie dann wieder wieder zu importieren (natürlich ohne das zu löschende Attribut). Dabei aktivierst in der Ameise du die Option "Vorhandene Attribute bei betroffenen Artikeln vorher löschen"

Gruß Markus
 
  • Gefällt mir
Reaktionen: mona

mona

Gut bekanntes Mitglied
26. April 2016
266
20
Hallo Markus
Danke für Deine Antwort. Das Attribut auf falsch setzen habe ich bereits per Workflow gelöst. Aus Korrektheitsgründen wollte ich diese "falschen" auswerten und löschen.
Der Tipp mit "vorhandene Attribute bei betroffenen Artikeln vorher löschen" wird die Lösung sein, danke. Bin bei löschen immer vorsichtig, da ich nie genau
weiss, ob es mir im ersten Vorgang alles löscht und dann importiert, oder ob es die Vorgänge je Artikel durchführt. Dies betrifft vorallem da wo steht, "alle Preise vorher löschen" aus einem anderen Import...(Artikelimport) Hier scheint es ja klar zu sein, da steht, vorhandene vorher löschen.
Lieber Gruss & Dank
mona
 
  • Gefällt mir
Reaktionen: SportNet
Ähnliche Themen
Titel Forum Antworten Datum
Neu Artikel einer AMAZON Bestellung können in WAWI gefunden werden Arbeitsabläufe in JTL-Wawi 0
Neu Bestandsabgleich von Excel zu Wawi via Ameise - How to? Schnittstellen Import / Export 4
Neu JTL-Shop 5.21 - WAWI 1.7.7.0 Hersteller erscheinen nicht im Shop JTL-Shop - Fehler und Bugs 0
Neu Aufruf von Daten in Wawi aus anderen Anwendungen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Pickliste erstellen aus der Wawi - Auftragsübersicht? Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 1
Neu Wie bucht man in der Wawi eine Mehrwertsteuer-Rückerstattung (Mehrwertsteuerrückerstattung)? User helfen Usern - Fragen zu JTL-Wawi 0
Neu Wawi 1.6 & 1.7 Varianten importieren mit Aufpreis per Ameise - Fehler mit 0 JTL-Ameise - Fehler und Bugs 1
Rechnungskorrektur Optionen Unterschied zu Wawi 1.5.xx JTL-Wawi 1.6 4
Neu Laufzeit von Stored Procedures in der Datenbank - Anzeige Fortschritt? Wawi steht still... JTL-Wawi - Ideen, Lob und Kritik 5
Neu Amazon FBA Retouren in JTL WaWi Amazon-Anbindung - Ideen, Lob und Kritik 1
Neu Shopify Retouren in JTL Wawi Shopify-Connector 1
Neu Angebote werden nicht in den WooCommerceShop übertragen JTL-Wawi 1.5.45.0 WooCommerce-Connector 0
Neu History in der Wawi zeigt keine .... JTL-Wawi - Ideen, Lob und Kritik 0
Neu Ebay anbinden an Wawi User helfen Usern - Fragen zu JTL-Wawi 0
Neu Neuen zusätzlichen Shop in der WaWi mit Connector anlegen - Hilfe Gambio-Connector 1
Neu Kunde möchte von Extern Zugang zu seinen Daten in der JTL Wawi User helfen Usern - Fragen zu JTL-Wawi 6
In Bearbeitung Artikel in Wawi und in POS richtig abgleichen Allgemeine Fragen zu JTL-POS 1
Neu JTL Wawi Artikel aus Kühllager mal gesperrt und mal frei für den Versand JTL-Wawi - Fehler und Bugs 0
Neu Shop 5.21 + Wawi 1.7.6.1 im Shop werden keine Hersteller Meta-Tags gesetzt JTL-Shop - Fehler und Bugs 2
Neu Artikel nachträglich einer Wawi Pickliste hinzufügen? Arbeitsabläufe in JTL-Wawi 0
Neu Versandarten JTL Wawi Versand User helfen Usern - Fragen zu JTL-Wawi 6
Neu Übernahme Freitextfeld aus Shopware 5 in Wawi Shopware-Connector 2
Neu JTL-Wawi-Connector Shopify Abbruch, 1.5.55.3 Shopify-Connector 3
Issue angelegt [WAWI-64829] Kanal / Ausgabeweg Artikelbeschreibung per Workflow setzen lassen JTL-Workflows - Ideen, Lob und Kritik 1
shöpping.at in WAWI einbinden JTL-Wawi 1.6 2
Neu Funktionsattr. aus Wawi wird nicht übertragen JTL-Shop - Fehler und Bugs 4
Neu Fehler bei Erstellung von Umlagerung FBA in WAWI 1.5.55.6 Amazon-Anbindung - Fehler und Bugs 5
Neu JTL Wawi Artikel erscheinen nicht in JTL POS Einrichtung / Updates von JTL-POS 0
Neu Shopify POS an WaWi anbinden Shopify-Connector 2
Neu SQL Datenbank mit JTL-Wawi 1.0.8.1 wiederherstellen User helfen Usern - Fragen zu JTL-Wawi 6
Neu Sicherheitswarnung - Wawi Datenbank (sa) Passwort mit öffentlichem Tool entschlüsselbar JTL-Wawi - Ideen, Lob und Kritik 24
Neu Kein Login in Wawi mehr möglich trotz korrekter Zugangsdaten User helfen Usern - Fragen zu JTL-Wawi 0
Neu Artikelimport von Shopify zu JTL-WaWi ohne SKU Shopify-Connector 4
JTL-Wawi Version 1.6.42.0 im Dwnloadbereich und Archiv nicht auffindbar ! JTL-Wawi 1.6 7
Neu Fehler bei Erstellung von Umlagerung FBA in WAWI 1.5.54.1 Amazon-Anbindung - Fehler und Bugs 6
Neu Fehler bei Erstellung von Umlagerung FBA in WAWI 1.5.55.6 User helfen Usern - Fragen zu JTL-Wawi 9
Neu JTL Wawi 2-Faktor-Authentifizierung User helfen Usern - Fragen zu JTL-Wawi 5
Neu Wawi auf Server PC und weitere Filiale User helfen Usern - Fragen zu JTL-Wawi 13
Neu WAWI will beim Versand nach Österreich Exportdokumente erstellen JTL-ShippingLabels - Fehler und Bugs 3
Neu Wawi -> temporärer Filter -> Filterung nach Lieferant funktioniert nicht (Preiskalkulation) JTL-Wawi - Fehler und Bugs 0
Issue angelegt [WAWI-66930] Workflow mit Positionstyp lässt sich nicht generieren JTL-Workflows - Fehler und Bugs 5
Fehler bei Abgleich von Wawi und JTL Shop 5 JTL-Wawi 1.6 2
Issue angelegt [WAWI-50550] Workflow: Versandart ändern berücksichtig nicht die Sprache des Auftrags JTL-Workflows - Fehler und Bugs 1
Paypal Zahlungziel Shop5 WAWI 1.6.45.2 Einrichtung JTL-Shop5 1
Neu JTL Shop Bestellung fehlt in Shop & Wawi, Zahlung erhalten JTL-Shop - Fehler und Bugs 4
In Diskussion Abverkauf Bestandsartikel JTL Wawi --> Shopware JTL-Workflows - Ideen, Lob und Kritik 4
Neu Kunde bestellt unregistriert im JTL Shop, beim zweiten mal mit identischen Eingaben wird er in der WaWi nicht zusammengeführt? Allgemeine Fragen zu JTL-Shop 2
Neu Seit Update auf 1.6, WAWI extrem langsam wenn man "Eigene Übersichten" hat. JTL-Wawi - Fehler und Bugs 7
In Bearbeitung Umsätze von JTL-POS in der Wawi anzeigen lassen Allgemeine Fragen zu JTL-POS 2
Neu JTL - Wawi Lageranordnung User helfen Usern - Fragen zu JTL-Wawi 4

Ähnliche Themen