In Diskussion TSE Verknüpfung Error Code 401

CafeKitsch

Neues Mitglied
9. April 2021
15
0
Hallo zusammen,

ich bin dabei, die Fiskal Cloud TSE einzurichten. Der Connector wurde wohl ohne Fehler installiert, aber bei der Verknüpfung in der Kasse kommt als Fehlermeldung Return Code 401.

Dabei ist mir aufgefallen, dass in der Mail mit dem EAS Code die Seriennummer NICHT angegeben ist, obwohl ich diese bei der Buchung angegeben habe.

Firewall ist angepasst.

Was nun?

Viele Grüße aus Linz!
 

Shahne

Moderator
Mitarbeiter
9. Januar 2020
184
20
Hallo CafeKitsch,

der Fehlercode 401 steht grundsätzlich für "Unauthorized" und wird der Kasse zurückgegeben, weil sie nicht zum Zugriff auf den FCC berechtigt war. Sie hat den Rechner also erreichen können, aber die Verbindung wurde abgelehnt.

Das passiert üblicherweise nur durch einen der drei folgenden Faktoren:
- Der FCC wurde nicht mit Windows-Administratorrechten gestartet und darf deswegen keine Zugriffe von außen zulassen. Gegebenenfalls wäre hier zu empfehlen den Dienst oder die run_fcc.bat Kommandozeile immer über einen Administrator oder mit Administratorrechten laufen lassen, um das zu vermeiden
- Eine Firewall oder Antivirensoftware verhindert den externen Zugriff auf den FCC aus Sicherheitsgründen. Wenn eine solche Software auf dem Rechner im Einsatz ist, bitte unbedingt eine Ausnahmeregel für den FCC einrichten, damit externe Verbindungen zugelassen werden
- Benutzerkontensteuerung aktiv und nicht bestätigt. Falls die Windows-Benutzerkontensteuerung aktiv ist (das berühmte "Möchten sie zulassen, dass diese Software Änderungen an ihrem System vornimmt" Popup was den ganzen Bildschirm ersetzt) und die Freigabe für den FCC nicht bestätigt wurde, kann er ebenfalls keine Verbindungen von außen zulassen. Auch hier greift im Kern wieder das Rechtesystem von Microsoft und macht im umgangssprachlichen Sinne "die Tür zu".

Mit freundlichen Grüßen,
Shahne
 

CafeKitsch

Neues Mitglied
9. April 2021
15
0
Hallo,

ich habe jetzt mal den Port gescannt - ok. Danach den Service, eingeloggt als Admin, gestoppt und erneut gestartet - ok.

Am Ergebnis ändert sich nichts. Verknüpfe ich die Kasse mit der TSE, kommt derselbe Fehler wie bisher auch.

Ich würde gerne noch einmal die Aufmerksamkeit auf die Tatsache lenken, dass in der E-Mail mit den Zugangsdaten das Feld mit der Seriennummer der Kasse (EAS Serial) LEER ist. Ich habe keine Ahnung, ob das eine Rolle spielt. Falls die Seriennummer Teil der Authentifizierung ist, dann kann sie natürlich nicht funktionieren.

Viele Grüße

Zsolt Majsai
 

Shahne

Moderator
Mitarbeiter
9. Januar 2020
184
20
Hallo CafeKitsch,

wir haben nochmal intern nachgesehen und die Seriennummer ist korrekt hinterlegt. Warum sie in der generierten E-Mail gefehlt hat kann ich nicht mehr sagen, aber sie ist auf jeden Fall ordentlich registriert worden. Als du als Admin eingeloggt warst, hast du den Prozess explizit mit Admin-Rechten aufgerufen? Standardmäßig ist unter Windows die sogenannte "Benutzerkontensteuerung" aktiv, sodass man vor jedem Programm das mit Adminrechten läuft erstmal eine Bestätigung abgeben muss. Das Fenster dafür kennt glaube ich jeder Windows-Anwender ("Möchten sie zulassen, dass durch diese Anwendung Änderungen am System vorgenommen werden")

Liebe Grüße,
Shahne
 

CafeKitsch

Neues Mitglied
9. April 2021
15
0
Hallo, danke für die Antwort.

bei der Installation selbst wusste ich nicht, dass Admin-Rechte notwendig sind. Aber die Installationsroutine selbst hat die Admin-Rechte angefordert (das berühmte Fenster, das jeder Anwender kennt ;) ) und sie auch bekommen.

Beim Neustart des Services war ich explizit als Admin-User eingeloggt. Beim Service selbst konnte ich nicht eingeben, ihn als Admin-User zu starten, allerdings war ich ja bereits Admin-User. Ich komme eigentlich aus der Unix-Welt, wenn ich da als root etwas ausführe, dann läuft er als root, es sei denn, ich will es bewusst anders und dann muss ich mich noch mit sudo oder Ähnlichem verrenken. Windows ist natürlich kein Unix, aber ich gehe einfach mal davon aus, dass ein als eingeloggter Admin-User gestarteter Dienst dann auch unter Admin läuft.

Wenn nicht, haben wir hier ein Problem.

Was soll ich als Nächstes prüfen? Irgendwann sollte TSE schon bitte laufen. Gibt es eine Log-Datei, die man auswerten könnte?

Liebe Grüße
Zsolt
 

Shahne

Moderator
Mitarbeiter
9. Januar 2020
184
20
Hallo Zsolt,

das kommt bei Windows tatsächlich darauf an, ob der FCC als Dienst installiert wurde oder nicht. Wenn über run_fcc.bat die Kommandozeile geöffnet wird für den FCC, dann hat die keine Adminrechte, nur weil sie von einem Admin-User ausgeführt wird. Das klappt tatsächlich nur mit Rechtsklicken -> "Als Administrator ausführen", oder indem man in den Eigenschaften der Datei unter Kompatibilität die Eigenschaft setzt, dass sie immer als Admin ausgeführt werden muss. Ansonsten gilt (bei aktiver Benutzerkontensteuerung, die ja bei dir aktiv ist) leider nicht Admin eingeloggt = root. Schön wärs 😅 So nett ist Microsoft leider nicht.

Eine Logdatei gibt's im Zweifelsfall im Installationsordner (bin -> logs)

Grüße zurück,
Shahne
 
Ähnliche Themen
Titel Forum Antworten Datum
In Diskussion SumUp + JTL-POS Erfahrungen / TSE ?! Allgemeine Fragen zu JTL-POS 1
In Diskussion TSE und alle Einstellungen sind weg! JTL-POS - Fehler und Bugs 5
In Bearbeitung Systemanforderungen für Fiskal Cloud TSE Allgemeine Fragen zu JTL-POS 1
Beantwortet Sumup TSE und JTL POS Allgemeine Fragen zu JTL-POS 1
Neu fehlende Verknüpfung WaWi Kunden Woocommerce Kunden JTL-Wawi - Fehler und Bugs 0
Neu PayPal Checkout - Verknüpfung nicht möglich Endlosschleife JTL-Shop - Fehler und Bugs 5
BUG: Keine Error Anzeige in SCX JTL-Wawi 1.7 5
Neu Error 500 auf einzelnen Artikelseiten, sonstiger Shop funktioniert JTL-Shop - Fehler und Bugs 2
Neu SQL Error -1 preforming exec nach Windows Update JTL-Wawi - Fehler und Bugs 2
Neu [Error][Code:518] Your application has exceeded usage limit on this call, please make call to Developer Analytics API to check yo eBay-Anbindung - Fehler und Bugs 41
BUG: Konfigurationsgruppen: Anmerkung leer + Thread-Error JTL-Wawi 1.7 2
Neu Ebay Abgleich Fehler Error calling EaEbaySynchronizeGet eBay-Anbindung - Fehler und Bugs 1
Neu Filestream Error - Datei defekt oder nicht vorhanden User helfen Usern - Fragen zu JTL-Wawi 10
Neu HTTP Error 500 Allgemeine Fragen zu JTL-Shop 2
Neu Warning und Error Installation / Updates von JTL-Shop 1
Neu ERROR: Der WooCommerce JTL-Connector funktioniert nicht mit dem Plugin Shield Security WooCommerce-Connector 0
Neu Error 400 - HändlerID ist ungültig Amazon-Anbindung - Fehler und Bugs 8
Neu Kein zugriff auf Backend / Fatal Error JTL-Shop - Fehler und Bugs 6
Runtime Error - Ungültige Klasse JTL-Wawi 1.6 4
Fehlercode 400 CreateProduct request failed with Exception: 'Unknown error' kaufland.de - Anbindung (SCX) 0
Neu 02.09.2022 JTL-Shipping The remote server returned an error: (502) Bad Gateway JTL-ShippingLabels - Fehler und Bugs 35
Neu Paypal checkout Express löst Error 500 aus Plugins für JTL-Shop 1

Ähnliche Themen