In Diskussion TSE Verknüpfung Error Code 401

CafeKitsch

Neues Mitglied
9. April 2021
15
0
Hallo zusammen,

ich bin dabei, die Fiskal Cloud TSE einzurichten. Der Connector wurde wohl ohne Fehler installiert, aber bei der Verknüpfung in der Kasse kommt als Fehlermeldung Return Code 401.

Dabei ist mir aufgefallen, dass in der Mail mit dem EAS Code die Seriennummer NICHT angegeben ist, obwohl ich diese bei der Buchung angegeben habe.

Firewall ist angepasst.

Was nun?

Viele Grüße aus Linz!
 

Shahne

Moderator
Mitarbeiter
9. Januar 2020
209
24
Hallo CafeKitsch,

der Fehlercode 401 steht grundsätzlich für "Unauthorized" und wird der Kasse zurückgegeben, weil sie nicht zum Zugriff auf den FCC berechtigt war. Sie hat den Rechner also erreichen können, aber die Verbindung wurde abgelehnt.

Das passiert üblicherweise nur durch einen der drei folgenden Faktoren:
- Der FCC wurde nicht mit Windows-Administratorrechten gestartet und darf deswegen keine Zugriffe von außen zulassen. Gegebenenfalls wäre hier zu empfehlen den Dienst oder die run_fcc.bat Kommandozeile immer über einen Administrator oder mit Administratorrechten laufen lassen, um das zu vermeiden
- Eine Firewall oder Antivirensoftware verhindert den externen Zugriff auf den FCC aus Sicherheitsgründen. Wenn eine solche Software auf dem Rechner im Einsatz ist, bitte unbedingt eine Ausnahmeregel für den FCC einrichten, damit externe Verbindungen zugelassen werden
- Benutzerkontensteuerung aktiv und nicht bestätigt. Falls die Windows-Benutzerkontensteuerung aktiv ist (das berühmte "Möchten sie zulassen, dass diese Software Änderungen an ihrem System vornimmt" Popup was den ganzen Bildschirm ersetzt) und die Freigabe für den FCC nicht bestätigt wurde, kann er ebenfalls keine Verbindungen von außen zulassen. Auch hier greift im Kern wieder das Rechtesystem von Microsoft und macht im umgangssprachlichen Sinne "die Tür zu".

Mit freundlichen Grüßen,
Shahne
 

CafeKitsch

Neues Mitglied
9. April 2021
15
0
Hallo,

ich habe jetzt mal den Port gescannt - ok. Danach den Service, eingeloggt als Admin, gestoppt und erneut gestartet - ok.

Am Ergebnis ändert sich nichts. Verknüpfe ich die Kasse mit der TSE, kommt derselbe Fehler wie bisher auch.

Ich würde gerne noch einmal die Aufmerksamkeit auf die Tatsache lenken, dass in der E-Mail mit den Zugangsdaten das Feld mit der Seriennummer der Kasse (EAS Serial) LEER ist. Ich habe keine Ahnung, ob das eine Rolle spielt. Falls die Seriennummer Teil der Authentifizierung ist, dann kann sie natürlich nicht funktionieren.

Viele Grüße

Zsolt Majsai
 

Shahne

Moderator
Mitarbeiter
9. Januar 2020
209
24
Hallo CafeKitsch,

wir haben nochmal intern nachgesehen und die Seriennummer ist korrekt hinterlegt. Warum sie in der generierten E-Mail gefehlt hat kann ich nicht mehr sagen, aber sie ist auf jeden Fall ordentlich registriert worden. Als du als Admin eingeloggt warst, hast du den Prozess explizit mit Admin-Rechten aufgerufen? Standardmäßig ist unter Windows die sogenannte "Benutzerkontensteuerung" aktiv, sodass man vor jedem Programm das mit Adminrechten läuft erstmal eine Bestätigung abgeben muss. Das Fenster dafür kennt glaube ich jeder Windows-Anwender ("Möchten sie zulassen, dass durch diese Anwendung Änderungen am System vorgenommen werden")

Liebe Grüße,
Shahne
 

CafeKitsch

Neues Mitglied
9. April 2021
15
0
Hallo, danke für die Antwort.

bei der Installation selbst wusste ich nicht, dass Admin-Rechte notwendig sind. Aber die Installationsroutine selbst hat die Admin-Rechte angefordert (das berühmte Fenster, das jeder Anwender kennt ;) ) und sie auch bekommen.

Beim Neustart des Services war ich explizit als Admin-User eingeloggt. Beim Service selbst konnte ich nicht eingeben, ihn als Admin-User zu starten, allerdings war ich ja bereits Admin-User. Ich komme eigentlich aus der Unix-Welt, wenn ich da als root etwas ausführe, dann läuft er als root, es sei denn, ich will es bewusst anders und dann muss ich mich noch mit sudo oder Ähnlichem verrenken. Windows ist natürlich kein Unix, aber ich gehe einfach mal davon aus, dass ein als eingeloggter Admin-User gestarteter Dienst dann auch unter Admin läuft.

Wenn nicht, haben wir hier ein Problem.

Was soll ich als Nächstes prüfen? Irgendwann sollte TSE schon bitte laufen. Gibt es eine Log-Datei, die man auswerten könnte?

Liebe Grüße
Zsolt
 

Shahne

Moderator
Mitarbeiter
9. Januar 2020
209
24
Hallo Zsolt,

das kommt bei Windows tatsächlich darauf an, ob der FCC als Dienst installiert wurde oder nicht. Wenn über run_fcc.bat die Kommandozeile geöffnet wird für den FCC, dann hat die keine Adminrechte, nur weil sie von einem Admin-User ausgeführt wird. Das klappt tatsächlich nur mit Rechtsklicken -> "Als Administrator ausführen", oder indem man in den Eigenschaften der Datei unter Kompatibilität die Eigenschaft setzt, dass sie immer als Admin ausgeführt werden muss. Ansonsten gilt (bei aktiver Benutzerkontensteuerung, die ja bei dir aktiv ist) leider nicht Admin eingeloggt = root. Schön wärs 😅 So nett ist Microsoft leider nicht.

Eine Logdatei gibt's im Zweifelsfall im Installationsordner (bin -> logs)

Grüße zurück,
Shahne
 
Ähnliche Themen
Titel Forum Antworten Datum
Gelöst EPSON TSE USB 5 JTL-POS - Fragen zu Hardware 1
Gelöst JTL-POS : Epson TSE Anbindung - TSE gebraucht (Tillhub) - OTHER_ERROR_HOST_AUTHENTICATION_FAILED JTL-POS - Fehler und Bugs 4
Gelöst App stürzt ab + TSE fällt sporadisch aus JTL-POS - Fehler und Bugs 8
In Bearbeitung Swiss Bit TSE Ausfall nach Update, pls Help JTL-POS - Fehler und Bugs 6
In Diskussion SumUp + JTL-POS Erfahrungen / TSE ?! Allgemeine Fragen zu JTL-POS 1
In Diskussion TSE und alle Einstellungen sind weg! JTL-POS - Fehler und Bugs 5
In Bearbeitung Systemanforderungen für Fiskal Cloud TSE Allgemeine Fragen zu JTL-POS 1
Beantwortet Sumup TSE und JTL POS Allgemeine Fragen zu JTL-POS 1
Neu fehlende Verknüpfung WaWi Kunden Woocommerce Kunden JTL-Wawi - Fehler und Bugs 0
Neu Logbuchfehler: Error sending mail: Bitte geben Sie mindestens eine Empfängeradresse an. JTL-Shop - Fehler und Bugs 0
Neu Error 500 bzw. 504 Gatewy Timeout nach Update Installation / Updates von JTL-Shop 5
Neu DELETE-Anweisung steht in Konflikt mit der REFERENCE-Einschränkung - eazybusiness-Datenbank Error JTL-Wawi - Fehler und Bugs 2
Neu JTL Shop 5.1.5 zu 5.2.1 Error Installation / Updates von JTL-Shop 2
Neu PHP Fatal error in Verfügbarkeitsbenachrichtigungen (OptinAvailAgain.php) JTL-Shop - Fehler und Bugs 4
Neu Nach Update auf 5.2.1 HTTP 500 Error beim Aufruf von Kategorie-Seiten JTL-Shop - Fehler und Bugs 6
Gelöst Problem mit der Produktseite? HTTP error 500 Installation / Updates von JTL-Shop 4
Neu 5.21 - Fatal Error sobald Artikel im Warenkorb JTL-Shop - Fehler und Bugs 5
Neu Artikelseite nicht verfügbar - HTTP ERROR 500 Installation / Updates von JTL-Shop 10
Beantwortet HTTP 500 Error nach Serverumzug Installation / Updates von JTL-Shop 0
Timeout 500 Error: Einrichten von Weiterleitungen anhand Artikelnummer Einrichtung JTL-Shop5 5
Neu Amazon Multi-Channel Fulfillment (MCF) Ausliefern Error User helfen Usern - Fragen zu JTL-Wawi 6
Neu Wenn ich einer bestimmte Artikel im Wawi Änderung durchführe kommt Error 500 PrestaShop-Connector 0
Neu Error: 503; Ladefehler ; ShopDown Allgemeine Fragen zu JTL-Shop 2
Neu Kann Pluginverwaltung nicht mehr aufrufen - HTTP ERROR 500 JTL-Shop - Fehler und Bugs 4
BUG: Keine Error Anzeige in SCX JTL-Wawi 1.7 7
Neu Error 500 auf einzelnen Artikelseiten, sonstiger Shop funktioniert JTL-Shop - Fehler und Bugs 2
Neu SQL Error -1 preforming exec nach Windows Update JTL-Wawi - Fehler und Bugs 4
Neu [Error][Code:518] Your application has exceeded usage limit on this call, please make call to Developer Analytics API to check yo eBay-Anbindung - Fehler und Bugs 41
BUG: Konfigurationsgruppen: Anmerkung leer + Thread-Error JTL-Wawi 1.7 4
Neu Ebay Abgleich Fehler Error calling EaEbaySynchronizeGet eBay-Anbindung - Fehler und Bugs 1

Ähnliche Themen