Neu Suchplugin Fehler

Afox

Gut bekanntes Mitglied
12. April 2012
331
4
Hallo,

ich habe ein Such-Plugin von einem Servicepartner erworben und es funktioniert nicht in meinem Setup ( Shop 3.20.6).

Er wirft folgenden Fehler:

Catchable fatal error: Argument 1 passed to Hersteller::loadFromObject() must be an instance of stdClass, boolean given, called in /Pfad/zum/Shop/classes/class.JTL-Shop.Hersteller.php on line 97 and defined in /Pfad/zum/Shop/classes/class.JTL-Shop.Hersteller.php on line 59
Vielleicht kann ja jemand etwas damit anfangen. Der Hersteller meint es würde bei anderen Kunden funktionieren.

Grüße,

Afox
 
Zuletzt bearbeitet:

david

Administrator
Mitarbeiter
16. Juli 2010
2.203
93
Ich vermute, das Plugin möchte einen Hersteller laden, den es in der Shopdatenbank nicht gibt.
Wawi-Abgleich mit Komplettübertragung der Globals / Hersteller schon probiert?
 

Afox

Gut bekanntes Mitglied
12. April 2012
331
4
habe gerade mal einen Komplettabgleich gemacht und einen verdächtigen Hersteller gelöscht. Bisher ohne Erfolg.
 

david

Administrator
Mitarbeiter
16. Juli 2010
2.203
93
Eine Fehleranalyse ist ohne Kenntnis deines Shops oder des angemerkten Suchplugins natürlich schwierig.
Wann genau wird denn der Fehler geschmissen? Direkt nach Installation des Plugins im Frontend oder dann, wenn einen Suchbegriff eintippt (einen bestimmten)?
 

Afox

Gut bekanntes Mitglied
12. April 2012
331
4
der Fehler tritt auf wenn ein Suchbegriff eingegeben wird. Konkret wird ein POST an die Datei "suggest.php" mit einem 500 Internal Server Error und dem genannten Fehler in den Logs beantwortet.
 

david

Administrator
Mitarbeiter
16. Juli 2010
2.203
93
Etwas Hilfe vom Pluginentwickler wäre dann prima - auch wenn es dazu sonst keine bekannten Fälle gibt.
Der Stacktrace im ersten Post geht ja leider nicht bis zur suggest.php.
 

Afox

Gut bekanntes Mitglied
12. April 2012
331
4
ja verstehe. Der weiß aber selbst nicht weiter :D
Ich habe jetzt etwas sehr merkwürdiges festgestellt:
Wenn ich das Plugin "Smarter Smarty Debug" (Kreativkonzentrat) mit aktivierter Option "Anzeige von PHP-Fehlern aktivieren?" aktiviere, funktioniert die Suche plötzlich. Auch wenn ich das genannte Plugin wieder deaktiviere funktioniert sie weiter. Allerdings habe ich einen Cronjob der mir die Webserver-configs erstellt und wenn der durchgelaufen ist, geht die Suche wieder nicht und ich muss wieder den "Trick" anwenden.

Ich möchte noch hinzufügen, dass PHP-FPM läuft.

@Southbridge Media ist der Entwickler des Plugins.
 
Zuletzt bearbeitet:

Afox

Gut bekanntes Mitglied
12. April 2012
331
4
ich wollte nochmal nachhören ob es irgendeine Vermutung gibt, weshalb das Plugin nach dem einmaligen Aufrufen bei aktiviertem "Smarter Smarty Debug" (einzig aktive Option in diesem Plugin: "Anzeige von PHP-Fehlern aktivieren") plötzlich und dauerhaft funktioniert und vorher nicht. Könnte es etwas mit suexec zu tun haben? Webserver ist ein Apache 2.4 mit PHP-FPM.

Die htaccess sieht so aus:
Code:
<Files suggest.php>
    <IfModule mod_authz_core.c>
        Require all granted
    </IfModule>
    <IfModule !mod_authz_core.c>
        Order Allow,Deny
        Allow from all
    </IfModule>
</Files>
Gruß, Afox
 

Afox

Gut bekanntes Mitglied
12. April 2012
331
4
gibt es eine Möglichkeit das weiter zu untersuchen? ich würde gerne der Ursache auf den Grund gehen...
 

Über uns

  • In unserem moderierten JTL-Forum könnt Ihr Euch themenbezogen mit der JTL-Community rund um die Produkte von JTL, passende Erweiterungen und den E-Commerce im Allgemeinen austauschen, Tipps und Tricks teilen sowie Verbesserungswünsche und Fehler diskutieren.

    Unsere Forumsnutzer helfen sich untereinander auch gerne weiter, wenn Sie mal nicht weiterkommen oder einen Ratschlag benötigen.

Schnell-Navigation

Benutzer Menü