Neu SQL Fehler im Logbuch

waagenwelt

Sehr aktives Mitglied
30. September 2012
504
145
Toppenstedt
Hallo

Im Logbuch finde ich an nach Migration einem Tag 100te von Einträgen der Form

Error executing query: SELECT tseo.cSeo, ssMerkmal.kKategorie, ssMerkmal.cName,
ssMerkmal.nSort, COUNT(*) AS nAnzahl
FROM (SELECT tkategorie.kKategorie, tkategorie.nSort, tkategorie.cName
FROM tartikel
#JOIN from JTLFilterStatesBaseCharacteristic::getSQLJoin
JOIN (SELECT kArtikel
FROM tartikelmerkmal
WHERE kMerkmalWert = 415
GROUP BY tartikelmerkmal.kArtikel
) AS tmerkmaljoin ON tmerkmaljoin.kArtikel = tartikel.kArtikel

#join from JTLFilterItemsCategory::getSQLJoin.... (gekürzt).

mit der abschließenden Fehlermeldung

SQLSTATE[42000]: Syntax error or access violation: 1066 Not unique table/alias: tkategorieartikelgesamt

Probeweise alle Plugins deaktiviert und auf Nova-Template gewechselt
Keine Verbesserung.

Die Maria-DB nimmt sich fasst die gesamte CPU, so dass der Server zeitweise kaum erreichbar ist (ob o.g. Fehler die Ursache sind oder es noch ein weiteres Problem gibt, weiß ich noch nicht).

Kennt jemand eine Lösung dazu?

Viele Grüße

Stefan
 

deliwelt

Gut bekanntes Mitglied
17. Januar 2013
134
20
Hallo,
beim Nachschauen fand ich das auch so oder so ähnlich ("Error executing query: SELECT tseo.cSeo, ssMerkmal.kKategorie, ssMerkmal.cName,...").
Fehlermeldung: SQLSTATE[HY093]: Invalid parameter number: mixed named and positional parameters

Da wir parallel auch plötzlich immer wieder komplette Ausfälle (Bad Gateway 502 nginx) haben, bin ich momentan etwas irritiert.
Freue mich auch über jegliche Info.

Gruß Micha
 

waagenwelt

Sehr aktives Mitglied
30. September 2012
504
145
Toppenstedt
Kein Hinweis von JTL?
Wenn der Shop (wie im Moment gerade) zeitweilig ausfällt, ist das nicht so lustig. 🙁
Leider auch noch keine Reaktion auf das Ticket, das ich vorgestern erstellt habe.

Viele Grüße
Stefan
 

waagenwelt

Sehr aktives Mitglied
30. September 2012
504
145
Toppenstedt
@deliwelt
Habe heute vom Support den Workaround vorgeschlagen bekommen, das Setting "Darstellung -> Standardansichten -> Artikelübersicht->Kategoriefilter anzeigen als" nicht auf "Hierarchische Filterung" zu stellen.
Das scheint zu helfen.

Viele Grüße
Stefan
 

gnarx

Sehr aktives Mitglied
18. Januar 2018
3.901
545
@deliwelt
Habe heute vom Support den Workaround vorgeschlagen bekommen, das Setting "Darstellung -> Standardansichten -> Artikelübersicht->Kategoriefilter anzeigen als" nicht auf "Hierarchische Filterung" zu stellen.
Das scheint zu helfen.

Viele Grüße
Stefan
War bei uns auch nicht auf "Hierarchische Filterung" eingestellt. Heute hat sich der Support gemeldet hoffe das sich morgen da was tut.
 

deliwelt

Gut bekanntes Mitglied
17. Januar 2013
134
20
Na vielleicht gibt es dann ja eine neue Info. Wäre toll wenn du sie dann hier posten würdest.

Gruß,
Micha
 

gnarx

Sehr aktives Mitglied
18. Januar 2018
3.901
545
Klar mache ich. Ich kann euch sagen wie ihr den Shop am Leben erhaltet.
1. Einloggen beim Provider und die Shop Datenbank per phpMyAdmin
2. Oben dann auf die Datenbank klicken (Server: local host)
3. Dort auf "Status" (oben in den Tabs)
4. Alle Prozesse beenden die mit "SELECT tseo.cSeo," beginnen. Unter Umständen auch die "ssMerkmal" enthalten, normal und die mit Max.
Manchmal kann es auch sein alle Prozesse zu kicken. Dann immer mal auf Aktualisieren klicken bist alle raus hast 2 (SHOW PROCESSLIST und Sleep) bleiben immer drinne und sind nicht zu beenden.
Dein Shop läuft dann wieder ein paar Stunden bis die Liste wieder voll ist bzw. Prozesse zu lange laufen.
 

fivelab.de

Aktives Mitglied
14. Dezember 2020
17
1
Emsdetten
Firma
fivelab GmbH
Wir haben bei einem Kunden das gleiche Problem: Der Server wird durch SQL-Anfragen ausgelastet.
Die "Kategoriefilter anzeigen als" Option habe ich gecheckt, die war in Ordnung.
Gibt's hier schon eine Idee?

Shop: 5.1.5
OS: Debian
LAMP: Apache, PHP8.1, MariaDB
 

fivelab.de

Aktives Mitglied
14. Dezember 2020
17
1
Emsdetten
Firma
fivelab GmbH
Feedback: Die Einstellung hat geholfen, seitdem haben wir keine Lastprobleme mehr.
Dankeschön für den Hinweis!

VG
 

das sams

Aktives Mitglied
17. März 2020
38
4
Ich habe das gleiche Problem und Hoaste direkt bei JTL und noch haben die keine Idee 🙁
 

shopmari

Aktives Mitglied
21. Dezember 2019
14
0
Hallo,

was für Fehler ist das?

Error executing query: SELECT SUM(ssMerkmal.anz0) AS anz0, SUM(ssMerkmal.anz1) AS anz1, SUM(ssMerkmal.anz2) AS anz2, SUM(ssMerkmal.anz3) AS anz3, SUM(ssMerkmal.anz4) AS anz4, SUM(ssMerkmal.anz5) AS anz5 FROM (SELECT COUNT(DISTINCT IF( < 5, tartikel.kArtikel, NULL)) AS anz0, COUNT(DISTINCT IF( < 7.5, tartikel.kArtikel, NULL)) AS anz1, COUNT(DISTINCT IF( < 10, tartikel.kArtikel, NULL)) AS anz2, COUNT(DISTINCT IF( < 12.5, tartikel.kArtikel, NULL)) AS anz3, COUNT(DISTINCT IF( < 15, tartikel.kArtikel, NULL)) AS anz4, COUNT(DISTINCT IF( < 17.5, tartikel.kArtikel, NULL)) AS anz5
FROM tartikel
#JOIN from JTLFilterStatesBaseCategory::getSQLJoin
JOIN tkategorieartikel ON tartikel.kArtikel = tkategorieartikel.kArtikel
LEFT JOIN tartikelkategorierabatt ON tartikelkategorierabatt.kKundengruppe = 1 AND tartikelkategorierabatt.kArtikel = tartikel.kArtikel
LEFT JOIN tartikelsonderpreis ON tartikelsonderpreis.kArtikel = tartikel.kArtikel
AND tartikelsonderpreis.cAktiv = Y
AND tartikelsonderpreis.dStart = CURDATE())
LEFT JOIN tsonderpreise ON tartikelsonderpreis.kArtikelSonderpreis = tsonderpreise.kArtikelSonderpreis
AND tsonderpreise.kKundengruppe = 1

#join1 from JTLFilterItemsPriceRange::getOptions
JOIN (tpreis
#subjoin for tpreis table
JOIN tpreisdetail ON tpreisdetail.kPreis = tpreis.kPreis AND tpreisdetail.nAnzahlAb = 0) ON tpreis.kArtikel = tartikel.kArtikel
AND tpreis.kKundengruppe = 1

#join2 from JTLFilterItemsPriceRange::getOptions
LEFT JOIN tartikelsichtbarkeit ON tartikel.kArtikel = tartikelsichtbarkeit.kArtikel
AND tartikelsichtbarkeit.kKundengruppe = 1

WHERE tkategorieartikel.kKategorie = 106 AND tartikelsichtbarkeit.kArtikel IS NULL AND tartikel.kVaterArtikel = 0
#default group by
GROUP BY tartikel.kArtikel

#limit sql
ORDER BY tartikel.nSort, tartikel.cName ) AS ssMerkmal
SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near < 5, tartikel.kArtikel, NULL)) AS anz0, COUNT(DISTINCT IF( < 7.5, tartikel.kA... at line 1
 

xadoX

Sehr aktives Mitglied
11. September 2012
664
70
Wir haben das Problem mit dem SQL beginnend mit

SQL:
SELECT tseo.cSeo,ssMerkmal.kHersteller,ssMerkmal.cName,ssMerkmal.nSortNr,ssMerkmal.cBildPfad,COUNT(*) AS nAnzahl

auch noch. Ist bekannt in welcher PHP-datei diese SQL-Anweisung ausgeführt wird?

Kategoriefilter anzeigen steht auf "Kategorien der Artikel"
optimizer_search_depth steht auf 0

JTL-Shop Version 5.2.4
 

Ähnliche Themen