Neu Shopware 5 Connector / Shop-Kundengruppe 0

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Sascha Hilger

Neues Mitglied
24. September 2020
3
0
Hallo,

ich bin neu mit JTL unterwegs und möchte zwecks Test unser bestehenden Shop mit den Connector verbinden und die Daten so importieren.

Das hat auch funktioniert, bis er die Artikel herunterladen wollte.

Jetzt kommt der folgende Fehler:

Fehler:
Artikel-Empfangen-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Zur Shop-Kundengruppe '0' konnte keine Wawi-Kundengruppe gefunden werden.
bei jtlDatabase.classes.ConnectorClasses.SaveClasses.Stuff.ConnectorSpecialValueGetter.GetCustomerGroupKey(String endpointID, Int32 kShop)
bei jtlDatabase.classes.ConnectorClasses.ProductSaver.nRResPrsWAQ(IEnumerable`1 , jtlArtikel , Boolean )
bei jtlDatabase.classes.ConnectorClasses.ProductSaver.Save(List`1 products, List`1& exceptions)
bei jtlDatabase.classes.ConnectorClasses.Saver.Save(IEnumerable`1 items, jtlShop shop, List`1& exceptions)
bei jtlCore.ControllerClasses.Connector.Abgleich.Funktionen.ConnectorPuller.Pull[TEntity](Int64 quantity)


Warnungen:
Artikelnummer 'ZU-STO-1077-0-0' ist bereits vorhanden. Der Wawi-Artikel wird aktualisiert.
Der Shop hat nicht alle Artikel gesendet.Abgleich abgebrochen.Abgleich abgebrochen.Abgleich abgebrochen.Abgleich abgebrochen.Abgleich abgebrochen.

Ich habe bereits in der Connector Einstellung die gefundenen Shop-Kundengruppen verknüpft.
Mehr Kundengruppen habe ich nicht.

Kann mir hier jemand helfen?
 

Frank Engelbrecht

Aktives Mitglied
15. Februar 2012
95
0
Worms
Hallo, genau den identischen Fehler haben wir hier auch festgestellt. Der Abgleich bricht mit exakt der gleichen Fehlermeldung ab.

Im Einsatz sind die Wawi 1.5.30.1, der Connector in Version 2.2.5.3, der Shop mit Version 5.5.6 auf PHP 7.3.23

Der Connector wurde schon zurückgesetzt, wonach der Fehler weiterhin auftrat.

Dann wurde der Connector vollständig neu installiert, Fehler ist noch vorhanden.

Müssen evtl. irgendwelche Datenbankeinträge manuell zurückgesetzt werden?
 
Zuletzt bearbeitet:

P24

Neues Mitglied
12. Oktober 2020
17
0
Auch bei uns besteht das Problem.
Danke @Shopküche.de für das Ticket!

In einem anderen Forum konnte Abhilfe aufgrund der Benutzereinstellungen geschaffen werden. In dem Forum war allerdings das Wordpress-Plugin woocommerce betroffen.
Hängt es eventuell mit Benutzerrechten im Shop zusammen?

Gruß
Peter
 
Zuletzt bearbeitet:

Shopküche.de

Offizieller Servicepartner
SPBanner
Auch bei uns besteht das Problem.
Danke @Shopküche.de für den Ticket-Link!

In einem anderen Forum konnte Abhilfe aufgrund der Benutzereinstellungen geschaffen werden. In dem Forum war allerdings das Wordpress-Plugin woocommerce betroffen.
Hängt es eventuell damit zusammen?

Gruß
Peter
Ich vermute hier eher einen Bug in JTL. Aufgrund der alten Shopware-Version und damit auch veralteten Connector-Version stimmt die Zuordnung der Kundengruppen in der Datenbank nicht. Wir sind gespannt auf die Rückmeldung von JTL.
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.122
237
Hallo,

an der Kundengruppen Logik wurde schon seit langem nichts mehr im Shopware 5 Connector geändert. Was passiert, wenn ihr die Kundengruppen in der Connector Konfiguration in JTL-Wawi neu zuordnet?

@P24 Beim WooCommerce Connector gab/gibt es unter bestimmten Umständen Probleme mit der Zuordnung einer Kundengruppe. Das ist allerdings ein anderes Problem.
 

Shopküche.de

Offizieller Servicepartner
SPBanner
Hallo,

an der Kundengruppen Logik wurde schon seit langem nichts mehr im Shopware 5 Connector geändert. Was passiert, wenn ihr die Kundengruppen in der Connector Konfiguration in JTL-Wawi neu zuordnet?
@Immanuel
Wir haben soeben den Abgleich mit einer Wawi Version 1.5.26 getestet. Der Abgleich funktioniert ohne Fehler. (Selbe Shop Version 5.5.6 und Connector 2.2.5.3)
Bei einer Wawi Version 1.5.30.X erscheint die oben genannte Fehlermeldung.
"Zur Shop-Kundengruppe '0' konnte keine Wawi-Kundengruppe gefunden werden."

Das neue zuordnen haben wir mehrfach probiert. Auch die Shop-Anbindung schon gelöscht und neu angelegt in JTL. Ohne Erfolg.
 
Zuletzt bearbeitet:

Shopküche.de

Offizieller Servicepartner
SPBanner

P24

Neues Mitglied
12. Oktober 2020
17
0
Da wieder einige Tage vergangen sind: Gibt es Neuigkeiten zu dem Thema?
Wenn wir auf eine ältere Version umstellen kommt beim Login die Meldung

"Die verwendete Version von JTL-Wawi ist zu alt. Bitte nutzen Sie die Version 1.5.31.0",

was wiederum zu dem Thema Shop-Kundengruppe '0' führt.
Wir drehen uns also im Kreis...

Gruß
Peter
 

olli1it

Gut bekanntes Mitglied
2. November 2009
147
0
Hi ich habe eine ältere Version von JTL installiert und ein älteres Datenbank Backup reingeladen dann hat es funtkioniert.
 

swolfram24

Aktives Mitglied
26. März 2013
8
0
Gott, bin ich mittlerweile genervt....

Das Problem mit "Kundengruppe 0" tritt auch bei anderen Connectoren und Shopsystemen auf in WAWI 1.5.34
Auch mit einem " modified eCommerce System" 2.0.5.0 sowie 2.0.5.1 sowie WooCommerce in aktueller Version (ebenfalls hier im Forum nachzulesen).

Beispiel:
Die Connectoren der Version 3 für das modified eCommerce System funktionieren ebenso nicht (man muss auf v2 zurückgreifen), dazu gibt es ebenfalls einen Thread hier im Forum, wo sogar der Fehler im Code gepostet wird.
Die Zusage von JTL man kümmert sich drum ist bis heute nix passiert.
 

hopser

Neues Mitglied
25. Dezember 2020
2
0
Guten Abend ich habe irgendwie nun genau den gleichen Fehler aber ich komme einfach nicht zur Lösung:

Fehler:
Artikel-Empfangen-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Zur Shop-Kundengruppe '0' konnte keine Wawi-Kundengruppe gefunden werden.
bei jtlDatabase.classes.ConnectorClasses.SaveClasses.Stuff.ConnectorSpecialValueGetter.GetCustomerGroupKey(String endpointID, Int32 kShop)
bei jtlDatabase.classes.ConnectorClasses.ProductSaver.VKL4xWLFy1Y(IEnumerable`1 , jtlArtikel , Boolean )
bei jtlDatabase.classes.ConnectorClasses.ProductSaver.Save(List`1 products, List`1& exceptions)
bei jtlDatabase.classes.ConnectorClasses.Saver.Save(IEnumerable`1 items, jtlShop shop, List`1& exceptions)
bei jtlCore.ControllerClasses. Connector.Abgleich.Funktionen.ConnectorPuller.Pull[TEntity](Int64 quantity)



Warnungen:
Artikelnummer 'SW10024.0' ist bereits vorhanden. Der Wawi-Artikel wird aktualisiert.
Der Shop hat nicht alle Artikel gesendet.Abgleich abgebrochen.Abgleich abgebrochen.Abgleich abgebrochen.Abgleich abgebrochen.Abgleich abgebrochen.
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Shopware - Connector - JTL 5 Shop Umstieg auf JTL-Shop 0
Neu Shopware Connector 5 und 6 Shopware-Connector 1
Neu Maximale Verkaufsmenge - Shopware 6 Connector Shopware-Connector 0
Neu Neuester Connector (2.8.6) synct Artikel unvollständig zu Shopware Shopware-Connector 5
Neu Shopware 6 Connector | Problem mit Variantenartikeln Shopware-Connector 0
Neu Shopware 6 Connector Fehler Shopware-Connector 1
Neu Shopware 6 Connector zerschießt Shopinstallation Shopware-Connector 0
Neu Shopware 6 Connector Abgleich Problem Shopware-Connector 4
Neu Shopware 6 Connector Fehler / Synch nicht möglich Shopware-Connector 5
Neu Wawi 1.5.27.3 ->JTL Connector 2.8.1 >- Shopware 5.6.9 Kategorien werden nicht übertragen Shopware-Connector 0
Neu Shopware mit Redis Cache und JTL Connector Problem Shopware-Connector 8
Neu Connector version 2.8.1 Shopware Fehlerhaft Shopware-Connector 6
Neu Keine Bild-Links mehr im Shopware Produktexport (Varianten Lösung) Shopware-Connector 3
Neu Shopware 6 - Probleme mit Attributen Shopware-Connector 1
Neu Shopware 6 und Variantenbilder (Swatches) Shopware-Connector 1
Neu JTL Wawi - Shopware - Subshops mit unterschiedlichen Beschreibungen Shopware-Connector 12
Neu Abgleichprobleme zu Shopware 6 nach Migration Shopware-Connector 1
Neu Übernimmt Shopware nicht alle Bilder bei langen Artikelnamen? Shopware-Connector 0
Neu Wawi Import von Shopware > Abbruch? Shopware-Connector 7
Neu Artikel aus Shopware 6 importieren Shopware-Connector 2
Neu Shopware Syncronisiert nicht mit JTL Shopware-Connector 2
Neu Aufträge: zugehörige Shopware Subshop-Namen in JTL-Wawi vorhanden? Shopware-Connector 2
Neu Name oder Bezeichnung der Zahlweise aus Shopware? JTL-Wawi - Fehler und Bugs 2
Neu Alle Daten aus vorhandenem Shopware Shop in Wawi Synchronisieren Shopware-Connector 3
Neu Fehler und Abbruch beim Shopabgleich zu Shopware User helfen Usern - Fragen zu JTL-Wawi 3
Neu Abgleich mit Shopware 6 ohne Änderung im Shop Shopware-Connector 0
Neu Abgleich mit Shopware 6 erzeugt einen Abbruch mit Fehler Onlineshop-Anbindung 3
Neu Shopware 6 - Fehler UTF-8 Fehler Shopware-Connector 0
Neu Fragen zur Anbindung/Verwaltung Shopware<->JTL-WaWi Onlineshop-Anbindung 0
Neu Daten eines Plugin (FAQ in Artikeldetailseiten) in shopware werden gelöscht Technische Fragen zu den JTL-Connectoren 3
Neu Shopware 6 - Abgleich klappt nicht Shopware-Connector 2
Neu Shopware Gratisartikel / Funktionsartikel von JTL ausschließen? Shopware-Connector 2
Neu Woocommerce -> Connector -> Steuernummer WooCommerce-Connector 0
Neu Gambio Connector Dokumentation Gambio-Connector 8
Neu Gambio Connector und Gambio Klarna HUB Gambio-Connector 5
Neu Alter Oxid Connector Oxid-Connector 0
Neu Connector für Gambio 4.3.3.0 Gambio-Connector 4
Neu Gelöst: WooCommerce-Connector: "Shop-URL verweist nicht auf gültigen Shop" - Was kann ich tun? Onlineshop-Anbindung 1
Neu Woocommerce Connector / Lizenzfehler WooCommerce-Connector 12
Neu Lizenzproblme mit Version 1.18 JTL Connector + Woocommerce 5.0 WooCommerce-Connector 1
Neu JTL Connector - Custom Product Options Dienstleistung, Jobs und Ähnliches 0
Neu eigener Connector zu PIMCORE : beim Auftragsimport werden die Order-Mengen der Artikel 1:1 zusätzlich als Wareneingänge gebucht Allgemeines zu den JTL-Connectoren 0
Neu Fehlermeldung bei Installation modified connector 3.3.0: Uncaught Exception: Cannot start session Modified eCommerce-Connector 1
Neu Fehler beim Gambio Connector Fehlermeldung Payment Gambio-Connector 18
Neu connector -> wawi 1.5.37 -> Abgleich schlägt fehl WooCommerce-Connector 1
Neu Woocommerce Connector 1.16.x / Bestände werden nicht aktualisiert WooCommerce-Connector 3
Neu Werte der Kattegorie-Attribute (Google Shopping) werden gelöscht - Connector 2.8.5 Shopware-Connector 0
Neu Rückfrage zu Gambio Connector-Update Gambio-Connector 3
Neu Connector für Gambio 4.2.0.1 Gambio-Connector 1
Neu Prestashop connector - SEO, Attribute anzeigen als etc. PrestaShop-Connector 0
Ähnliche Themen