Neu Shop5 - Artikelübersicht: Beim Mouseover wird autom. das zweite Artikelbild angezeigt - wie abstellen?

tsinus

Gut bekanntes Mitglied
7. Januar 2013
232
6
Shop 5 / NOVA:
In der Artikelübersicht einer Kategorie werden z.B. acht Produktbilder der Artikel angezeigt, die sich in dieser Kategorie befinden.
Will der Besucher nun ein Produkt auswählen, um zur Artikeldetailseite zu kommen, erscheint automatisch das zweite Produktbild sobald er mit der Maus über den gewünschten Artikel fährt.
Wie, bzw. wo kann ich das abstellen?

Gruß
Thomas
 
Zuletzt bearbeitet:

ARA-Marketing

Offizieller Servicepartner
SPBanner
2. Oktober 2008
902
91
Regensburg
Hi.... mit den Bordmittel gar nicht...

Child-Template machen und die entsprechende tpl kopieren, und die Bildernummer {$image = $Artikel->Bilder[0]}
ändern, damit die Funktion selber erhalten bleibt (es erscheint ja beim hover noch mehr, Wunschartikel/Vergleich usw...)
aber das Bild bei Bild 1 bleibt.

Viele Grüße
Eas
 
  • Gefällt mir
Reaktionen: hula1499

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
591
166
Hallo @tsinus

du könntest es auch einfach per css machen (ungetestet):
CSS:
.list-gallery:hover img.first {

  opacity: 1;

}

.list-gallery:hover img.second {

  opacity: 0;

}

Dann wären die Bilder allerdings trotzdem noch unnötigerweise vorhanden, halt nur unsichtbar. Man könnte sie also in einem Child-Template noch entfernen.

Viele Grüße
Michael
 

Alban

Aktives Mitglied
17. November 2014
9
1
Hi.... mit den Bordmittel gar nicht...

Child-Template machen und die entsprechende tpl kopieren, und die Bildernummer {$image = $Artikel->Bilder[0]}
ändern, damit die Funktion selber erhalten bleibt (es erscheint ja beim hover noch mehr, Wunschartikel/Vergleich usw...)
aber das Bild bei Bild 1 bleibt.

Viele Grüße
Eas

Hmm, verstehe ich nicht, zu was muss {$image = $Artikel->Bilder[0]} geändert werden?

VG,
Alban
 

frezno

Neues Mitglied
18. März 2021
20
1
München
gibt es dahingehend was Neues?
Ich hab das oben empfohlene css eingefügt (in my-nova_crt.scss) kompiliert, Cache geleert - aber nichts passiert, nach wie vor erscheint das zeite Artikelbild beim hovern.
Was mach ich ggf falsch oder wie erreiche ich es, dass das zweite Bild beim hovern nicht mehr erscheint?
 
Zuletzt bearbeitet:

ARA-Marketing

Offizieller Servicepartner
SPBanner
2. Oktober 2008
902
91
Regensburg
Servus....
also mal so zur Erklärung: die xxxx_crt.scss ist sozusagen der "Preload" der CSS-Dateien, also das schnelle, damit die Browser was zu lesen und zum Initialisieren haben.
wenn dann musst du es in die xxx.scss eintragen und dann kompilieren....

der richtige und Königsweg ist allerdings, Child-Template -> custom.css !!!

VG
Eas
 

mastertango

Sehr aktives Mitglied
10. Oktober 2009
2.299
11
Wustrow
Habe es folgendermaßen gelöst im Nova ...

Ich habe in der item_list.tpl folgendes geändert

Code:
{if !$isMobile && !empty($Artikel->Bilder[0])}
                                                    {$image = $Artikel->Bilder[0]}
                                                    <div class="productbox-image square square-image second-wrapper">
                                                        <div class="inner">
                                                            {image alt=$image->cAltAttribut|escape:'html' fluid=true webp=true lazy=true
                                                                src="{$image->cURLKlein}"
                                                                srcset="{$image->cURLMini} {$Einstellungen.bilder.bilder_artikel_mini_breite}w,
                                                                    {$image->cURLKlein} {$Einstellungen.bilder.bilder_artikel_klein_breite}w,
                                                                    {$image->cURLNormal} {$Einstellungen.bilder.bilder_artikel_normal_breite}w"
                                                                sizes="auto"
                                                                class="second"
                                                            }
                                                        </div>
                                                    </div>
                                                {/if}

dazu dann folgende Zeile gelöscht
Code:
class="{if !$isMobile && !empty($Artikel->Bilder[1])}first{/if}"

das gleiche in der item_box.tpl
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Nach dem Upgrade Shop4 > Shop5 - Wawi-Syncdaten müssen manuell abgespeichert werden? JTL-Shop - Fehler und Bugs 1
Neu Shop5 NOVA - SWATCH-Image - PopUp deaktivieren Templates für JTL-Shop 2
Neu Shop5 NOVA - Galerieansicht Bilder vergrößern Templates für JTL-Shop 2
Neu JTL Shop5 Paypal Express Checkout PayerID is missing Plugins für JTL-Shop 0
Komprimierung des HTML-Ausgabedokuments / Template Einstellung fehlt JTL Shop5 ? Einrichtung JTL-Shop5 0
Neu Produktdaten für rich snippets werden von Shop5 (NOVA) nicht geliefert Allgemeine Fragen zu JTL-Shop 1
Neu Artikel im Shop5 aber nicht in der Wawi User helfen Usern - Fragen zu JTL-Wawi 2
libzip/ ziparchive/ ZIP für Shop5 Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu Preloader für JTL Shop5 Allgemeine Fragen zu JTL-Shop 6
Neu Shop5 Neuinstallation - bei aufruf von /News - HTTP ERROR 500 Allgemeine Fragen zu JTL-Shop 3
Shop5 neu installiert, Wawiabgleich vorgenommen, keine Artikel im Shop sichtbar Einrichtung JTL-Shop5 2
Neu Umzug von Modified auf JTL Shop5 Allgemeine Fragen zu JTL-Shop 3
Neu Suche Inspiration für unseren neuen Shop5 User helfen Usern 0
Neu JTL Shop5 Zahlung mit Paypal Differenz in Wawi JTL-Wawi - Fehler und Bugs 5
Neu shop5 > canonical tags für eigene seiten enthalten doppelte urls? Allgemeine Fragen zu JTL-Shop 2
Neu Shop5 Nova Template Allgemeine Fragen zu JTL-Shop 2
Neu Shop5 Kategorien unübersichtlich Allgemeine Fragen zu JTL-Shop 0
Neu Shop5 - Fest hinterlegte Lieferadresse in Kategorie User helfen Usern 0
Neu Werbung Shop5 Betrieb / Pflege von JTL-Shop 2
Neu Shop5. Check24 Allgemeine Fragen zu JTL-Shop 0
Neu Wie läuft Plugin-Update von Shop4 auf Shop5? Technische Fragen zu Plugins und Templates 4
Neu Shop5 und Adminbereich Einrichtung JTL-Shop5 7
Idee gesucht für eine Altersverifikation im Shop5 Einrichtung JTL-Shop5 4
Neu Fehlermeldungen bei Neu-Installation von Shop5 Installation / Updates von JTL-Shop 5
Startseite Shop5 Kategorien Einrichtung JTL-Shop5 4
Neu Shop5: Wurzelkategorie geändert, alle Kategorien weg Betrieb / Pflege von JTL-Shop 0
Neu Shop5 Eigene Felder unterhalb Artikelbeschreibung einfügen Templates für JTL-Shop 2
Neu Shop5: favicon.ico und Touch-Icons - wohin damit? Technische Fragen zu Plugins und Templates 0
JTL Shop5 Composer SVG Dateien Einrichtung JTL-Shop5 4
Neu [Shop5] Sitemap.php failed to delete buffer JTL-Shop - Fehler und Bugs 1
Neu Kein Wawi Abgleich nach Update auf Shop5 Installation / Updates von JTL-Shop 4
Neu Shop5 nur für spezielle Kundengruppe zugänglich Allgemeine Fragen zu JTL-Shop 2
Neu Lieferzeit schon in der Artikelübersicht anzeigen Allgemeine Fragen zu JTL-Shop 4
Neu Eigene Übersicht in der Artikelübersicht Individuelle Listenansichten in der JTL-Wawi 2
Neu "Jetzt nur" in der Artikelübersicht ausblenden Allgemeine Fragen zu JTL-Shop 2
Neu Artikelübersicht - Shopversion 5: alle Artikel anzeigen verursacht Weiterleitungsfehler JTL-Shop - Fehler und Bugs 5
Individuelle Sortierung der Artikel in der Artikelübersicht/Kategorieansicht Shop Einrichtung JTL-Shop5 4
Neu Wasserzeichen Artikelübersicht Betrieb / Pflege von JTL-Shop 0
Neu Fehlermeldung beim Webshop-Abgleich JTL-Wawi - Fehler und Bugs 9
Neu Warnhinweis beim Datenbankimport - Prozess-ID 17216 ?!? JTL-Wawi - Fehler und Bugs 3
Gelöst Verpackungseinheiten beim Wareneingang in WMS Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 2
Neu Fehler beim Update in Version 1.5.47.3 (1.5.47.0) JTL-Wawi - Fehler und Bugs 1
Neu Probleme beim Artikelbilder hochladen User helfen Usern - Fragen zu JTL-Wawi 10
In Diskussion Nicht angelegte Artikel rutschen beim Kassiervorgang ohne Erfassung durch JTL-POS - Fehler und Bugs 1
Neu Artikel werden beim Upload immer erst gelöscht Shopware-Connector 0
Neu Probleme beim Artikelbilder hochladen Arbeitsabläufe in JTL-Wawi 0
Neu Bilder werden beim Abgleich gelöscht seit 6 Tagen WooCommerce-Connector 0
Gelöst Fehler beim Druck der Pickliste Arbeitsabläufe in JTL-Wawi 2
Neu Zeilenumbruch beim Positionspreis im HTML-Editor Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Php.ini im Rootverzeichnis wird beim Wawi Abgleich überschrieben Upgrade JTL-Shop4 auf JTL-Shop5 1

Ähnliche Themen