Neu Probleme mit Umlaute bei Shop 4.06

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

christianunterlechner

Aktives Mitglied
23. Januar 2016
12
0
Hallo habe leider das gleiche Problem, dass im Storefront als auch im Backend die Umlaute nicht mehr angezeigt werden (siehe Abbildung). Hatten von 4.06.15 (PHP 7.2) auf aktuell 4.06.17 (PHP 7.3) aktualisiert.
Wir haben den gesamten /admin Folder schon übertragen hat aber auch keine Besserung gebracht.
Habe auch einen frische Installation gestartet. Auch hier gibt es Problem mit den Sonderzeichen (siehe Anhang).
Habe die Daten binär übertragen.
Bitte um Hilfe Danke :)
 

Anhänge

css-umsetzung

Offizieller Servicepartner
SPBanner
6. Juli 2011
4.557
718
Berlin
Ich glaube nicht das es an php 7.3 liegt aber hast du es Mal mit der 7.2 probiert?
Ich kann das in keiner Installation nachvollziehen, habe aber alle nur geupdated und noch keine neue Installation hochgezogen.

Interessant wäre es vermutlich was für ein php header gesendet wird, in dem wird der Zeichensatz auch übertragen. Es kann auch sein das der Charset wegen Plugins zu spät erscheint im Quellcode. Das müsste sich Mal jemand von JTL oder dein SP anschauen wenn dir die technischen Fähigkeiten fehlen.
 
  • Gefällt mir
Reaktionen: christianunterlechner

McAvity

Sehr aktives Mitglied
7. September 2016
330
78
@christianunterlechner

Das Problem liegt sehr wahrscheinlich darin begründet, dass die Apache Config die Zeile AddDefaultCharset UTF-8 enthält.
Wenn Ihr das auf AddDefaultCharset Off ändert bzw. ändern lasst und den Apache-Dienst neu startet sollte das Problem mit den Umlauten verschwunden sein.

MfG

McAvity

P.S.: Ich sehe gerade das es nicht alle Umlaute betrifft. Im ersten Bild ist das Wort "benötigt" unten am Bildrand korrekt dargestellt. Auch im zweiten Bild ist bei "Übersicht" im Bereich "Zahlungsarten" die Darstellung korrekt. Möglicherweise hilft dann mein Lösungsvorschlag nicht weiter, es käme aber auf einen Versuch an.
 
  • Gefällt mir
Reaktionen: christianunterlechner

css-umsetzung

Offizieller Servicepartner
SPBanner
6. Juli 2011
4.557
718
Berlin
@christianunterlechner

Das Problem liegt sehr wahrscheinlich darin begründet, dass die Apache Config die Zeile AddDefaultCharset UTF-8 enthält.
Wenn Ihr das auf AddDefaultCharset Off ändert bzw. ändern lasst und den Apache-Dienst neu startet sollte das Problem mit den Umlauten verschwunden sein.
Dieses Problem wird durch das eigene senden des Shops vom charset im php Header umgangen, daher ist es egal was die config sagt. Es wäre nur ein ein Problem wenn das versehentlich deaktiviert wäre.
 

christianunterlechner

Aktives Mitglied
23. Januar 2016
12
0
Hallo,

Habe lokal auf xampp den JTL shop installiert. Hier konnte ich kein Problem mit den Umlauten feststellen.
Ich habe mal den php header / php einstellung / Quellcode der Seite gegenübergestellt. Evtl habt Ihr da eine Idee.

Danke für eure Unterstützung :)
Liebe Grüße
Christian
 

Anhänge

McAvity

Sehr aktives Mitglied
7. September 2016
330
78
@christianunterlechner

Hallo,

auch wenn @css-umsetzung da anderer Ansicht ist (wenn ich Ihn da richtig verstanden habe), für mich ist das immer noch ein das oben beschreibene Probleme mit der Apache-Direktive AddDefaultCharset.

In deinem linken Beispiel (XAMPP) wird im Header nur der Content-Type geschickt ( [8] => Content-Type: text/html ). Dadurch greift die Charset-Angabe im Head der PHP-Datei (<meta charset="windows-1252">).

In deinem rechten Beispiel auf dem Live-Webserver wird der Charset mitgesandt ( [18] => Content-Type: text/html; charset:UTF-8 ). Ich bin der Auffassung das die Charset-Angabe im Header da ignoriert wird. Dadurch entsteht der Zeichenfehler.

Das hat übrigens nichts mit dem default_charset aus deiner phpinfo()-Ausgabe zu tun. Das gilt nur für PHP, es geht hier aber um eine Charset-Angabe die der Apache schickt (PHP ist nur ein Modul).
Ändere, wie bereits oben beschrieben, AddDefaultCharset UTF-8 in AddDefaultCharset Off und das Phänomen sollte weg sein (auch wenn ich mich mit dem JTL- Shop nicht auskenne).

Bitte nicht versuchen das per .htaccess zu machen, ändere es wirklich in der Apache-Config.
Der Apache kann da nämlich echt zur Bitch werden und solche Angabe in der .htaccess gern mal ignorieren.

MfG

McAvity
 

christianunterlechner

Aktives Mitglied
23. Januar 2016
12
0
Hallo McAvity, Vielen Danke für deine Unterstützung.
Ich habe es mit meinem Provider durchgesprochen.
Es war ein Problem mit dem PHP-FPM. PHP-FPM wurde deaktiviert jetzt funktioniert wieder alles und die Umlaute werden wieder angezeigt.
LG Christian
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Probleme mit Stücklistenartikeln User helfen Usern - Fragen zu JTL-Wawi 2
Neu Probleme beim Shopabgleich / Bilderübertragung findet nicht statt / bricht mit 404er ab... Shopify-Connector 4
Gelöst Probleme mit Rechnung versenden/Speichern Workflow Gelöste Themen in diesem Bereich 3
In Bearbeitung Probleme mit dem ebay-Abgleich - "Die Eingabezeichenfolge hat das falsche Format" JTL-Wawi - Fehler und Bugs 3
Neu HTML Editor, der neue, Probleme mit VideoCodes JTL-Wawi - Fehler und Bugs 1
Neu Dropshipping: CSV auf Server kopieren - Probleme mit Fritzbox Schnittstellen Import / Export 1
Gelöst Probleme mit dem Amazonabgleich (sowohl manuell und Worker) Amazon-Anbindung - Fehler und Bugs 1
Neu Immer wieder Probleme mit eBay Rechnungskauf - als unbezahlt eBay-Anbindung - Fehler und Bugs 3
Neu Probleme mit globaler Rechnungsvorlage Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Probleme mit JTL Shipping der Deutschen Post`? User helfen Usern - Fragen zu JTL-Wawi 9
Neu Weiterhin: Preis-Probleme bei Varkombi-Artikeln Gambio-Connector 0
Neu 30.06.2020 Warenpost Probleme JTL-ShippingLabels - Fehler und Bugs 1
Neu Erneut Probleme beim Erstellen von Etiketten JTL-ShippingLabels - Fehler und Bugs 3
Neu 08.06.2020 Montag wieder Warenpost Int. Probleme JTL-ShippingLabels - Fehler und Bugs 1
Neu Performance Probleme beim speichern von Artikeln? User helfen Usern - Fragen zu JTL-Wawi 4
Neu Urlaubsmodus > Amazon > eBay > eazy auction = Probleme beim Ausblenden der Angebote? User helfen Usern - Fragen zu JTL-Wawi 1
Neu Warenpost International Label Druck Probleme JTL-ShippingLabels - Fehler und Bugs 0
Neu e-mail probleme JTL-Wawi - Fehler und Bugs 0
Neu Eingangsrechnungen buchen seit letztem Update Probleme! User helfen Usern - Fragen zu JTL-Wawi 1
Neu Import aus Gambio 4.0.0.1 - Probleme Gambio-Connector 5
Gelöst Probleme bei Versanddatenexport Gelöste Themen in diesem Bereich 6
Gelöst DHL Probleme heute ? Gelöste Themen in diesem Bereich 2
Neu Excel Profi gesucht - 4 Zeilen aus einer Zelle mit neuer Zelle verketten User helfen Usern 3
Neu Kundenliste mit hinterlegten Emailadressen exportieren User helfen Usern - Fragen zu JTL-Wawi 4
Neu Alle Artikel mit einem Preis von 0€ filtern und anzeigen lassen User helfen Usern - Fragen zu JTL-Wawi 4
In Bearbeitung Preiseingabe - Ändern der MwSt mit Mausklick ohne Funktion JTL-POS - Fehler und Bugs 1
Neu Auftrag per Mail versendet hat 1 CSV-Datei mit Positionsaufstellung im Anhang User helfen Usern - Fragen zu JTL-Wawi 1
Neu Problem JTL-POS mit OPI Schnittstelle an ICT220 - Abrechnung JTL-Wawi Aufträge über EC-Karte nicht möglich Arbeitsabläufe in JTL-Wawi 0
Neu Stückliste mit Varianten User helfen Usern - Fragen zu JTL-Wawi 0
Neu DHL GKP - was hat es mit dieser Meldung auf sich? JTL-ShippingLabels - Fehler und Bugs 2
Neu Workflow Etikett während Verpacken mit WMS EazyShipping drucken User helfen Usern - Fragen zu JTL-Wawi 8
Neu Fragen zu Rechnungnummer auf Etikett und Versand-/Packliste mit Kundenname User helfen Usern - Fragen zu JTL-Wawi 3
Neu Amazon VCS eine Position mit 0% Steuer Amazon-Anbindung - Fehler und Bugs 2
Neu Anzeige der Artikelanmerkungen Problem mit Zeilenumbruch Individuelle Listenansichten in der JTL-Wawi 0
Offen Mit JTL-WMS Mobile können nun Ersatzartikel kommissioniert / Mit JTL-WMS können nun Ersatzartikel verpackt werden JTL-WMS - Ideen, Lob und Kritik 1
Neu Shop Connector: Was passiert mit alten Bestellungen beim Erstimport? User helfen Usern - Fragen zu JTL-Wawi 1
Neu Optimierung nach Auftrag picken/verpacken mit Packtisch+ oder WMS - Anregungen gesucht User helfen Usern - Fragen zu JTL-Wawi 5
Neu Ablgeich der SEO-Daten mit YOAST WooCommerce-Connector 0
Neu Rechnungsvorlage mit schon getätigten Zahlungen Brutto netto und Saldo Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Kategorie als Link anstatt mit Artikeln befüllen Allgemeine Fragen zu JTL-Shop 0
Neu Rechnungsstellung mit falscher Artikelbeschreibung Arbeitsabläufe in JTL-Wawi 2
Neu Meine Artikel samt eigener Attribute mit Ameise importieren Starten mit JTL: Projektabwicklung & Migration 1
Neu Anzeige der Angebote ohne Mwst. und mit eBay-Anbindung - Ideen, Lob und Kritik 0
Neu Absenderreferenz für DHL-Labelerzeugung (Versenden 3.0) als Variable um Kundenspezifische Absender (mit Logo) nutzen zu können JTL-Wawi - Ideen, Lob und Kritik 0
Neu Versandart mit Preisstaffel Einrichtung von JTL-Shop 1
Neu Aktivieren/deaktivieren von Sonderpreisen mit der Ameise User helfen Usern - Fragen zu JTL-Wawi 1
Neu Preisliste mit CrossSelling-Artikeln User helfen Usern - Fragen zu JTL-Wawi 0
Neu Leistungsdatum in Rechnungsvorlagen als Variable (mit automatischer Ermittlung) JTL-Wawi - Ideen, Lob und Kritik 0
Neu JTL Wawi Datenabgleich mit Shopify Shopify-Connector 0
Neu 1.5.24.1 - gesperrtes Lager mit Zulauf? JTL-Wawi - Fehler und Bugs 0
Ähnliche Themen