Neu Probleme Datenbankzugriff

Dennis103

Gut bekanntes Mitglied
19. April 2018
154
17
Hey Zusammen,

ich habe ein Problem. Wir hatte bis vor kurzem JTL und den MSSQL Server auf einer Virtuellen Maschine, ich habe das nun Getrennt auf 2 Virtuelle Maschinen. Erstmal soweit sogut. Allerdings habe ich nun das Problem, das ich den MSSQL Server nur über nen Host Namen Erreiche und nicht mehr über die IP. Heißt der SQL Server Reagiert in den Einstellungen auf MSSQL-Server aber nicht auf die Interne IP 192.168.2.33
Hört sich erstmal Intern nicht Problematisch an, aber Extern, alle unsere VPN Mitarbeiter haben keinen Zugriff auf nen Host Namen. Die können die MSSQL-Server Adresse nicht Auflösen. Die muss ich per IP Ansprechen, was aber nicht geht.

Hat nen SQL Experte vielleicht Ahnung, sodass ich den Server wieder auf IP Antworten lassen kann?

mfg Dennis
 

Karalanta

Sehr aktives Mitglied
18. April 2020
319
114
Das können Einstellungen an vielen verschiedenen Stellen sein, der SQL Server Konfig, dem Netzwerk, der Firewall, denn Gruppenrichtlinien, dem AD wenn vorhanden, fehlende Weiterleitungen da neue Maschine oder gar die Hostdatei.
"Never Change a Running System" heißt es ja so oft... Deswegen - aus persönlichem Interesse - warum die Maschinen getrennt? Laufen doch wahrscheinlich auf der selben Hardware nehme ich an?!

Da man auch nicht weis wie das Netzwerk aufgebaut ist, schwer Ratschläge zu geben. Welche VPN Methode etc.
Ich würde allerdings jetzt beim VPN anfangen, ob da die Routings und Allowed IP Bereiche passen, da sich ja IPs geändert haben.
Am einfachsten lass bitte jemand mit Erfahrung direkt drauf schauen, gerade wenn alles von außen erreichbar ist und solche Fehler nicht gelöst werden können, bekomm ich direkt immer Bauchschmerzen.
 

Dennis103

Gut bekanntes Mitglied
19. April 2018
154
17
Das können Einstellungen an vielen verschiedenen Stellen sein, der SQL Server Konfig, dem Netzwerk, der Firewall, denn Gruppenrichtlinien, dem AD wenn vorhanden, fehlende Weiterleitungen da neue Maschine oder gar die Hostdatei.
"Never Change a Running System" heißt es ja so oft... Deswegen - aus persönlichem Interesse - warum die Maschinen getrennt? Laufen doch wahrscheinlich auf der selben Hardware nehme ich an?!

Da man auch nicht weis wie das Netzwerk aufgebaut ist, schwer Ratschläge zu geben. Welche VPN Methode etc.
Ich würde allerdings jetzt beim VPN anfangen, ob da die Routings und Allowed IP Bereiche passen, da sich ja IPs geändert haben.
Am einfachsten lass bitte jemand mit Erfahrung direkt drauf schauen, gerade wenn alles von außen erreichbar ist und solche Fehler nicht gelöst werden können, bekomm ich direkt immer Bauchschmerzen.
Gruppenrichtlinien, AD etc. alles vorhanden.

Zur Anfangszeit vor 2 Jahren, haben wir alles auf die Kiste geballert. Lief auch, aber es kamen zuviele Dienste dazu. Es war einfacher einfach nur den SQL Auszulagern, was auch sehr erfolgreich war, anstatt alle Dienste auf ne neue Maschine zu packen. Vorher 70-90% CPU Last, jetzt ist die Kiste bei 10% und der SQL auch bei 10%. Also erfolgreich war es.

Der VPN ansich ist so nicht das Problem, den konnte ich ausschließen. Auf die IP und Remote Desktop komme ich. Ich komme aber schon Intern nicht per IP, sondern nur per Name auf den SQL. Remote geht per IP.

Ich habe unseren IT Dienstleister schon angesprochen, die meinten, Windows, Hyper-V, VPN etc. alles kein Problem, aber MSSQL Server packen die nicht an.

mfg Dennis
 

Karalanta

Sehr aktives Mitglied
18. April 2020
319
114
Mal versucht bei der IP den Port mit anzuhängen?

192.168.2.33,XXXXX\JTLWAWI (oder wie auch immer eure Instanz heißt)

Dann evtl. in der SQL Server Konfig checken ob die IPs auch aktiv sind
 

Karalanta

Sehr aktives Mitglied
18. April 2020
319
114
ganz vergessen und ganz wichtig... betreibt ihr eigenen DNS und wird der Name überhaupt ordentlich aufgelöst?

Und wenn bei der Verbindung der richtige DNS übergeben wird an den Client, sollte auch die Anmeldung mit Hostname funktionieren. Unabhängig vom IP Problem.
Da müsste der Dienstleister auch nicht an den SQL Server ;) 🤷‍♂️

Code:
ping hostname.domäne

oder

nslookup hostname.domäne
 

Dennis103

Gut bekanntes Mitglied
19. April 2018
154
17
Den Hostnamen erreiche ich ja, aber die IP nicht, das ist das Problem. Ja wir haben nen eigenen DNS und DHCP Server.
 

Karalanta

Sehr aktives Mitglied
18. April 2020
319
114
Den Hostnamen erreiche ich ja, aber die IP nicht, das ist das Problem. Ja wir haben nen eigenen DNS und DHCP Server.

kann die IP angepingt werden (darauf achten das vorher evtl. in der Firewall freigeben) und antwortet?

Ist schwer das jetzt so einzuschätzen und ein wildes schießen in alle Richtungen. Auf dem SQL Server sonst mal ne Freigabe oder nen Dummy Dienst starten und schauen ob diese per IP erreichbar ist.



Das einzige was sein kann eigentlich, ihr habt nen dynamischen Port (was Standart ist) vergeben, deswegen geht nur die Named Connection. Versuch mal denn manuellen Port und Verbinde mit Portangabe wie oben beschrieben über IPAddress,PORT\JTLWAWI


Funktioniert dort:

Screenshot 2021-08-05 171251.png

Dort gewünschten Port eintragen z.B. 45678 mit OK beenden und Serverdienst neustarten. Dann noch Firewall konfigurieren und es sollte per IP erreichbar sein.
 
Zuletzt bearbeitet:
Ähnliche Themen
Titel Forum Antworten Datum
Neu Probleme mit Telekom Mails Betrieb / Pflege von JTL-Shop 4
Neu Probleme ecoDMS (burns) 21.06 - Suche funktioniert nach gewisser Zeit nicht mehr User helfen Usern 1
Neu Und wieder mal Probleme mit Artikelbildern... Wer kann helfen? JTL-Wawi - Fehler und Bugs 0
In Bearbeitung Chromebox: Probleme mit Autofill bei Eingabefeldern JTL-POS - Fragen zu Hardware 2
Neu Verbindung Shop 5.1 mit WAWI hat bei Umlauten Probleme JTL-Wawi - Fehler und Bugs 1
In Bearbeitung Probleme Terminal zu POS JTL-POS - Fragen zu Hardware 2
Neu Probleme beim Anpassen der Facebook Export CSV Plugins für JTL-Shop 2
Neu Probleme mit den Einstellungen die der Connector vornimmt (Preise) WooCommerce-Connector 1
Neu ebay Probleme mit EA Server heute? eBay-Anbindung - Fehler und Bugs 5
Neu Probleme mit Zahlungsart Klarna Sofortüberweisung Gambio-Connector 0
Neu Probleme mit Facebook Katalog Plugins für JTL-Shop 0
JTL Shop Sitemap Probleme Allgemeiner HTTP Fehler bei Google Einrichtung JTL-Shop5 10
Neu Probleme bei der Übernahme von Amazon-Bestellungen (31.08.2021) Amazon-Anbindung - Fehler und Bugs 41
Neu Probleme mit der Startseite Allgemeine Fragen zu JTL-Shop 2
Neu Probleme bei JTLShop5 hausintern auf dem gleichen Rechner wie JTL Wawi Onlineshop-Anbindung 5
Neu Extensionstore Probleme - Mollie??? Plugins für JTL-Shop 0
Neu Probleme mit AMAZON PAY WooCommerce-Connector 1
Neu Shopware 6 / Artikelbilder Upload Probleme Shopware-Connector 2
Neu EA-Amazon Server Probleme Gelöste Themen in diesem Bereich 19
Neu Shop macht Probleme: JTL-Shop - Fehler und Bugs 1
Neu Shop Probleme JTL-Shop - Fehler und Bugs 0
Neu Probleme beim Import / Abgleich von Amazon Bestellungen (Fehler / Das angegebene Argument liegt außerhalb des gültigen Wertebereichs ) User helfen Usern - Fragen zu JTL-Wawi 1
In Bearbeitung Probleme mit Artikelrabatt JTL-POS - Fehler und Bugs 6
Neu Probleme beim Artikelbilder hochladen User helfen Usern - Fragen zu JTL-Wawi 10
Neu Worker Probleme Amazon Abgleich - Keine Hintergrunddienst aktiven Mandanten gefunden JTL-Wawi - Fehler und Bugs 0
Neu Probleme beim Artikelbilder hochladen Arbeitsabläufe in JTL-Wawi 0
Gelöst Probleme mit Umlauten bei Mediendatei JTL-Wawi - Fehler und Bugs 2
Neu DATEV Rechnungsdatenservice 2,0 Probleme mit der Einrichtung bzw. Übertragung Arbeitsabläufe in JTL-Wawi 2
Neu Probleme bei Paypal Plus Plugins für JTL-Shop 0
Neu Update zu WooCommerce v5 PRobleme mit Lizenz / Vernbindung / Syncro WooCommerce-Connector 2
Neu ACHTUNG! Störung Lizenzserver - Login-Probleme News, Events und Umfragen 83
Neu Shopware 6 - Probleme bei Produktbildern Shopware-Connector 1

Ähnliche Themen