In Diskussion Problem bei zeitversetztem Workflow

eufory

Aktives Mitglied
8. Mai 2014
75
2
Hallo,

ich habe einen Workflow erstellt, der schon einmal so funktionierte, aber leider scheint dieser nach einem Update nicht mehr zu funktionieren. Es geht um eine Abholung, wo der Kunde regelmäßig informiert wird, dass die Abholung bereit liegt. Der Ablauf sieht wie folgt aus:

1. Ware wird eingepackt und ein Lieferschein mit Rechnung erstellt.
2. Mit Erstellung der Rechnung werden drei Workflows angelegt. Einer für "Sofort", der die Mail versendet, dass die Ware abholbereit ist, einer für 4 Tage nach Erstellung der Rechnung und einer nach 7 Tagen.

Wird die Ware abgeholt, wird ein Auftragsattribut per manuellem Workflow auf 1 gesetzt.

3. Nach 4 Tagen sollte der zeitversetzte Workflow prüfen, wenn Kundenattribut=0, dann erinnere den Kunden per E-Mail. Ansonsten natürlich nicht. Das selbe nach 7 Tagen.

Anbei findet Ihr einen Screenshot der Workflows. Und auch einen Auszug aus dem Logbuch. Dort steht, dass die Workflows per Queue eingefügt wurden, aber sie werden trotzdem ausgelöst. In dem Beispiel ist erkennbar, dass das Kundenattribut am 30.12.2020 auf 1 gesetzt wurde. Darum sollten die anderen Workflows nicht mehr ausgelöst werden.

Scheinbar werden diese Bedingungen aber nicht zum Zeitpunkt nach 4 Tagen geprüft. Der Kunde bekommt eine E-Mail, obwohl das Auftragsattribut gesetzt wurde. Liegt hier ein Denkfehler meinerseits vor, oder ist es ein Fehler von JTL?

Vielen Dank für Eure Mithilfe.
 

Anhänge

forumjtlolshopag

Sehr aktives Mitglied
6. Juni 2018
395
81
Welche Version nutzt ihr? Am besten das immer angeben, sonst muss da immer unnötig nachgerfragt werden, zumal du ja geschrieben hast, das es nach einem Update scheinbar nicht mehr geht.

Wir haben eine ähnliche Erinnerungsfunktion für einen anderen Fall und nutzen da auch verzögerte Workflows. Ebenfalls mit einer zusätzlichen Bedingungen, die verhindern soll, das eine unnötige Erinnerung rausgeht. Eingestellt damals mit 1.3, aktuell nutzen wir 1.5.36.2 und es gab meines wissens noch keine Rückmeldung das es nicht mehr geht.
 

eufory

Aktives Mitglied
8. Mai 2014
75
2
Welche Version nutzt ihr? Am besten das immer angeben, sonst muss da immer unnötig nachgerfragt werden, zumal du ja geschrieben hast, das es nach einem Update scheinbar nicht mehr geht.

Wir haben eine ähnliche Erinnerungsfunktion für einen anderen Fall und nutzen da auch verzögerte Workflows. Ebenfalls mit einer zusätzlichen Bedingungen, die verhindern soll, das eine unnötige Erinnerung rausgeht. Eingestellt damals mit 1.3, aktuell nutzen wir 1.5.36.2 und es gab meines wissens noch keine Rückmeldung das es nicht mehr geht.
Stimmt, habe ich ganz vergessen. Wir nutzen gerade 1.5.38.1

Ist denn die Logik bei uns so korrekt oder ist da ein Denkfehler enthalten?
 

forumjtlolshopag

Sehr aktives Mitglied
6. Juni 2018
395
81
Meiner Meinng nach ja. Du brauchst für die Erinnerungen natürlich jeweils 2 Workflows, damit du die 2 Zeitfenster hast. Was sagt den die Log, wenn die Erinnerung rausgeht obwohl das Attribut nicht gesetzt ist? Vorallem was passiert, wenn du den Workflow an einem Auftrag ohne gesetztem Attribut testest?

So wie ich es bei euch verstanden hab:

* ein manueller Workflow, der das Attribut für Abholbereitschaft setzt
* zwei Erinnerungsworkflows, die in der Bedingung das Attribut prüfen und jeweils eine Email senden, Ausführung jedoch verzögert (jeweils 4 Tage und 7 Tage nach Erstellung der Rechnung (Rechnnung erstellt Ereignis) )
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Problem bei Artikel Import über Ameise / Variationen werden nicht erstellt wenn Variationsnamenwert 1 leer ist. JTL-Ameise - Fehler und Bugs 1
Neu Versandkosten Brutto Netto Problem bei Händler-Gruppe User helfen Usern - Fragen zu JTL-Wawi 0
Neu Problem bei der Installation siehe Anhang Installation von JTL-Wawi 1
Neu Datev UO Problem bei gemischter MWST - IST-Versteuerung User helfen Usern - Fragen zu JTL-Wawi 0
Neu Problem mit Preisberechnung bei Mindestabnahme und Abnahmeintervall Betrieb / Pflege von JTL-Shop 0
In Bearbeitung WMS Mobile App Problem bei der Anzeige für Eingabe MHD in der Horizontalen [WAWI-53300] JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 4
Gelöst Problem bei Anzeige Slider Templates für JTL-Shop 1
Neu Problem bei instalation SQL "does not support the language of the OS" Installation von JTL-Wawi 8
Neu Problem: Verschiedene Versandkosten bei Produktkategorien Allgemeine Fragen zu JTL-Shop 2
Beantwortet GELÖST: Problem beim Import einer Datenbank JTL-Wawi - Fehler und Bugs 5
Neu Import-Problem: "Überverkäufe ermöglichen" lässt sich nicht aktivieren... User helfen Usern - Fragen zu JTL-Wawi 4
Neu Shopware 6 Abgleich Problem Bilder Shopware-Connector 3
Neu Immer wieder Überverkäufe (auch Amazon) - wo ist das Problem? eBay-Anbindung - Fehler und Bugs 7
Neu Problem: Wie die Versandarten aus dem JTL Shop mit den WaWi Versandarten verknüpfen? User helfen Usern - Fragen zu JTL-Wawi 2
Neu JTL Shop 5 PayPal Problem JTL-Shop - Fehler und Bugs 0
Neu Google Recaptcha Version 3 Problem User helfen Usern - Fragen zu JTL-Wawi 0
Neu Problem: Sysgrade ecommerce Integrator - Magento 2.4 API-Verbindung Einstellungen Onlineshop-Anbindung 1
Neu Problem mit Eigene Felder User helfen Usern - Fragen zu JTL-Wawi 8
Neu Problem mit der Anzeige der Beschreibung für Mediendateien im Shop. JTL-Shop - Fehler und Bugs 1
Neu Problem mit der Anbindung des Connectors zu Shopify Shopify-Connector 10
Neu Webstollen "EU Cookie" Plugin Problem mit Paypal Zahlungsmöglichkeiten beim Checkout Plugins für JTL-Shop 0
Neu Lagerauswahl Problem Onlineshop Onlineshop-Anbindung 0
Neu Woocommerce / Problem mit den Filtern / Attribute WooCommerce-Connector 3
Neu Merkmalwerte gezielt entfernen, wenn mehr als ein Merkmalwert vorhanden (eBay Problem xxx darf nur einen Wert haben) User helfen Usern - Fragen zu JTL-Wawi 0
Neu Problem mit der Auswahl an Lieferländern. Wie begränzen auf Länder die man beliefert? JTL-Shop - Fehler und Bugs 13
Neu Bin gerade am verzweifeln...Problem mit Test-Demo-Shop Onlineshop-Anbindung 13
Gelöst DHL Versenden 3.0 Warenpost Problem JTL-ShippingLabels - Ideen, Lob und Kritik 0
Neu 1.5.38.2 Logbuch Problem JTL-Wawi - Fehler und Bugs 2
Neu Problem Drucker aus Vorlage Artikeletikett User helfen Usern - Fragen zu JTL-Wawi 1
Neu Problem mit Shop Anbindung JTL-Wawi - Fehler und Bugs 0
Neu Ameise Import via CLI - eBay Angebot Encoding Problem mit eBay Vorlagenname JTL-Ameise - Fehler und Bugs 1
Gelöst JTL Shop 5 Nova Template Problem beim Einrichten des PayPal Plug-ins Einrichtung JTL-Shop5 2
Zahlung nicht erforderlich, Großes Problem mit Zahlungsart Einrichtung JTL-Shop5 11
Neu Idealo Export: Problem mit Umlauten Allgemeine Fragen zu JTL-Shop 6
Neu Workflow Problem/Bug Arbeitsabläufe in JTL-Wawi 0
Neu Server error 500 nach Warenkorb im Bestellvorgang ( nicht jeder Kunde hat dieses Problem ) JTL-Shop - Fehler und Bugs 1
Neu Problem Update von Version 4 auf 5 - Admin Seite weiß Installation / Updates von JTL-Shop 0
Neu [Shop4] Problem mit einer Versandarten und der Bezeichnung im Shop (Dopplung) Technische Fragen zu Plugins und Templates 1
Neu Problem mit der Signatur Servicedesk (Beta) 3
Neu Problem Update von Version 4 auf 5 - Plugin Manager - Admin Seite weiß Installation / Updates von JTL-Shop 2
Neu Startseite Shop5 kleines Problem Einrichtung von JTL-Shop4 4
Neu Problem beim buchen der Inventurbestände (DB Fehler) JTL-Wawi - Fehler und Bugs 0
Beantwortet WICHTIG: Problem mit JTL-Wawi Version 1.5.37.0Problem mit JTL-Wawi Version 1.5.37.0 JTL-Wawi - Fehler und Bugs 14
Neu Shopware 6 Connector | Problem mit Variantenartikeln Shopware-Connector 0
Neu Galerie-Problem nach Zoom JTL-Shop - Fehler und Bugs 5
Neu Feature Request: EORI-Nummer bei Parcel.One-Versanddatenexport übertragen JTL-ShippingLabels - Ideen, Lob und Kritik 0
Neu Gewicht wird bei Var-Kombis nicht ausgegeben... User helfen Usern - Fragen zu JTL-Wawi 1
Neu [JTL-Shop 5] Mediendateien anzeigen unter Artikelbeschreibung - 2 Column Layout bei zwei Mediendatein? JTL-Shop - Ideen, Lob und Kritik 0
Neu Spalten breit bei export, Artikeltexte sind in der csv nicht am richtigen Platz JTL-Ameise - Fehler und Bugs 1
Neu Falsche Berechnung der MwSt. bei Variationen mit Aufpreis JTL-Wawi - Fehler und Bugs 0

Ähnliche Themen