Gelöst Preise spielen verrückt bei 1.8.0.4

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Olaf K.

Aktives Mitglied
9. August 2018
51
10
Bei dem Connector 1.8.0.4 habe ich massive Probleme miit meinen Preisen ... Preise die vorher sauber übertragen wurden haben sich plötzlich geändert !!! Es fing damit an das angeblich meine Authentifizierung des connectors nicht passte und ich den Key erneut eingeben musste ... danach spielen die Preise verrückt !!! Insbesondere sind Sonderpreise und Preise mit 7% Mehrwertsteuer betroffen !!! Ich brauche umgehend Hilfe, das ist so nicht tragbar und alle Preise zu überprüfen dauert Stunden !!!

Mit geändert meine ich, das der Preis in der WAWI z.B. 7.49 ist und Online dann plötzlich 8.01 Euro ..... änert man den Preis dann manuell in der WAWI wird er normalerweise "sauber" upgedatet ....
 

biotraxx

Aktives Mitglied
29. Juli 2012
27
3
... exakt das selbe Problem habe ich auch vor 2 Std. in unserem Shop festgestellt. Erst die Authentifizierung dann Preise - soweit ich es überblicken kann, werden jetzt auf die im woo Shop hinterlegten Preise zusätzlich die UST aufgeschlagen. Sonderpreise werden bei mir nach Änderung in der wawi wieder korrekt angezeigt, die "normalen" Preise jedoch nicht.
Ich hoffe auf eine schnelle Lösung des Problems!
 
  • Gefällt mir
Reaktionen: Olaf K.

biotraxx

Aktives Mitglied
29. Juli 2012
27
3
Nachtrag: wie ich festgestellt habe wurde anscheinend vom Connector 1.8.0.4 die Einstellungen in woocommerce "Steuer Optionen" auf die Option (2) "Nein, ich gebe die Produktpreise exklusive Mehrwertsteuer ein" automatisch gesetzt, auch wenn zuvor die Option (1) auf "Ja, ich gebe die Produktpreise inklusive Mehrwertsteuer ein" ausgewählt war. Nachdem ich die Einstellungen zurück auf Option (1) gesetzt habe, werden bei mir die Endpreise wieder korrekt angezeigt.

Einen Haken hat das jedoch! Mit jedem Onlineshop-Abgleich wird die "Steuer Optionen" auf die Option (2) "Nein, ich gebe die Produktpreise exklusive Mehrwertsteuer ein" erneut gesetzt.
Den Onlineshop-Abgleich habe ich vorerst deaktivieren müssen.
So wie es aussieht werden vom connector dennoch die Bruttopreise für die Standard-Artikel gesetzt, jedoch die Nettopreise aus Angebotsartikel (Test Komplettabgleich alle Preise aus wawi neu übertragen).
Jetzt bedarf es doch dringend einer Lösung, bitte um Aufklärung!
 
Zuletzt bearbeitet:

Jan Weskamp

Moderator
Mitarbeiter
19. August 2015
346
33
Schaut mal in die Entwickler Einstellungen dort befinden sich neue Optionen die das ganze erklären sollten.

Wenn nicht hier die komplizierte Erklärung der 1.8 Connector setzt Einstellungen die so als empfohlen gelten. Der Grund dafür ist das andere Einstellungen häufig zu Fehlern führen auf die wir keinen Einfluss haben.
Als Beispiel Preise brutto im backend pflegen.
Die Wawi schickt immer Nettopreise und die VAT dazu. Diese gebe ich an der passenden Stelle an WooCommerce weiter. Die Methode zum speichern der Bruttopreise ist aber von woo fehlerhaft und macht diverse Rundungsfehler. Wenn man die Preise allerdings in netto im backend pflegt (was für euch kein Problem sein sollte, da die Wawi das federführende System ist) , dann berechnet woo für den Kunden den korrekten Preis in Frontend.
 

Olaf K.

Aktives Mitglied
9. August 2018
51
10
Hallo,

besten Dank für die Info .... was ich dann aber nicht verstehe ist, wenn ich einen kompletten Datenabgleich starte, warum die angezeigten falschen Preise dann teilweise korrigiert werden und warum dieser Sonderpreis:

1555317927127.png

in Woocommerce dann zu diesem Ergebnis führt:

1555317799466.png

und das obwohl ich die Default Einstellungen des Connectors nutze ........

Viele Grüße,

Olaf K.
 

Olaf K.

Aktives Mitglied
9. August 2018
51
10
Ich habe noch einen Test gemacht ... dieser Preis:

1555320225789.png

führt in Woocommerce zu diesem Ergebnis:

1555320286000.png

Wenn ich als Brutto-VK z.B. 5,29 in der JTL WAWI einfüge, dann passt der Preis auch in Woocommerce (5,29) ......
 
  • Gefällt mir
Reaktionen: Jan Weskamp

Jan Weskamp

Moderator
Mitarbeiter
19. August 2015
346
33
Hallo,

besten Dank für die Info .... was ich dann aber nicht verstehe ist, wenn ich einen kompletten Datenabgleich starte, warum die angezeigten falschen Preise dann teilweise korrigiert werden und warum dieser Sonderpreis:

Den Anhang 32647 betrachten

in Woocommerce dann zu diesem Ergebnis führt:

Den Anhang 32646 betrachten

und das obwohl ich die Default Einstellungen des Connectors nutze ........

Viele Grüße,

Olaf K.
Was steht denn im regulären Preis ?
 

Olaf K.

Aktives Mitglied
9. August 2018
51
10
Im regulären Preis steht :

1555339850038.png

ABER ... wie oben erwähnt tritt das Problem auch OHNE Sonderpreise bei Brutto-VK 6,95€ auf .... dann lautet der Preis in Woocommerce 6,96€ !!!! Wenn ich dann den Preis ändere (wie oben erwähnt) auf 5,29€dann werden in Woocommerce auch 5,29 angezeigt .... ändere ich auf 6,95 zurück wird wieder falsch 6,96 angezeigt .... hier ist irgendetwas mit den Rundungen nicht in Ordnung denke ich .... VOR dem Connector 1.8.0.4 stimmten ALLE Preise .... auch das entfernen des Produktzes und wiederaufnahme bringt nichts ....
 

mobile-bags.de

Gut bekanntes Mitglied
10. Dezember 2013
301
19
Gera
Hallo, das ist ja echt grass... bei uns genau das gleiche.
Wir pflegen unsere Artkel unter Woocommerce und der Lösungsansatz:
Nachtrag: wie ich festgestellt habe wurde anscheinend vom Connector 1.8.0.4 die Einstellungen in woocommerce "Steuer Optionen" auf die Option (2) "Nein, ich gebe die Produktpreise exklusive Mehrwertsteuer ein" automatisch gesetzt, auch wenn zuvor die Option (1) auf "Ja, ich gebe die Produktpreise inklusive Mehrwertsteuer ein" ausgewählt war. Nachdem ich die Einstellungen zurück auf Option (1) gesetzt habe, werden bei mir die Endpreise wieder korrekt angezeigt.
funktioniert bei uns nicht. Egal wie wir die Enstellungen machen, die Preise werden nicht in den Ursprung zurück gesetzt.
Hat jemand noch weiteren Rat? Die Preise Netto einzupflegen ist bei uns schier unmöglich, da dazu müssten wir ja alle erst umrechnen und das bei knapp 1000 Artkeln.
Was meint Ihr, würde es helfen den Connector mit Rollback eine Version zurück zusetzen? Zumindest bis das Problem gelöst ist? Wird der Connector so wie er jetzt die Preise managed bleiben oder wird hier nachgebessert?
 

mobile-bags.de

Gut bekanntes Mitglied
10. Dezember 2013
301
19
Gera
Woocommerce --> Mehrwertsteuer --> Steuer-Optionen --> Preise im Shop anzeigen: MwSt. nicht inbegriffen bracht jetzt den erhofften Erfolg. Muss das aber noch mit der Wawi testen, wie die die berechnung annimmt. Im Shop jedenfalls sind die Preise wieder ok.
 

Olaf K.

Aktives Mitglied
9. August 2018
51
10
Woocommerce --> Mehrwertsteuer --> Steuer-Optionen --> Preise im Shop anzeigen: MwSt. nicht inbegriffen bracht jetzt den erhofften Erfolg. Muss das aber noch mit der Wawi testen, wie die die berechnung annimmt. Im Shop jedenfalls sind die Preise wieder ok.
Prima, das ist aber nicht mein eigentliches Problem ... ich habe das Problem das bei bestimmten Preisen, der Preis scheinbar um 1 Cent nach oben oder unten abweicht ..... das ist vor allem ärgerlich wenn man dann dem Finanzamt erklären muss was das wohl soll .......
 

Olaf K.

Aktives Mitglied
9. August 2018
51
10
... den Thread habe ich schon gelesen ! Weiter oben ist auch zu lesen das ich das empfohlene genau schon vor 2 Tagen getan habe und meine Einstellungen vom Connector gesetzt werden ! TROTZDEM habe ich bei einigen scheinbar spezifischen Preisen eine Abweichung nach oben oder unten von 1em Cent (auch dazu stehen weiter oben gleich 2 Beispiele !!!) Ich weiß nicht was ich hier noch an Hinweisen geben soll ... German Market nutze ich nicht ! Ich nutze Germanized ! Das Problem ging los mit 1.8.0.4 .... die Preise Pflege ich über die WAWI ... die Netto Preise lasse bei Eingabe durch die WAWI berechnen und lade sie dann nur hoch .... irgendetwas scheint hier Rundungsprobleme zu verursachen die ich bis dato niemals hatte .....

BEISPIEL Connector 1.8.0.4 Preis der funktioniert !!!
1555406129566.png1555406166230.png

BEISPIEL Connector 1.8.0.4 Preis der NICHT funktioniert: 1 CENT UNTERSCHIED ZU OBEN !!! ANSTELLE 6,94 Brutto-VK habe ich nun 6,95 Brutto-VK genommen ! Produkt und alles andere ist 100%ig das von davor !

1555406472379.png1555406548698.png

Meine Connector Einstellung:
1555406289673.png

HINWEIS !!!! Scheinbar habt ihr aber nun irgendetwas gefunden, korrekt ?!? Da ich soeben (als letzte Maßnahme) gesehen habe das ihr ein Update auf den Connector 1.8.0.5 freigegeben habt ... kaum hatte ich den installiert und schon funktioniert es !!! Auch mit 6,95 € !!! Wäre nur nett gewesen wenn mal einer gesagt hätte das daran gearbeitet wird, dann hätte ich mir die Tests sparen können ;)

Viele Grüße
 
  • Gefällt mir
Reaktionen: Jan Weskamp

Jan Weskamp

Moderator
Mitarbeiter
19. August 2015
346
33
... den Thread habe ich schon gelesen ! Weiter oben ist auch zu lesen das ich das empfohlene genau schon vor 2 Tagen getan habe und meine Einstellungen vom Connector gesetzt werden ! TROTZDEM habe ich bei einigen scheinbar spezifischen Preisen eine Abweichung nach oben oder unten von 1em Cent (auch dazu stehen weiter oben gleich 2 Beispiele !!!) Ich weiß nicht was ich hier noch an Hinweisen geben soll ... German Market nutze ich nicht ! Ich nutze Germanized ! Das Problem ging los mit 1.8.0.4 .... die Preise Pflege ich über die WAWI ... die Netto Preise lasse bei Eingabe durch die WAWI berechnen und lade sie dann nur hoch .... irgendetwas scheint hier Rundungsprobleme zu verursachen die ich bis dato niemals hatte .....

BEISPIEL Connector 1.8.0.4 Preis der funktioniert !!!
Den Anhang 32679 betrachtenDen Anhang 32680 betrachten

BEISPIEL Connector 1.8.0.4 Preis der NICHT funktioniert: 1 CENT UNTERSCHIED ZU OBEN !!! ANSTELLE 6,94 Brutto-VK habe ich nun 6,95 Brutto-VK genommen ! Produkt und alles andere ist 100%ig das von davor !

Den Anhang 32683 betrachtenDen Anhang 32684 betrachten

Meine Connector Einstellung:
Den Anhang 32681 betrachten

HINWEIS !!!! Scheinbar habt ihr aber nun irgendetwas gefunden, korrekt ?!? Da ich soeben (als letzte Maßnahme) gesehen habe das ihr ein Update auf den Connector 1.8.0.5 freigegeben habt ... kaum hatte ich den installiert und schon funktioniert es !!! Auch mit 6,95 € !!! Wäre nur nett gewesen wenn mal einer gesagt hätte das daran gearbeitet wird, dann hätte ich mir die Tests sparen können ;)

Viele Grüße
Olaf du siehst es falsch ^^ WooCommerce hatte dinge geändert die nicht Mittgeteilt wurden. Deine Tests haben uns ja erst darauf gebracht =)
1.8.0.6 Hat sogar einen fix für euch für die Grundpreise ;)
 
  • Gefällt mir
Reaktionen: Olaf K.

Olaf K.

Aktives Mitglied
9. August 2018
51
10
Na so oder so, dann bin ich mal froh das ich mir das Problem nicht eingebildet habe, ich habe schon an meinem Verstand gezweifelt :) Und zumindest waren die Tests dann nicht völlig sinnlos ;)

... jedenfalls freut es mich, das ich hier helfen konnte diese Probleme zu finden und zu lösen ... auch wenn sie durch woocommerce verursacht wurden ... habt ihr wirklich gut hinbekommen ! ;)

Viele Grüße, Olaf
 
  • Gefällt mir
Reaktionen: Jan Weskamp
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Kundengruppen Preise werden nicht korrekt ausgegeben JTL-POS - Fehler und Bugs 5
Neu Variable Preise für bestimmte Artikel Allgemeine Fragen zu JTL-POS 3
Neu Immer selbe Preise bei Varkombis User helfen Usern - Fragen zu JTL-Wawi 3
Neu Shopabgleich - Nur Preise anpassen Shopware-Connector 2
Neu Newsletter Preise bei Artikeln fehlen Allgemeine Fragen zu JTL-Shop 1
Neu Preise ALLER Artikel prozentual verändern User helfen Usern - Fragen zu JTL-Wawi 3
Neu Aufträge werden Brutto (Artikelpreise) in die Wawi übertragen. Netto Preise mit 4 Nachkommastellen Shopware-Connector 3
Neu Wie verstecke ich die Preise von Produkten und zeige sie nach der Registrierung im Jtl Online-Shop? User helfen Usern - Fragen zu JTL-Wawi 2
In Bearbeitung Preise werden mit 4 Stellen (nach Komma) und einem Punkt anstatt Komma an den Shop gesendet WooCommerce-Connector 2
In Bearbeitung Negative Preise - POS-902 JTL-POS - Fehler und Bugs 1
Neu Preise für OnlineShop aus JTL-Wawi-Reiter für alle Artikel User helfen Usern - Fragen zu JTL-Wawi 1
Neu Option "Preise vorher löschen" - Variation Aufpreis JTL-Ameise - Fehler und Bugs 3
Neu Preise anderer Kundengruppen in Exportformat Einrichtung von JTL-Shop 2
Neu Preise / Bestand Import EAN Fehler JTL-Ameise - Fehler und Bugs 1
Neu Preise erst nach Anmeldung per Funktionsattribut steuern? Betrieb / Pflege von JTL-Shop 3
Neu Anpassung der Preise per Ameise | Indiv. VK-Brutto fehlt User helfen Usern - Fragen zu JTL-Wawi 3
In Diskussion Woocommerce zeigt nur Netto-Preise an! WooCommerce-Connector 3
Neu SQL Abfrage Rechnungspositionen und Preise User helfen Usern - Fragen zu JTL-Wawi 0
Neu Stücklisten Preise in Netto ? Einrichtung von JTL-Shop 0
In Bearbeitung Kundengruppen Preise werden nicht übernommen Gambio-Connector 2
Neu DotLiquid Preise runden Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 5
Neu Preise werden online nicht mehr geändert Onlineshop-Anbindung 15
In Bearbeitung Kundenindividuelle Preise werden nicht übertragen - WAWI-47454 JTL-POS - Fehler und Bugs 2
Neu JTL Workflow Auftrag Preise anpassen User helfen Usern - Fragen zu JTL-Wawi 0
Offen POS ändert nicht die MW Steuer auf 16% / Preise ändern sich nicht in POS Allgemeine Fragen zu JTL-POS 3
Offen Wie bekommt man die Preise nach der Umstellung auf 16% in den Shop? PrestaShop-Connector 2
Neu "Ab Preise" bei Artikeln ohne Vaterartikel falsche Anzeige Allgemeine Fragen zu JTL-Shop 4
Neu Preise werden nicht übertragen Shopify-Connector 1
Neu Preise der Artikel Var. Kombis ändern User helfen Usern - Fragen zu JTL-Wawi 2
In Bearbeitung Kosmetik - Floating Button versperrt Sicht auf Preise JTL-POS - Fehler und Bugs 1
Neu Manuell geänderte Preise (Angebotspreise) automatisch beim Kunden hinterlegen JTL-Wawi - Ideen, Lob und Kritik 0
Ähnliche Themen