Gelöst Nach Update von JTL-Connector von 1.5.6 auf 1.5.7.1 keine Verbindung zum Connector möglich

trol_bergski

Aktives Mitglied
15. Dezember 2014
39
5
JTL-WAWI 1.3.21.0
Presta 1.7.5.1
Connector-Version 1.5.7.1
Module in Presta sind die Standards

Kurzer Vorwort. Es handelt sich noch um eine Testumgebung. Prestashop ist in einem Unterverzeichnis im Domain installiert.

Connector Version 1.5.6 -> Verbindung besteht alles läuft so wie ich es haben will.

Heute habe ich nach JTL-Guide den Connector auf 1.5.7.1 aktualisiert. Nach Update kann die Verbindung im JTL-WAWI zur Connector nicht mehr hergestellt werden mit dem Fehler "Keine Verbindung zum Onlineshop möglich. Die Url verweist auf Keinen gültigen Shop. Überprüfen Sie die Conntecor-Konfiguration."

Hab im Forum schon gesucht -> keine richtige Lösung des Problems gefunden.

Habe nochmal zur Sicherheit alle URLs aktualisiert, ohne Erfolg.
Habe Connector deinstalliert, Verzeichnigs gelöscht, clean installiert -> weiterhin derselbe Fehler

Und jetzt kommts.
1.5.7.1 deinstalliert und das Verzeinis vom jtlconnector entfernt
1.5.6 wieder installiert und sieh da... Verbindung ist wieder da

Mache ich da was falsch? Irgendwie komme ich nicht wirklich dahinter, was sich so großartig ändert, dass da keine Verbindung zustande kommt.

Kein Log in shop connector
Kein Log in shop abgleich


Danke im voraus

Gruß
Toma
 
Zuletzt bearbeitet:

Benjamin Schaffrath

Moderator
Mitarbeiter
31. Juli 2018
157
29
Hallo,
was passiert wenn du die URL des Connectors im Browser aufrufst währen du die 1.5.7.1 installiert hast?
Wenn alles korrekt installiert ist und die URL stimmt solltest du folgendes sehen:
1553174044123.png
 

trol_bergski

Aktives Mitglied
15. Dezember 2014
39
5
Aaalso

Version 1.5.6 - funktionierend
wenn ich nach deinem Beispiel vorgehe -> presta.test/jtlconnector abrufe, bekomme ich
Not found
The requested URL /jtlconnector was not found on this server.


wenn ich das Unterverzeichnis einbeziehe, wo auch der Shop tatsächlich installiert ist, sprich presta.test/ps17rc/jtlconnector
kriege ich
404 Seite nicht gefunden


bei presta.test/ps17rc/modules/jtlconnector werde ich zu Hauptdomain weitergeleitet -> in dem Fall presta.test/ps17rc/

bei presta.test/ps17rc/modules/jtlconnector/jtlconnector.php
weiße Seite mit folgendem Inhalt:


<html>
<head>
</head>
<body>
</body>
</html>


1.5.6 läuft aber auch momentan - einfach alles - Bestellungen, Artikelimport, -update alles


Version 1.5.7.1
1 zu 1 gleiches Ergebnis mit der Ausnahme, dass wieder keine Verbindung zum Shop möglich ist.


Alles grade eben zwei Mal getestet.

Gruß und danke für die schnelle Antwort
 
Zuletzt bearbeitet:

trol_bergski

Aktives Mitglied
15. Dezember 2014
39
5
Sorry mein Fehler.... da war der "/" am Ende doch sehr ausschlaggebend.....

bei 1.5.6

Code:
result    null
error
code    -32600
message    "Invalid Request"
data    "Exception 'jtl\\Connector\\Core\\Exception\\RpcException' (Code: -32600) with message 'Invalid Request' in prestashop/modules/jtlconnector/connector.phar/library/jtl/connector/src/jtl/Connector/Core/Rpc/RequestPacket.php:173"
jtlrpc    "2.0"
id    "unknown"

bei 1.5.7.1

HTTP ERROR 500
 
Zuletzt bearbeitet:

trol_bergski

Aktives Mitglied
15. Dezember 2014
39
5
Hab den Fehler gefunden.

Lag an der php.ini Konfiguration

max_execution_time

Bei mir habe ich das auf = 0 & 1 gehabt

Der integrity_check meldet aber "0"

Anscheinend muss jedoch ein konkretes Wert eingegeben werden.

Jetzt hab ich wieder Verbindung.

Danke
 
  • Gefällt mir
Reaktionen: Benjamin Schaffrath
Ähnliche Themen
Titel Forum Antworten Datum
Datenbankupdate nach Update von 4.06 auf 5.1.5 läuft endlos Upgrade JTL-Shop4 auf JTL-Shop5 8
nach Update von 1.5.52 auf 1.6.44 Wawi nur offline zu starten JTL-Wawi 1.6 11
Kategorie Bilder werden nach Update von JTl-Shop 4 auf JTL-Shop 5 nicht angezeigt Upgrade JTL-Shop4 auf JTL-Shop5 2
Nach Update Fehlermeldung beim einstellen von Kinderartikeln. kaufland.de - Anbindung (SCX) 1
Neu Fehler nach Update von 4.06.18 nach 4.06.20 JTL-Wawi - Fehler und Bugs 2
In Diskussion Swiss Bit TSE Ausfall nach Update, pls Help JTL-POS - Fehler und Bugs 2
Gelöst POS Abgleich mit WaWi geht nicht mehr nach Update JTL-Wawi - Fehler und Bugs 3
Neu Kasse läuft nicht mehr nach Update und zeigt Fehlermeldung JTL-POS - Fehler und Bugs 6
Neu nach Update auf JTL WAWI 1.7.5.2 abbruch des abgleiches Modified eCommerce-Connector 1
Neu PayPal Timeout nach Update Allgemeine Fragen zu JTL-Shop 0
Neu Nova Template zerschossen nach Update? Linke Seitenleiste geht über die komplette Seite. Templates für JTL-Shop 2
Neu Problem mit dem WooCommerce Abgleich nach Update auf 1.6.44.0 WooCommerce-Connector 0
??? Stable Release 1.6.44.0 - wieso zeigt die Oberfläche nach dem Update ein Gemisch aus Deutsch und Englisch an? JTL-Wawi 1.6 3
Beantwortet Kein Shopabgleich nach Wawi Update auf 1.6.44 mit Shop 4.06 (Build: 18) JTL-Wawi 1.6 1
Neu SQL Error -1 preforming exec nach Windows Update JTL-Wawi - Fehler und Bugs 2
Neu Fehler nach Datenbank Update User helfen Usern - Fragen zu JTL-Wawi 9
Neu nach Wawi 1.6.44.0 Update Die Nummerierung der eBay Bilder fehlen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Abgleich defekt nach Update auf 1.6.44.0 Shopify-Connector 34
Neu Hilfe benötigt, SQL Fehler nach Windows update User helfen Usern - Fragen zu JTL-Wawi 21
Neu ecoDMS (18.09) Lizenz nach Windows 22H2 Update inaktiv User helfen Usern 1
Nach Update admin/boxes.php weiße Seite Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu Nach Update auf 1.6 alle Export und Import Vorlagen verschoben. In der Ameise User helfen Usern - Fragen zu JTL-Wawi 7
Neu Variationen (für Wunschtexte) nach Update falsch sortiert JTL-Wawi 1.6 1
Beantwortet Fehlermeldung nach Shop-Update Upgrade JTL-Shop4 auf JTL-Shop5 2
Fehlerhafter Datev-Rechnungsdatenexport mit Ameise nach Update auf 1.6. JTL-Wawi 1.6 0
Nach Update auf 1.6.43 wird die Ware im Zulauf nicht mehr zusammengezählt JTL-Wawi 1.6 7
Neu Fehler nach Update auf 1.6.43 JTL-Wawi - Fehler und Bugs 0
Neu Keine TransaktionsID mehr nach Update auf Wawi1.6 JTL-Ameise - Fehler und Bugs 0
Neu Maßeinheit wird nach Shop-Update nicht mehr angezeigt Allgemeine Fragen zu JTL-Shop 1
Nach Update auch 1.6 Problem mit Export-Ameise JTL-Wawi 1.6 2
Neu Angabe Artikel im Zulauf stimmt nicht mehr nach Update auf 1.6.43 JTL-Wawi - Fehler und Bugs 4
Neu Variablen funktionieren nach Update nicht mehr JTL-Shop - Fehler und Bugs 2
Neu Access Violation nach Update auf 1.6.42.2 JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
Neu Datenbankfehler nach Update auf 5.1.5 Installation / Updates von JTL-Shop 2
Neu Bestellvorschläge funktioniert nach Update auf 1.6.42.2 nicht mehr JTL-Wawi - Fehler und Bugs 4
Neu Boxen füllen - Druckt jetzt Auftrag und keine Rechnung Nach Update 1.6 Arbeitsabläufe in JTL-Wawi 0
Amazon Rechnungen VCS Probleme nach dem Update auf der 1.6 JTL-Wawi 1.6 3
Neu Nach update auf Shop 5 lädt Bestellabschlussseite nicht mehr Installation / Updates von JTL-Shop 4
Neu Problem bei Artikelimport nach Update auf JTL-WAWI 1.6 User helfen Usern - Fragen zu JTL-Wawi 0
Nach Update Fehler bei eBay-Abgleich JTL-Wawi 1.6 4
Neu Weiße Seite nach Update auf 5.1.5 Installation / Updates von JTL-Shop 1
Fehler Retourenlabel nach Update auf 16.42.0 Fehler JTL-Wawi 1.6 2
Neu Nach Upgrad auf JTL 5 keine Kinderartikel in der Artikelansicht mehr sichtbar Upgrade JTL-Shop4 auf JTL-Shop5 0
Neu Einkauf nach Rabattaktionen User helfen Usern - Fragen zu JTL-Wawi 11
Neu Nach zusammenfassen: Auftragspositionen werden falsch sortiert JTL-Wawi - Fehler und Bugs 0
Beantwortet JTL 1.5 - Workflow Brieftrackingnummer nach Amazon übertragen? JTL-Workflows - Ideen, Lob und Kritik 2
NEUE Artikel werden nicht nach kaufland und otto übertragen kaufland.de - Anbindung (SCX) 0
Neu wms pickliste nach uhrzeit und nicht nach intervall steuern? Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 0
Gelöst Artikel nach Gewicht verkaufen Allgemeine Fragen zu JTL-POS 2
Neu Kundengruppe automatisch nach Land anpassen WooCommerce-Connector 0

Ähnliche Themen