Gelöst Nach Shop Umzug auf einen anderen Server werden keine Datenbankinhalte mehr angezeigt

mseydel

Aktives Mitglied
8. Oktober 2009
7
1
Hallo zusammen,
da in Kürze eine Umstellung auf PHP 7 erfolgt wollte ich kurzfristig auf einen anderen Server ausweichen bevor ein Update auf Version 4 erfolgt. Es handelt sich beim dem Umzug also um die Version 3.20

Ich habe alle Inhalte per FTP übertragen die Datenbank mit einem Dump gesichert und wieder eingespielt alle rechte gesetzt den Systemcheck ausgeführt mit dem angebotenen Paket (alles grün) die ini angepasst usw.

Nun wird die Seite auch angezeigt und ich kann mich auch fehlerfrei im Backend anmelden. Das Problem, es werden aber keinerlei Inhalte aus der Datenbank angezeigt also weder Artikel noch Kategorien usw...

Ich würde mich über einen Hinweis freuen wo ich noch ansetzen kann.
Danke
Matthias
 

mseydel

Aktives Mitglied
8. Oktober 2009
7
1
Als Ergänzung:
ich habe das jetzt nochmal in der anderen Variante installiert also erst eine komplett neue Installation gemacht lief einwandfrei durch alles grün und danach alles angepasst. In der ini den Key getauscht Verzeichnisse getauscht usw. das Ergebnis ist das selbe es werden keinerlei Artikel usw, angezeigt. Hat wirklich niemand einen Tipp?

Gruß
Matthias
 

mseydel

Aktives Mitglied
8. Oktober 2009
7
1
Hier die Lösung für mein Problem das ich mithilfe des JTL Supports lösen konnte nachdem Sie mir die Fehlermeldung zugesandt haben.

Ein Eintrag in der config Datei der Datenbank (my.cnf) wird wohl bei einigen Ubuntu und Mysql Version wie folgt gesetzt :

sql_mode=ONLY_FULL_GROUP_BY,NO_ZERO_IN_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION

wenn man den ersetzt durch
sql_mode=STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION

funktioniert auch der Shop 3 wieder in vollem Umfang

Mehr kann man hier zu dem Thema Lesen ONLY_FULL_GROUP_BY
 

Ähnliche Themen