Neu Megamenu zeigt keine Kategorien mehr an

istan

Mitglied
27. September 2021
8
2
Hey,

ich verzweifle gerade ein wenig. Ich habe meinen JTL Shop von 5.1.1 auf 5.1.3 upgedatet und dann die Primärfarbe angepasst. Soweit so gut.
Jetzt werden mir aber im Megemenu keine Kategorien mehr angezeigt, es öffnet sich nur eine graue Box ohne Inhalt.

Ich hab jetzt schon ein paar Artikel hier im Forum gelesen, allerdings keine Abhilfe gefunden. Hatte jemand mal ein ähnliches Problem?

Vielen Dank für die Hilfe!
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: servogt

servogt

Aktives Mitglied
19. Mai 2015
19
3
Hallo,

ein ähnliches Problem haben wir auch.
Im Zuge des Umstiegs von Shop 4 zu Shop 5 haben wir die Version 5.1.3 komplett neu aufgesetzt und genauso mit der Wawi verbunden wie den bisherigen Shop, die Kategorien funktionieren zwar, werden aber nicht im Megamenu angezeigt. Habe auch schon sämtlichen Threads durchgelesen und die Lösungen probiert, jedoch ohne Erfolg.

LG
 
  • Gefällt mir
Reaktionen: istan

istan

Mitglied
27. September 2021
8
2
Ja, genau so ist es bei mir auch.
Leider habe ich immer noch keine Abhilfe gefunden, sieht's bei euch schon besser aus?
 
  • Gefällt mir
Reaktionen: servogt

css-umsetzung

Offizieller Servicepartner
SPBanner
6. Juli 2011
5.193
994
Berlin
Das geht von fehlerhafter Einstellung im Template bis hin zu fehlerhafter Angabe des Kategorie Pfades in der Onlineshop Anbindung.
Das müsste direkt im System geprüft werden.
 

istan

Mitglied
27. September 2021
8
2
Ein Link wäre gut, dann könne man sehen ob es nur ein Design Problem ist.
Der Shop ist noch nicht online, war kurz vor Fertigstellung. Dann das Update gemacht, jetzt das Problem... ich hab mal Bilder angehangen, vielleicht ist ja was zu erkennen.
Es ist auch egal, welches Template ich nutze, ob das Nova Standard oder mein Childtemplate, funktioniert bei beiden nicht.
 

Anhänge

  • Bildschirmfoto 2022-08-01 um 17.33.09.png
    Bildschirmfoto 2022-08-01 um 17.33.09.png
    1,2 MB · Aufrufe: 4
  • Bildschirmfoto 2022-08-01 um 17.33.11.png
    Bildschirmfoto 2022-08-01 um 17.33.11.png
    577,2 KB · Aufrufe: 4
  • Bildschirmfoto 2022-08-01 um 17.33.27.png
    Bildschirmfoto 2022-08-01 um 17.33.27.png
    247,5 KB · Aufrufe: 4

istan

Mitglied
27. September 2021
8
2
Ich habe nochmal ein neues Childtemplate erstellt und jetzt festgestellt, dass der Fehler erst auftritt, nachdem ich in der variables.ccs "$primary: #085663;" hinzugefügt habe, wenn ich es danach wieder lösche bleibt der Fehler bestehen.
Bearbeite ich also die Primärfarbe nicht, ist alles okay. Passe ich sie allerdings an, geht es danach nicht mehr, egal ob die ccs wiederhergestellt wird oder nicht.
 

css-umsetzung

Offizieller Servicepartner
SPBanner
6. Juli 2011
5.193
994
Berlin
Poste am besten mal die _variables.scss aus deinem Child, mit dem gesetztem Wert "$primary: #085663;" in einem Codeblock damit man sich das mal anschauen kann.
 

servogt

Aktives Mitglied
19. Mai 2015
19
3
Ich habe den Fehler jetzt bei mir beheben können, die Lösung lag ganz woanders als ich dachte.

Ich habe die Kategorien in der Wawi zunächst durch Entfernen des Häkchens in den Kategoriestammdaten vom Shop gelöst und komplett abgeglichen.
Dann wieder die Häkchen gesetzt, sodass in der Spalte "Alle Unterkat./Artikel senden" der Wert "Alle Unterkategorien/Artikel" stand und dann wieder einen Komplettabgleich durchgeführt.
Ich musste das selbe dann komischerweise nochmal für die Unterkategorien machen, die sind danach aber auch reingekommen.

Mit den Unterkategorien habe ich jetzt jedoch noch ein weiteres Problem, zu dem ich wahrscheinlich einen weiteren Thread erstellen werde.
Die Unterkategorien werden nämlich nicht als Dropdown ausgeklappt, stattdessen kann man innerhalb des unausgeklappten Megamenus scrollen und die Unterkategorien werden überlappend und ohne Bilder/Text angezeigt und lassen sich auch nicht anklicken
 

istan

Mitglied
27. September 2021
8
2
Poste am besten mal die _variables.scss aus deinem Child, mit dem gesetztem Wert "$primary: #085663;" in einem Codeblock damit man sich das mal anschauen kann.
Code:
//
// Platz für eigene Variablen in SCSS-Notation
//
// Alle Änderungen hier müssen anschließend mit einem SCSS-Compiler
// (z.B. dem JTL-Theme-Editor Plugin) nach my-nova.css kompiliert werden
// --------------------------------------------------

// my-nova Theme
// Hier können alle Variablen notiert werden, die nur Auswirkungen auf dieses Theme haben
// -------------------Beginn eigene Variablen----------------------------------




$primary: #085663;






// -------------------Ende eigene Variablen----------------------------------

// Lädt clear-Variablen
@import '../../../../NOVA/themes/clear/sass/variables';

// passt die Pfade an
$nova-theme-path:                   "../../../NOVA/themes";
$fa-font-path:                      "../../../NOVA/themes/base/fontawesome/webfonts";

__________________________________

So sieht es dann aus
 
Zuletzt bearbeitet:
Ähnliche Themen
Titel Forum Antworten Datum
Neu Unterkategorien im Megamenu lassen sich nicht ausklappen Templates für JTL-Shop 0
Neu NOVA Theme Megamenu ohne Dropdown Templates für JTL-Shop 3
Neu Hotfix von 5.1.2 auf 5.1.4 zeigt noch die alte Version im Backend an. Installation / Updates von JTL-Shop 2
Neu PAYPAL Plugin 2.1.2. zeigt bei JTL SHOP 5.1.4 unsere Bestellnummern nicht mehr an JTL-Shop - Fehler und Bugs 2
Neu PAYPAL Plugin 2.1.2. zeigt bei JTL SHOP 5.1.4 unsere Bestellnummern nicht mehr an Plugins für JTL-Shop 2
Gelöst Shipping - geht fast nichts mehr Statusseite zeigt "haufenweise Probleme" JTL-ShippingLabels - Fehler und Bugs 5
Neu Nivo Slider zeigt nicht höchstes Aufgelöste Bildversion an Allgemeine Fragen zu JTL-Shop 5
Neu WMS - bestimmter Mitarbeiter darf KEINE Pakete für das Ausland bearbeiten können Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 4
Neu Seit 19.09.22 funktioniert die Amazon.com Anbindung (USA) nicht mehr. Ticket eröffnet - keine Reaktion :-( Amazon-Anbindung - Fehler und Bugs 0
Neu keine Versandart wählbar nach Kundenimport in Shop 5 JTL-Shop - Fehler und Bugs 3
Neu Boxen füllen - Druckt jetzt Auftrag und keine Rechnung Nach Update 1.6 Arbeitsabläufe in JTL-Wawi 0
Verwiesen an Support keine Rechnungserstellung möglich JTL-Wawi - Fehler und Bugs 1
Neu tbesucherarchivist keine InnoDB-Tabelle Installation / Updates von JTL-Shop 4
Neu Keine Angebote werden eingestellt..... eBay-Anbindung - Fehler und Bugs 1
Neu Vorschlag: Bitte keine h4, h5 Überschriften mehr in den modal-titeln JTL-Shop - Ideen, Lob und Kritik 0
Neu Shop SQL-Injection Sicherheitslücke - Patch drauf und gut ist? Sonst keine Maßnahmen? Betrieb / Pflege von JTL-Shop 11
Neu Keine Checkbox im Kontaktformular Allgemeine Fragen zu JTL-Shop 3
Neu Paypal Checkout - Rechnungskauf Ratepay - Keine Zahlungsinformationen JTL-Wawi - Fehler und Bugs 1
Neu keine Shopify Anbindung möglich, da im Hauptmenü "Onlineshop" fehlt Onlineshop-Anbindung 5
Neu Keine Datenübertragung Shopify-Connector 0
Neu Keine Verbindung von JTL Wawi zu JTL Shop 5 JTL-Shop - Fehler und Bugs 11
Neu Es konnte keine Zahlungsart für folgende Daten gefunden werden - Versand wird nicht angezeigt Allgemeine Fragen zu JTL-Shop 0
Habe Probleme mit Novaschild, keine Veränderungen ersichtlich Einrichtung JTL-Shop5 8
Neu Exportfehler - Keine Steuerklasse hinterlegt obwohl hinterlegt JTL-Ameise - Fehler und Bugs 2
Neu Update auf aktuelle Version - keine Plusbuchung nur mit Scanner mehr möglich JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
Neu DHL Prime - Amazon Anbindung / JTL keine Auswahlmöglichkeit Amazon-Anbindung - Fehler und Bugs 1
Neu 1.6.41.2 - Import Lieferadressen - keine UStID importierbar JTL-Ameise - Fehler und Bugs 0
Neu Amazon Pay - Keine Zahlungsmeldung an Wawi mehr - Status bezahlt fehlt Amazon-Anbindung - Fehler und Bugs 1
Neu JTL-Connector Sendet Keine Produkte an Shopify ! User helfen Usern - Fragen zu JTL-Wawi 0
Seit Update auf Wawi 16 werden uns keine Variationen im Shop mehr angezeigt!!!! JTL-Wawi 1.6 17
Nach Update Shop4 auf Shop5 keine Neukunden Anmeldung möglich Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu Mehrsprachiger Shop - plötzlich keine Auswahl mehr User helfen Usern - Fragen zu JTL-Wawi 1
Ich kann keine Artikel in den Warenkorb legen Upgrade JTL-Shop4 auf JTL-Shop5 2
Gelöst Seit ca. 2 Stunden kommen keine Bestellungen mehr in die Wawi von Amazon Amazon-Lister - Fehler und Bugs 76
Neu Ecodms: Keine Verbindung mehr möglich User helfen Usern 2
Neu ecoDMS connection manager bietet keine Verbindungen mehr an User helfen Usern 1
Neu Artikelbeschreibung lang, kurz oder keine - Funktion im Formulareditor Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 9
Neu eBay: Angebot kann nicht hochgeladen werden, da keine Antribute der Fahrezeugverwendungsliste ermittelt werden konnten. eBay-Anbindung - Fehler und Bugs 0
Wawi 1.6.40.0 - mehrere ausgewählte Merkmale löschen - keine funktion JTL-Wawi 1.6 1
Neu Bestellung kann keine Zahlung zugewiesen werden JTL-Wawi - Fehler und Bugs 1
Neu Es können keine Emails abgeholt werden Servicedesk (Beta) 6
Shipping - Keine Versandkosten in internationalen Exportdokumenten + Art der Sendung immer Sonstiges JTL-Wawi 1.6 1
Nach Update (Stunden später) keine Unterseiten mehr aufrufbar - nur Startseite Upgrade JTL-Shop4 auf JTL-Shop5 0
Neu Es können keine Prime Lable gedruckt werden JTL-ShippingLabels - Fehler und Bugs 2
Neu Plötzlich keine Leerzeichen mehr bei Textausgabe User helfen Usern - Fragen zu JTL-Wawi 0
Beantwortet Priorisierung eines Auftrages - keine Änderung der Liste im Packtisch+ --- Verstehe den Ablauf nicht Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 3
Neu Keine Versandmarken und Paketscheine JTL-ShippingLabels - Fehler und Bugs 1
Zahlungsabgleich - Auch mit der 1.6 keine Zuordnung bei minimaler Abweichung - bitte verbessern JTL-Wawi 1.6 2
Neu keine Preise bei der Abrechnungsposition wenn bei Kunden individuelle Preise hinterlegt sind Arbeitsabläufe in JTL-Wawi 0

Ähnliche Themen