Gelöst Megabug: Rechnungsbetrag wird falsch ausgewiesen

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Vox

Aktives Mitglied
3. März 2009
33
1
Hallo liebe JTL-Gemeinde,

wir mussten diesen Monat ein großes Problem feststellen welches wir leider noch nicht lösen konnten. Seit der Umstellung der MwSt.-Senkung von 19 auf 16% wird auf unseren Rechnungen teilweise, aber nicht bei allen, ein falscher MwSt.-Betrag und somit auch ein falscher Endbetrag auf der Rechnung ausgewiesen. Völlig skurril ist, dass in der Wawi sowohl netto als auch Bruttoendbetrag korrekt dargestellt werden. Auf der gedruckten Rechnung und Auftrag die Bruttobeträge aber falsch ausgewiesen werden. Ferner wird der Einzelbruttopreis des Produkts in der Auftrags- und Rechnungsverwaltung falsch dargestellt. Der Fehler tritt nicht immer dafür aber bei allen Produkten auf. Wir arbeiten aktuell mit der Version 1.5.14.2.

Ferner mussten wir auch feststellen, dass ein Problem bei Artikelvariationen sporadisch auftritt. Bei uns haben verschiedene Variationen verschiedene Aufpreise welches vermutlich mit dem Fehler zusammenhängt.

Wir können uns hier keinen Reim auf die Sache machen. Der Bug sich leider auch nicht "stabil" zu reproduzieren. Hat jemand schon mal ein deratiges Probleme gehabt und hat hier evtl. einen Lösungsansatz?

Beste Grüße und vielen Dank für eure Hilfe vorab,

Vox
 
Zuletzt bearbeitet:

Vox

Aktives Mitglied
3. März 2009
33
1
Wir haben gerade auf einem Testsystem das neueste Update installiert und fleißig getestet. Das Update hat das Problem nicht gelöst. Wir haben den Fehler nun aber gefunden aber leider noch keine Lösung. Der Fehler entsteht dadurch, dass das System für Variationsartikel welche einen Aufpreis haben für den Aufpreis statt 16% MwSt. mit 19% MwSt. rechnet.

Beispiel Produkt A Grundpreis netto: 10 EUR
Aufpreis für bestimmte Variation netto: 1 EUR
Um den Bruttopreis zu berechnen rechnet das System nun wie folgt: (10 x 1,16) + (1 x 1,19) = 12,79 EUR

Hat jemand eine Idee wie dieser Fehler entstehen kann? In der Variationsverwaltung werden die Aufpreise richtig ausgewiesen. D.h. die Wawi muss gelegentlich auf den falschen "alten" Steuersatz von 19% zugreifen. Aber wo und warum?
 

Philipp Laumen

Moderator
Mitarbeiter
16. Juli 2018
235
68
Hallo,

du müsstest bitte einmal die Preise der Variationen aktualisieren, das kannst du z.B. per Ameise ziehen. Die Preise aktualisieren sich für die Aufträge in dem Fall nicht korrekt.
 

Vox

Aktives Mitglied
3. März 2009
33
1
Hallo Phlilipp,

vielen Dank für die Rückmeldung. D.h. alle Netto- und Bruttopreise der Aufpreise der Variationen einmal neu eintippen?

Und wie kann dieser Fehler entstehen? Er tritt ja auch nicht stabil auf. Muss man bei der Umstellung des Steuersatzes im Januar wieder mit diesem Problem rechnen?
 
Zuletzt bearbeitet:

Philipp Laumen

Moderator
Mitarbeiter
16. Juli 2018
235
68
Hallo,

es reicht wenn du die Netto Preise neu eingibst, der Fehler ensteht aufgrund alter Code Bestandteile. Im Januar könnte das gleiche passieren.
Wie gesagt solltest du die auch mit der Ameise aktualisieren können.
 

Vox

Aktives Mitglied
3. März 2009
33
1
Hallo Philipp,

vielen, vielen Dank für die schnelle Rückmeldung. Die Anleitung hat funktioniert und der Fehler ist behoben! Wir sind mehr als erleichtert!

Dieser Fehler ist aber schon ein dickes Ding. Wenn sich dieser alte Code nicht beseitigen lässt, solltet ihr die JTL-Gemeinde schon auf dieses Problem hinweisen. Euer MwSt.-Umstellungs-Video wäre z.B. eine gute Plattform gewesen dieses Problem anzusprechen. So hätten auch wir uns viel Ärger erspart.

Beste Grüße,
Vox
 

querbits

Gut bekanntes Mitglied
24. Juli 2006
250
11
Marburg
Wir hatten das Problem auch mehrfach. Ich denke das tritt nur auf wenn man mit "alten" Variationsartikeln arbeitet. Sobald alles auf Variationskombinationen umgestellt ist sollte das nicht mehr auftreten. In der 1.6 soll es ja wohl keine Unterstützung mehr für "alte" Variationsartikel geben. Müssen dann zwangsweise auf Varkombis umgestellt werden.
Bin gespannt wieviele unserer Kunden das noch bemerken und bemängeln.
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Kein Rechnungsbetrag bei Rechnungsdruck via JTL POS Allgemeine Fragen zu JTL-POS 6
Neu Netto-Rechnungsbetrag nach Mehrwertsteuer-Satz aufschlüsseln Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
Neu Marke wird bei der eBay Suche nicht gefunden eBay-Anbindung - Fehler und Bugs 0
Neu Kurzbezeichnung wird vor Artikelbezeichnung gedruckt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Zahlungsart wird nicht angezeigt , ist leer Arbeitsabläufe in JTL-Wawi 0
Neu Nummernkreis Artikel geändert, jetzt wird nicht hochgezählt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Änderungen an Child Template SCSS Variablen wird nicht übernommen Technische Fragen zu Plugins und Templates 1
Neu UstID Prüfung - wie wird geloggt? amtliche Bestätigung ab 01.01.2021 weggefallen - keine Briefe mehr. User helfen Usern - Fragen zu JTL-Wawi 0
Gelöst NOVA Template - Slick Slider macht Probleme - Geladen wird nach 'mouseenter' & 'touchstart' Templates für JTL-Shop 5
Consent-Manager wird nicht angezeigt Upgrade JTL-Shop4 auf JTL-Shop5 0
Neu Product-Stream Falsches Produkt wird angezeigt Allgemeine Fragen zu JTL-Shop 4
Neu Lieferdatum bei ebay wird nicht automatisch berechnet Einrichtung und Installation von JTL-eazyAuction 0
Neu Email für Änderung der Kundengruppe wird auch bei keiner Änderung versandt JTL-Shop - Fehler und Bugs 0
Gelöst "Artikel existiert nicht" wird in JTL-POS und JTL-WMS Mobile angezeigt Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 23
Neu Sortierreihenfolge von Artikeln wird nicht richtig im Shop angezeigt WooCommerce-Connector 0
Neu Mein Worker arbeitet nicht richtig, wenn sein Fenster minimiert wird User helfen Usern - Fragen zu JTL-Wawi 5
Neu Belegdatum bei DATEV Export wird von DATEV falsch verstanden JTL-Ameise - Fehler und Bugs 1
Gelöst Amazon Schweden Bestellungen: Auftrag wird mit Euro statt Kronen angelegt Amazon-Anbindung - Fehler und Bugs 1
Neu JTL Shop5 - Startseite aus dem Backend wird umgeleitet. Einrichtung von JTL-Shop4 0
In Diskussion Workflow Bedingung trifft nicht zu, Workflow wird dennoch selten ausgeführt JTL-Workflows - Fehler und Bugs 5
In Bearbeitung Wird es ein eBay NOVA-Template geben? eBay-Designvorlagen - Ideen, Lob und Kritik 2
Neu Logo wird auf Mobilen Geräten anders dargestellt!? Templates für JTL-Shop 1
Neu Lieferantendatum wird nicht mehr übermittelt? Shopware-Connector 0
Neu Backup wird nicht abgelegt. User helfen Usern - Fragen zu JTL-Wawi 6
Beantwortet Guthaben wird nicht übertragen Shop5 JTL-Shop - Fehler und Bugs 3
In Bearbeitung Anhang wird nicht im Servicedesk angezeigt Servicedesk (Beta) 1
Neu Top Angebot wird in manchen Kategorien nicht angezeigt JTL-Shop - Fehler und Bugs 1
Neu Voraussichtliches Lieferdatum wird falsch berechnet JTL-Wawi - Fehler und Bugs 5
Neu Eigene Seiten wird mehrfach dargestellt Einrichtung von JTL-Shop4 1
Neu Artikel wird als Teillieferung angezeigt an obwohl Artikel noch vorrätig ist Arbeitsabläufe in JTL-Wawi 7
Neu Einstellung der Anzeigefenster wird nicht beibehalten JTL-Wawi - Fehler und Bugs 0
Neu Shop5 - Artikelübersicht: Beim Mouseover wird autom. das zweite Artikelbild angezeigt - wie abstellen? Einrichtung von JTL-Shop4 2
Neu "Speichern bearbeiten" wird nicht mit exportiert? Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Fehler beim Ausliefern Auftrag wird nicht ausgeliefert: Keine Teillieferung erlaubt JTL-Wawi - Fehler und Bugs 2
Neu Logo wird falsch in PDF Dargestellt JTL-Wawi - Fehler und Bugs 10
Gelöst Ameise: Fehlermeldung beim Import - 2. Position wird nie importiert Gelöste Themen in diesem Bereich 8
Neu JTL SHOP 5 Neuinstallation - On Page wird nicht geladen JTL-Shop - Fehler und Bugs 17
In Bearbeitung Grundpreis wird bei Amazon nicht angezeigt Amazon-Lister - Ideen, Lob und Kritik 14
Neu Staffelpreis wird nur in Vorschau angezeigt nicht auf der Artikelseite JTL-Shop - Fehler und Bugs 6
Neu WAWI Artikelseite wird nicht angezeigt JTL-Wawi - Fehler und Bugs 1
Beantwortet LS-POS - Artikel wird nicht immer ausgeliefert JTL-Workflows - Fehler und Bugs 1
Neu bootstrap.css wird nicht kompiliert Allgemeine Fragen zu JTL-Shop 1
In Bearbeitung Auftrag unter Offen, die Versanddaten werden exportiert aber es wird kein Etikett ausgedruckt! JTL-ShippingLabels - Fehler und Bugs 1
Neu Lagerbestand verkauf wird nicht abgeogen User helfen Usern - Fragen zu JTL-Wawi 5
Neu Internes Kundendisplay wird nicht erkannt (sunmi t2 mini) Einrichtung / Updates von JTL-POS 2
Neu Frage Shop5 wird es da auch eine Lite Version geben wie beim Shop4 Allgemeine Fragen zu JTL-Shop 8
Neu OnPage Composer wird nicht angezeigt Allgemeine Fragen zu JTL-Shop 3
In Bearbeitung XSeller Gallerie wird nicht angezeigt eBay-Designvorlagen - Fehler und Bugs 2
Neu Ansprechpartner Export -> Import Wawi wird nicht übernommen JTL-Ameise - Fehler und Bugs 3
Neu Artikelname Drucken/Mailen/Faxen wird nicht ausgegeben JTL-Wawi - Fehler und Bugs 3
Ähnliche Themen