Gelöst Megabug: Rechnungsbetrag wird falsch ausgewiesen

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Vox

Aktives Mitglied
3. März 2009
33
1
Hallo liebe JTL-Gemeinde,

wir mussten diesen Monat ein großes Problem feststellen welches wir leider noch nicht lösen konnten. Seit der Umstellung der MwSt.-Senkung von 19 auf 16% wird auf unseren Rechnungen teilweise, aber nicht bei allen, ein falscher MwSt.-Betrag und somit auch ein falscher Endbetrag auf der Rechnung ausgewiesen. Völlig skurril ist, dass in der Wawi sowohl netto als auch Bruttoendbetrag korrekt dargestellt werden. Auf der gedruckten Rechnung und Auftrag die Bruttobeträge aber falsch ausgewiesen werden. Ferner wird der Einzelbruttopreis des Produkts in der Auftrags- und Rechnungsverwaltung falsch dargestellt. Der Fehler tritt nicht immer dafür aber bei allen Produkten auf. Wir arbeiten aktuell mit der Version 1.5.14.2.

Ferner mussten wir auch feststellen, dass ein Problem bei Artikelvariationen sporadisch auftritt. Bei uns haben verschiedene Variationen verschiedene Aufpreise welches vermutlich mit dem Fehler zusammenhängt.

Wir können uns hier keinen Reim auf die Sache machen. Der Bug sich leider auch nicht "stabil" zu reproduzieren. Hat jemand schon mal ein deratiges Probleme gehabt und hat hier evtl. einen Lösungsansatz?

Beste Grüße und vielen Dank für eure Hilfe vorab,

Vox
 
Zuletzt bearbeitet:

Vox

Aktives Mitglied
3. März 2009
33
1
Wir haben gerade auf einem Testsystem das neueste Update installiert und fleißig getestet. Das Update hat das Problem nicht gelöst. Wir haben den Fehler nun aber gefunden aber leider noch keine Lösung. Der Fehler entsteht dadurch, dass das System für Variationsartikel welche einen Aufpreis haben für den Aufpreis statt 16% MwSt. mit 19% MwSt. rechnet.

Beispiel Produkt A Grundpreis netto: 10 EUR
Aufpreis für bestimmte Variation netto: 1 EUR
Um den Bruttopreis zu berechnen rechnet das System nun wie folgt: (10 x 1,16) + (1 x 1,19) = 12,79 EUR

Hat jemand eine Idee wie dieser Fehler entstehen kann? In der Variationsverwaltung werden die Aufpreise richtig ausgewiesen. D.h. die Wawi muss gelegentlich auf den falschen "alten" Steuersatz von 19% zugreifen. Aber wo und warum?
 

Philipp Laumen

Moderator
Mitarbeiter
16. Juli 2018
219
60
Hallo,

du müsstest bitte einmal die Preise der Variationen aktualisieren, das kannst du z.B. per Ameise ziehen. Die Preise aktualisieren sich für die Aufträge in dem Fall nicht korrekt.
 

Vox

Aktives Mitglied
3. März 2009
33
1
Hallo Phlilipp,

vielen Dank für die Rückmeldung. D.h. alle Netto- und Bruttopreise der Aufpreise der Variationen einmal neu eintippen?

Und wie kann dieser Fehler entstehen? Er tritt ja auch nicht stabil auf. Muss man bei der Umstellung des Steuersatzes im Januar wieder mit diesem Problem rechnen?
 
Zuletzt bearbeitet:

Philipp Laumen

Moderator
Mitarbeiter
16. Juli 2018
219
60
Hallo,

es reicht wenn du die Netto Preise neu eingibst, der Fehler ensteht aufgrund alter Code Bestandteile. Im Januar könnte das gleiche passieren.
Wie gesagt solltest du die auch mit der Ameise aktualisieren können.
 

Vox

Aktives Mitglied
3. März 2009
33
1
Hallo Philipp,

vielen, vielen Dank für die schnelle Rückmeldung. Die Anleitung hat funktioniert und der Fehler ist behoben! Wir sind mehr als erleichtert!

Dieser Fehler ist aber schon ein dickes Ding. Wenn sich dieser alte Code nicht beseitigen lässt, solltet ihr die JTL-Gemeinde schon auf dieses Problem hinweisen. Euer MwSt.-Umstellungs-Video wäre z.B. eine gute Plattform gewesen dieses Problem anzusprechen. So hätten auch wir uns viel Ärger erspart.

Beste Grüße,
Vox
 

querbits

Gut bekanntes Mitglied
24. Juli 2006
250
10
Marburg
Wir hatten das Problem auch mehrfach. Ich denke das tritt nur auf wenn man mit "alten" Variationsartikeln arbeitet. Sobald alles auf Variationskombinationen umgestellt ist sollte das nicht mehr auftreten. In der 1.6 soll es ja wohl keine Unterstützung mehr für "alte" Variationsartikel geben. Müssen dann zwangsweise auf Varkombis umgestellt werden.
Bin gespannt wieviele unserer Kunden das noch bemerken und bemängeln.
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Versandart an Rechnungsbetrag koppeln Plugins für JTL-Shop 3
Neu Artikelletikett - Bild wird nicht gedruckt JTL-Wawi - Fehler und Bugs 0
Neu Fenstergröße Artikeldetails wird nicht gespeichert. JTL-Wawi - Fehler und Bugs 1
Neu Lieferdatum wird im Auftrag gesetzt und fehlt in Pakete JTL-Wawi - Fehler und Bugs 0
In Bearbeitung [WAWI-50220] Gewicht in der Artikelübersicht wird abgeschnitten (nur 2-stellig) JTL-Wawi - Fehler und Bugs 3
Verwiesen an Support/SP Logo in Versandbenachrichtigung - Email wird nicht geändert User helfen Usern - Fragen zu JTL-Wawi 0
Neu Bei PayPal Zahlungen wird falsch gerundet z.B. -0,01 Zahlung offen JTL-Shop - BETA - Feedback und Bugmeldungen 11
Neu Workflow Fehler bat Datei wird nicht ausgeführt User helfen Usern - Fragen zu JTL-Wawi 1
Gelöst langes Zahlungsziel wird nicht korrekt gespeichert Gelöste Themen in diesem Bereich 4
Inaktiv Versand bei einer Bestellung mit verschiedenen Artikeln wird mehrfach berechnet Gelöste Themen in diesem Bereich 3
In Bearbeitung Bestand bei ebay wird nicht korrekt angezeigt eBay-Anbindung - Fehler und Bugs 3
Neu Suchmaschinenname wird nicht gespeichert Betrieb / Pflege von JTL-Shop 3
Neu Variationsbeschreibung wird nicht an Woocommerce übertragen WooCommerce-Connector 7
Neu Wieso wird die Kundennummer aus Shopware nicht importiert Shopware-Connector 1
Offen Powershell aus Workflow wird nicht ausgeführte JTL-Workflows - Fehler und Bugs 4
Neu Bildername wird nicht aus Wawi übernommen JTL-Shop - Fehler und Bugs 3
Neu Herstellerseite eines aktiven Herstellers wird im Shop als 404 angezeigt Betrieb / Pflege von JTL-Shop 1
In Bearbeitung Standardkategorie wird in Importvorlage nicht übernommen JTL-Ameise - Fehler und Bugs 2
Neu Kundenspezifischer Staffelpreis (Sp) wird nicht berücksichtigt, wenn der SP des Kunden größer als der SP in Registerkarte 'JTL-Wawi' ist JTL-Wawi - Fehler und Bugs 0
Neu abgeschlossene EC-Zahlung am Terminal wird nicht an die Kasse übertragen JTL-POS - Fehler und Bugs 2
Neu Artikelsuche > Auswahl aus Liste: Eingabe der Anzahl wird ignoriert JTL-POS - Fehler und Bugs 2
Neu Kassenbon wird nicht geladen JTL-POS - Fehler und Bugs 0
In Bearbeitung Verwaltung von Ebay Managed Payments - Aschenputtel wird müde User helfen Usern - Fragen zu JTL-Wawi 8
Neu Lieferantenbestellung wird vom Lieferanten auf 2 Liefertermine gesplittet Arbeitsabläufe in JTL-Wawi 3
Neu Formal geändertes .pdf (Auftragsbestätigung) wird nicht gespeichert ... User helfen Usern - Fragen zu JTL-Wawi 1
Neu Auf Amazon Rechnung wird das Firmen Logo abgeschnitten Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Rechnungskorrektur nimmt gelegentlich nicht die Rechnungsnummer zu der sie erstellt wird JTL-Wawi - Fehler und Bugs 1
Neu Bruttobetrag wird nicht korrekt angezeigt Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
In Bearbeitung [BUG] Amazon VCS-Lite in Zahlungen wird die Rechnungsnummer nicht eingetragen - JTL-Wawi 1.5.29.2 User helfen Usern - Fragen zu JTL-Wawi 5
Neu SCHON WIEDER: Nichts wird mehr von bzw. zu Amazon übertragen Amazon-Anbindung - Fehler und Bugs 2
Offen Shopware 5 -> JTL WaWi : Lieferadresse wird nicht übernommen Onlineshop-Anbindung 4
URL-Pfad wird bei Artikeln nicht richtig gesetzt. JTL-Shop - Fehler und Bugs 3
In Diskussion Firmenname zu lang, DHL Label wird nicht gedruckt JTL-ShippingLabels - Fehler und Bugs 6
Abgelehnt Internetmarke wird nicht gedruckt Gelöste Themen in diesem Bereich 1
In Diskussion Internetmarke wird nicht gedruckt | Fehler: Zeichenfolgen- oder Binärdaten würden abgeschnitten JTL-ShippingLabels - Fehler und Bugs 4
Neu PLU von Favoriten wird nicht erkannt JTL-POS - Fehler und Bugs 1
Neu Rechnung wird nicht gespeichert User helfen Usern - Fragen zu JTL-Wawi 1
In Bearbeitung Bestand bei Amazon wird nicht angepaßt JTL-Wawi - Fehler und Bugs 4
Neu Versandart bei Import aus modified Shop wird willkürlich gewählt JTL-Wawi - Fehler und Bugs 0
Neu Auftragsimport via XML, Zahlungsziel wird ignoriert JTL-Wawi - Fehler und Bugs 0
Neu Auftrag per Paypal bezahlt wird aber nicht in der Wawi zugeordnet User helfen Usern - Fragen zu JTL-Wawi 3
Gelöst Mehrwertsteuer 16% und Mehrwertsteuer 19% wird doppelt berechnet Gelöste Themen in diesem Bereich 2
Neu Ausgewählte Versandoption wird nicht vollständig übertragen WooCommerce-Connector 0
Neu Patagona Repricing Funktionsattribut wird nicht mehr ausgespielt JTL-Wawi - Fehler und Bugs 2
Gelöst die tse wird nicht angezeigt Gelöste Themen in diesem Bereich 10
Neu Warenkorb wird aktualisiert JTL-Shop - Fehler und Bugs 6
Neu BT Drucker wird als offline angezeigt JTL-POS - Fragen zu Hardware 2
Neu Gesucht wird jemand mit Kenntnissen für PHP / IONCUBE Betrieb / Pflege von JTL-Shop 5
Neu Kassette X wird nicht ausgewählt beim Drucken User helfen Usern - Fragen zu JTL-Wawi 0
Neu NOVA - Template wird nicht angezeigt JTL-Shop - BETA - Feedback und Bugmeldungen 4
Ähnliche Themen