Neu Lieferantenauswahl beim Import

  • JTL-Connect 2022: Ihr habt noch kein Ticket? Jetzt schnell sichern! Die PreConnect ist bereits ausgebucht, auch für die After-Show-Party auf der Ocean Diva sind nur noch wenige Plätze verfügbar! HIER geht es zum Ticketverkauf

  • Das Stable Release von JTL-Wawi 1.6 ist startklar: HIER gehts zum Forenbeitrag

KThieme

Aktives Mitglied
31. Oktober 2019
6
0
Hallo,
habe ein Problem beim Importieren.
Wenn ich in der Ameise beim Artikelimport den Lieferanten auswählen möchte, erscheint pro Ansprechpartner ein Lieferanteneintrag.
Bei fünf Ansprechpartnern des Lieferanten wird also fünf mal der Lieferant im Dropdown angezeigt.

Wähle ich einen davon aus, kann es sein, dass der EK-Preis des Lieferanten nicht importiert wird.
Dann muss ich den nächsten Eintrag wählen und ein Update auf die importierten Datensätze machen.
Solange, bis der richtige Eintrag gewählt wurde, dass der EK-Preis eingetragen wird.

Wie kann das sein, bzw. was kann ich machen, dass immer schon beim ersten Import der EK-Preis importiert wird?
Ist das eine Einstellung im Lieferanten, den ich übersehe?

Viele Grüße
Karin Thieme
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
6.790
1.191
Hallo Karin,
ich hab das mal in der 1.6, mit der ich gerade Tests durchführe, geprüft.
Da kann ich das von Dir beschriebene Verhalten nicht nachstellen, es wird jeder Lieferant nur ein mal im Dropdown angezeigt, egal, wieviele Ansprechpartner hinterlegt sind.
Ich finde allerdings auch kein Ticket, welches besagen würde: Hey, das Thema hatten wir schon, ist gefixt mit Version xxx.
Deshalb müssen wir hier wohl erst ein wenig Ursachenforschung betreiben.
Mit welcher Version tritt dieses Verhalten bei Dir auf?
 

KThieme

Aktives Mitglied
31. Oktober 2019
6
0
Hallo Enrico,

wir haben im Moment die Version 1.5.48.1. Aber das Problem war schon in vorherigen Versionen, bin aber jetzt erst auf Ursachenforschung gegangen, weil die Liste halt immer länger wird.
Habe einen Lieferantenexport gemacht und habe pro Lieferant so viel Zeilen wie dort Ansprechpartner hinterlegt sind. Dies habe ich dann mit dem Dropdown gegengeprüft und musste dann halt feststellen, dass dies genau zu der Häufigkeit im Dropdown passt. Habe auch mal bei drei Herstellern Einträge gelöscht, so ist dann bei diesen Herstellern auch "nur noch" ein Eintrag.
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
6.790
1.191
Aus der Wawi gelöscht heißt nicht aus der Datenbank gelöscht. Kannst du mal nachschauen, ob der Lieferant in der Datenbank in tLieferant nur ein mal hinterlegt ist oder ob es da mehrere davon gibt?
Hintergrund ist, dass Lieferanten beim Löschen aus der Wawi nicht aus der Datenbank gelöscht werden sondern nur auf inaktiv geschaltet werden.
Nach einem Hinweis eines netten Kollegen habe ich nämlich gerade festgestellt, dass auch inaktive Lieferanten in dem Dropdown angezeigt werden. Das ist natürlich ein Fehler, dafür mache ich sofort ein Ticket für die Entwicklung fertig.

Hast du ein wenig Ahnung, wie man ein kleines Statement auf die Datenbank absetzt?
Mit

delete tLieferant where cAktiv = 'N'

könntest du alle inaktiven Lieferanten aus der Datenbank löschen.
Wenn nicht, dann gib uns mal kurz Bescheid, ich kanns zwar nicht mehr heute versprechen, aber dann helfen wir Dir mal eben.

Edit:
https://issues.jtl-software.de/issues/WAWI-59081
Hier noch der Issue zum Nachverfolgen, Bewerten und Kommentieren.
 
Zuletzt bearbeitet:
Ähnliche Themen
Titel Forum Antworten Datum
Neu SEO URL Pfad beim Artikel fehlerhaft JTL-Workflows - Fehler und Bugs 2
Bestellung beim Lieferanten und Bestellungen vom Kunden JTL-Wawi 1.6 0
Neu CSRF validation failed beim Speichern der OPC-Seiten (...shop/admin/io.php) Einrichtung von JTL-Shop4 0
PayPal beim template Evo funktioniert nicht Einrichtung JTL-Shop5 2
Neu Fehlermeldungen beim Abruf über Kaufland Marktplatz Onlineshop-Anbindung 0
Neu Nova-Template: Logo bzw. Header in groß und klein beim Scrollen (analog Evo-Template) Technische Fragen zu Plugins und Templates 5
Neu Problem beim Ändern der Rohdaten einer E-Mail Vorlage. Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 15
Neu Puffer beim Artikel - wird vom Shopify-Connector berücksichtigt? Shopify-Connector 0
Neu Fehler beim Amazon Prime Label Drucken JTL-Wawi - Fehler und Bugs 4
Neu klitzekleiner Fehler beim Länderkürzel JTL-Wawi - Fehler und Bugs 0
Neu Einstellungen beim ausdrucken der Versandscheine DHL 3.0 JTL-ShippingLabels - Fehler und Bugs 1
Neu Fehler beim Verkaufskanal anlegen JTL-Wawi - Fehler und Bugs 1
Neu Fehler beim speichern. JTL-Wawi - Fehler und Bugs 5
Zahlart wird falsch exportiert, wenn beim Kunden eine andere Standard Zahlart hinterlegt ist, er aber ein anderes Zahlungsmittel genutzt hat. JTL-Wawi 1.6 3
Neu Fehlermeldungen beim Prime Label Kauf - InternalFailure - We encountered an internal error. Please try .... Amazon-Anbindung - Fehler und Bugs 54
Neu WAWI 1.6.40.0 Beim Speichern von Globaler Angebotsvorlage kommt eine Fehlermeldung eBay-Designvorlagen - Fehler und Bugs 1
Neu Fehler beim erstellen der Rechnung "LLPDF" Fragen rund um LS-POS 1
Neu Details zur Versandeinstellungsautomatisierung beim Lieferversprechen User helfen Usern - Fragen zu JTL-Wawi 0
1.6.39.0: Deadlocks beim Ausliefern JTL-Wawi 1.6 1
Neu Fehler beim Bestellvorgang JTL-Shop - Fehler und Bugs 2
JTL Wawi 1.6 Auftrag Splitten beim Auf die Pickliste packen JTL-Wawi 1.6 0
HILFE PICKLISTE WIRD GEDRUCKT BEIM AUSLIEFERN JTL-Wawi 1.6 1
Neu Fehler beim Export: Deprecated: JTL\Catalog\Currency: getter should be used to get cISO in /var/www/vhosts/ JTL-Shop - Fehler und Bugs 0
Fehler beim Update JTL-Wawi 1.6 0
Neu Probleme beim Uk-Export - Zollinhaltserklärung CN23 veraltet? Arbeitsabläufe in JTL-Wawi 2
Neu Gratisbeigabe beim Kauf bestimmter Artikel Allgemeine Fragen zu JTL-Shop 6
Neu Beim Hochladen wird die Steuerklasse auf 0 gesetzt! Gambio-Connector 5
Neu Problem / Fehler beim Update von JTL Connector 2.2.5.3 auf 2.13.0 (Shopware 5.5.10) Shopware-Connector 1
Neu WAWI 1.6.38.2: Skontosatz geht beim Erstellen der Rechnung verloren JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim Shopify Abgleich Shopify-Connector 0
Neu Fehler beim senden von Rechnungen per Mail JTL-Wawi - Fehler und Bugs 1
Kopf & Fußzeile sind verschwunden bei der Rechnungsvorlage beim Drucken JTL-Wawi 1.6 1
Neu Fehler beim Bearbeiten von Vorlagen Bausteinen JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim Abgleich mit Shopware 6.4.11.1 Onlineshop-Anbindung 3
Neu Wawi 1.6 / Kommunikation aus Wawi wird beim Lieferanten (in JTL wawi) nicht abgelegt JTL-Wawi - Fehler und Bugs 2
Neu Probleme beim Update auf 1.6 - Datenbank Fehler? Ideen zur Lösung? JTL-Wawi 1.6 1
MwSt. beim Versand JTL-Wawi 1.6 6
Neu (WooCommerce) JTL Connector Aufträge lassen sich nicht bearbeiten "Fehler beim MARS-Batch" User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim heutigen Update von 1.6.38.1 auf 1.6.38.2 Installation von JTL-Wawi 1
Beantwortet JTL Wawi reagiert nicht mehr beim Klick auf "VCS Rechnungsduplikate" JTL-Wawi - Fehler und Bugs 2
In Bearbeitung Wawi stürzt ab beim markieren in Listen JTL-Wawi 1.6 3
Problem beim Importieren neuer Kategorien über Ameise - Kategorien Level und Interner Schlüssel gesetzt JTL-Wawi 1.6 4
Neu Individuelle Kundennachricht beim Angebot mitschicken User helfen Usern - Fragen zu JTL-Wawi 2
Neu Nichtgelieferte/Defekte Waren beim Wareneingang vermerken Arbeitsabläufe in JTL-Wawi 3
Neu Fehler beim Speichern der Daten für den Verkaufskanal-PrestaShop-JTL Wawi 1.6 PrestaShop-Connector 0
Neu Kritischer Fehler beim Abgleich mit dem Shop WooCommerce-Connector 3
Neu Probleme mit Ameise beim Artikelimport / Artikelaktualisierung und Lieferantenartikeln (insbes. mit Dropshipping + VPE) JTL-Ameise - Fehler und Bugs 22
Issue angelegt [WAWI-62034] Fehlermeldungen beim Anlegen neuer Produktionsartikel JTL-Plan&Produce - Fehler und Bugs 7
Neu Wie vorgehen beim Connector Update? Modified eCommerce-Connector 2
Beantwortet JTL Ameise Auftrag Import - Artikel unbekannt User helfen Usern - Fragen zu JTL-Wawi 1

Ähnliche Themen