Neu Lieferantenauswahl beim Import

KThieme

Aktives Mitglied
31. Oktober 2019
6
0
Hallo,
habe ein Problem beim Importieren.
Wenn ich in der Ameise beim Artikelimport den Lieferanten auswählen möchte, erscheint pro Ansprechpartner ein Lieferanteneintrag.
Bei fünf Ansprechpartnern des Lieferanten wird also fünf mal der Lieferant im Dropdown angezeigt.

Wähle ich einen davon aus, kann es sein, dass der EK-Preis des Lieferanten nicht importiert wird.
Dann muss ich den nächsten Eintrag wählen und ein Update auf die importierten Datensätze machen.
Solange, bis der richtige Eintrag gewählt wurde, dass der EK-Preis eingetragen wird.

Wie kann das sein, bzw. was kann ich machen, dass immer schon beim ersten Import der EK-Preis importiert wird?
Ist das eine Einstellung im Lieferanten, den ich übersehe?

Viele Grüße
Karin Thieme
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
6.179
1.009
Hallo Karin,
ich hab das mal in der 1.6, mit der ich gerade Tests durchführe, geprüft.
Da kann ich das von Dir beschriebene Verhalten nicht nachstellen, es wird jeder Lieferant nur ein mal im Dropdown angezeigt, egal, wieviele Ansprechpartner hinterlegt sind.
Ich finde allerdings auch kein Ticket, welches besagen würde: Hey, das Thema hatten wir schon, ist gefixt mit Version xxx.
Deshalb müssen wir hier wohl erst ein wenig Ursachenforschung betreiben.
Mit welcher Version tritt dieses Verhalten bei Dir auf?
 

KThieme

Aktives Mitglied
31. Oktober 2019
6
0
Hallo Enrico,

wir haben im Moment die Version 1.5.48.1. Aber das Problem war schon in vorherigen Versionen, bin aber jetzt erst auf Ursachenforschung gegangen, weil die Liste halt immer länger wird.
Habe einen Lieferantenexport gemacht und habe pro Lieferant so viel Zeilen wie dort Ansprechpartner hinterlegt sind. Dies habe ich dann mit dem Dropdown gegengeprüft und musste dann halt feststellen, dass dies genau zu der Häufigkeit im Dropdown passt. Habe auch mal bei drei Herstellern Einträge gelöscht, so ist dann bei diesen Herstellern auch "nur noch" ein Eintrag.
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
6.179
1.009
Aus der Wawi gelöscht heißt nicht aus der Datenbank gelöscht. Kannst du mal nachschauen, ob der Lieferant in der Datenbank in tLieferant nur ein mal hinterlegt ist oder ob es da mehrere davon gibt?
Hintergrund ist, dass Lieferanten beim Löschen aus der Wawi nicht aus der Datenbank gelöscht werden sondern nur auf inaktiv geschaltet werden.
Nach einem Hinweis eines netten Kollegen habe ich nämlich gerade festgestellt, dass auch inaktive Lieferanten in dem Dropdown angezeigt werden. Das ist natürlich ein Fehler, dafür mache ich sofort ein Ticket für die Entwicklung fertig.

Hast du ein wenig Ahnung, wie man ein kleines Statement auf die Datenbank absetzt?
Mit

delete tLieferant where cAktiv = 'N'

könntest du alle inaktiven Lieferanten aus der Datenbank löschen.
Wenn nicht, dann gib uns mal kurz Bescheid, ich kanns zwar nicht mehr heute versprechen, aber dann helfen wir Dir mal eben.

Edit:
https://issues.jtl-software.de/issues/WAWI-59081
Hier noch der Issue zum Nachverfolgen, Bewerten und Kommentieren.
 
Zuletzt bearbeitet:
Ähnliche Themen
Titel Forum Antworten Datum
Neu Fehler beim installieren von JTL Software Edition JTL-Wawi - Fehler und Bugs 0
Neu Probleme beim Update von Version 1.5.48.2 auf 1.5.53.1 Installation von JTL-Wawi 0
Neu Nach Update auf JTL-Wawi 1.6.33.1 - Fehler beim Onlineshopabgleich JTL-Wawi - Fehler und Bugs 4
Neu .com.de Domains werden zu .com Domains beim Mailversand User helfen Usern - Fragen zu JTL-Wawi 1
Neu HTTP ERROR 500 beim Blog-Beiträge speichern JTL-Shop - Fehler und Bugs 2
Gelöst Absturz JTL-Pos mit Sunmi D2 Mini beim Bon-Druck Version 1.0.5.18 (4409) JTL-POS - Fehler und Bugs 4
Neu Shopware 6 Connector Problem beim Abgleich von Bildern Shopware-Connector 1
Gelöst JTL POS stürzt beim Starten ab und Zeigt Fehler: JTL POS muss beendet werden 1.0.5.17 (4390) JTL-POS - Fehler und Bugs 4
In Bearbeitung Fehler beim Bon Druck mit Sunmi T2 lite JTL-POS - Fehler und Bugs 2
Neu Häufige Abstürze beim Kassiervorgang mit LS-POS Fragen rund um LS-POS 1
Neu Fehlermeldung beim Shop Abgleich Gambio-Connector 1
Neu Beim waren Eingang wird der Eingang im Standardlager gebucht User helfen Usern - Fragen zu JTL-Wawi 1
Neu Konfigurator verursacht HTTP Error 500 beim Abgleich JTL-Shop - Fehler und Bugs 0
Neu Nummernkreis - Auftragsnummer Prefix <J> beim Jahreswechsel zu frü? JTL-Wawi - Fehler und Bugs 2
Neu Shopware - Fehler beim Senden von Artikeln Shopware-Connector 0
Neu Fenstergröße beim Start User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung [LÖSUNG Android 11] TSE Modul bei Neustart vom Tablet Dauerschleife beim Verbinden. JTL-POS - Fehler und Bugs 3
Neu Hilfe beim XML Import von Extern direkt in die Datenbank Schnittstellen Import / Export 5
In Bearbeitung HILFE!!! Artikel im System aber beim Barcode scannen wird kein Artikel gefunden! JTL-POS - Fehler und Bugs 3
In Diskussion Workflow ob Artikel beim Lieferanten bestellt ist, dann Lieferdatum auslesen. JTL-Workflows - Ideen, Lob und Kritik 2
Neu Editor in News - Formatierungen entfernt beim Speichern - 4.06.18 JTL-Shop - Fehler und Bugs 1
Neu Fehlermeldung beim Update von Version 1.5.45.1 auf 1.5.52.0 JTL-Wawi - Fehler und Bugs 1
Neu Verbindungsprobleme SQL Server beim Öffnen verschiedener JTL Bereiche wie Rechnungen und Rechnungskorrekturen ODBC Setup JTL-Wawi - Fehler und Bugs 0
Neu Wie kann man in Einstellungen das so machen das wenn beim eBay das Artikel bezahlt ist dann wird das Automatisch in Wawi eine Rechnung erstellt?? User helfen Usern - Fragen zu JTL-Wawi 1
Neu Fehler beim Erstellen des GoogleShopping.xml (Plugin) JTL-Shop - Fehler und Bugs 0
Neu Fehler beim FTP Import User helfen Usern - Fragen zu JTL-Wawi 4
floatval ersetzen mit ????? - Fatal error beim Checkout Einrichtung JTL-Shop5 2
Neu Emoji Symbole bei den Attributen beim Amazon Listing Amazon-Lister - Fehler und Bugs 0
Neu Shop 5.1.1 - weiße Seite beim anlegen von Blogbeiträgen JTL-Shop - Fehler und Bugs 2
Neu Connector Fehler beim Verbindungsaufbau WooCommerce-Connector 0
Neu Shopware 6 Connector Probleme beim Abgleich der Bestellungen mit Klarna Shopware-Connector 1
Neu DB-Fehler beim Update von 1.5 auf 1.6: Foreign Key in tBestellung JTL-Wawi - Fehler und Bugs 0
Neu Exportformat für AdCell - Problem beim Grundpreis Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Problem mit Fstr() beim Formatieren des Einzelstückpreises User helfen Usern - Fragen zu JTL-Wawi 2
Neu Pause beim Druck von Lieferscheinen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Verwiesen an Support Fehler beim Verpacken JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 1
Neu Lagerplatzempfehlung beim Einlagern Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 2
Neu Plugin Migrations werden beim deinstallieren nicht zurück gesetzt JTL-Shop - Fehler und Bugs 0
Neu Fehler beim Anlegen von Verkaufskanal Shop5 im Testsystem Onlineshop-Anbindung 0
Neu Problem beim Connect Shopify-Connector 1
Neu Rabatt beim Einkauf, nachträglich ändern User helfen Usern - Fragen zu JTL-Wawi 2
Neu Plugin: "JTL Theme Editor" in Shop 5 - Fehler beim Speichern der Datei. Allgemeine Fragen zu JTL-Shop 6
Neu Seitenränder/Shop Container auf eigene Seiten beim Composer Allgemeine Fragen zu JTL-Shop 5
Neu Fehler beim Anlegen von Verkaufskanal Shop5 im Testsystem Installation / Updates von JTL-Shop 3
Neu Produktion ohne zu wissen welche Stückzahl beim Endprodukt hergestellt wird. JTL-Plan&Produce - Ideen, Lob und Kritik 14
Neu Falscher Mailclient beim Export von Aufträgen und Co als PDF User helfen Usern 0
Neu Fehler beim Shopware Shopabgleich JTL-Wawi - Fehler und Bugs 0
Neu JTL SHOP 5 unter Mobile IOS Safari verschwindet das Menü beim Scrollen JTL-Shop - Fehler und Bugs 7
Neu Wawi mails landen beim Kunden im Spam Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Merkmale - Eingaben beim HTML-Editor werden nicht gespeichert - übernommen JTL-Wawi - Fehler und Bugs 2

Ähnliche Themen