Neu leere Seiten beim Aufruf des Install

ManneBT

Neues Mitglied
22. Dezember 2020
1
0
Ich versuche gerade den JTl Connector in der version 3.3.0 zu installieren und bekomme jedes mal wenn ich den Installer aufrufen will eine leere Seite und nichts weiter angezeigt (keine Fehlermeldung oder sonstwas)

Das ganze soll mit Shop Version v2.0.5.1 rev 12725 laufen.

Ich habe keine Ahnung was ich falsch mache.
Selbst auf das Biär und auf die Berechtigungen habe ich geachtet und auch verschiedenen Browser probiert, aber überall kommt einfach nur einen weiße leere Seite.

Was mache ich falsch?
 

neuling64

Aktives Mitglied
3. Februar 2018
12
1
Ich habe das gleiche Problem.
Erst mit 3.3.0 probiert, dann mit 3.2.0. Der install startet nicht (leerer Bildschirm).
Übertragung ftp mit filezilla binär.
 

neuling64

Aktives Mitglied
3. Februar 2018
12
1
Ich habe das gleiche Problem.
Erst mit 3.3.0 probiert, dann mit 3.2.0. Der install startet nicht (leerer Bildschirm).
Übertragung ftp mit filezilla binär.
Vorgeschichte: Ich habe Anfang Januar den modified-Shop auf den neuesten Stand upgedatet und musste seitdem die Verbindung zum Onlienshop immer zweifach starten. 1. Mal kam ein Fehler, das 2. Mal funktionierte die Übertragung. Deshalb wollte ich jetzt den JTLConnector updaten.
 

Litho

Gut bekanntes Mitglied
17. Juni 2017
344
23
Hänge mich mal hier dran habe das Problem aber mit 3.4.0
der 3.3. ließ sich dann isntallieren.
 

Girahlutions

Aktives Mitglied
12. April 2017
23
2
Kann ich bestätigen. Hatte auch immer eine weiße Seite beim Aufruf. Allerdings schon seit der Version 3.1.0 🙁 Daher spiele ich den einfach auf dem Server drüber.
Bisher war der Connector leider immer noch Fehlerhaft. Ich hoffe, bei dieser Version funktioniert nun alles.
 

Immanuel

Gesperrter Benutzer
24. August 2016
1.542
329
Hallo @Litho, hallo @Girahlutions,

wir haben das gerade mit verschiedenen PHP Versionen getestet: Ab PHP 7.1 sollte der Installer aufrufbar sein. Checkt am besten mal den Webserver Log nach Fehlern.

PS: Welche Shop Versionen kommen zum Einsatz?
 

Girahlutions

Aktives Mitglied
12. April 2017
23
2
Ich habe die PHP Version 7.4 und die neueste Modified shop Version 2.0.5.1
Der Connector überträgt leider auch die Sortierung der Varkombis nicht und legt im Shop die Werte zb. Farbe Rot jedes Mal neu an. Neuerdings setzt der Connector auch die Bestellung beim Erstellen des Lieferscheins im Shop schon auf versendet.
 

markenschuheshop

Gut bekanntes Mitglied
8. September 2010
282
17
Hallo

Hab den aktuellen connector 3.4.0 und versucht zu installieren, hab die Daten natürlich binär übertragen, wenn php Version unter 7.1 zeigt mir dass ich über php Version 7.1 brauche dann hab ich php Version 7.3 umgestellt und dann kommt Fehlermeldung
 

markenschuheshop

Gut bekanntes Mitglied
8. September 2010
282
17
Hallo,
hier die Fehlermeldung:
Warning: session_start(): Cannot start session when headers already sent in phar:///www/htdocs/w01b67fd/jtlconnector/index.php/src/jtl/Connector/Modified/Installer/Installer.php on line 25

Fatal error
: Uncaught Exception: Cannot start session. in phar:///www/htdocs/w01b67fd/jtlconnector/index.php/src/jtl/Connector/Modified/Installer/Installer.php:26 Stack trace: #0 /www/htdocs/w01b67fd/jtlconnector/install/index.php(6): jtl\Connector\Modified\Installer\Installer->__construct() #1 {main} thrown in phar:///www/htdocs/w01b67fd/jtlconnector/index.php/src/jtl/Connector/Modified/Installer/Installer.php on line 26
 

markenschuheshop

Gut bekanntes Mitglied
8. September 2010
282
17
klein update:
jetzt habe ich auf php version 7.4 umgestellt und erhalten nur weiße seite. bei umstellung von php version ehalte diese anweisung wie im Bild zu sehen ist.
 

Anhänge

  • connector-problem.PNG
    connector-problem.PNG
    176,2 KB · Aufrufe: 8

Immanuel

Gesperrter Benutzer
24. August 2016
1.542
329
Hallo @markenschuheshop,

aus irgendeinem Grund wird etwas in PHP ausgegeben, bevor die Session des Installers starten konnte. Die Ausgabe führt zu dem Problem. Auch bei der älteren PHP Version kommt es zu dem Fehler (im Screenshot sieht man die Warnungen oben im Hintergrund). Allerdings wird bei der älteren PHP Version trotzdem der Rest ausgegeben.
 

markenschuheshop

Gut bekanntes Mitglied
8. September 2010
282
17
Hallo @markenschuheshop,

aus irgendeinem Grund wird etwas in PHP ausgegeben, bevor die Session des Installers starten konnte. Die Ausgabe führt zu dem Problem. Auch bei der älteren PHP Version kommt es zu dem Fehler (im Screenshot sieht man die Warnungen oben im Hintergrund). Allerdings wird bei der älteren PHP Version trotzdem der Rest ausgegeben.
OK, haben Sie eine Idee wie ich vorgehen muss damit die Installation klappt? gerne können sie das gegen Bezahlung übernehmen.
 

Immanuel

Gesperrter Benutzer
24. August 2016
1.542
329
OK, haben Sie eine Idee wie ich vorgehen muss damit die Installation klappt? gerne können sie das gegen Bezahlung übernehmen.
Versuche mal jegliche Meldungen (Notices, Warnungen, Fehler...) von PHP zu unterdrücken. Anstelle der Ausgabe, können diese Meldungen auch in eine Datei geschrieben werden. Möglicherweise verursacht eine solche Meldung das Problem. Wende dich am besten an deinen Hoster. Der sollte wissen wie das geht.
 

markenschuheshop

Gut bekanntes Mitglied
8. September 2010
282
17
Versuche mal jegliche Meldungen (Notices, Warnungen, Fehler...) von PHP zu unterdrücken. Anstelle der Ausgabe, können diese Meldungen auch in eine Datei geschrieben werden. Möglicherweise verursacht eine solche Meldung das Problem. Wende dich am besten an deinen Hoster. Der sollte wissen wie das geht.
Jetzt hab ich mit andere hoster und andere Domain versucht, Ergebnisse beim Aufruf von install ist nur weiße Seite. Bin momentan ratlos
 

Ähnliche Themen