Neu Keine Verbindung zu Shop 5: Shop URL ungültig

deutschevita

Aktives Mitglied
7. November 2015
46
5
Hallo zusammen,

wir haben das Update auf JTL- Shop 5 gemacht - hat soweit alles geklappt und der Shop läuft ohne Probleme. Logs sind clear, wirft keine Fehler - top.
Allerdings kann ich keine Verbindung zur JTL WAWI (1.5.40.0) herstellen.
Er gibt den Fehler aus:

Synchronisation mit Webshop nicht möglich! Die Shop-URL verweist nicht auf einen gültigen Shop!


Ich weiß, dass das Thema schon häufiger aufkam, daher gleich vorweg, was ich schon geprüft habe:
  1. Schreibweise geprüft, stimmt exakt (hat sich durch das Upgrade auch nicht geändert) = https:// kein www, kein trailing slash
  2. Domain Subscription ist gültig und korrekt eingetragen.
  3. Ich habe wegen der UTF-8-Geschichte die Passwörter für den sync erneuert und eingetragen, bringt nichts.
  4. /dbeS/mytest.php ist erreichbar, gibt aber seit der 5.0 natürlich eine leere Antwort bei Status 200 zurück, denn freilich wurde der Inhalt der Datei ja entfernt.
  5. Verzeichnisse sind beschreibbar, Zugriffsrechte korrekt
  6. .htaccess ist drinnen und läuft überall gut.
  7. Systemcheck läuft
  8. Laut PHP-Info und JTL-Admin erkennt der Shop seine domain auch wie eingetragen.
Da ich nicht, weiß, wie JTL-Wawi den Shop verifiziert, kann ich schlicht nicht näher untersuchen, woher das Problem kommen könnte.

Das ist mir aufgefallen:

1.
Wenn ich auf Verbindung testen klicke, macht die WAWI zwei HTTP-Calls:
Code:
application_server_1       | xxx - - [26/Aug/2021:19:56:04 +0000] "POST /dbeS/mytest.php HTTP/1.0" 200 0 "-" "JTL-Wawi" "xxxx, xxxx"
application_server_1       | xxx - - [26/Aug/2021:19:56:05 +0000] "POST / HTTP/1.0" 200 35660 "-" "-" "xxxx, xxxx"

Ich weiß ja nicht, ob die Wawi da vielleicht aus der mytest.php noch eine Antwort erwartet, die es nicht mehr gibt?

2.
Wenn ich /dbeS/ aurufe, ruft er den Inhalt der index.php auf und schmeißt einen Fehler (es fehlt ein Argument). Wenn man einen Querystring mit ?id=1 anhängt, kommt eine leere 200er Antwort zurück.

3.
Für eine korrekte Verarbeitung von UTF-8 Zeichensätzen wird mindestens JTL-Wawi 1.6 benötigt!
aus: https://guide.jtl-software.de/jtl-s...ionen/von-jtl-shop-4-auf-jtl-shop-5-upgraden/
Jo, Wawi 1.6 gibts noch nicht? :D

Das ist besonders:

Ich verwende einen NGINX als Reverse-Proxy vor meinem Apache. Der NGINX reicht die Anfragen aber ganz normal an den Apache durch - klappt ja wie gesagt auch überall (außer beim Sync eben).


Hat jemand eine Idee, wie ich das Problem weiter eingrenzen kann? Weiß jemand, wie die WAWI den Shop verifiziert?
Hab solange auf die 4er Version zurückgerollt.

Liebe Grüße und vielen Dank für jede Hilfe!

Lukas
 

dkzg

Aktives Mitglied
31. August 2013
23
4
Kümmersbruck
die .htaccess braucht man nicht mehr wenn man nginx nutzt. ABER! die Einstellungen der .htaccess müssen in den nginx.config drin sein.

Hab da auch ein Wochenende gebraucht bis es funktioniert hat. Nginx wird Seitens JTL wohl noch nicht offiziell unterstützt
 

deutschevita

Aktives Mitglied
7. November 2015
46
5
Hallo @iason33
vielen Dank für deine Antwort. Stimmt, das bräuchte man nicht. Allerdings verwende ich NGINX nur als Reverse-Proxy in meinem dockerized Setup. Daher spielt das keine Rolle.
Meinen Fehler habe ich mittlerweile gefunden. Es sind - wie so oft - die Kleinigkeiten: Ich hatte einne Fehler in meiner .gitignore und daher sind Änderungen an meiner Config nicht übernommen worden.
Es war irreführend für mich, dass die mytest.php mittlerweile leer ist. Das ändert am Verhalten der URL (!) nichts, denn es wird ab Shop 5 eben einfach redirected. Muss man eben genau hinschauen! :)
Danke für deine Hilfe und deine Zeit jedenfalls.
Vielleicht stolpert ja mal noch jemand drüber.
Liebe Grüße!
 

volvisti

Sehr aktives Mitglied
18. Juli 2017
256
28
Hallo zusammen,
ich hänge mich hier mal ran.
Hatte einen testweise laufenden shop4 in meinem webspace installiert.

Da ich damit, außer ein bisschen rumzuspielen nichts gemacht hatte, dachte ich mir, lösche den Verzeichnisinhalt und installiere Shop5 neu
Die Installation ist auch sauber verlaufen und der Shop ist grundsätzlich über den Browser erreichbar. (shop.mailing-werkstatt.de)
Allerdings nur die Startseite.
Beim Versuch z.B. das Impressum aufzurufen, erscheint ein 500-er Fehler.
In der .htaccess habe ich die "Anpassung 2" im Ursprung gelassen. Der Shop soll ja nicht über www.mailing-werkstatt.de erreichbar sein.


Außserdem wird mir beim Versuch den Shop an die Wawi anzubinden angezeigt, dass die URL nicht auf einen gültigen Shop verweist.

Ich verstehe nicht so ganz wo mein Fehler ist.

Freue mich über jeden Ansatz, der mich näher ans Ziel bringt.
 
Zuletzt bearbeitet:
Ähnliche Themen
Titel Forum Antworten Datum
Keine Verbindung von Wawi zum Shop nach Upgrade Upgrade JTL-Shop4 auf JTL-Shop5 1
Keine Verbindung Wawi zum Shop Einrichtung JTL-Shop5 1
Beantwortet Wawi 1.5.36.2 JTL SHOP 5.0.3 keine Verbindung Einrichtung JTL-Shop5 1
Neu Dies ist keine sichere Verbindung Betrieb / Pflege von JTL-Shop 14
Neu Rechnungsvorlagen: Keine Vorschau möglich. Keine Vorlage gefunden. User helfen Usern - Fragen zu JTL-Wawi 0
Neu Sendet Amazon keine Versandmails mehr??? Smalltalk 0
Beantwortet (erledigt) keine Übertragung von Artikeln Onlineshop-Anbindung 1
Neu Attribut "keine Preissuchmaschine" bzw verschiedene Preissuchmaschinen steuern Allgemeine Fragen zu JTL-Shop 3
Neu Fehlermeldung: Ameise - Die Sequenz enthält keine Elemente JTL-Ameise - Fehler und Bugs 3
Neu Woocomerce Shop Ablgeich - keine Daten im Shop WooCommerce-Connector 0
Neu warum kann ich aus variationen keine varkombis erstellen? User helfen Usern - Fragen zu JTL-Wawi 5
Neu Ebay Aktualisierung - Keine Kategorien vorhanden eBay-Anbindung - Fehler und Bugs 4
Neu Bei JTL SHOP5 Installation - Keine config.JTL-Shop.ini.php gefunden / 500 - Internal Server Error Installation / Updates von JTL-Shop 3
Neu Kunde bekommt keine Sendungsbenachrichtigung Arbeitsabläufe in JTL-Wawi 6
Neu Kann keine Sonderpreise eingeben JTL-Wawi - Fehler und Bugs 1
Neu DRINGEND: nach update auf jtl5 (Hosting!) keine Plugins installierbar Plugins für JTL-Shop 3
Neu Newsletterempfänger keine Kundengruppe zugewiesen Betrieb / Pflege von JTL-Shop 0
Neu Nach update auf 5.1. lassen sich keine PlugIns mehr installieren Plugins für JTL-Shop 5
Neu Keine Daten in der Druckvorschau User helfen Usern - Fragen zu JTL-Wawi 3
Beantwortet Gewünschte Variation und/oder Variationswert sind nicht beim Vaterartikel vorhanden. #Erstelle keine Variationskombination# JTL-Ameise - Fehler und Bugs 2
Neu Attribut "keine Preissuchmaschinen" bei Google Shopping Plugin Onlineshop-Anbindung 0
Neu Track & Trace Problem in der WaWi - keine gültige Lizenz User helfen Usern - Fragen zu JTL-Wawi 1
Neu Gibt es keine "eigene Felder" für Vorgänge wie Angebot, Auftrag, Rechnung etc.? Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Keine Artikeldaten an Shopware übermitteln? Nur Bestellungen und Bestände Shopware-Connector 0
Keine Bestellbestätigung und PW-Anforderungsmails an Kunden Upgrade JTL-Shop4 auf JTL-Shop5 9
Neu Newsletter Standardvorlage findet keine Artikel, Kategorien, Hersteller JTL-Shop - Fehler und Bugs 0
In Bearbeitung SUNMI POS;: Keine Reaktion mehr des Touchscreens JTL-POS - Fehler und Bugs 1
Upgrade 4.06 -> 5.1.1 - Keine Auswahl bei Varkombis möglich Upgrade JTL-Shop4 auf JTL-Shop5 2
Neu Worker arbeitet, aber keine Aufträge im Wawi JTL-Wawi - Fehler und Bugs 16
Neu Keine Auswahl eindimensionale Variationen? JTL-Shop - Fehler und Bugs 2
Neu JTL Shop 5.0.1 zeigt Update Papyal auf 2.1.0 - reagiert aber nicht und keine Abwicklung mehr möglich?! JTL-Shop - Fehler und Bugs 16
Neu bestellabschluss.php=i trackt keine Conversion mehr JTL-Shop - Fehler und Bugs 1
Neu Keine Variationen ab Wawi Version 1.6 erlaubt Arbeitsabläufe in JTL-Wawi 6
Neu DHL Express GWS - keine Übertragung der Kundentelefonnummer JTL-ShippingLabels - Fehler und Bugs 0
Gelöst Keine Etiketten Hermes HSI - 4118 Gelöste Themen in diesem Bereich 1
In Bearbeitung Keine Minusbuchung und kein "Versand" nach Zahlung Allgemeine Fragen zu JTL-POS 5
Neu Keine Ausgabe von Skonto Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 5
Neu Shop 5 Installation Fehler Keine config.JTL-Shop.ini.php gefunden. JTL-Shop - Fehler und Bugs 2
Neu Keine Lieferzeiten im Shop | JTL kann keine Lieferzeiten an Woocommerce übertragen und überschreibt auch jede Änderung im backend von Woocommerce WooCommerce-Connector 2
Neu Immer noch keine einfache Preisübernahme der in der Wawi kalkulierten Preise eBay-Anbindung - Ideen, Lob und Kritik 0
Neu Jtl druckt keine versandetiketten mehr User helfen Usern - Fragen zu JTL-Wawi 3
Neu Bekomme keine Mail mit dem Passwort Einrichtung und Installation von JTL-eazyAuction 1
Neu Amazon VCS Light es werden keine Rechnungen erzeugt. Amazon-Anbindung - Fehler und Bugs 0
Gelöst Workflow KEINE Rechnung erstellen JTL-Workflows - Ideen, Lob und Kritik 5
Neu Google Shopping Export berücksichtigt Attribut "keine preissuchmaschinen" nicht mehr Plugins für JTL-Shop 2
Neu JTL-Shop 5 - Video Portlet Keine Anzeige JTL-Shop - Fehler und Bugs 2
Neu Trotz Rechnung keine Warenausgangsbuchung möglich? Gelöste Themen in diesem Bereich 19
Neu Kann keine neue Produktseite erstellen Amazon-Lister - Ideen, Lob und Kritik 1
Gelöst Keine Etiketten weder DHL noch DPD Shipping Status-Seite öffnet nicht Gelöste Themen in diesem Bereich 22
Neu Ebay: Es werden keine Aufträge mehr abgeholt eBay-Anbindung - Fehler und Bugs 16

Ähnliche Themen