Neu Formulareditor: Bug beim Entfernen von Projektbausteinen [Wawi 1.6.36.0]

SLiPCoR

Aktives Mitglied
14. März 2016
45
8
Hallo zusammen!

TL;DR:

1) Kann man Projektbausteine löschen? Ich meine diese die man beim Importieren und beim Anlegen von Designs automatisch mit angelegt bekommt, wenn man keine bestehenden auswählt. Diese sind nicht in den Vorlagensets auswählbar und im Formulareditor nicht löschbar.

2)
Projektbausteine aus einer Vorlage zu entfernen, kann dazu führen, dass Benutzervariablen verschwinden UND dass die Ebenen der Vorlage (mit Inhalten) zumindest bis zum Schließen erhalten bleiben. Ich bin mir nicht sicher, was das verursacht, da ich das Gefühl habe dass meine Bausteine komplett kaputt sind und/oder das durch Fehler in den Variablen verursacht wird.

-------
Story Time :)

Ich habe vorhin im 1.6.35.2 versucht, meine Projektbausteine aufzuräumen und dabei einige Probleme gehabt. Habe nun mal auf 1.6.36.0 geupdatet, in der Hoffnung dass es gefixt wurde, aber da sind die Probleme leider immer noch da.

Erstmal die generelle Frage, kann es sein, dass Projektbausteine *nicht* gelöscht werden können? Ich meine jetzt Projektbausteine, die beim Erstellen jeder Vorlage automatisch erstellt werden (es sei denn man wählt bestehende Bausteine aus, aber das habe ich erst beim dritten Mal verstanden was das eigentlich ist), und diese Bausteine sind nicht in den Vorlagensets aufzufinden. Wo verstecken sie sich, falls ich sie irgendwo löschen kann? In der Formularverwaltung kann ich nur neue erstellen und bestehende zu meinem Formular (oder zu Bausteinen) hinzufügen. Es wäre ja irgendwie sinnvoll, wenn diese bei dem jeweiligen Vorgangstyp drunter wären. Sind sie aber nicht, ist das eine Einstellungssache?

Wie auch immer, das führte natürlich bei mir zu sehr vielen Bausteinen die ich nicht mehr benötige. Ich würde diese gerne weg bekommen, damit ich nicht aus Versehen diese zu meinem Formular hinzufüge. Warum? Ganz einfach:

Ich habe meine Bausteine dummerweise seit Jahren in Benutzung und sehr ähnlich benannt wir ich sie jetzt auch nutze. "Mit Logo" und "Ohne Logo". Beim Testen vorhin hinzugefügt habe ich dann wohl eine alte Formular-Version, denn nach neu Öffnen der Vorlage bekam ich den Fehler, dass unbekannte Variablen drin sind. Diese waren von der alten Formular-Logik, die deutsche Variablennamen hatte.

Dann habe ich versucht, den Baustein (aus dem Formular) zu entfernen, dadurch ging "der Baustein" aus der Liste weg, aber dessen Elemente hingen wohl noch auf meinem Beleg drauf, denn die Fehler blieben bestehen. Dazu kommt noch, dass nach dem Entfernen eines meiner Bausteine (weiß grad nicht welcher das verursacht hat) plötzlich alle meine Benutzervariablen weg waren. Selbst eine wie @FontSize, die ist doch im Standard auch drin. Das muss doch ein Bug sein?

Wie dem auch sei, ich wäre sehr dankbar über einen Fingerzeig, falls es irgendwo eine Möglichkeit gibt, die Projektbausteine zu entfernen. Ich bin mir sicher ich brauche die alten deutschen Dinger nicht mehr, sie stiften nur Verwirrung. Ich werde sie jetzt erst einmal umbenennen, falls das noch geht, damit ich sie nicht mehr aus Versehen benutze.

Dann sollte man mal nach schauen, warum Benutzervariablen verschwinden, eventuell in Verbindung mit Skriptfehlern im Baustein, den man entfernt. Dadurch werden anscheinend Elemente in die aktuelle Vorlage kopiert anstatt sie weg zu nehmen. Ob das nun nur ein visueller Bug ist oder nicht habe ich nicht getestet. Fest steht, dass die Fehler der alten Variable auf jeden Fall noch kamen, als ich den Baustein angeblich raus hatte.


Vielen Dank für eventuelle Mühen :)

MfG

SLiPCoR
 
Zuletzt bearbeitet:

SLiPCoR

Aktives Mitglied
14. März 2016
45
8
Ich muss mir hier erstmal selber antworten da ich nicht weiss was ich nun machen soll.

1) DIe Projektbausteine räumen sich selber auf. Was ich da gesehen habe und was Projektbaustein genannt wird, sind sowohl die Vorlagen als auch die unter-Projektbausteine. Alles wird da zum Einfügen angeboten. Ich habe also wahrscheinlich eine komplette Vorlage nochmal als Baustein hinzugefügt, ohne das zu wollen.

2) Der Variablen-Fehler könnte durch ein "Export"-Formular kommen, was ich gar nicht bearbeiten kann, aber unter Wawi 1.5 vor Ewigkeiten importieren konnte. Wahrscheinlich schießt der Import eines CSV-Formulars hier die Darstellung komplett kaputt oder so.

Im Prinzip denke ich, ist das hier erledigt. Ich finde es nur sehr seltsam, dass die generell Vorlagen (Bei mir sind es verschiedene Vorlagen für Druck, Mail, Speichern) in anderen Formularen als Baustein angeboten werden, und ich dachte ich habe 8 alte Versionen meines Bausteins, es sind aber alles aktive benutzte Bausteine UND Formulare.

Kann das zu? Ist es ein Bug? Ist es MEIN Bug? Keine Ahnung.

🙈
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Bug Gelöst: ZIELVERSION develop-1.7 JTL-Wawi - Fehler und Bugs 6
Neu Bug bei Auftragszahlung über LS-POS seit Wawi 1.6 Fragen rund um LS-POS 2
Neu Nova Template Product Stream Slider Bug JTL-Shop - Fehler und Bugs 3
PROBLEM/BUG bei Auftrag Übernahme in die JTL- POS JTL-Wawi 1.6 3
Neu Bug Syntaxprüfung Exportformate JTL-Shop - Fehler und Bugs 0
Neu Nach einem Upselling Verkauf wurden nicht alle Produkte in die WaWi übermittelt, ein bekannter Bug? Shopify-Connector 0
Neu BUG? Nicht erkannten doppelten Eintrag Schnittstellen Import / Export 0
Neu BUG: Sprachwechsel CMS wiedermal unzuverlässig JTL-Shop - Fehler und Bugs 0
Neu Minimaler Bug im Dashboard. Gruppierung Zeitbereich wird nur im Dashboard nicht korrekt angezeigt JTL-Wawi - Fehler und Bugs 0
In Bearbeitung JTL-POS v. 1.0.6.2 Bug: Artikel wird nach Eingabe der EAN 2x zum Bon hinzugefügt JTL-POS - Fehler und Bugs 5
Neu Workflow Markierung bei Lieferscheine - Bug JTL-Wawi - Fehler und Bugs 0
Neu Details zur Versandeinstellungsautomatisierung beim Lieferversprechen User helfen Usern - Fragen zu JTL-Wawi 0
1.6.39.0: Deadlocks beim Ausliefern JTL-Wawi 1.6 1
Neu Fehler beim Bestellvorgang JTL-Shop - Fehler und Bugs 2
JTL Wawi 1.6 Auftrag Splitten beim Auf die Pickliste packen JTL-Wawi 1.6 0
HILFE PICKLISTE WIRD GEDRUCKT BEIM AUSLIEFERN JTL-Wawi 1.6 1
Neu Fehler beim Export: Deprecated: JTL\Catalog\Currency: getter should be used to get cISO in /var/www/vhosts/ JTL-Shop - Fehler und Bugs 0
Fehler beim Update JTL-Wawi 1.6 0
Neu Probleme beim Uk-Export - Zollinhaltserklärung CN23 veraltet? Arbeitsabläufe in JTL-Wawi 2
Neu Gratisbeigabe beim Kauf bestimmter Artikel Allgemeine Fragen zu JTL-Shop 0
Neu Beim Hochladen wird die Steuerklasse auf 0 gesetzt! Gambio-Connector 5
Neu Problem / Fehler beim Update von JTL Connector 2.2.5.3 auf 2.13.0 (Shopware 5.5.10) Shopware-Connector 1
Neu WAWI 1.6.38.2: Skontosatz geht beim Erstellen der Rechnung verloren JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim Shopify Abgleich Shopify-Connector 0
Neu Fehler beim senden von Rechnungen per Mail JTL-Wawi - Fehler und Bugs 1
Kopf & Fußzeile sind verschwunden bei der Rechnungsvorlage beim Drucken JTL-Wawi 1.6 1
Neu Fehler beim Bearbeiten von Vorlagen Bausteinen JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim Abgleich mit Shopware 6.4.11.1 Onlineshop-Anbindung 3
Neu Wawi 1.6 / Kommunikation aus Wawi wird beim Lieferanten (in JTL wawi) nicht abgelegt JTL-Wawi - Fehler und Bugs 2
Neu Probleme beim Update auf 1.6 - Datenbank Fehler? Ideen zur Lösung? JTL-Wawi 1.6 1
MwSt. beim Versand JTL-Wawi 1.6 6
Neu (WooCommerce) JTL Connector Aufträge lassen sich nicht bearbeiten "Fehler beim MARS-Batch" User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim heutigen Update von 1.6.38.1 auf 1.6.38.2 Installation von JTL-Wawi 1
Beantwortet JTL Wawi reagiert nicht mehr beim Klick auf "VCS Rechnungsduplikate" JTL-Wawi - Fehler und Bugs 2
In Bearbeitung Wawi stürzt ab beim markieren in Listen JTL-Wawi 1.6 3
Problem beim Importieren neuer Kategorien über Ameise - Kategorien Level und Interner Schlüssel gesetzt JTL-Wawi 1.6 4
Neu Individuelle Kundennachricht beim Angebot mitschicken User helfen Usern - Fragen zu JTL-Wawi 2
Neu Nichtgelieferte/Defekte Waren beim Wareneingang vermerken Arbeitsabläufe in JTL-Wawi 3
Neu Fehler beim Speichern der Daten für den Verkaufskanal-PrestaShop-JTL Wawi 1.6 PrestaShop-Connector 0
Neu Kritischer Fehler beim Abgleich mit dem Shop WooCommerce-Connector 3
Neu Probleme mit Ameise beim Artikelimport / Artikelaktualisierung und Lieferantenartikeln (insbes. mit Dropshipping + VPE) JTL-Ameise - Fehler und Bugs 22
Issue angelegt [WAWI-62034] Fehlermeldungen beim Anlegen neuer Produktionsartikel JTL-Plan&Produce - Fehler und Bugs 7
Neu Wie vorgehen beim Connector Update? Modified eCommerce-Connector 2
Neu Probleme beim Verbinden mit SQL Server von Arbeitsplatzrechner Installation von JTL-Wawi 18
Neu Puffer beim Verkauf in JTL POS automatisch anpassen User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung Fehler beim Kassiervorgang / Kundin will Geld per Üwerweisung / Wie kann man das anstellen? Allgemeine Fragen zu JTL-POS 3
Neu Wareneingang - Denkfehler? - Artikel wird Stückweise beim Hersteller bestellt - Soll Paarweise eingebucht werden? Arbeitsabläufe in JTL-Wawi 9
Neu Kategorie beim Aufruf immer anzeigen, auch wenn nur 1 Artikel enthalten ist Allgemeine Fragen zu JTL-Shop 2
Neu Fehler beim Online-Abgleich Onlineshop-Anbindung 0
Neu [modified shop] plötzlich Fehler beim Shopabgleich - Artikel einstellen nicht möglich Modified eCommerce-Connector 3

Ähnliche Themen