Neu Fehler im Theme Editor nach Shop-Update von 4.06.11 auf 4.06.14 und Editor-Update

liquid

Gut bekanntes Mitglied
3. April 2015
209
14
Bremen
#1
Hallo zusammen,nachdem ich meinen Shop von der Version 4.06.11 auf 4.06.14 upgedatet habe, compiliert der Theme-Editor nicht mehr (ebenfalls auf aktuelle Version upgedatet). Es erscheint stets folgende Fehlermeldung:

variable @fa-font-path is undefined in file /"Pfad zum Shoproot"/templates/Evo/themes/base/less/font-awesome/path.less in path.less on line 6, column 12 4| @font-face { 5| font-family: 'FontAwesome'; 6| src: url('@{fa-font-path}/fontawesome-webfont.eot?v=@{fa-version}'); ...

Als ich vor einigen Stunden damit gearbeitet hatte /vor dem Update), funktionierte noch alles. Komisch ist, dass die path.less jedoch im Paket gar nicht upgedatet wurde.

Hat jemand eine Idee, wo sich da der Wurm versteckt?

Gruß
Ingo
 

tbrenner

Neues Mitglied
5. September 2019
16
0
#3
Ich habe das Problem ohne ChildTemplate ---> siehe meinen Post
Gibts hier ne Lösung?
 

Inge

Aktives Mitglied
21. Juni 2014
67
8
Bad Kissingen
#4
Hatte das Problem auch nach Update auf Build 14. Ist nen JTL Bug. Hier sieht man auch, dass die ganze Q&A bei JTL kein Child-Template einsetzt, weil bei einem einzigen Compile-Check wäre der Fehler gleich aufgeflogen.
Da wir aber eh Fonts Awesome 5 "Pro" einsetzen, haben wir die base.less sowieso angepasst und deren FontAwesome gleich wieder komplett ersetzt, somit war der Fehler auch wieder vom Tisch. Schade, dass da überhaupt dran gefummelt wurde.
 

Arthur

Gut bekanntes Mitglied
5. März 2014
266
2
#5
Wäre schön wenn auch jemand schreiben würde, wie dieser BUG zu beheben ist.
Danke!