Neu Falsche Preise in Var. Kombi Artikeln

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Philip Z

Neues Mitglied
25. Februar 2020
19
1
Hallo Zusammen!

Ich habe ein merkwürdiges Problem bei Händler Preisen in den Var. Kombi Artikeln. Im Artikelstammblatt gibt es drei Preis- bzw. Kundengruppen, Endkunde, Gast und Händler, siehe Artikelstammblatt.jpg
Der JTL Reiter zeigt die Hauptpreise und der Reiter "glamotti.com" für den Shop ebenfalls die richtigen Preise. (Artikelstammblatt2.jpg)
Nun ist es aber leider so, das links unten unter dem Inforeiter Preise alle Gruppen (in Grau) den selben Preis ausweisen (kundengruppenpreise..jpg)
Leider wird so immer ein falscher Händlerpreis an den Shop übermittelt.

Versionen:
JTL 1.5.14.4
Connector 1.9.0.2
B2B Market 1.0.5
Woocommerce 4.0.1

Wie können wir das Problem lösen?
 

Anhänge

Rico Giesler

Offizieller Servicepartner
SPBanner
10. Mai 2017
13.213
1.386
In deinem letzten Bild ist die Preisanpassung zu sehen, aber die ist für die Plattform Wawi ausgewählt...
Wenn dies nur ein zufälliges Bild sein sollte und bei allen Produkten tatsächlich so ist wie von dir beschrieben, dann bitte wenn möglich ein Supportticket erstellen.
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
4.287
571
Da das Thema im Bereich Ameise erstellt wurde gehe ich davon aus, dass du die Preise auch mit der Ameise importiert hast? Dann stell bitte sicher, dass Du die Kundengruppenpreise nicht nur für die Wawi importiert hast. Wenn Du sicher bist, dass Du alles richtig eingestellt hast, dann bitte - wie Rico bereits schrieb - das Ticket aufmachen. Sende bitte deine CSV und die Importvorlage im Ticket gleich mit, damit die Kollegen dann direkt prüfen können.

Falls Du den Import mehrfach durchgeführt hast und sich nichts ändert, achte bitte auch auf den ausgegebenen Bericht. Es kann sein, dass da so etwas steht wie, "... hat sich nicht geändert, daher wird der Datensatz übergangen". Das liegt dann daran, dass du diese CSV unverändert bereits importiert hattest. Du musst die Einstellung "Nur geänderte updaten" dann umstellen.
 

Philip Z

Neues Mitglied
25. Februar 2020
19
1
Danke Euch für die schnelle Reaktion!
Sorry, ich habe mich im Bereich Ameise vertan!
Die Artikel sind alle manuell angelegt worden und zeigen im Artikelstammblatt die korrekten Preise je Kundengruppe, aber wie im letzten Screen zu sehen ist, erscheint bei Händlern ebenfalls der Endkundenpreis und wird so auch an den Connector übergeben. Ich versuche mal ein Ticket zu erstellen.
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
4.287
571
Kannst Du mich bitte mal privat anschreiben und mir dort Deine Teamviewer-Zugangsdaten geben? Dann kann ich kurz schauen, ob ich auf die Schnelle was finde.

Edit: Da scheinst du die Antwort nicht mehr gelesen zu haben. Machen wir es so: Schreib mich per PM an und wir vereinbaren einen Termin, an dem ich mich mal aufschalten kann. Alternativ kannst Du auch ein Supportticket erstellen. Die Kollegen würden sich das dann auch genauer ansehen.
 
Zuletzt bearbeitet:

Philip Z

Neues Mitglied
25. Februar 2020
19
1
Das ist super nett von Dir!

Das Preisproblem haben wir nun gelöst. Die Einstellung "Preis aus Registerkarte JTL WaWi nutzen" zeigt zwar den richtigen Preis, aber er wird nicht übernommen.
ArtikelstammblattA137.jpg
Haben jetzt einfach in das rosa Feld Indiv. VK-Brutto zusätzlich den Wert eingesetzt.

Tja, nächstes Problem...
Leider übernimmt Woocommerce nun die variablen Produkte nur noch als einfaches Produkt.
Merkmale und Variationen werden aber übergeben, nur werden sie bei dem einfachem Produkt nicht ausgegeben.
Setzen jetzt nochmal ganz neu auf...

Beste Grüße!
 

Philip Z

Neues Mitglied
25. Februar 2020
19
1
Hallo, hier ein Paar Schritte von unserem Entwickler:
  1. WaWi neu installiert auf einen frisch installierten Windowsrechner
  2. Wordpress auf anderen Webserver installiert
  3. Woo Commerce installiert
  4. JTL Connector installiert
  5. WaWi mit Shop verbunden
  6. B2B Market Plugin installiert
  7. Kundengruppen angelegt nach Anleitung
  8. Produkt in WaWi angelegt
  9. Var.-Kombis erstellt
  10. Kategorie und Produkt zum Shop übertragen
Ergebnis (negativ):
  1. Produkt wurde im Shop nur als „Einfaches Produkt“ angelegt.
  2. Kundengruppen Preise wurden nicht übermittelt
Neuer Versuch:
  1. B2B Market deinstalliert
  2. Connector neu konfiguriert, nur mit der Standardkundengruppe
  3. Produkt neu übertragen
Ergebnis (positiv):
  1. Produkt wurde als „Variables Produkt“ angelegt
  2. Endkundenpreis bzw. Standardpreis wurde korrekt übermittelt
Weiterer Versuch (teils positiv):
  1. B2B Market wieder installiert
  2. Kundengruppe „Händler“ neu angelegt
  3. Connector neu konfiguriert (Händler hinzugefügt).
  4. Connector „Komplettabgleich - Preise“ eingestellt
  5. Die Kundengruppenpreise wurde nachgetragen
Nächste Maßnahme:

Nachdem das alles so geklappt hat, hab ich einen neue Artikel angelegt und Var.-Kombinationen erstellt und die Kundengruppenpreise gesetzt. Danach hab ich den Artikel mit der „letzten Stand Konfiguration“ in den Shop übertragen.

Das Ergebnis war leider wieder negativ. Das Produkt wurde als „Einfaches Produkt“ angelegt und die Kundengruppenpreise fehlten. Alle Preise.

Also hab ich mir den Artikel im Backend des Shops angeschaut und diesen dort auf „Variables Produkt“ gestellt.
Danach waren sofort im Backend alle Var.-Kombis mit Bestand zu sehen, nur die Preise nicht.

Dann bin ich wieder in den Connector:
  1. Komplettabgleich - Preise
  2. Onlineshop abgleich
Ergebnis:
  1. Nun wurde die Preise nachgetragen und das Produkt scheint komplett im Shop angelegt zu sein.
Also Endergebnis:

Wenn ich einen Artikel komplett anlegen möchte, dann muss ich leider immer den neuen Artikel einmal im Backend des Shops das neue Produkt auf „Variables Produkt“ stellen, danach „Komplettabgleich - Preise“ stellen, und die Preise nochmal komplett übertragen.

Wordpress, WooCommerce, JTL-Connector und B2B Market sind alle auf den neusten Stand.

Es hatte mit Wordpress 5.3, einen älteren Connector und dem letzten B2B Market Plugin auch ohne funktioniert.

Allerdings bezweifle ich das es an unseren Eingaben oder falschen Konfigurationen liegt, denn wie gesagt… aus lauter Verzweifelung haben wir JTL auf einem neuen Rechner komplett neu installiert, sowie Wordpress mit WooCommerce und den Plugins. Also alles Standard.

LG
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
4.287
571
Also mir macht hier schon die Tatsache Sorge, dass ihr Sachen im Shop-Backend an den Artikeln umstellt. Bitte wende Dich dazu besser an den Connector-Bereich. Soweit mir bekannt ist darf sowas nicht mehr durchgeführt werden, nachdem die Wawi angebunden wurde, da sonst Inkonsistenzen drohen. Im Zweifelsfall müssen dann alle Artikel einmal aus dem Shop entfernt und per Wawi wieder an den Shop übermittelt werden. Das kann im Übrigen hier auch bereits die Ursache sein.
 

Philip Z

Neues Mitglied
25. Februar 2020
19
1
Hier die Antwort von unserem Entwickler:
Hallo Enrico,

genau deshalb haben wir ja auf einen neuen PC JTL installiert,
ganz neu Wordpress und WooCommerce,
JTL-Connector und B2B Market.

Das hatten wir uns ja schon gedacht das wir durch rumprobieren da was zerschossen haben.

Bei dem ganzen Neuinstallationen war dann ja alles frisch und wir haben einen Testartikel,
ganz neu hochgeladen. Es kam dann der selbe Fehler.

Der Artikel wurde nur als „Einfaches Produkt“ angelegt,
Die Datensätze für die Var.-Kombis waren aber da.

Die Kundengruppen-Preise fehlten.
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu "Ab Preise" bei Artikeln ohne Vaterartikel falsche Anzeige Allgemeine Fragen zu JTL-Shop 4
Neu Ameise Warnungen - falsche Formatierung JTL-Ameise - Fehler und Bugs 1
Neu Falsche Anrede in den Formularen ? Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 14
Offen Workflow DATEI SCHREIBEN als Batch - Fehler/falsche Formatierung? JTL-Workflows - Fehler und Bugs 6
Gelöst Falsche Angabe der Lieferzeit Gelöste Themen in diesem Bereich 8
Neu Meta Discription falsche Zuordnung? Shopware-Connector 15
Offen WAWI berechnet Versandkosten falsch und übernimmt falsche Paypalsummen WooCommerce-Connector 1
In Bearbeitung Probleme mit dem ebay-Abgleich - "Die Eingabezeichenfolge hat das falsche Format" JTL-Wawi - Fehler und Bugs 6
In Bearbeitung [WAWI-45813] Workflow-Aktion "Auf Einkaufsliste" setzt falsche Bestellmenge 1.5.14.4 JTL-Workflows - Fehler und Bugs 2
Gelöst Sellxed Payrexx Plugin zeigt falsche Version an Gelöste Themen in diesem Bereich 3
Neu SQL Server hat einen logischen, konsistenzbasierten E/A-Fehler gefunden: Falsche Prüfsumme (erwartet: 0xddb6cd45; tatsächlich: 0x933cd14a). Gelöste Themen in diesem Bereich 1
Gelöst Rechnungskorrektur enthält falsche Angeben Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 4
Neu DRINGEND: Var.Kombi Artikel haben plötzlich falsche Artikelnummer Gelöste Themen in diesem Bereich 3
Neu Falsche Zeilenumbrüche im Retourenetikett (HTML) JTL-Wawi - Fehler und Bugs 0
Neu Preise erst nach Anmeldung per Funktionsattribut steuern? Betrieb / Pflege von JTL-Shop 3
Neu Anpassung der Preise per Ameise | Indiv. VK-Brutto fehlt User helfen Usern - Fragen zu JTL-Wawi 3
In Diskussion Woocommerce zeigt nur Netto-Preise an! WooCommerce-Connector 3
Neu SQL Abfrage Rechnungspositionen und Preise User helfen Usern - Fragen zu JTL-Wawi 0
Neu Stücklisten Preise in Netto ? Einrichtung von JTL-Shop 0
In Bearbeitung Kundengruppen Preise werden nicht übernommen Gambio-Connector 2
Neu DotLiquid Preise runden Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 5
Neu Preise werden online nicht mehr geändert Onlineshop-Anbindung 15
In Bearbeitung Kundenindividuelle Preise werden nicht übertragen - WAWI-47454 JTL-POS - Fehler und Bugs 2
Neu JTL Workflow Auftrag Preise anpassen User helfen Usern - Fragen zu JTL-Wawi 0
Offen POS ändert nicht die MW Steuer auf 16% / Preise ändern sich nicht in POS Allgemeine Fragen zu JTL-POS 3
Offen Wie bekommt man die Preise nach der Umstellung auf 16% in den Shop? PrestaShop-Connector 2
Neu Preise werden nicht übertragen Shopify-Connector 1
Neu Preise der Artikel Var. Kombis ändern User helfen Usern - Fragen zu JTL-Wawi 2
In Bearbeitung Kosmetik - Floating Button versperrt Sicht auf Preise JTL-POS - Fehler und Bugs 1
Neu Manuell geänderte Preise (Angebotspreise) automatisch beim Kunden hinterlegen JTL-Wawi - Ideen, Lob und Kritik 0
Neu Brutto / Netto Preise bei Kundengruppen User helfen Usern - Fragen zu JTL-Wawi 2
Neu Repricer senkt stetig die Preise JTL-Wawi - Fehler und Bugs 1
Neu Rechnungsvorlage EK Preise mit anzeigen User helfen Usern - Fragen zu JTL-Wawi 2
Neu Neues Plugin: Profi Preise - für Flächen- & Volumenberechnungen, prozentuale Aufpreise & eigene Formel Plugins für JTL-Shop 45
In Bearbeitung Fehler Brutto/Netto Preise | Woocommerce Option: Preise mit Steuern eingegeben wird von Wawi zurückgesetzt! WooCommerce-Connector 1
In Bearbeitung Ebay Preise eBay-Anbindung - Fehler und Bugs 1
Neu Preise im Shop bei 0% Ust. werden falsch angezeigt/berechnet. Gibt es eine Lösung? Allgemeine Fragen zu JTL-Shop 10
Neu JTL Shop 4.06 Var Kombis werden nicht geladen Allgemeine Fragen zu JTL-Shop 0
Gelöst Var.Kombis in Shopware werden nicht angezeigt Shopware-Connector 1
Neu manuell Bestand ändern bei Var.Kombis User helfen Usern - Fragen zu JTL-Wawi 5
Neu Stücklistenartikel aus Var. Kombi User helfen Usern - Fragen zu JTL-Wawi 1
Neu Druckprofil für Artikel-Etiketten für Artikel und Var.Kombis? User helfen Usern - Fragen zu JTL-Wawi 0
Ähnliche Themen