In Bearbeitung EC-Terminal Anbindung connection refused

beeblebrox_tm

Mitglied
31. Oktober 2019
9
3
Hallo,

wir haben vor kurzer Zeit das EC-Terminal gewechselt (CCV VX680) und kriegen das neue (Ingenico Desk/3500) nicht zum laufen. IP-Einstellungen (feste IPs), POS-Einstellungen, Portabfrage beim Anbieter (jeweils 5577), Modul im Kundencenter gebucht, POS-Meldungen - alles gecheckt, geprüft, abgeglichen (siehe screenshots). Nichts.
Sobald von JTL-POS etwas an das Terminal geht kommt die Meldung "connection refused" ohne nähere Informationen. Welche Ursachen führen zu dieser Fehlermeldung oder was kann ich noch versuchen?

JTL-POS EC-Terminal Fehler.pngJTL-POS EC-Terminal Einstellungen.pngJTL-POS EC-Terminal Router v2.pngJTL-POS EC-Terminal Meldungen.png


PS: Was hat eigentlich die tägliche Meldung "Manuelles Datum" zu bedeuten?

Grüße
 

Philipp K.

Moderator
Mitarbeiter
21. August 2018
359
194
Hückelhoven
Hallo @beeblebrox_tm

welchen Zahlungsanbieter nutzt du konkret? Auf Anhieb würde ich sagen, dass die Ports (5077) falsch sind. Ich meine mich zu erinnern, dass das aus Sicherheitsgründen zwingend zwei unterschiedliche sein müssten.

PS: Was hat eigentlich die tägliche Meldung "Manuelles Datum" zu bedeuten?
Da Manipulationsgefahr besteht, prüft JTL-POS bei jedem Start der App ob Datum und Zeit des Geräts manuell oder automatisch (via Internet) eingestellt wurden. In Deinem Fall weiß der Prüfer des Finanzamts dank dieser Meldung, dass er ganz genau hinsehen sollte... ;)

Beste Grüße

Philipp
 

beeblebrox_tm

Mitglied
31. Oktober 2019
9
3
Wir nutzen Payone. Die Ports sollen 5577 und 5578 sein. Bei einem aktuellen Telefonat wurde mir vom Techniker bestätigt dass das Terminal mit seiner ID im System auftaucht, d.h. das Gerät ist mit dem Server des Anbieters verbunden. Die Aussage lautete: Der Fehler kann demzufolge nur auf der Softwareseite liegen.

Vielleicht könnten sich Hardware- und Softwareanbieter mal direkt unterhalten. Oder kann ich etwas machen um die Problemlösung zu unterstützen? Langsam wird nämlich die Zeit eng, denn ich muss das alte Gerät bald abgeben.

Grüße
 

beeblebrox_tm

Mitglied
31. Oktober 2019
9
3
Hallo,

langsam brennt mir es unter den Fingernägeln. Das alte Gerät muss ich zurückschicken und das neue funktioniert nicht. Das kostet mich einen Haufen Geld. Ich brauche dringend Antworten und Lösungen.

Grüße
 

trummerjo

Aktives Mitglied
30. März 2016
96
24
Hallo beeblebrox_tm,

hast du
  1. das Terminal auf den Betriebsmodus OPI umgestellt?
  2. im Terminal unter Verbindungen
    1. Kasse eingehend: TCP/IP, IP: 0.0.0.0 Port 5577
    2. Kasse ausgehend: TCP/IP, IP: 0.0.0.0 Port 5578
eingestellt?
 

Philipp K.

Moderator
Mitarbeiter
21. August 2018
359
194
Hückelhoven
Hallo Dirk / @beeblebrox_tm,

Schau mal, in Deinem ersten Post sind die Ports gleich, beide 5077:
1592943736477.png

Darunter weiße ich Dich darauf hin. Du antwortest:
Wir nutzen Payone. Die Ports sollen 5577 und 5578 sein. Bei einem aktuellen Telefonat wurde mir vom Techniker bestätigt dass das Terminal mit seiner ID im System auftaucht, d.h. das Gerät ist mit dem Server des Anbieters verbunden. Die Aussage lautete: Der Fehler kann demzufolge nur auf der Softwareseite liegen.
"Die Ports sollen 5577 und 5578 sein." Ja sollen, aber hast Du die Ports in den Zahlungsart-Einstellungen von JTL-POS denn auch geändert? Darauf finde ich keinen konkreten Hinweis. In den folgenden Posts wird nur über die EInstellungen im Terminal gesprochen.

Die Verbindung ist ja da, "Connection refused" heißt "Verbindung abgelehnt" und nicht "Keine Verbindung". JTL-POS wird blockiert, was eben vermuten lässt dass die Ports nicht stimmen.

Viele Grüße,

Philipp
 

beeblebrox_tm

Mitglied
31. Oktober 2019
9
3
Hallo,

zwischen dem ersten Beitrag mit den Screenshots und dem, mit den vom Anbieter erfragten Daten, 5577 & 5578 liegen ja auch zwei Wochen. Natürlich haben wir das so eingestellt wie es gewünscht wurde. Deshalb ist ja langsam die Verzweiflung einigermaßen groß. Über solch einen leicht zu findenden Fehler wären wir ja froh!
Morgen muss eines der Geräte wieder zurück...

JTL-POS EC-Terminal Einstellungen-2.png
 

ofenheizer

Sehr aktives Mitglied
26. Oktober 2012
258
45
Vllt. liegt es ja auch am Emulator Bluestack, dass hier die Kommunikation nicht reibungslos funktioniert?
Evtl. ist ja irgendwo ein Handy vorhanden, um das man mit einem echten Android-Gerät zu testen.
 

Philipp K.

Moderator
Mitarbeiter
21. August 2018
359
194
Hückelhoven
Vllt. liegt es ja auch am Emulator Bluestack, dass hier die Kommunikation nicht reibungslos funktioniert?
Evtl. ist ja irgendwo ein Handy vorhanden, um das man mit einem echten Android-Gerät zu testen.
Danke @ofenheizer, das wäre auch mein nächster Vorschlag.

@beeblebrox_tm, Super, dass Du die Pins geändert hast. Wir haben schon des öfteren festgestellt, dass sich Emulatoren unter Windows anders verhalten als native Android Geräte. Deshalb raten wir auch von der produktiven Verwendung eines Emulators ab. Ihr könnt das mit dem Handy testen wie Ofenheizer schreibt, oder auch einen Ping-Test starten wie Janusch hier schreibt: https://forum.jtl-software.de/threads/opi-und-ingenico-connection-refused.125563/#post-686349

Ansonsten, evtl. liegt es auch daran: Hast Du das OPI-Modul im Kundencenter freigeschaltet?
Anmerkung 2020-06-25 131249.jpg

Viele Grüße, Philipp
 

Sousa

Mitglied
20. Januar 2020
13
2
Also ich habe ein CCV Fly und damit geht es auch nicht. Habe mit dem Anbieter alles eingestellt, wie hier beschrieben und auch das OPI Modul aktiviert. Der anbieter bestätigt die Anmeldung bei sich. Man merkt das die eingegebenen Daten in JTL-POS stimmen Müssen (Port: 20007,20009+ip) da er beim Kassieren im Hinweis: Sende login -> Sende Zahlungsaufforderung anzeigt. Dann bleibt es aber stecken bei Sende Zahlungsaufforderung. Am Terminal selbst tut sich nix... Hier scheint es ein Bug in eurer OPi Schnittstelle zu geben!
 
Ähnliche Themen
Titel Forum Antworten Datum
Gelöst POS mit SumUp 3G terminal über bluetooth verbinden Gelöste Themen in diesem Bereich 6
Gelöst SUNMI T2 Terminal mit Jtl Pos Kassenapp ... Drucker nicht auffindbar JTL-POS - Fehler und Bugs 2
Neu MUNBYN Android pos Terminal 6.0 PDA/NFC Funktion Zebra-Scanner Arbeitsabläufe in JTL-Wawi 0
In Bearbeitung Kassenschnitt am Terminal drucken? Allgemeine Fragen zu JTL-POS 13
Neu JTL Shop5 - Wawi Anbindung Fehler Onlineshop-Anbindung 1
Neu PayPal Ratenzahlung Anbindung an JTL-Shop 4 User helfen Usern - Fragen zu JTL-Wawi 1
Neu Trotz Multishop keine zweite Shop-Anbindung Onlineshop-Anbindung 2
Umleitungsfehler beim Aufruf der Startseite - Keine WAWI-Anbindung möglich Einrichtung JTL-Shop5 0
In Diskussion Anbindung GLS Letterbox an die Wawi JTL-ShippingLabels - Ideen, Lob und Kritik 0
Neu [Biete] Paketdienstleister Anbindung - Packeta.de + weitere Dienstleistung, Jobs und Ähnliches 1
Gelöst TSE Anbindung TM-30 Fehler "TSE1_ERROR_SIG_ERROR" Einrichtung / Updates von JTL-POS 1
Neu Avocadostore Anbindung an JTL Wawi Schnittstellen Import / Export 0
Neu Otto market Anbindung Onlineshop-Anbindung 2
Neu Fehler bei erster Anbindung eBay-Anbindung - Fehler und Bugs 2
Neu Amazon Anbindung Marktplätze / Prime durch Verkäufer Amazon-Anbindung - Fehler und Bugs 0
Neu Product Feed Management - Anbindung von JTL WAWI über API? User helfen Usern - Fragen zu JTL-Wawi 1
Neu Kategorie Ebenen Beschränkung bei Anbindung an Onlineshops Starten mit JTL: Projektabwicklung & Migration 0
Neu Anbindung nicht möglich Shopify-Connector 7
Neu Problem mit der Anbindung des Connectors zu Shopify Shopify-Connector 10
In Diskussion POST.NL Anbindung JTL-ShippingLabels - Ideen, Lob und Kritik 1
Neu Onlineshop-Anbindung 2. Sprache "Englisch" kann nicht gesetzt werden WooCommerce-Connector 1
Neu Presta anbindung via Ameise Dienstleistung, Jobs und Ähnliches 0
Neu Gambio Onlineshop Anbindung Gambio-Connector 1
Neu Problem mit Shop Anbindung JTL-Wawi - Fehler und Bugs 0
Neu Outlook Anbindung Allgemeine Fragen zu JTL-Shop 1
Neu Wie ausgereift ist die Anbindung von Woocommerce WooCommerce-Connector 0
In Diskussion Anbindung an cargoboard? Speditionsversand aus der Wawi JTL-ShippingLabels - Ideen, Lob und Kritik 4
Neu eBay Anbindung eBay-Anbindung - Fehler und Bugs 3
Neu Fehlerhafte Anbindung zur Datenbank User helfen Usern - Fragen zu JTL-Wawi 1
Neu EA Anbindung mit mehr als 500.000 (Schwellenwert) Artikel Amazon-Anbindung - Ideen, Lob und Kritik 0
In Diskussion Anbindung Sendcloud JTL-ShippingLabels - Ideen, Lob und Kritik 3
Neu JTL-Wawi mit WooCommerce - Shop Anbindung Fehler wegen Spracheinstellung User helfen Usern - Fragen zu JTL-Wawi 2

Ähnliche Themen