Datenbank Import wie gehts??? Fehlermeldung

Papierhaus

Gut bekanntes Mitglied
21. Mai 2008
491
0
Hamburg
AW: Datenbank Import wie gehts??? Fehlermeldung

ja richtig, hatte beim kopieren vergessen die zeilen zusammenzufügen, gibt mir aber dennoch eine Fehlermeldung raus:

C:\>osql.exe -D eazy -U sa -P sa04jT14 -d master -Q "restore database mandant_2
from disk ='c:\sicherung20080305.bak' with replace, move 'eazybusiness' to 'C:\P
rogram Files (x86)\Microsoft SQL Server\MSSQL.1\MSSQL\Data\Mandant_2.MDF' , move
'eazybusiness_log' to 'C:\Program Files (x86)\Microsoft SQL Server\MSSQL.1\MSSQ
L\Data\Mandant_2_log.LDF' "
Meldung '3201', Ebene '16', Status '2', Server 'CT224\JTLWAWI', Zeile 1
Das Sicherungsmedium 'c:\sicherung20080305.bak' kann nicht geöffnet werden.
Betriebssystemfehler 5(Access is denied.).
Meldung '3013', Ebene '16', Status '1', Server 'CT224\JTLWAWI', Zeile 1
RESTORE DATABASE wird fehlerbedingt beendet.
 

Papierhaus

Gut bekanntes Mitglied
21. Mai 2008
491
0
Hamburg
AW: Datenbank Import wie gehts??? Fehlermeldung

Ja das ist momentan aber erst eine VServer Testumgebung, ich habe mich in der einzig für mich möglichen Weise angemeldet.
Da aber der Benutzer Administrator heißt, kann ich mir nicht vorstellen, das das Konto irgendwo eingeschränkt ist. Habe bisher auch keinen Bereich gefunden, in dem er gemeckert hat.
Gruß Stefan
 

Dealux-GmbH

Sehr aktives Mitglied
5. März 2007
8.676
7
Düsseldorf
AW: Datenbank Import wie gehts??? Fehlermeldung

Hast du mal versucht mit der rechten Maustaste die Eingabeaufforderung "als Administrator" zu starten?
 

Papierhaus

Gut bekanntes Mitglied
21. Mai 2008
491
0
Hamburg
AW: Datenbank Import wie gehts??? Fehlermeldung

muss mal doof nachfragen...
wie soll ich das machen??? wenn ich mit der rechten Maustaste auf Ausführen klicke, kommt die Auswahl Ausführen, im weiteren Verlauf gebe ich cmd ein und drücke auf Enter.
bin dann angemeldet als:

C:\Documents and Settings\Administrator>

Also denke ich, dass ich auch Admin bin.
 

a.preuss

Aktives Mitglied
11. August 2009
10
0
AW: Datenbank Import wie gehts??? Fehlermeldung

Ich habe fast das gleiche Problem.

Erstmal zu meinem Vorhaben:
Es liegen insgesamt 3 Kunden auf einer Instanz.
2 Kunden sollen auf einer neuen Instanz verschoben werden, sowie auf der alten instanz (sofern denn alles nachher richtig läuft) gelöscht werden.

Informationen zum Server:
Windows Server 2008
MSSQL 2005 Express
2 MSSQL Instanzen

Informationen über den Instanzen:
Instanz A mit 3 Mandanten (inkl. default)
- eazybusiness (Leer)
- Mandant_2 (Kunde1)
- Mandant_3 (Kunde 2)
- Mandant_4 (Kunde 3)
Verzeichniss:
C:\Program Files (x86)\Microsoft SQL Server\MSSQL.2\


Instanz B mit 2 Mandanten (inkl. default)
- eazybussiness (Leer, wird nie gebraucht)
- Mandant_2 (Leer, kommt Kunde1 hin)
- Mandant_3 (Leer, kommt Kunde3 hin)
Verzeichniss:
C:\Program Files (x86)\Microsoft SQL Server\MSSQL.3\

Habe bereits versucht direkt via WaWi die Backups (werden jede 3 Stunden von der alten Instanz angelegt) zu importieren. Ging anfangs auch, es kam danach aber ein Fehler, das die Datenbank beschädigt sei.

Jezt habe ich es via CMD versucht:
Zitat von Kopie des Mandanten_2 (Kunde1) vom Backup:
osql.exe -D dotbay -U sa -P ***Passwort*** -d master -Q "restore database Mandant_2 from disk='c:\MeinBackupName.bak' with replace, move 'Mandant_2' to 'C:\Program Files (x86)\Microsoft SQL Server\MSSQL.3\MSSQL\Data\Mandant_2.mdf', move 'Mandant_2_Log' to'C:\Program Files (x86)\Microsoft SQL Server\MSSQL.3\MSSQL\Data\Mandant_2_log.LDF'"

Folgende Fehlermeldung erscheint:
Zitat von Fehlermeldung nach eingabe:
Msg 3634, Level 16, State 1, Server ***Servername***, Line 1
The operating system returned the error '32(error not found)' while attempting
'RestoreContainer::ValidateTargetForCreation' on 'c:\Program Files
(x86)\Microsoft SQL Server\MSSQL.2\MSSQL\DATA\Mandant_2.mdf'.
Msg 3156, Level 16, State 8, Server ***Servername***, Line 1
File 'Mandant_4' cannot be restored to 'c:\Program Files (x86)\Microsoft SQL
Server\MSSQL.2\MSSQL\DATA\Mandant_2.mdf'. Use WITH MOVE to identify a valid
location for the file.
Msg 3634, Level 16, State 1, Server ***Servername***, Line 1
The operating system returned the error '32(error not found)' while attempting
'RestoreContainer::ValidateTargetForCreation' on 'c:\Program Files
(x86)\Microsoft SQL Server\MSSQL.2\MSSQL\DATA\Mandant_2_log.LDF'.
Msg 3156, Level 16, State 8, Server ***Servername***, Line 1
File 'Mandant_4_log' cannot be restored to 'c:\Program Files (x86)\Microsoft
SQL Server\MSSQL.2\MSSQL\DATA\Mandant_2_log.LDF'. Use WITH MOVE to identify a
valid location for the file.
Msg 3119, Level 16, State 1, Server ***Servername***, Line 1
Problems were identified while planning for the RESTORE statement. Previous
messages provide details.
Msg 3013, Level 16, State 1, Server ***Servername***, Line 1
RESTORE DATABASE is terminating abnormally.

[Grün-markierte Daten] = Servername sowie Passwörter (Aus Datenschutzrechtlichen Gründen will ich dies nicht gern bekanntgeben)
[Rot-markierte Daten] = Auch wenn ich im Statement angegeben habe, das er MSSQL.3 benutzen soll, macht er dort irgendetwas bei MSSQL.2, was mache ich hierbei falsch?


Hätte eventuell jemand eine Idee, wie ich mein Problem gelöst bekomme?
Habe bereits auch versucht die kompletten Verzeichnisse zu Kopieren, dann bräuchte ich leztendlich nurnoch die jeweiligen Mandanten aus einer anderen Instanz herauslöschen.
FUnktionierte aber leider nicht, die Neue Instanz ließ sich danach leider nicht mehr starten.

Noch eine etwas andere Frage:
Gibt es eine art "Multiclient"?
Da ich mit mehr als nur einer Instanz arbeiten werde, ist es abundzu etwas blöd, dauernd die ODBC-Verbindung zu wechseln sowie die Server-Daten immerwieder neu einzugeben.
Wäre es möglich von den Entwicklern, extra eine version anzufertigen, wo auch verschiedene Instanzen angewählt werden? Soetwas wäre ziemlich hilfreich.
 

Ähnliche Themen