Gelöst Connector übermittelt keine Produkte mehr

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

johannesress

Neues Mitglied
5. August 2020
4
0
Hallo,

wir haben für einen Kunden eine Wordpress/ WooCommerce Installation mit Anbindung an JTL Wawi erstellt und während der Entwicklungsphase lief alles prima. Nun wollten wir live gehen und der Kunde hat hierfür seinen korrekten Datenbestand nun komplett eingetragen und plötzlich funktioniert der Connector nicht mehr.

Kategorien, Einstellungen etc werden noch korrekt übertragen, aber sobald es zum Synchronisieren der Produkte kommt, erscheint nur eine Fehlermeldung - siehe Details.

Ich nehme an, es gibt irgend welche Inkompatibilitäten in den Produkten, aber wie finde ich heraus, wo ich suchen soll, oder was nicht passen könnte? Die Logs und Fehlermeldungen helfen hier - mir zumindest - nicht weiter.

Vielen Dank vorab für jegliche Unterstützung!
Johannes

Wawi-Version : 1.5.27.0
Wordpress-Version : 5.4.2
Connector-Version : 1.10.0

Fehler:
Exception: Der Remoteserver hat einen Fehler zurückgegeben: (403) Unzulässig.
Der Remoteserver hat einen Fehler zurückgegeben: (403) Unzulässig.
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei product.push: Der Remoteserver hat einen Fehler zurückgegeben: (403) Unzulässig.

Der Remoteserver hat einen Fehler zurückgegeben: (403) Unzulässig.

Response: <Empty>
Exception bei product.push: Der Remoteserver hat einen Fehler zurückgegeben: (403) Unzulässig.

Der Remoteserver hat einen Fehler zurückgegeben: (403) Unzulässig.

Response: <Empty>
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.yqyYCZFsuLB(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.uKrYCI49NpH(String , Object , Boolean , NetworkCredential )
bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.yqyYCZFsuLB(String , Object , Boolean , NetworkCredential )


Dateianhänge:
  • Wawi Abgleichlog
  • Connector Debug Logs als zip
 

Anhänge

Achim L.

Moderator
Mitarbeiter
3. Juli 2017
414
64
Hallo Johannes,

der Fehlercode 403 deutet auf fehlende Berechtigungen hin. Hinweise was dazu führt kannst du wahrscheinlich im PHP-Errorlog finden.
 

johannesress

Neues Mitglied
5. August 2020
4
0
Danke für das erste Feedback, aber wenn es an serverseitigen Berechtigungen liegt, wie kann es dann sein, dass Kategorien etc. korrekt übertragen werden und es erst bei den Produkten zu Problemen kommt?

Ich habe ein wenig in den Protokolldateien gewühlt und da folgendes gefunden, das mit Sicherheit dafür verantwortlich ist:

[client 87.123.203.0] ModSecurity: [file "/etc/httpd/conf/modsecurity.d/rules/tortix/modsec/10_asl_rules.conf"] [line "1093"] [id "350147"] [rev "155"] [msg "Atomicorp.com WAF Rules: Potentially Untrusted Web Content Detected"] [severity "CRITICAL"] Access denied with code 403 (phase 2). Match of "rx ((?:submit(?:\\\\+| )?(request)?(?:\\\\+| )?>+|<<(?:\\\\+| )remove|(?:sign ?in| log ?(?:in|out)|next|modifier|envoyer|add|continue|weiter|account|results|select)(?:\\\\+| )?>+)$|^< ?\\\\??(?: |\\\\+)?xml|^<samlp|^>> ?$)" against "ARGS:jtlrpc" required. [hostname "xxxxxxxxx"] [uri "/index.php/jtlconnector"] [unique_id "XysTDwOOb-v-iQWcbgN5kwAAAIk"]

So wie ich das interpretiere, wird irgendwas an der Übermittlung als potentiell schädlicher Code interpretiert.
 

Achim L.

Moderator
Mitarbeiter
3. Juli 2017
414
64
Ja das liebe Modsecurity, so etwas in der Art habe ich schon vermutet.
Modsecurity ist hier übereifrig. Lösung ist es, in Modsecurity eine Ausnahme für den Eintrag mit der ID 350147 anzulegen.
 

johannesress

Neues Mitglied
5. August 2020
4
0
Vielen Dank dafür - das wird bestimmt noch nützlich!

In der Zwischenzeit hatte ich das Problem gelöst, indem ich im Wawi den Connector neu installiert habe - ich nehme an, dadurch hat sich die ID geändert und es steht jetzt nicht mehr auf der "schwarzen Liste" von Mod Security? Irgendwie ein bisschen seltsam.

Ich nehme an, das Problem wird in Zukunft wieder auftreten und dann werde ich das mit dem ID Eintrag ausprobieren.

Danke nochmal und noch einen schönen Tag!
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Connector überträgt keine Kategorien bzw löscht beim Abgleich die Kategorien der bestellten Artikel Shopware-Connector 0
Neu Wawi 1.5.34.0 > Connector 2.7 zerschießt Shopware 5.6.9 > 502 bad Gateway Shopware-Connector 14
Neu JTL-Connector (SW6) - Artikelpflege in JTL / SEO Pflege in Shop? Shopware-Connector 2
Neu Shopware Connector Update - hat sich etwas geändert!? Shopware-Connector 0
Neu Keine Verbindung zur WAWI möglich. Die Shop-URL verweist nicht auf einen gültigen Shop! Bitte prüfen Sie die Connector-Konfiguration Allgemeines zu den JTL-Connectoren 0
Neu Fehlermeldung bei Connector 2.12.1 Gambio-Connector 14
Beantwortet Ist der Connector 2.7.0 kompatibel zu Shopware 5.2 ? Shopware-Connector 2
Beantwortet JTL Shopware Connector für Shopware 5.6.9 Shopware-Connector 3
In Diskussion Daten löschen und Connector mit neuer Wawi-Instanz verbinden Shopware-Connector 4
Neu Wawi Connector Woocommerce Lizenz-Logbuch meldet Wrong Token WooCommerce-Connector 0
In Bearbeitung Massive Probleme mit der Mehrwertsteuer bei Connector 1.15 WooCommerce-Connector 18
Neu Keine automatische Auslieferung bei Bestellungen über Online Shopanbindung (Connector & Unicorn 2) Onlineshop-Anbindung 0
Beantwortet Shopware 6 - Connector Konfiguration in der wawi Shopware-Connector 5
Neu JTL Connector Deinstallieren Technische Fragen zu den JTL-Connectoren 1
Neu Suche Freelancer für JTL Connector - Shopware 6 Anbindung Dienstleistung, Jobs und Ähnliches 0
Neu Schopware jtl connector extrem langsam nach Server migration Shopware-Connector 5
Neu Connector Error Shopware-Connector 6
Gelöst JTL Shop 5 Keine Verbindung zur WAWI möglich. Die Shop-URL verweist nicht auf einen gültigen Shop! Bitte prüfen Sie die Connector-Konfiguration Gelöste Themen in diesem Bereich 6
Neu Connector URL ändern Shopware-Connector 2
Neu Connector 2.7 -- "Added config option 'consider_supplier_inflow_date_for_shipping' (default: true) for calculation delivery time" Shopware-Connector 8
Neu Servicepartner gesucht: WooCommerce Connector - Unterstützung mehrerer Währungen? WooCommerce-Connector 1
Neu WooCommerce JTL-Connector Version 1.14.0 / Woocommerce/Preis auf 0 gesetzt WooCommerce-Connector 3
Neu JTL Connector xtcmodified fehlende Datei configure.php Modified eCommerce-Connector 1
Neu Wann kommt die nächste Connector Version? Nächster Fehler Modified eCommerce-Connector 0
Neu How to connect example connector plugin to JTL wawi Allgemeines zu den JTL-Connectoren 1
Neu Custom JTL-Connector Technische Fragen zu den JTL-Connectoren 1
Neu Onlineshop Abgleich Fehler Woocomerce Connector Onlineshop-Anbindung 6
Neu Connector schickt ohne Ende Preise Shopware-Connector 8
Neu JTL Shopware Connector Fehler beim Import von Kunden und Bestellungen Shopware-Connector 2
Neu Shopware > Connector > Falsche Firmenzuordnung Shopware-Connector 0
Neu Fehler im Connector 3.0 Modified eCommerce-Connector 1
Neu Shopware 6 Connector - Kategorie Import - Indexierung Shopware-Connector 0
Neu Shopware 5 Connector / Shop-Kundengruppe 0 Shopware-Connector 18
Neu Connector: ready2order <-> WAWI Technische Fragen zu den JTL-Connectoren 9
Neu Shopware connector stellt keine verbindung her Shopware-Connector 0
Neu Rabatt auf Bestellposition im Basis-Connector Allgemeines zu den JTL-Connectoren 2
Neu Import über Connector Gambio User helfen Usern - Fragen zu JTL-Wawi 0
Neu JTL-Connector WooCommerce Mediadateien Anzeigen lassen WooCommerce-Connector 1
Neu Wechsel von Variationen mit Lagerbestand zu Var Kombis - modified connector 3.0 Modified eCommerce-Connector 3
Neu Gambio 4 Connector, ohne Fehlermeldung, arbeitet nicht! Gambio-Connector 3
**RELEASE: JTL-Connector (SaaS) für Shopware 6 startet in die Open Beta** Shopware-Connector 151
In Diskussion Connector lässt sich nicht Installieren PrestaShop-Connector 3
In Bearbeitung Connector 1.9.5.1 / Artikelname mit "&" WooCommerce-Connector 3
Gelöst OSCommerce connector Download osCommerce 2
Neu Connector resetten? Alle Artikel aus JTL erneut zum Shop Modified eCommerce-Connector 4
Gelöst Fehler beim Connector? bei Komplettabgleich? Modified eCommerce-Connector 0
In Diskussion Plugin für Woocommerce Connector - Abgleich zusätzliche Felder für Artikel WooCommerce-Connector 2
Neu Chinesische Schriftzeichen werden erfolgreich zu Ebay übermittelt aber verschwinden danach direkt wieder aus der WaWi JTL-Wawi - Fehler und Bugs 0
Neu Umlaute werden komplett falsch übermittelt Amazon-Anbindung - Fehler und Bugs 4
Neu Adressdaten werden nicht komplett übermittelt Modified eCommerce-Connector 0
Ähnliche Themen