Neu Connector synchronisiert nur in eine Richtung

hak

Neues Mitglied
12. November 2020
5
0
Wawi-Version : 1.5.44.0
Wordpress-Version : 5.7.1
Connector-Version : 1.23.2
WooCommerce-Version: 5.2.2

Clever Addons 1.0.1
Clever Addons for Elementor 2.1.0
Clever Addons Pro for Elementor 1.2.2
Clever Swatches 2.2.2
Clever WooCommerce Product Filter 1.0.3
Elementor 3.2.1
Germanized für WooCommerce 3.4.5
Google Ads und Marketing von Klinken 1.0.7
Loco Translate 2.5.2
Meta Box 5.3.9
WooCommerce 5.2.2
WooCommerce JTL-Connector 1.23.2
WooCommerce PayPal Checkout Gateway 2.1.1
WooCommerce PDF Invoices & Packing Slips 2.8.3
WooCommerce Shipping & Tax 1.25.12
WP Mail SMTP 2.7.0
Yoast SEO 16.1.1

Hallo!

Seit einiger Zeit habe ich das Problem, dass Lagerbestände nicht mehr korrekt vom Shop in die WaWi übertragen werden. Ein Abgleich in die andere Richtung (also WaWi -> Shop) funktioniert jedoch.

Beispiel:
Ich stelle den Bestand eines Artikels in der Wawi auf 5 und mache anschließend einen Onlineshop-Abgleich, dann wird der Bestand im WooCommerce-Backend korrekt aktualisiert und zeigt 5 an.
Wenn nun allerdings der Artikel verkauft wird (oder ich den Bestand manuell im Backend ändere), wird der Bestand in der Wawi nicht geändert, ausschließlich in WooCommerce.

Nirgendwo wird eine Fehlermeldung angezeigt, der Connector ist offensichtlich richtig verbunden, die Einstellungen sind auf eine Synchro in beide Richtungen gesetzt.
Was meint Ihr, Connector zurücksetzen? Habe Angst, da irgendwas zu kaputtzumachen.
Bin für jede Hilfe dankbar!
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.450
305
Hallo @hak,

sobald die Bestellung von dem in deinem Beispiel genannten Artikel in JTL-Wawi importiert wird, sollte JTL-Wawi den Bestand des Artikels entsprechend anpassen.
 

Shopworker.de

Offizieller Servicepartner
SPBanner
4. Januar 2011
3.744
437
Arnsberg, Sauerland
  • Gefällt mir
Reaktionen: Immanuel

hak

Neues Mitglied
12. November 2020
5
0
Erst mal Danke für die schnellen Antworten!

sobald die Bestellung von dem in deinem Beispiel genannten Artikel in JTL-Wawi importiert wird, sollte JTL-Wawi den Bestand des Artikels entsprechend anpassen.

Auf diese Nachricht hin habe ich in der Wawi mal die Bestellungen überprüfen wollen und – die sind leer, die Tabelle zeigt keine Bestellungen an. Hängt damit zusammen, dass der Bestand nicht abgezogen wird?
Jetzt habe ich daraufhin doch mal den Connector in den Wawi-Einstellungen zurückgesetzt und beim Erstabgleich wurden auch alle Bestellungen angezeigt (zumindest konnte ich während des Vorgangs die richtige Zahl in der Statistik sehen), danach war die Tabelle jedoch weiterhin leer. Nach einer Testbestellung und anschließendem Onlineshop-Abgleich wurden zwei neue Daten (wohl Bestellung und Kunde) übertragen, der Kunde wurde korrekt eingetragen, die Bestellung taucht jedoch nicht auf (weiterhin 0) und der Bestand des Artikels wurde nicht reduziert.

Aus meiner Sicht sollten die Bestände nach dem initialen Abgleich nur noch in der Wawi geändert werden ...

Dumm gefragt: Kann ich den Bestand also ausschließlich in der Wawi ändern und eine Änderung in WooCommerce wird hier generell nicht übertragen? Dann läge der Fehler ja "nur" bei den Bestellungen, die zwar irgendwie erkannt aber nicht angezeigt und verarbeitet werden.
 

Shopworker.de

Offizieller Servicepartner
SPBanner
4. Januar 2011
3.744
437
Arnsberg, Sauerland
Dumm gefragt: Kann ich den Bestand also ausschließlich in der Wawi ändern und eine Änderung in WooCommerce wird hier generell nicht übertragen?

Ja, das sollte so sein.

Dann läge der Fehler ja "nur" bei den Bestellungen, die zwar irgendwie erkannt aber nicht angezeigt und verarbeitet werden.

Hast du die Bestellungen in der Wawi denn korrekt abgeschlossen?
Die Lieferscheine zu den Aufträgen sollten alle unter >Lieferschein >Versendet sein, ansonsten hast du die Aufträge nicht korrekt ausgeliefert ..
 

hak

Neues Mitglied
12. November 2020
5
0
Die Lieferscheine zu den Aufträgen sollten alle unter >Lieferschein >Versendet sein, ansonsten hast du die Aufträge nicht korrekt ausgeliefert ..

Ich habe die Bestellungen in der Wawi nun gefunden, hatte im falschen Fenster geschaut (Onlineshop), wo nichts aufgeführt steht. Muss dazu sagen, der Shop ist noch recht neu und ich hatte mich mit vielem in der Wawi noch nicht ausreichend beschäftigt.
Die Bestellungen sind alle aufgelistet und wenn ich dort auf "Ausliefern" klicke, wird der entsprechende Bestand auch korrekt abgezogen, nach einem Abgleich dann auch in WooCommerce.
So weit so gut, ist also kein technisches Problem – eher ein Denkfehler, Sorry! 😅

Dieser Klick auf "Ausliefern" ist – so mein Eindruck – aber erst seit einem kürzlichen Update nötig, ob bei Wawi oder WooCommerce/ Connector kann ich nicht sagen.
Davor wurde der Bestand auch so direkt abgeglichen, auch bei alten Bestellungen, die in der Wawi noch als ausstehend galten. Daher meine letzte Frage: Gibt es eine Einstellungsmöglichkeit jede neue Bestellung automatisch in der Wawi auszuliefern? Ein Häkchen irgendwo, dass eine eingehende Bestellung automatisch abgeschlossen und der Bestand reduziert wird?

Vielen Dank für die Hilfe bisher!
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Artikelstammdaten Varianten und Variation Kombination // Import durch WooCommerce Connector User helfen Usern - Fragen zu JTL-Wawi 6
Neu Probleme mit den Einstellungen die der Connector vornimmt (Preise) WooCommerce-Connector 1
Neu Crossselling mit Connector 2.12.0 und SW 5.7.3 Shopware-Connector 1
Neu Shop teilweise anbinden? bzw., Bestand und Aufträge ohne Connector synchronisieren Shopify-Connector 1
Neu SW5 auf SW6 Migration & Connector Shopware-Connector 2
Neu Shopware 6 Connector User helfen Usern 0
Neu Shopware 6 Connector - API error .. "Dieser Wert sollte nicht leer sein" Shopware-Connector 3
Neu JTL-Connector - Einstellungen der Übertragungsparameter Allgemeines zu den JTL-Connectoren 0
Neu SW5 - Nach Connector Update - Bilder werden Artikel nicht zugewiesen Shopware-Connector 19
Neu Invalid request JTL Connector 1.26.0 mit Woocommerce 5.5.1, GermanMarket 3.12.2 WooCommerce-Connector 0
Neu Überverkäufe mit dem Connector managen? Gambio-Connector 3
Neu Shopware 6 Connector schmeißt ständig Fehlermeldung Shopware-Connector 4
Neu Einfacher Connector zum Bestandsabgleich Technische Fragen zu den JTL-Connectoren 2
Neu Woo Connector connector.identify "Der Remoteserver hat einen Fehler zurückgegeben: (403) Unzulässig. WooCommerce-Connector 1
Neu Shopware 5 Connector anmeldung nicht möglich nach Update Shopware-Connector 2
Neu JTL-SW6 Connector Error: The File for media object with id: [...] is not supported for creating thumbnails. Shopware-Connector 11
Neu Prestashop Connector - Zahlungsarten zuordnen PrestaShop-Connector 0
Neu Aufträge werden nicht synchronisiert. Shopify-Connector 4
Neu Nur Rechnungen von Nicht-Business-Kunden erstellen JTL-Workflows - Ideen, Lob und Kritik 8
Neu Bestand pro Lager bei mehrern Lägern ausblenden im Nova Template nur Ampel anzeigen in Artikelbeschreibung Templates für JTL-Shop 0
Neu Nur Firmenkunden-Preise sichtbar Allgemeine Fragen zu JTL-Shop 2
Neu Breadcrumb -> Navigation nächster Artikel -> Vorschaubild statt nur den Titel Templates für JTL-Shop 0
Neu Artikeldatenbank immer nur ein Produkt? Oder Ebay und Amzon import Produkte doppelt drin lassen Arbeitsabläufe in JTL-Wawi 0
Neu Keine Artikeldaten an Shopware übermitteln? Nur Bestellungen und Bestände Shopware-Connector 0
In Bearbeitung Bondrucker TM30 druckt Bon nur halb JTL-POS - Fragen zu Hardware 3
Beantwortet Bestandswarnung funktioniert nur im Test JTL-Workflows - Fehler und Bugs 4
Neu Amazon Aufträge nur im Pending - Vorher JTL-Authentifizierung abgelaufen Amazon-Anbindung - Fehler und Bugs 4
Neu Rechnung nur über gelieferte Artikel? Arbeitsabläufe in JTL-Wawi 1
Neu Warenkorbmatrix nur je Kundengruppe Allgemeine Fragen zu JTL-Shop 2
Neu Auftrag ist OHNE Rechnung nicht editierbar? und auch nur einer von vielen! JTL-Wawi - Fehler und Bugs 3
Gelöst nur leere Seiten nach Abgleich Allgemeine Fragen zu JTL-Shop 5
In Bearbeitung Angemeldete Retoure nur terilweise einbuchen können (Teillieferung) [WAWI-57338] Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 19
Neu Absender Adresse immer "nur" die E-Mail Adresse Servicedesk (Beta) 5
Neu Dashboard Anzeige "JTL-Worker: Status" nur für bestimmte Benutzer einblenden User helfen Usern - Fragen zu JTL-Wawi 5
Neu Webshop reagiert während Onlineshopabgleich nur noch sehr langsam - Serverproblem? Hostingproblem? Modified eCommerce-Connector 8
Neu Einzelne Landingpages nur einsprachig einpflegen Allgemeine Fragen zu JTL-Shop 4
Neu Mediendatei: Bei selbstbenannten Tabs mit mehreren Dateien wird nur eine angezeigt JTL-Shop - Fehler und Bugs 0
Neu Produkt mit Ablaufdatum: Nur für DE auswählbar Amazon-Anbindung - Fehler und Bugs 6
Neu Versanddaten exportieren funktioniert nur manuell JTL-Wawi - Fehler und Bugs 0
Beantwortet Workflow "Bestandskundenabfrage" funktioniert nur in der Simulation JTL-Workflows - Fehler und Bugs 2
Neu Stücklisten Artikel taucht 2 oder 3x im Auftrag auf, obwohl nur 1x vom Kunden bestellt JTL-Wawi - Fehler und Bugs 20
Neu Mehrsprachiger Shop: MerkmalNAMEN werden nur auf Deutsch angezeigt JTL-Shop - Fehler und Bugs 1
Neu Info im Warenkorb nur für bestimmte Kundengruppe Allgemeine Fragen zu JTL-Shop 4
Neu Slick Slider: Bei Init nur eine Slide auf ganze Breite JTL-Shop - Fehler und Bugs 0
Neu Wie nur bestimmte Werte in Eigene Felder zulassen? JTL-Wawi - Fehler und Bugs 1
Neu Filter mit nur einem Merkmalwert ausblenden Shop 5 EVO Technische Fragen zu Plugins und Templates 0
Neu Umlaute falsch in E-Mail aus Shop - aber nur Titel des Produkts JTL-Shop - Fehler und Bugs 10
Neu Wie nur bestimmte Werte in Eigene Felder zulassen? User helfen Usern - Fragen zu JTL-Wawi 2
Neu Erweiterte Kundendaten nur im Kundenkonto sichtbar JTL-Shop - Ideen, Lob und Kritik 2
Neu Verkauf Farbe - nach Eimer oder Liter (Gebinde nur im WMS?) Arbeitsabläufe in JTL-Wawi 3

Ähnliche Themen