Neu Bildgrößen Ändern, nur für einen Marktplatz

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.692
891
Hallo,

unsere Bilder in der WaWi sind eigentlich alle 800x800.

Jetzt gibts jedoch bei Otto die Vorschrift für mind. 480x960. Ja, blöd gelaufen...

Die Funktion "Bilder skalieren und konvertieren" in der WaWi kann ich ja vermutlich vergessen, die würde ja die Bilder in "global" ersetzen....

Irgendwelche Vorschläge/Ideen, wie das Problem gelöst werden kann, die alle zb. auf 1000x1000 zu skalieren, aber NUR! für den Multishop X?
 
  • Gefällt mir
Reaktionen: aadursun

Enrico W.

Administrator
Mitarbeiter
27. November 2014
6.713
1.169
Ich fürchte, da wirst du um eine externe Bearbeitung nicht herum kommen.
Exportier Dir die Bilder am besten mit der Ameise, lass mit Gimp, Photoshop o.ä. per Stapelverarbeitung die Bildgröße anpassen und das vorher exportierte Original-Bild im Ordner direkt überschreiben. Dann kannst Du die angepassten Bilder ohne Anpassung der CSV auch direkt wieder importieren.
Bitte den Import Bilder pro Plattform nutzen und die Einstellung "Vorhandene Zuordnungen vorher löschen" umstellen auf "Ja". Dann werden die Bilder dieser Plattform entfernt und die angepassten Bilder werden in der gleichen Reihenfolge importiert.
 
  • Gefällt mir
Reaktionen: aadursun und hula1499

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.692
891
Haben ehrlichgesagt noch nie was mit dem Bilderexport gemacht, aber das schaut ja eigentlich eh relativ simple aus mit der Ameise und mein Schrecken hält sich in Grenzen.

Die Bilder werden ja exportiert mit
-1.jpg
-2.jpg
usw.
d.h. er nimmt dann einfach für -1 die Sortiernummer 1, für -2 die 2er usw. - also so wie die Bilderreihenfolge gerade angelegt ist, richtig?

1647432853820.png


Mehr brauch ich dann nicht (Stapelverarbeitung natürlich noch)?
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
6.713
1.169
Genau, das sollte ausreichen. Mit der dann mitgelieferten CSV hast du alle Daten, um die Bilder direkt wieder zu importieren.
Im Präfix würd ich für die Bilder dann noch den Pfad zum Ordner hinterlegen, in dem die Bilder gespeichert wurden, einfach, weil die Ameise für den Import den kompletten Pfad erwartet.

Edit: Wichtig ist halt, dass die Bildbearbeitung die Original-Bilder überschreibt oder alternativ unter exakt gleichem Namen in einen anderen Ordner schreibt.
 
Zuletzt bearbeitet:
  • Ich liebe es
  • Gefällt mir
Reaktionen: aadursun und hula1499

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.692
891
Wäre ja fast zu einfach gewesen... :D

Der Multishop wurde neu angelegt von Unicorn.
Durch dieses Anlegen gibt es keinerlei Bilderverweis, im Produkt selbst:
1647435313365.png

Der Import läuft hier dann auch nicht (Trockenlauf):
1647435396024.png

"Bestehende Plattformen Zuordnungen vorher löschen" hab ich beides probiert, in beiden der gleiche Fehler.
Sonst kann ich da beim reinen "Artikelbilder je Plattform" ja nichts mehr wirklich einstellen.

Muss ich jetzt irgendwie noch die Aktivierung der jeweiligen Produkte, vorher, in die WaWi bekommen?


Nachtrag:
Der Haken für "Bestehende Plattformen Zuordnungen vorher löschen" ist fatal. Der löscht ja komplett alle anderen Plattformen raus (und nicht nur mögliche Bilder in der Plattform die angeführt ist).
Hab jetzt 3 Artikel zum Test in der CSV gelassen, alles eingestellt wie beschrieben:
1.) er hat weiterhin nichts in der Plattform "Otto" hinzugefügt (Fehler wie oben)
2.) der Import hat nun alle Bilder, aus ALLEN! Plattformen gelöscht
 
Zuletzt bearbeitet:

Enrico W.

Administrator
Mitarbeiter
27. November 2014
6.713
1.169
Oh, das darf nicht sein, da bin ich bei Dir.
Da es die Bilder bisher für diese Plattform noch gar nicht gibt brauchst du die Einstellung nicht anfassen. Somit wärest du dann immerhin safe.
Wenn du den Import (nicht den Trockenlauf - der bockt öfter mal) dann laufen lässt - passt das dann?

Edit: Nachdem Du es geschrieben hattest hab ich noch mal was gegraben:
https://issues.jtl-software.de/issues/WAWI-35541

Das Ticket hatte ich schon mal dazu aufgemacht. Ich seh mal zu, ob wir da was Druck machen können.
 
Zuletzt bearbeitet:

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.692
891
1647437422049.png

1647437472157.png


Nope, nichts eingespielt


Durch diese ""Vorhandene Zuordnungen vorher löschen"" hat er sogar den/die Artikel auf allen Plattformen inaktiv geschalten...ja, ich war sicher bei "Artikelbilder je Plattform"
Das ist quatsch!
 
Zuletzt bearbeitet:

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.692
891

Enrico W.

Administrator
Mitarbeiter
27. November 2014
6.713
1.169
oO
Das ist strange. Ich schaffe es heute leider nicht mehr, das in aktuellen Versionen gegenzuprüfen. Wenn es sehr dringend ist, würde ich einen Kollegen bitten drüberzuschauen.
Ansonsten kann ich Dir anbieten, dass ich mir die Sache morgen noch mal in Ruhe anschaue.
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
6.713
1.169
Moin. Wie versprochen hab ich noch mal genauer geschaut - und hätte ich gestern nicht so unter Zeitdruck gestanden (nicht deinetwegen), hätte ich wahrscheinlich auch besser hingeschaut.
Dein Screenshot verrät schon, was da schief läuft.
Zum Import der Bilder ist der komplette Pfad notwendig.

Das bedeutet, dass Du hier zwei Möglichkeiten hast.
  1. Du passt die CSV an. das ist mühselig.
  2. Du gibtst den Pfad zu den Bildern (also den kompletten Pfad ohne Bildnamen) in Präfix/Suffix als Präfix ein.
    Als Beispiel: Das Präfix "C:\Bilderimport\" ohne die Anführungsstriche + dem Bildnamen "53-1.png" ergeben in der Summe den kompletten Pfad zum Bild C:\Bilderimport\53-1.png

    Das heißt, dass du das Präfix ggf. bei 10 möglichen Bildern hinterlegen musst - das machst du in der Ameise dann aber auch nur ein mal.
    In meinem Screenshot habe ich so für Bild 3 ganz bewußt den Pfad einmal nicht hinterlegt und hatte dann damit auch direkt die gleiche Fehlermeldung.
    1647500370826.png
    Das Ergebnis dieses Importes: Artikel 53 hat zwei Bilder für den Testshop importiert bekommen, die auf keiner anderen Plattform aktiv sind:
    1647501935692.png
Edit:
Zum besseren Verständnis: Die Meldung im Import besagt nicht, dass im Artikel kein Bild existiert, es besagt, dass unter dem der Ameise bekanntem Pfad dieses Bild nicht existiert.
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: aadursun und hula1499

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.692
891
Leider muss ich das nochmals hochholen, irgendwas ist mit dem Import nicht ganz rund gelaufen.

Ich hab plötzlich, bei genau diesen Produkten die ich importiert hab, keinen Bilderhaken mehr bei - komischerweise - nur U2 Plattformen.

Ama, drucken, dev shop, hauptshop, ebay, wms....Haken vorhanden, also quasi alles, was JTL "selbst" ist.
Alle angeschlossenen "externen" Shops (U2) haben keinen Haken mehr bei den Bildern...

Ist dieses
"Auch verwenden auf Plattform" irgendwie mit der Ameise abholbar?
Ich find nichts bei den Artikelbildern, Artikeldaten...
 
Zuletzt bearbeitet:

Enrico W.

Administrator
Mitarbeiter
27. November 2014
6.713
1.169
Du meinst, auf einer anderen Plattform hast du die Bilder korrekt und willst nur den Haken übertragen? Das wäre der Import "Artikelbild verknüpfen"
Rechts in den Standardeinstellungen Quell- und Zielplattform einstellen und die Artikelnummern importieren.
 
  • Gefällt mir
Reaktionen: hula1499

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.692
891
Das Export und Import so unterschiedlich ist... :D

Hab lediglich im Export nachgesehen, obs da irgendwelche Dinge gibt, yup, genau so, merci :)
 
  • Gefällt mir
Reaktionen: Enrico W.

DrGreen

Aktives Mitglied
24. Dezember 2017
96
15
Hi Leute, ich bräuchte nun genau dasselbe jedoch für die Kategoriebilder, da diese im neuen Shop nicht angezeigt werden müsste ich jetzt da überall den Haken setzen. Gibts hier auch eine schnellere Lösung zB via Ameise?
 
Ähnliche Themen
Titel Forum Antworten Datum
Beantwortet Artikel aus Ladenlokal versenden / Lagerplatztyp ändern Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 2
Neu Import ändern keine Sichtbarkeit von Kundengruppe User helfen Usern - Fragen zu JTL-Wawi 1
Neu Bundesländer ändern sich nicht JTL-Shop - Fehler und Bugs 1
Neu Email Adresse für Rechnung im nachhinein ändern JTL-Wawi 1.6 3
Verwiesen an Support Retourenstatus automatisch ändern JTL-Workflows - Fehler und Bugs 2
News/Blog: Seitentitel und breadcrump ändern Einrichtung JTL-Shop5 0
Neu Server IP JTL WaWi ändern User helfen Usern - Fragen zu JTL-Wawi 0
Neu Rechnung ändern nicht mehr möglich User helfen Usern - Fragen zu JTL-Wawi 16
Bestehenden Artikel zu Kindartigel ändern JTL-Wawi 1.6 0
Neu Rechnungskorrektur ändern bzw. Stornorechnung einfach erstellen User helfen Usern - Fragen zu JTL-Wawi 2
Neu Preise für Kaufland.de über die Ameise ändern?? JTL-Ameise - Fehler und Bugs 9
Neu Ändern der Mengenauswahl Templates für JTL-Shop 0
Neu Suche SQL Spezialist der Mwst Sätze u. Beträge in der dbo.tbestellpos von Amazon VCS Bestellungen ändern kann Dienstleistung, Jobs und Ähnliches 3
Neu Wie kann ich die Bild Anzeigegröße der Kategorie ändern? Allgemeine Fragen zu JTL-Shop 0
Neu KATEGORIEN REIHENFOLGE ÄNDERN Arbeitsabläufe in JTL-Wawi 7
Neu Lieferantenlieferzeit ändern Arbeitsabläufe in JTL-Wawi 1
Neu NOVA Template Hover Button Farbe ändern Templates für JTL-Shop 3
Neu Shop5 EVO Slate Schrift bei Preise Fahre und größe ändern. Technische Fragen zu Plugins und Templates 1
Farbe Ändern NOVA Einrichtung JTL-Shop5 2
Hintergrundfarbe ändern (Dropdown-footer) Einrichtung JTL-Shop5 0
Neu Kategorien im Shop-Frontend ändern Einrichtung von JTL-Shop4 1
Offen Versandart in Eazy Shipping ändern - im Auftrag bleibt die "alte Position" JTL-Wawi - Ideen, Lob und Kritik 2
Neu Exportdokumente mit DHL Versenden 3.0 / Anzahl Zollinhaltserklärungen ändern User helfen Usern - Fragen zu JTL-Wawi 0
Neu Anzahl an Vorschauprodukten pro Zeile ändern Allgemeine Fragen zu JTL-Shop 3
Versandart nachträglich ändern Einrichtung JTL-Shop5 3
Neu Artikelnummer Ausgabe ändern auf Lieferschein und Rechnung Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Gelöst Barcodes Versandart ändern Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 7
Neu Chinesische Händler ändern meine Amazon Listings (Marke, Bilder, Beschreibung etc.) Smalltalk 11
Neu Auftragsfarbe XML Import ändern Schnittstellen Import / Export 0
API Key ändern (Kaufland SCX) kaufland.de - Anbindung (SCX) 3
Neu JTL Wawi empfangene Aufträge enthalten nur Vaternamen Shopware-Connector 1
Rechnungsvorlagen/ Fußzeile nur noch zur hälfte da. JTL-Wawi 1.6 1
Nach Update (Stunden später) keine Unterseiten mehr aufrufbar - nur Startseite Upgrade JTL-Shop4 auf JTL-Shop5 0
Neu Pickliste > Ausliefern erstellt wieder Pickliste statt nur auszuliefern JTL-Wawi - Fehler und Bugs 0
Neu "Das Handle ist ungültig" - Labeldruck nur über GKP möglich, Sendungsnummer aber in Wawi JTL-ShippingLabels - Fehler und Bugs 0
Artikelabhängigen Versand mit Artikelunabhängigen nur einmal mit dem teureren berechnen JTL-Wawi 1.6 0
Neu Farbcodierung bei ausgelieferten Aufträgen nur über Workflow JTL-Wawi - Fehler und Bugs 0
Neu Ameisen Import nur für bestimmten Shop JTL-Wawi 1.6 2
Neu Shopware Artikel nur in der jeweiligen Kategorie anzeigen - ohne Unterkategorien Shopware-Connector 0
Rechnungen haben keine Netto Positionen nur Brutto?! JTL-Wawi 1.6 2
Eigene Felder nur im Auftrag? JTL-Wawi 1.6 3
Neu Artikel nur innerhalb Deutschlands versenden Arbeitsabläufe in JTL-Wawi 2
Neu Artikel | Attribute/Merkmale | Merkmale lassen sich nur noch einzeln entfernen JTL-Wawi 1.6 1
Issue angelegt Retouren > nur angemeldete anzeigen im WMS [WAWI-62644, WAWI-62645] Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 3
Neu Bei Zahlungsarten werden nur Vorkasse und Kreditkarte gezeigt JTL-Shop - Fehler und Bugs 1
Neu Mollie-Backend im 5er Shop lässt sich nur schwer aufrufen Plugins für JTL-Shop 1
Neu Element nur drucken wenn Seitenzahl > 1 ist Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu DATEV Anbindung nur direkt an den Steuerberater? Arbeitsabläufe in JTL-Wawi 0
Neu nur lieferschein errstellen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Exportvorlage - nur bestimmte Artikel im Feed - Fehlersuche Allgemeine Fragen zu JTL-Shop 5

Ähnliche Themen