Neu 404 Crawling Fehler mit $cCanonicalURL

mwamser

Aktives Mitglied
26. März 2013
55
9
Hallo,
momentan verwenden wir noch den 4.04er Shop und haben bemerkt das in der Google Search Console einige Urls auftauchen mit 404 Fehlern die "$cCanonicalURL" im Url-Namen haben.

Ist jemandem dieses Problem bekannt und weiß wo man da ansetzen muss? Ich vermute ja das hier im Shop/Template eine URL falsch zusammen gesetzt wird. Ich bin aber noch nicht auf de Quelle gestossen wo genau die URL auftaucht. Wie gesagt ich sehe sie nur in der Google Search Console.

Mike
 

holzpuppe

Sehr aktives Mitglied
14. Oktober 2011
1.715
260
Leipzig
Hallo,
ja kenne ich, und das trotzdessen, dass Canonicaltags im Shop und Wawi richtig eingegeben wurden.
Ich habe es bis auf weiteres so gelöst, dass ich in der Search Console bei URL-Parameter den Parameter "CanonicalURL" hinzugefügt habe und Seiteninhalt auf nein gesetzt. Seit dem habe ich auch nicht mehr die Fehler. Einen negativen Effekt im Ganzen konnte ich noch nicht feststellen.
 

mwamser

Aktives Mitglied
26. März 2013
55
9
Hmm mit dem Gedanken habe ich auch schon gespielt. Allerdings ist es bei mir kein echter Parameter da ja kein ? davor steht. sprich müsste es ja so heissen: meineurl.de/meinartikel?$cCanonical, und nicht wie bei mir meineurl.de/meinartikel$cCanonical oder erkennt das Google als echten Parameter? Da war ich mir dann doch etwas unsicher.
 

holzpuppe

Sehr aktives Mitglied
14. Oktober 2011
1.715
260
Leipzig
Der Search Console scheint das egal zu sein. Ich hatte nur festgestellt, dass für den Bot "meineurl.de/meinartikel$cCanonical" und "meineurl.de/meinartikel" 2 verschiedene Links sind. Ob nun das "?" drinn stand oder nicht kann ich nicht mehr nachvollziehen. Ich vermute sogar, dass das mit der Sitemap zusammenhängt. Kann mich aber auch völlig irren.

Aber vlt. weiß das hier jemand besser. 😉
 

david

Administrator
Mitarbeiter
16. Juli 2010
2.310
170
Auch wenn dieses Problem schon etwas älter ist.
Wir hatten es aufgrund eines Supportfalls heute nochmal aufgerollt und sind dabei auf das JTL-Debug-Plugin gestoßen. Dieses gibt u.a. die Smarty-Variable $cCanonicalURL sowie direkt davor den Variablenwert aus.
Der GoogleBot scheint offenbar unter gewissen Umständen bei aktivem Debug-Plugin den Ajax-Request für die Aktivierung der Debug-Ausgabe auszulösen und folgt dabei URLs mit dem Zusatz $cCanonicalURL aus der Debug-Ausgabe.

Das ganze macht natürlich überhaupt keinen Sinn und eine "404 Not Found"-Antwort für fehlerhafte URLs ist hier korrekt. Bitte keine Weiterleitungen für den GoogleBot anlegen oder Ähnliches, das bringt nichts. Die Warnungen in der Search-Console werden mit der Zeit verschwinden.
Wichtig: Bitte stellt sicher, dass das JTL-Debug-Plugin in Produktivshops inaktiv ist.
Falls ihr es für Debugging-Zwecke kurz benötigt, aktiviert es bitte ausschließlich in Verbindung mit einem zusätzlichen GET-Parameter, den ihr bei Bedarf an die URL anhängt (Einstellung). Und danach nicht vergessen, das Plugin wieder zu deaktivieren, es hat in einem Liveshop wirklich nichts zu suchen.
 

mwamser

Aktives Mitglied
26. März 2013
55
9
Danke für die Rückmeldung! Werde ich im Hinterkopf behalten. Das Debug-Plugin ist bei besagtem Shop nicht mehr aktiv. Ich kann aber (da es schon lange her ist) nicht mehr sagen ob es vl. anfangs als Google das erste mal drüber gerannt ist, doch am aktiven Plugin lag.
 

Ähnliche Themen