Neu Nach SSL Umstellung nur noch Probleme.

wernereins

Gut bekanntes Mitglied
2. Oktober 2011
126
1
Hallo, wir haben unseren Shop auf SSL umgestellt und haben jetzt nur noch Probleme.

Im Adminbereich wurde alles umgestellt.

.htaccess (alt kann aufgerufen werden Startbild siehe Screenshot)

RewriteCond %{HTTP_HOST} ^xxx.de

RewriteRule ^(.*)$ http://www.xxx.de/$1 [R=301,L]

.htaccess (neu. Error 500)

RewriteCond %{HTTP_HOST} ^xxx.de

RewriteRule ^(.*)$ https://www.xxx.de/$1 [R=301,L]

Admin kann aufgerufen werden mit alter .htaccess, mit neuer ebenfalls Error 500

Nachdem ich nun das ganze Wochenende mit den verschiedensten .htaccess, aus dem Forum,
herumprobiert habe, keine funktionierte ausser wie geschrieben die alte, weiss ich absolut nicht mehr weiter.
Bin für jede Hilfe dankbar.

 

Xantiva

Sehr aktives Mitglied
28. August 2016
1.795
316
Düsseldorf
Hast Du in der config Datei die Shop-URL angepasst?
/includes/config.JTL-Shop.ini.php
PHP:
define('URL_SHOP', 'https://www.example.com');

Ansonsten schau in das error - Log des Servers, was dort als Ursache für den #500er drin steht.
 

wernereins

Gut bekanntes Mitglied
2. Oktober 2011
126
1
/includes/config.JTL-Shop.ini.php wurde angepasst. log des servers war nicht aktiv, dauert 24h nach Aktivierung
 

wernereins

Gut bekanntes Mitglied
2. Oktober 2011
126
1
Hallo Xantiva, Du hattest Recht mit der /includes/config.JTL-Shop.ini.php, Ich habe das www. entfernt und mit .htaccess (http) läuft der admin als https und der shop als http. Ich kann den shop unter https://xxx.de manuell aufrufen, dann läuft er auch unter https! Aber sowie ich in der .htaccess ein https einstelle kommt der Error 500.
 

Mirko.Schmidt User deaktiviert

Guest
Es wäre gut zu wissen was für ein Fehler da kommt, einfach 500er ist zu allgemein und könnte alles sein 😉
 

wernereins

Gut bekanntes Mitglied
2. Oktober 2011
126
1
Im Admin ist kein Fehler, ich hatte zwar das Error - Log des Servers aktiviert, aber ich finde keinen Log-Eintrag.
 

Mirko.Schmidt User deaktiviert

Guest
Wenn die Seite weiß bleibt, dann die Display Errors in der Config aktivieren, mehr dazu hier.
 

wernereins

Gut bekanntes Mitglied
2. Oktober 2011
126
1
Das ist ja das Problem, wenn ich die .htaccess auf https umstelle, dann komme ich weder ins Frontend noch ins Backend, ich kann mich nur einloggen wenn ich die alte http .htaccess verwende, dann aber sowohl als http und auch als https.

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at [no address given] to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.4.27 Server at liebrechts.de Port 443
 

Mirko.Schmidt User deaktiviert

Guest
Dann müsste in der error.log vom Server, die wird teilweise nur vom Hoster bereitgestellt, definitiv ein Eintrag vorhanden sein. Da am besten einmal den Hoster kontaktieren, vielleicht ist das Zertifikat nicht richtig ausgestellt.
 

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
1.881
529
Halle
Hallo, bitte sende mal deine komplette (nichtfunktionierende) .htaccess als Anhang (gezipped, ggfs. auch als PN).
Um welche Shopversion geht es?
 

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
1.881
529
Halle
Statt deiner drei Regeln sollten zwei genügen:
Code:
#REWRITE ANPASSUNG 2 (auf meinedomain.de umleiten)
RewriteCond %{HTTP_HOST} ^www.meinedomain.de
RewriteRule ^(.*)$ https://meinedomain.de/$1 [R=301,L]

#REWRITE ANPASSUNG 4 (Weiterleitung auf SSL-Verschlüsselung bei Aufruf über http)
RewriteCond %{HTTPS} !=on
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
 

wernereins

Gut bekanntes Mitglied
2. Oktober 2011
126
1
Also so? Läuft leider auch nicht.

#REWRITE ANPASSUNG 2 (auf meinedomain.de umleiten)
RewriteCond %{HTTP_HOST} ^www.liebrechts.de
RewriteRule ^(.*)$ https://liebrechts.de/$1 [R=301,L]

#REWRITE ANPASSUNG 4 (Weiterleitung auf SSL-Verschlüsselung bei Aufruf über http)
RewriteCond %{HTTPS} !=on
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
 

wernereins

Gut bekanntes Mitglied
2. Oktober 2011
126
1
Genau immer noch, ich habe das Gefühl nach 5 Tagen .htaccess, dass es egal ist was ich dort eingebe, es kommt immer der 500. Nur wenn ich die alte .htaccess benutze bekomme ich das jetzige Bild. Ich habe mir jetzt 2 server-logs machen lassen kann ich die Euch zur Verfügung stellen, denn ffür mich sind es böhmische Dörfer.
 

Ähnliche Themen