In Diskussion "Zeitverschiebung" um mehrere Tage in POS 1.0.9.0

marine.art.2018

Aktives Mitglied
9. April 2019
69
3
Hallo zusammen,
wir hatten letzten Jahr ein merkwürdiges Phänomen: JTL POS 1.0.9.0 läuft in einem Android-Emulator unter Win10 und beide hatten den korrekten Tag und die korrekte Uhrzeit.
JTL POS auf dem Startbildschirm auch noch: 15.12.2023 12:21 (die Bilder sind etwa blurry, weil "echte" Bildschirmfotos... ;- )

Direkter Klick nach "Alle Bons" - da war dann heute auf einmal der 12.12.2023 und der 15.12. lag noch in der Zukunft (und war nicht auswählbar).
Schon mal gesehen?

Ein Neustart von Windows, Android Emulator und JTL POS hat das Problem beseitigt, es ließ sich auch nicht reproduzieren.

Grüße,
Markus
 

Anhänge

  • AlleBons_JTLPOS1090.jpg
    AlleBons_JTLPOS1090.jpg
    82 KB · Aufrufe: 5
  • StartBS_JTLPOS1090.jpg
    StartBS_JTLPOS1090.jpg
    152,4 KB · Aufrufe: 5

Karalanta

Sehr aktives Mitglied
18. April 2020
448
171
Ja ich hab das auch schon mal gesehen, aber konnte es nie nachstellen und nur Vermutungen.
Der Zeit Abgleich zwischen Gerät und Emulator hängt da sehr gerne mal. Dabei spielt es keine Rolle ob lokaler oder externer NTP Server oder ein Abgleich mit der Windows Geräte Zeit.
War in einigen Memu Versionen auch echt schlimm mit der TSE und 12/24Std. Format.

Ich war auch lange ein Freund von der POS im Emulator aber mittlerweile hab ich da echt nicht mehr wirklich Lust drauf.
Es lief zwar - gerade auch mit Memu - recht ordentlich und stabil (haben VIP wegen keine Werbung und so) aber irgendwas kleines war/ist immer.
Andere Emulatoren hab ich nie zufriedenstellend zum laufen bekommen. Und ich habe noch nie so viele verschiedene Konstellationen getestet wie Android und JTL-POS. Beim WSA in Windows 11 hab ich den Bluetooth Scanner bis heute nicht zum laufen bekommen (Teste das aber immer noch mit jedem Update)
Natives Android hab ich nie ernsthaft in Erwägung gezogen da dann der Vorteil des Emulators verloren gegangen wäre (gleichzeitige Einsatz POS und WaWi auf einem Bildschirm). Nativ in einer VM ist dann letztendlich auch nur die Krönung des Selbstbestrafens was Einrichtung und Betrieb betrifft in meinen Augen.

Ich habe jetzt jedenfalls das komplette System umgebaut. Oben ein Touchscreen mit angeschlossenem PC und Windows für die WaWi, Browser etc.
Darunter jetzt ein Samsung Galaxy Tab S8 Ultra (wegen der Bildschirmgröße) für die POS. Hatte das Ursprüngliche Tab A 10.5" dran, aber aufgrund der Gewohnheit des Emulators auf dem "großen" Bildschirm war das dann meiner Frau viel zu klein.

Was soll ich sagen, jetzt sind es zwar doch zwei Geräte im Kassenbereich, aber dank Spacepole lässt sich das vernünftig verbauen und jedes Gerät macht was es soll.

Kein altes Android 7 oder 9 im Emulator sondern aktuelle Versionen und Sicherheitsupdates. Backups funktionieren dank Syncthing Traumhaft, RustDesk für den Support läuft auch. Ich glaube was zumindest diese Baustelle angeht hab ich nun einige Sorgen weniger.

Entschuldigt mein abschweifen, aber ich nutzte das mal fix als kleine Therapiestunde zum Thema JTL-POS und Emulatoren ;)
 

gigi80

Sehr aktives Mitglied
3. Juni 2016
550
72
Hallo zusammen,
wir hatten letzten Jahr ein merkwürdiges Phänomen: JTL POS 1.0.9.0 läuft in einem Android-Emulator unter Win10 und beide hatten den korrekten Tag und die korrekte Uhrzeit.
JTL POS auf dem Startbildschirm auch noch: 15.12.2023 12:21 (die Bilder sind etwa blurry, weil "echte" Bildschirmfotos... ;- )

Direkter Klick nach "Alle Bons" - da war dann heute auf einmal der 12.12.2023 und der 15.12. lag noch in der Zukunft (und war nicht auswählbar).
Schon mal gesehen?

Ein Neustart von Windows, Android Emulator und JTL POS hat das Problem beseitigt, es ließ sich auch nicht reproduzieren.

Grüße,
Markus
Ähnliches Verhalten kennt JTL in einem Ticket. Hier wurde die Kasse aber nie ausgemacht. Bei dir immer wieder jeden Tag angemacht oder läuft die durch seit dem 15.12.?
 

marine.art.2018

Aktives Mitglied
9. April 2019
69
3
Ähnliches Verhalten kennt JTL in einem Ticket. Hier wurde die Kasse aber nie ausgemacht. Bei dir immer wieder jeden Tag angemacht oder läuft die durch seit dem 15.12.?
Immer so wie Win10 Updates benötigt, wird das gesamte System neu gestartet oder läuft dann auch mal 7-14 Tage durch...
Ich habe jetzt extra im Eventlog nachgesehen: das Win10 lief seit 11.12. ohne reboot - wie lange der Emulator mit JTL POS unterbrechungsfrei lief lässt sich nicht mehr feststellen, kann aber durchaus auch set 11.12. gewesen sein.

Grüße,
Markus
 

gigi80

Sehr aktives Mitglied
3. Juni 2016
550
72
Immer so wie Win10 Updates benötigt, wird das gesamte System neu gestartet oder läuft dann auch mal 7-14 Tage durch...
Ich habe jetzt extra im Eventlog nachgesehen: das Win10 lief seit 11.12. ohne reboot - wie lange der Emulator mit JTL POS unterbrechungsfrei lief lässt sich nicht mehr feststellen, kann aber durchaus auch set 11.12. gewesen sein.

Grüße,
Markus
na dann siehste doch den Fehler. wenn du die Kasse seit 12.12. laufen lässt....... Genau der Fehler liegt JTL schon vor aber eben halt mit richtigem Android und nicht Emuquark
 

marine.art.2018

Aktives Mitglied
9. April 2019
69
3
na dann siehste doch den Fehler. wenn du die Kasse seit 12.12. laufen lässt....... Genau der Fehler liegt JTL schon vor aber eben halt mit richtigem Android und nicht Emuquark
Hallo @gigi80,

"Ähnliches Verhalten kennt JTL in einem Ticket." - weißt Du die zugehörige Ticketnummer? Die würde ich gerne beobachten...
(und wenn es im Android nicht korrekt tut, dann bestimmt auch nicht im "Eumquark")

Grüße,
Markus
 

Shahne

Moderator
Mitarbeiter
9. Januar 2020
342
53
Der einzige Fall, den ich bisher jemals mit einer solchen Verschiebung gesehen habe, hatte einen zentralen Controller im Netzwerk genutzt, der als Zeitgeber für alle Geräte im Netzwerk agierte (Stichwort Active Directory). Und der hatte dann einen Fehler gebaut und schickte alle Geräte im Netzwerk auf den 1. Januar 1970 (auch bekannt als Timestamp 0).

Grundsätzlich benutzen wir in der JTL-POS aber einfach nur die Systemzeit des Geräts auf dem die Kasse läuft. Wenn die temporär falsch ist, sind natürlich auch die Bons mit betroffen - deswegen rufen wir auch den Typ der Zeit mit ab und warnen entsprechend, wenn es eine manuell gesetzte Zeit ist. Wenn diese Warnung bei dir fehlt, war die automatische Systemzeit vermutlich verfälscht.

Mit freundlichen Grüßen,
Shahne
 

Ähnliche Themen