Beantwortet Worklflow istAktiv = FALSE, Shop bleibt aber aktiv

dj0815

Mitglied
20. Juli 2020
70
14
Hi,
wenn ich manuell einen Artikel inaktiv setze, wird er für alle Shops deaktiviert.

Ich habe aber nun einen Workflow eingerichtet, der unter bestimmten Umständen die Artikel auf inaktiv setzen soll.
Das macht er auch wie gewünscht, ABER: allerdings bleibt in diesem Fall der Artikel in den Shops aktiv.

Nach @Enrico W. ist es aber korrekt, dass der Artikel auch aus den Shops gelöscht wird. https://forum.jtl-software.de/threads/inaktive-artikel-werden-geloescht.153328/post-837121
Also sollte es dies doch auch beim Deaktivieren per workflow der Fall sein?

WAWI 1.5.45.1

LG Dominik
 

Björn Ponsen

Moderator
Mitarbeiter
1. Juli 2016
891
74
Hi,
wenn ich manuell einen Artikel inaktiv setze, wird er für alle Shops deaktiviert.

Ich habe aber nun einen Workflow eingerichtet, der unter bestimmten Umständen die Artikel auf inaktiv setzen soll.
Das macht er auch wie gewünscht, ABER: allerdings bleibt in diesem Fall der Artikel in den Shops aktiv.

Nach @Enrico W. ist es aber korrekt, dass der Artikel auch aus den Shops gelöscht wird. https://forum.jtl-software.de/threads/inaktive-artikel-werden-geloescht.153328/post-837121
Also sollte es dies doch auch beim Deaktivieren per workflow der Fall sein?

WAWI 1.5.45.1

LG Dominik
Guten morgen @dj0815 ,

kannst du mal bitte deinen Workflow als Screenshot Posten. Vorallem ist interessant was für eine Konfiguration du in der Aktion genommen hast.
 

Björn Ponsen

Moderator
Mitarbeiter
1. Juli 2016
891
74
Hi, aber wenn ich manuell den Artikel auf inaktiv setze, dann wird der Artikel auch für die Shops deaktiviert. Theoretisch sollte das doch das gleiche sein?
Ich hab es gerade noch mal getestet. In der Wawi wird Shop aktiv mit dieser Option ebenfalls entfernt. Ich denke das danach ein Shopabgleich gemacht werden muss damit der Artikel auch im Shop entfernt wird. Habt ihr den gemacht?
 

dj0815

Mitglied
20. Juli 2020
70
14
Bleibt dieser auch unverändert wenn Ihr das Händisch ändert?
Wie bereits um 9:39 geschrieben:

aber wenn ich manuell den Artikel auf inaktiv setze, dann wird der Artikel auch für die Shops deaktiviert

Sobald der Artikel über den Workflow deaktiviert wird, muss ich ihn erst noch einmal aktivieren, um den Artikel anschließend auch für die Shops zu deaktivieren.
 

Björn Ponsen

Moderator
Mitarbeiter
1. Juli 2016
891
74
Wie bereits um 9:39 geschrieben:



Sobald der Artikel über den Workflow deaktiviert wird, muss ich ihn erst noch einmal aktivieren, um den Artikel anschließend auch für die Shops zu deaktivieren.
Guten morgen,

mach hierzu gerne mal ein Ticket auf. Bei mir wird der Artikel durch den Workflow inaktiv geschaltet und auch die Shopzuordnung entfernt und in den Artikeldetails steht "Wird gelöscht"
1628568799714.png