Neu Verschwundene Rechnungskorrektur

HL-Koeln

Aktives Mitglied
13. Februar 2019
14
1
Hallo. Wir haben offenbar eine "verschwundene" Rechnungskorrektur, d.h. einen unterbrochenen Nummernkreis. Die Erstellung des Beleges ist ist in Admin>JtlWawiLogbuch vermerkt. Die Löschung nicht. Kein Nutzer hat das Recht, Rechnungskorrekturen zu Löschen. Wie kann das passiert sein, wie können wir das prüfen/belegen/fürs Amt dokumentieren und wie in Zukunft verhindern. Wir freuen uns auf Anregungen. LG
 

jtldudel

Sehr aktives Mitglied
4. Januar 2018
145
34
Welche Version nutzt ihr? Wir hatten das mal das, vermutlich durch Verbindungsabbrüche oder Fehler beim Speichern, einige RKs nicht mehr zu sehen waren. In der Datenbank konnte man aber sehen das sie noch einen Eintrag hatten, also gelöscht wurden sie nicht. Es fehlten dann aber Daten in der DB Tabelle, wodurch die RK nicht mehr in der Wawi angezeigt wurde.
Lösung war über einen Update Befehl die notwendigen wieder einzutragen, da sind dann dinge wie Bezug auf die Rechnung, Währung, Rechnungsadresse, etc. notwendig. Wenn du davon keine Ahnung hast, lass unbedingt die Finger davon. Mach am besten bei JTL ein Support Ticket auf oder wende dich an einen Servicepartner falls du einen hast.
Zunächst wäre abzuklären ob der Eintrag mit kGutschrift noch in deiner DB ist, wenn ja hast du vermutlich das gleiche Problem.
Ist mit neueren Wawi Versionen nicht mehr aufgetreten, war aber ohnehin eher selten.
 

HL-Koeln

Aktives Mitglied
13. Februar 2019
14
1
Hallo jtldudel,
wir sind auf JTL Wawi 1.5.45.1 .
Prüfung mit unserer Informatik ergab, die betreffende Gutschrift ist in keiner Datenbanktabelle enthalten.
Auch zwei Aufträge aus dem Datumsbereich fehlen (ebenfalls weder in JTL noch DB enthalten, Nummernkreis unterbrochen.
Wir machen ein Support Ticket auf.
 

Sven Firnrohr

Aktives Mitglied
17. Juli 2019
4
0
Guten Abend zusammen,

ich kann regelmäßig ähnliche Probleme bei uns selbst wie auch bei mehreren Kunden feststellen. Bisher habe ich drei verschiedene Probleme identifiziert, die meiner Meinung nach ausschließlich nach Datenbankabrissen / Verbindungsproblemen auftreten:

1. Die Rechnungskorrektur ist vollständig gelöscht, in der Datenbank finden sich keinerlei Spuren mehr von ihr, weder in tgutschrift noch in tGutschriftPos oder sonstwo. In solchen Fällen dokumentieren wir mit einem Standardformular das Fehlen der Rechnungskorrektur und nehmen es zu unserer FiBu-Dokumentation.
2. Es finden sich noch Reste der Rechnungskorrektur in der Datenbank: In der Regel sind die Kopfdaten der Rechnungskorrektur (Beziehungen zu Kunde, Auftrag etc) verschwunden, der Eintrag in tgutschrift ist also quasi leer, außer der internen ID gibt es keine oder nur noch wenig Inhalte; in tGutschriftPos finden sich aber die einzelnen Positionen der Gutschrift noch, dank kBestellpos kann man dann über die Tabelle tbestellpos alle notwendigen Daten nachvollziehen, um die Rechnungskorrektur manuell wieder herzustellen.
3. In Tabelle tgutschrift ist der Wert von kFirma für die Rechnungskorrektur gleich 0, alle anderen Daten sind vorhanden. Wenn man den Wert auf die tatsächliche ID der Firma, zu der die Rechnungskorrektur gehört, ändert, dann erscheint der Beleg auch wieder in der WaWi.

@HL-Koeln Habt ihr dazu damals ein Ticket aufgemacht? Falls ja, verlinkst du es bitte noch?

Herzliche Grüße vom Niederrhein
Sven Firnrohr
 

HL-Koeln

Aktives Mitglied
13. Februar 2019
14
1
Hallo Sven Firnrohr,

Ja haben wir: Ticket#2021061810004804

Bisheriges Ergebnis: einige der Dokumente wurden durch den Support wiederhergestellt, die Restlichen dokumentiert.

Vermutete Ursache ist die Client-Server-Kommunikation (DB-Server bei CMO).
Wir wurden angewiesen grundsätzlich, insbesondere aber bei Stapelverarbeitung (zB +10 Aufträge mit Workflow oÄ) per RDP zu arbeiten.
Offenbar verschluckt das System im Clientbetrieb gelegentlich Daten, das Scheint wenn nicht bekannt zumindest nicht "neu" zu sein.
Das ist inzwischen auch an anderer Stelle zu Tage getreten: "verschwundene" ABs mit unterbrochenem Nummernkreis (separat Ticketnummer: 2021061810004804) sowie nicht an GLS übermittelte Paketnummern.
Bisher (2 Wochen) scheint das per RDP zu funktionieren.

LG
 

Sven Firnrohr

Aktives Mitglied
17. Juli 2019
4
0
Hallo HL-Koeln,

ich hatte überlesen, dass Ihr ein Support- Ticket und keines im Issue Tracker eröffnet hat. In letzterem Fall hätte ich gerne moralischen Support geleistet, da mir das Thema selbst auch sehr wichtig ist.

Bei uns bzw. unseren Kunden treten die Probleme übrigens auch in RDP-Umgebungen auf, nicht nur bei lokaler Client-Installation. Gehostet wird unter anderem bei relyon und ecomDATA, aber auch anderen. Ich habe gerade frisch die WaWi in v1.5.46.4 für eine eigene neue GmbH aufgesetzt, dort einige Testaufträge über OTTO durchgeführt, diese vollständig über WaWi bzw. WMS abgeschlossen und im Anschluss dann retourniert und die zugehörigen Rechnungskorrekturen erstellt. Die erste Rechnungskorrektur fängt in der DB nicht mit ID 1 an, sondern mit 2. Wohlgemerkt, es handelt sich um eine frische Installation, in der außer Basiseinrichtung und Connection zu OTTO bisher nichts gelaufen ist. Die für die erste Rechnungskorrektur vergebene Belegnummer ist korrekt nach dem im Belegnummernkreislauf vorgegebenen Muster erstellt worden, hier wurde also keine Rechnungskorrektur gelöscht, sondern schon beim Anlegen des Datensatzes in der DB ein Fehler gemacht - ob durch die WaWi oder aufgrund eines Bugs im DB-Server, keine Ahnung.

Herzliche Grüße vom Niederrhein
Sven Firnrohr
 

HL-Koeln

Aktives Mitglied
13. Februar 2019
14
1
Hallo Sven Firnrohr,

der moralische Support ist auch so angekommen. Danke.

Das ist eine nützliche Info. Wir sind noch im Gespräch mit dem Support und werden diese mit ins nächste Meeting nehmen. Danke auch dafür.

LG