Neu Umlaute falsch in E-Mail aus Shop - aber nur Titel des Produkts

misterGST

Gut bekanntes Mitglied
23. September 2007
320
23
Hallo liebe Mitmenschen,

ich richte gerade die E-Mails im JTL- Shop 5.0.3 ein und habe folgendes Problem:
Die Umlaute des Artikelnamens (Titel) {$Artikel->cName} wird sowohl im Titel, als auch im Body der E-Mail falsch dargestellt (ü statt ü).
Im JTL-Shop 5 wird der Artikelname jedoch richtig dargestellt.

Es ist die Mail: "Frage zum Artikel" im TXT Format - geöffnet in Outlook (neueste 365-Version):

Umlaute-in-Mail.jpg

Mich wundert, dass es nur den Titel (Artikelnamen {$Artikel->cName}) betrifft, und nicht den restlichen Inhalt.
An welcher Schraube muss ich drehen?

Vielen Dank
LG Georg
 

AWausF

Neues Mitglied
20. Juli 2021
3
0
Habe das selbe Problem, Mailversand über SMTP an den lokalen Exchange Server. Wo wird der Betreff denn generiert?
 

AWausF

Neues Mitglied
20. Juli 2021
3
0
In der mailTools.php wird zu iso88591 konvertiert, rausnehmen bringt aber auch nix. Blöd ist das die Umlaute in den Testmails RICHTIG dargestellt werden 🙄 Im Shop und im Mailbody wird aber das was in der DB steht auch richtig angezeigt, sehr merkwürdig!
 

AWausF

Neues Mitglied
20. Juli 2021
3
0
Nochmal ich 😁 Ändert man den Mailversand von HTML in Text, ist neben dem Betreff auch im Mailbody das Feld "Frage zu folgendem Produkt" mit falschen Umlauten. Also liegt das Problem irgendwo bei DB nur Text konvertierung und bei HTML ist wieder gut?!
 

misterGST

Gut bekanntes Mitglied
23. September 2007
320
23
Hallo Michael,

wenn der Fehler seit 13.04.2021 bekannt ist und nun fast 4 Monate "In Prüfung" ist - dann bin ich zuversichtlich, daß "bald" eine Lösung zur Verfügung gestellt wird.
Wünsche gutes Gelingen.

LG Georg
 

FMoche

Moderator
Mitarbeiter
15. Dezember 2014
1.048
187
Halle (Saale)
Als Workaround müsste es reichen, in der Vorlage die Betreffzeile von
Code:
Frage zu: #artikel.name# (#nachricht.mail#)
nach
Code:
Frage zu: #artikel.originalName# (#nachricht.mail#)
zu ändern.
 
  • Gefällt mir
Reaktionen: ma-carstyle

misterGST

Gut bekanntes Mitglied
23. September 2007
320
23
Als Workaround müsste es reichen, in der Vorlage die Betreffzeile von
Code:
Frage zu: #artikel.name# (#nachricht.mail#)
nach
Code:
Frage zu: #artikel.originalName# (#nachricht.mail#)
zu ändern.

Das Problem in der Betreffzeile ist damit gelöst - Vielen Dank!
Bleibt nur die fehlerhafte Darstellung im Mail-Body!
Habe {$Artikel->cOriginalName}, {$Artikel->coriginalName}, {$Artikel->originalName} getestet - aber hat dort nicht funktioniert (wird nix ausgegeben).

Umlaute-in-Mail-2.jpg
---------------
Gruss Georg
 

Anhänge

  • Umlaute-in-Mail-2.jpg
    Umlaute-in-Mail-2.jpg
    125,2 KB · Aufrufe: 4
Zuletzt bearbeitet:

misterGST

Gut bekanntes Mitglied
23. September 2007
320
23
{$Artikel->originalName} funktioniert bei mir problemlos auch im (Text-)Body..
Sicher, dass du es nicht im HTML-Feld geändert hast?

Habe alle Mails auf "nur TXT" stehen. Dachte die Variablen würden in beiden Versionen funktionieren? ... scheinbar nicht.

Hintergrund: Habe aktuell ein Problem, dass im Footer meine Signatur + AGB nicht angezeigt werden - mit [AKZ][LEGAL_DATA] - bei TXT und HTML. Deshalb vorübergehend alles auf TXT umgestellt (Code ist dort übersichtlicher) und Signatur manuell eingetippt. Ticket ist noch offen: #2021072710003313 (Teilproblem mit Logo im Ticket wurde schon gelöst).

Gruss Georg
 

misterGST

Gut bekanntes Mitglied
23. September 2007
320
23
GUTE NACHRICHTEN: Habe {$Artikel->originalName} soeben wieder getestet - und es funktioniert auch in TXT-Mails !!!
Verstehe nicht, warum es vorhin nicht geklappt hat.

PROBLEM IST GELÖST - nun kann ich Feierabend machen - DANKE nochmal!

LG Georg

EDIT: Habe erst jetzt deinen Satz: "Sicher, dass du es nicht im HTML-Feld geändert hast?" verstanden.
Richtige Antwort: Nein - hatte es sicher im TXT-Body geändert (sollte nun wirklich Feierabend machen).
 
Zuletzt bearbeitet:
Ähnliche Themen
Titel Forum Antworten Datum
Neu Umlaute gehen verloren Technische Fragen zu den JTL-Connectoren 0
Neu Steuern werden falsch in die Wawi importiert Shopware-Connector 1
Neu Feld falsch verknüpft - Wawi stürzt ab Amazon-Lister - Fehler und Bugs 1
Neu Wawi Bereich "Verkauf" in JTL5 ->Kundendaten werden falsch angezeigt und sogar falsch generiert JTL-Wawi - Fehler und Bugs 1
utf8mb3_unicode_ci - MariaDB 10.6.4 - Kollationsprüfung ist falsch Einrichtung JTL-Shop5 5
Neu Redundanter Bon - Tagesabschluss falsch Allgemeine Fragen zu JTL-POS 2
Neu Exporte der Auftragsgewichte falsch? JTL-Wawi - Fehler und Bugs 0
Neu Rabatte im JTL Shop bei mir im Gesamtbetrag falsch? Allgemeine Fragen zu JTL-Shop 1
Gelöst Kassenbuch Übertrag falsch JTL-POS - Fehler und Bugs 1
Neu Variationen im JTL Shop 5 falsch dargestellt Allgemeine Fragen zu JTL-Shop 6
Neu Import mit Ameise / csv falsch importiert User helfen Usern - Fragen zu JTL-Wawi 7
Neu 1.5.47.3: Downloadlink im Release Forenbeitrag falsch Gelöste Themen in diesem Bereich 1
Neu Canonical Link bei Eigenen Inhaltsseiten falsch JTL-Shop - Fehler und Bugs 1
Neu Nova Midnight, @import in _allstyles falsch? JTL-Shop - Fehler und Bugs 2
In Bearbeitung Hakt in der Schnittstelle - Amazon-Aufträge werden seit 1.7.'21-0:00Uhr falsch in externe Rechnungen übernommen -> kein Rechnungsdruck mehr möglich! Amazon-Anbindung - Fehler und Bugs 176
Neu Breadcrumb Weiterleitung ist falsch JTL-Shop - Fehler und Bugs 1
Neu Kein Versand von Bestellbestätigung an Kunden mehr per mail. User helfen Usern - Fragen zu JTL-Wawi 5
Neu Lieferanten Bestellung E-Mail Vorlage JTL-Wawi - Fehler und Bugs 0
Neu Nicht lieferbare Positionen in einer E-Mail versenden Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Einrichten des E-Mail Versandes User helfen Usern - Fragen zu JTL-Wawi 4
In Diskussion Workflow Fehlbestand Auftrag -> Mail + Eintrag Einkaufsliste JTL-Workflows - Ideen, Lob und Kritik 0
Neu E-Mail Benachrichtigung JTL-Workflow Mitarbeiter ändert Preis User helfen Usern - Fragen zu JTL-Wawi 2
Neu Absender Adresse immer "nur" die E-Mail Adresse Servicedesk (Beta) 5
Neu Automatische Mail nach Lieferung um Feedback einzuholen User helfen Usern - Fragen zu JTL-Wawi 1
Neu Wie kann ich die in Auftragsattribute hinterlegte E-Mail Adresse und andere Attribute in E-Mail Vorlage abfragen? User helfen Usern - Fragen zu JTL-Wawi 7
Neu Bekomme keine Mail mit dem Passwort Einrichtung und Installation von JTL-eazyAuction 1
Neu Workflow EK angepasst E-Mail User helfen Usern - Fragen zu JTL-Wawi 3
Neu Textausrichtung in Html Mail Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu Ausgabe Rechnung über Mail User helfen Usern - Fragen zu JTL-Wawi 2
Neu Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Beantwortet Workflow Mail versenden bei neuem Unicorn Auftrag geht nicht JTL-Workflows - Fehler und Bugs 4
Neu Workflow E-Mail wenn Bestand 0 User helfen Usern - Fragen zu JTL-Wawi 4
Beantwortet Lieferantenbestellung Workflow Teillieferung E-Mail senden JTL-Workflows - Ideen, Lob und Kritik 6
Neu Wie kann ich die hinterlegte E-Mail Adresse für Rechnungsversand von "Eigene Felder" in E-Mail Vorlage abfragen? User helfen Usern - Fragen zu JTL-Wawi 15
Neu E-Mail Benachrichtigung bei neuer JTL Shop Version Installation / Updates von JTL-Shop 0
Gelöst POS-Bon (externe Rechnung) aus WaWi per Mail versenden Gelöste Themen in diesem Bereich 6
Neu Checkbox E-Mail Benachrichtigung funktioniert nicht JTL-Shop - Fehler und Bugs 4
In Bearbeitung E-Mail Adresse wird nicht angezeigt JTL-POS - Fehler und Bugs 5
Gelöst Gesamtbetrag wir in E-Mail nur mit einer Stelle nach dem Komma ausgegeben. JTL-Workflows - Fehler und Bugs 2
Neu Missing currency in "Zahlungseingang" mail template (English) JTL-Wawi - Fehler und Bugs 0
E-Mail-Versand mit SSL/TLS geht nicht Einrichtung JTL-Shop5 3

Ähnliche Themen