In Bearbeitung Sonderpreise Label Anzeige -0,00€ Prestashop 1.7 DB ps_specific_price

backamblock

Mitglied
1. August 2018
20
0
Hallo zusammen,
so langsam würde ich mich ja anbieten mit an der Dokumentation zum Connector zu schreiben, so viele Dinge wie bei mir schon angepasst werden mussten bzw Problemchen auf die in der Doku nicht hingewiesen wird :D

Zum Thema:
In der WaWi sind alle Preise für Prestashop mit einem Rabatt von 0,00% angelegt, das ist in den Kategorien und in den Artikeln selbst so eingestellt. Also kein Rabatt.
Nun wird in Prestashop in den Artikellisten, also z.B. Startseite und Suche, bei jedem Artikel ein Label mit "-0,00€" über dem Artikelbild eingeblendet.

Wenn ich im Prestashop Backoffice den Artikel öffne sind im Tab "Preise" keine Sonderpreise eingetragen. Auch Warenkorb oder Katalog Preisregeln sind keine vorhanden.
Die Kundengruppen habe ich in Prestashop bei "Leistung" deaktiviert.

Wenn möglich, würde ich die Anzeige des Rabattes in Prestashop generell behalten, da ich mit einer Preisregel für eine neue "Sonderangebote" Kategorie arbeiten möchte.
Die WaWi arbeitet ja anders mit den Sonderpreisen als Presta.

Was hat es mit dieser Anzeige auf sich und wie werde ich diese -0,00€ los?

Gruß und danke für eure Ideen und Tipps!
 
Zuletzt von einem Moderator bearbeitet:

backamblock

Mitglied
1. August 2018
20
0
Nachtrag.
die fehlende Anzeige im Backoffice war auf die Umstellung der Standardwährung per DB zurückzuführen, es fehlte der richtige Eintrag in der ps_configuration table bei default currency.

zum Problem:
nach jeder Aktualisierung der Preise in der WaWi ist die Tabelle "ps_specific_price" wieder voll mit "reduction"-"0" Einträgen.

Die Wawi behandelt die Preisregeln absolut, Presta anders, das habe ich verstanden.

Aber muss denn der Connector wirklich bei jeder NICHT VORHANDENEN Preisregel den Wert "0" senden?
Das muss sich doch eleganter lösen lassen, z.B. indem WaWi Rabatte von "0" gar nicht übertragen werden! Einfach den Preis und fertig.

Was muss ich dafür ändern?
 
Zuletzt bearbeitet:

Immanuel

Gesperrter Benutzer
24. August 2016
1.542
324
Hallo backamblock,

so langsam würde ich mich ja anbieten mit an der Dokumentation zum Connector zu schreiben, so viele Dinge wie bei mir schon angepasst werden mussten bzw Problemchen auf die in der Doku nicht hingewiesen wird :D
Wir werden uns der Doku annehmen und sie auf den aktuellen Stand bringen.


so langsam würde ich mich ja anbieten mit an der Dokumentation zum Connector zu schreiben, so viele Dinge wie bei mir schon angepasst werden mussten bzw Problemchen auf die in der Doku nicht hingewiesen wird :D

was passiert, wenn du bei Preise für Kundengruppen die Auswahl "Standard-VK des Artikels" setzt, anstelle von "Standard-VK um % verringern"?


nach jeder Aktualisierung der Preise in der WaWi ist die Tabelle "ps_specific_price" wieder voll mit "reduction"-"0" Einträgen.

Die Wawi behandelt die Preisregeln absolut, Presta anders, das habe ich verstanden.

Aber muss denn der Connector wirklich bei jeder NICHT VORHANDENEN Preisregel den Wert "0" senden?
Das muss sich doch eleganter lösen lassen, z.B. indem WaWi Rabatte von "0" gar nicht übertragen werden! Einfach den Preis und fertig.

Was muss ich dafür ändern?
Was passiert, wenn du in der Wawi bei einem Artikel => Preise für Kundengruppen die Auswahl "Standard-VK des Artikels" setzt, anstelle von "Standard-VK um % verringern"?
 
Zuletzt von einem Moderator bearbeitet:

backamblock

Mitglied
1. August 2018
20
0
@Immanuel Ich denke die Einstellung ist so gesetzt wie du es meinst, werde da irgendwie auch nicht schlau draus.

Tab " JTL-WaWi"Unbenannt.PNG
Tab "OnlineshopXYZ"Unbenannt2.PNG

Als Behelfslösung muss ich jetzt jedesmal die Tabelle "ps_specific_price" löschen und die richtigen Rabattte in Presta als CSV importieren. Leider sendet er ja beim Abgleich nach jeder Bestellung wieder den neuen "-0,00" Eintrag für den Artikel an Presta zurück.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Sonderpreise werden nicht mit €0,-- gespeichert 1.6.40.0 JTL-Wawi - Fehler und Bugs 0
Neu 1.6.44.0 Sonderpreise werden nicht aktivier JTL-Ameise - Fehler und Bugs 17
Neu Sonderpreise richtig übertragen Shopify-Connector 1
Neu Label wieder entfernen? Servicedesk (Beta) 6
Neu Glitch: Label hinzufügen JTL-Wawi - Fehler und Bugs 0
Neu aria-label="Menge erhöhen" und aria-label="Menge verringern" abschalten Templates für JTL-Shop 0
Neu Label auf den Lieferschein drucken User helfen Usern - Fragen zu JTL-Wawi 0
Neu DHL Label ohne Auftrag/Rechnung/Lieferschein User helfen Usern - Fragen zu JTL-Wawi 10
Verwiesen an Servicepartner DHL-Label nach dem Erstellen mit JTL Shipping automatisch per Email ans Lager schicken JTL-ShippingLabels - Ideen, Lob und Kritik 1
DHL Gewicht auf Label stimmt nicht mit Auftragsgewicht überein JTL-Wawi 1.6 4
Neu Variabeln für den Nettopreis und der Produktmenge einer Auftragsposition im List & Label Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu List & Label - Fettschrift eines einzelnen Wortes in einem Text Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
JTL 1.6 / JTL Worker 2.0 / Langsamer Individual-Label-Druck JTL-Wawi 1.6 2
Neu Lieferschein Druck mit Artikelbilder - List&Label Abfrage auf "existierendes" Bild Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Alle Label für einen Artikel bei E-Mail (Workflow) abfragen JTL-Wawi 1.6 0
Kunden Label setzten, Workflow JTL-Wawi 1.6 0
Neu Laufzeit von Stored Procedures in der Datenbank - Anzeige Fortschritt? Wawi steht still... JTL-Wawi - Ideen, Lob und Kritik 5
Neu Wareneingang => Anzeige der Aufträge, für die Artikel eingebucht wurden User helfen Usern - Fragen zu JTL-Wawi 6
BUG: Keine Error Anzeige in SCX JTL-Wawi 1.7 7
Neu Anzeige Variationswert in Swatches Templates für JTL-Shop 6
Neu Vorlagen Editor (mehrere Optionen der Anzeige) User helfen Usern - Fragen zu JTL-Wawi 2
Neu Anzeige von eigenen Feldern in der Artikelliste wie in 1.5.x möglich? User helfen Usern - Fragen zu JTL-Wawi 0

Ähnliche Themen